Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1427 connectés 

  FORUM HardWare.fr
  Réseaux grand public / SoHo
  Tutoriels

  [Tuto] Freebox v5 en bridge, Freebox HD, routeur dd-wrt et UPnP DLNA

 


 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Tuto] Freebox v5 en bridge, Freebox HD, routeur dd-wrt et UPnP DLNA

n°667841
Fuli10
Le gras, c'est la vie !
Posté le 20-05-2013 à 12:45:12  profilanswer
 

Bonjour à tous  :hello:  
Ceci est mon premier tuto, donc je vous demande d'être indulgent  :jap:
Après avoir passé une nuit à écumer internet à la recherche d'une réponse claire à ce que je cherche, j'ai galéré à regrouper de nombreuse information éparse pour avoir la solution. Du coup je fais un tuto car ça peut valoir le coup de garder une réponse simple et complète à la problématique (précise) suivante:
Comment faire que la freebox HD accède au serveur DLNA derrière un routeur personnalisé, quand la freebox v5 est en mode bridge
 
Pour commencer, cela concerne tous ceux qui ont une architecture réseau comme suit:
 


internet ---- Freebox v5 --------- routeur (dd-wrt) -+---- PC (enfin réseau interne)
                        |                            |
                        +--- Freebox HD              +----- NAS (serveur DLNA)
                                                     | etc.


En détail:
- vous avez une Freebox v5 configuré en mode bridge
- vous avez confié la sécurité et le routage à un autre routeur plus performant flashé avec un firmware dd-wrt (un Belkin dans mon cas)
- vous avez un seul serveur DLNA qui partage toute vos donnés multimédia et qui vous intéresse (en général c'est un NAS, un DNS-320 dans mon cas)
 
Votre tripe ?
- Accéder depuis la freebox HD au serveur DLNA de ce petit cachotier de NAS planqué derrière votre réseau privé
 
Alors en fait, les problèmes réseau sont assez nombreux et j'ai donc décidé de tous les regrouper ici ainsi que les solutions que j'ai utilisé.
 
1. Premier problème: Identifier sa freebox HD
Aussi curieux qu'il n'y parait, la freebox HD à une IP propre qui est donné par la box et qui ne correspond pas, mais alors vraiment pas du tout à l'IP que l'on a sur internet.
Pour la trouver, il sufit dans une console (Windows+R puis cmd dans windows) de taper un simple:

ping mafreebox.freebox.fr
PING mafreebox.freebox.fr (212.27.38.253): 56 data bytes
64 bytes from 212.27.38.253: seq=0 ttl=63 time=4.390 ms


Et voila, j'ai l'IP de ma freebox. Dans mon cas 212.27.38.253. Je suppose que cette IP ne change pas souvent et beaucoup de monde doit avoir la même IP.
 
2. Second problème: Router le protocole DLNA depuis la freebox HD vers le serveur
 
Ca c'est assez simple, et je pense que la majorité d'entre vous a déjà tenté cela.
Une fois que l'on connait l'IP de sa freebox, il faut connaitre les règles de routages à appliquer. Il n'y a au final que 2 règles.
Dans l'interface de dd-wrt, allez dans les options du NAT et ajouter les 2 règles suivantes:

règle: DLNA-1  type: UDP  | source  IP: 212.27.38.253  port: 1900  | destination  IP: 192.168.24.150 port:1900
règle: DLNA-2  type: Both | source  IP: 212.27.38.253  port: 49200 | destination  IP: 192.168.24.150 port:49200


(j'ajouterai une image quand j'aurais le temps)
Évidemment, ces règles sont spécifiques à votre réseau et à votre serveur DLNA.
L'IP source dépend du retour que vous avez eu sur le point 1.
L'IP destination correspond à l'IP de votre serveur DLNA (mon NAS étant à l'IP 192.168.24.150). Je vous conseille d'affecter une IP fixe à votre serveur.
Et concernant le port 49200, il s'agit le plus souvent d'un réglage dans votre serveur DLNA. Le port 49200 est le port par défaut utilisé par minidlna par exemple.
Il faut toujours garder le port 1900.
 
Bien, la plupart d'entre vous a essayé cela, et là: ça ne marche pas !
Mais pourquoi est-ce que la freebox est si méchante :gun: ???
Est bien c'est parce que le protocole DLNA utilise une saleté de truc qui s'appel le multicast. Et ce truc là, c'est une horreur à configurer.
 
3. Configurer le multicast
3.a Autoriser le multicast à passer
Tout d'abord, il faut commencer par ouvrir une brèche dans la sécurité de son système (même s'il faudra un jour m'expliquer en quoi c'est une brèche).
Il faut autoriser le multicast. Et donc il faut aller dans l'interface de dd-wrt, onglet "Security", et désactiver l'option "Filter IP multicast" (TODO: image à insérer).
Concrètement, désactiver cette option fait que le routeur lance automatiquement un deamon qui s'appelle "igmprt". Celui-ci laisse passer les requêtes multicast depuis le WAN vers le LAN.
Attention, le deamon n'autorise que les requêtes provenant du réseau de l'interface WAN à passer. Qu'est ce que cela signifie concrètement  :??: ? Et bien tout simplement que les seules requêtes multicast autorisées à passer doivent venir de 82.xx.xx.xx (mon IP sur internet). Et donc que seules des requêtes venant d'internet peuvent passer.
3.b Mais la freebox HD, elle n'a pas une IP sur internet ! Comment je fais :??:
Et là commence la bidouille ! Le freebox HD ayant une IP en 212.27.38.253, igmprt ne daignera même pas regarder la requête.
Heureusement il est possible de dire à igmprt qu'au final le réseau "légal" vient de 212.27.38.xx. Il faut modifier son fichier de configuration et ajouter "altnet 212.27.38.0/24" sur l'option qui configure l'interface du WAN. Cela indique que les requêtes multicast peuvent venir d'un réseau "alternatif", entre autre de toute IP 212.27.38.xxx.
Mais comment configurer igmprt avec l'interface de dd-wrt ? C'est simple: on peut pas !
Il va falloir utiliser les scripts.
Dans "admin->scripts", ajouter le texte suivant:

sleep 20
killall igmprt
cat <<EOF> /tmp/igmpproxy.conf
quickleave
phyint vlan2 upstream  ratelimit 0  threshold 1 altnet 212.27.38.0/24
phyint br0 downstream  ratelimit 0  threshold 1
phyint eth0 disabled
phyint eth1 disabled
phyint eth2 disabled
phyint vlan0 disabled
phyint vlan1 disabled
phyint lo disabled
EOF
/usr/sbin/igmprt /tmp/igmpproxy.conf &


Puis cliquez sur "Custom".
 
Attention, adaptez bien le script en fonction de votre réseau (chez moi, le WAN = vlan2, et j'ai 2 interfaces wifi).
Pour être sur de bien modifier le fichier, vous pouvez faire un

cat /tmp/igmpproxy.conf


Et modifiez le script en fonction de votre réseau. L'option "altnet" devant être ajouté à l'interface contenant "upstream".
Je ne suis pas sur qu'il soit nécessaire de faire un "killall". Peut-être juste qu'un "killall -HUP" suffit. Mais bon, c'est un bidouillage qui fonctionne chez moi.
 
Pourquoi avoir choisit "Custom" au lieu de firewall ? Et bien parce que dans firewall cela n'a pas l'air de fonctionner (et je ne sais pas pourquoi). A chaque changement de réglage du firewall, le fichier "/tmp/igmpproxy.conf" est recréé, et le deamon relancé. Quoi qu'il en soit, le premier "sleep 20" n'est là que pour s'assurer que le firewall a bien tout remit en place avant d'écraser la configuration par notre configuration personnalisé.
Après, il faut mettre un :

/tmp/custom.sh &


que l'on enregistre dans "firewall". Ainsi, à chaque changement de règle du firewall, on relance notre script custom qui modifie la configuration de "igmprt" avant de le relancer.
C'est un peu tordu  :pt1cable: mais ça marche chez moi. Si quelqu'un a une autre façon de faire, je veux bien qu'il lève la main  :hello:  
 
3.c Bon, tout est là mais ça ne marche toujours pas ! Pourquoi :??:
 
Bon, on est heureux, les requêtes multicast doivent passer, on fait donc l'essai et puis :fuck:. Ça ne marche toujours pas !
Avant d'envisager le meurtre :gun: il est bon de voir que le multicast venant de la freebox est POURRIE.
C'est là on j'ai commencer à déprimer jusqu'à ce que je trouve une explication vers 2h du mat': non seulement l'IP de la freebox HD est pourrite, mais en plus son TTL est à 1 !
Qu'est ce que le TTL ? Et bien c'est un compteur qui est diminué de 1 à chaque fois qu'un paquet traverse un routeur. Et s'il vaut 1, et bien le routeur qui reçoit la requête, avant de le faire passer de l'autre côté, décrémente sa valeur, voit que le TTL vaut zéro. Et là le routeur dit :fuck: "tiens, je ne t'envoie pas parce que tu vaux 0".
Alors si jamais le serveur DLNA c'est vôtre routeur, mettre un TTL à 1 se tient. Ça évite de propager l'information au delà du premier routeur de Free. Mais dans notre cas c'est un peu gênant car il y a au moins un routeur à traverser.
Heureusement, la solution pour cela est un peu plus simple. Il suffit de dire au routeur de forcer le TTL à une autre valeur (moi j'ai choisi 4) sur les requêtes multicast.
Cela se fait avec la commande:

iptables -A PREROUTING -t mangle -i vlan2 -d 239.255.255.250 -j TTL --ttl-set 4


On doit ajouter cela dans le script configurant le firewall. Au final votre script pour le firewall doit ressembler à ça:

iptables -A PREROUTING -t mangle -i vlan2 -d 239.255.255.250 -j TTL --ttl-set 4
/tmp/custom.sh &


 
Ouf ! On voit le bout du tunnel !
 
Normalement, une fois arrivé ici, cela doit fonctionner pour la plupart d'entre vous. Vous pouvez rebooter le routeur et vérifier que la configuration se réapplique bien à chaque fois.
 
4. Mais pourquoi chez moi ça ne marche pas ???
 
Il reste quand même un dernier petit souci à régler pour certain. Avant d'envisager de tuer votre famille et de les manger assaisonné d'une sauce au routeur cuit sur un feu fait de vos neveux, sachez qu'il existe encore des petits détails développés exprès pour névroser les gens.
 
Chez moi ça n'a pas marché. Pourtant tout était correcte ! Je voyais bien les paquets multicast traverser le routeur dans la joie et la bonne humeur, et arriver sur le NAS.
Malheureusement, j'ai découvert (à 3h du mat') que minidlna (qui est mon serveur DLNA) possède une "sécurité":
- il filtre les requêtes multicast ne venant pas du réseau de l'interface (192.168.24.xxx chez moi).
Alors pour ce dernier problème, je n'ai trouvé qu'une seule solution: recompiler minidlna avec le patch suivant:
https://svn.redports.org/lippe/net/ [...] er-subnets
Une fois fait, ça fonctionne chez moi.
J'ignore ce qu'il en est des autres serveur DLNA. Mais sachez que ce dernier problème ne peut venir que de votre serveur DLNA.
Et voila..
 
Bonne chance !
 

mood
Publicité
Posté le 20-05-2013 à 12:45:12  profilanswer
 

n°693858
Greg
Posté le 01-09-2013 à 21:59:57  profilanswer
 

Salut Fuli10,
 
Tout d'abord, merci pour ce tuto qui a le mérite de tout rassembler.
Je n'ai rien trouver d'équivalent !! Ca, c'est pour tes chevilles ;)
 
Malheureusement, ca n'a pas résolu mon problème.
 
J'aimerai t'exposer ma config...
 
Config :
HP Prolian N54L + ESXi 5.1 + VM Xpenology DSM 4.2
WRT54G v2.2 + DD-WRT v23 SP2 vpn
Freebox V5 en mode bridge
 
J'ai repris tes indications une à une.
 
1. Premier problème: Identifier sa freebox HD
A ce sujet, je n'ai pas bien compris tes explications.
J'ai déjà remarqué que cette ip est la même pour tout le monde.
Et je ne vois pas bien l'intérêt de la connaitre (CF : point 2).
 
2. Second problème: Router le protocole DLNA depuis la freebox HD vers le serveur
Là encore, je ne t'ai pas bien suivi.
Il s'agit de faire un NAT dans ce cas, il n'est pas possible de préciser la source.
Le NAT se fait dans tous les cas sur l'interface WAN du routeur donc voici ce que j'ai mis en place en reprenant les infos de l'interface du WRT54G :

Code :
  1. Application - Port from - Protocol - IP Address  - Port to  - Enable
  2. DLNA-1      -  1900     -  UDP     - 172.18.0.14 - 1900     - coché
  3. DLNA-2      -  50001    -  Both    - 172.18.0.14 - 50001    - coché
  4. DLNA-3      -  50002    -  Both    - 172.18.0.14 - 50002    - coché


 
3. Configurer le multicast
3.a Autoriser le multicast à passer

Ok c'est décoché. Y a-t-il un moyen de le confirmer ?
Je ne vois même pas le processus igmprt en faisant un ps en ssh sur le WRT54G ?!
 
3.b Mais la freebox HD, elle n'a pas une IP sur internet ! Comment je fais :??:
Pour cette partie, je suis passé par le menu Administration/Commands.
J'ai l'impression que nous n'avons exactement les mêmes options puisque je n'ai pas l'encart custom.
Je n'ai que "startup" et "firewall".
J'ai donc inclus cette partie dans "startup".
Je crois que la partie "firewall" ne permet que des commandes iptables.
J'ai donc mis le script dans la partie "startup".
Pour ma part ma config est la suivante :
vlan0 = LAN
vlan1 = WAN
WLAN inclus au LAN
 
Voici donc mon script :

Code :
  1. sleep 20
  2. killall igmprt
  3. cat <<EOF> /tmp/igmpproxy.conf
  4. quickleave
  5. phyint vlan1 upstream  ratelimit 0  threshold 1 altnet 212.27.38.0/24
  6. phyint br0 downstream  ratelimit 0  threshold 1
  7. phyint eth0 disabled
  8. phyint eth1 disabled
  9. phyint vlan0 disabled
  10. phyint lo disabled
  11. EOF
  12. /usr/sbin/igmprt /tmp/igmpproxy.conf &


 
Est-il bien adapté ?
 
3.c Bon, tout est là mais ça ne marche toujours pas ! Pourquoi :??:
Pour augmenter la TTL, j'ai modifié le vlan à adapter :

Code :
  1. /usr/sbin/iptables -A PREROUTING -t mangle -i vlan1 -d 239.255.255.250 -j TTL --ttl-set 4


J'a mis cette partie dans "firewall".
 
4. Mais pourquoi chez moi ça ne marche pas ???
Je ne sais pas si Video Station peut avoir une limitation identique.
 
 
Bon, bah voilà. Tu sais tout sur ma config.
Si tu as des pistes, je suis preneur...
Ce que je me demande, c'est comment s'assurer que le multicast arrive sur le DLNA.
Je n'ai pas de tcpdump sur le wrt ou sur le serveur dlna donc suivre les packets me semble difficile (sans matériel spécifique).
 
Merci par avance...
 
a+
Grégory

Message cité 1 fois
Message édité par Greg le 01-09-2013 à 22:33:01

---------------
Nul n'est trop bon et peu le sont assez.
n°705023
Fuli10
Le gras, c'est la vie !
Posté le 07-10-2013 à 15:31:00  profilanswer
 

Hello (oui, j'ai mis un peu de temps avant de voir qu'il y avait ce message  :kaola:)
 
Je vais essayer de répondre à chacune de tes questions:
 

Greg a écrit :


1. Premier problème: Identifier sa freebox HD
A ce sujet, je n'ai pas bien compris tes explications.
J'ai déjà remarqué que cette ip est la même pour tout le monde.
Et je ne vois pas bien l'intérêt de la connaitre (CF : point 2).


 
Ca c'est parce que je ne sais pas si l'IP change ou pas. Mais oui, c'est utile de la connaitre tout simplement pour des raisons de sécurité: n'autoriser que ta freebox HD à lire le contenue DLNA de ton NAS.
 

Greg a écrit :


2. Second problème: Router le protocole DLNA depuis la freebox HD vers le serveur
Là encore, je ne t'ai pas bien suivi.
Il s'agit de faire un NAT dans ce cas, il n'est pas possible de préciser la source.
Le NAT se fait dans tous les cas sur l'interface WAN du routeur donc voici ce que j'ai mis en place en reprenant les infos de l'interface du WRT54G :

Code :
  1. Application - Port from - Protocol - IP Address  - Port to  - Enable
  2. DLNA-1      -  1900     -  UDP     - 172.18.0.14 - 1900     - coché
  3. DLNA-2      -  50001    -  Both    - 172.18.0.14 - 50001    - coché
  4. DLNA-3      -  50002    -  Both    - 172.18.0.14 - 50002    - coché




 
En théorie dans le firmware WRT, on peut configurer le NAT en précisant une adresse source (ou un range) autorisée. Cela active le NAT pour le transfert d'un port A à une machine + port B, et en même temps cela règle le filtrage IP pour n'autoriser que le range d'IP source à se connecter au port A de ton routeur. D’où l’intérêt de préciser l'IP source.
Cela est en général très pratique pour sécuriser un peu certains services critiques (genre VPN) qui tu limites qu'à certaines IP (boulot, certains amis, etc.).
 

Greg a écrit :


3. Configurer le multicast
3.a Autoriser le multicast à passer

Ok c'est décoché. Y a-t-il un moyen de le confirmer ?
Je ne vois même pas le processus igmprt en faisant un ps en ssh sur le WRT54G ?!


 
Pour le coup, c'est peut-être spécifique à ton routeur ou à la version d'openWRT. J'ai cru voir que le service igmprt a évolué, mais je ne me rappel plus du nouveau nom du service. Dans le pire des cas, essaye de voir ce qui se passe si tu lance manuellement igmprt depuis un ssh sur ton routeur (si ça lance quelque chose ou pas). Voir fait un delta sur la commande ps entre le filtre IGMP activé et désactivé. Juste histoire de voir si ça lance quelque chose.
Après, il faut peut-être un reboot en plus entre le filtre actif et désactivé.
 

Greg a écrit :


3.b Mais la freebox HD, elle n'a pas une IP sur internet ! Comment je fais :??:
Pour cette partie, je suis passé par le menu Administration/Commands.
J'ai l'impression que nous n'avons exactement les mêmes options puisque je n'ai pas l'encart custom.
Je n'ai que "startup" et "firewall".
J'ai donc inclus cette partie dans "startup".
Je crois que la partie "firewall" ne permet que des commandes iptables.
J'ai donc mis le script dans la partie "startup".
Pour ma part ma config est la suivante :
vlan0 = LAN
vlan1 = WAN
WLAN inclus au LAN
 
Voici donc mon script :

Code :
  1. sleep 20
  2. killall igmprt
  3. cat <<EOF> /tmp/igmpproxy.conf
  4. quickleave
  5. phyint vlan1 upstream  ratelimit 0  threshold 1 altnet 212.27.38.0/24
  6. phyint br0 downstream  ratelimit 0  threshold 1
  7. phyint eth0 disabled
  8. phyint eth1 disabled
  9. phyint vlan0 disabled
  10. phyint lo disabled
  11. EOF
  12. /usr/sbin/igmprt /tmp/igmpproxy.conf &


 
Est-il bien adapté ?


 
En fait comme je l'ai dis, normalement tu devrais déjà avoir un fichier /tmp/igmpproxy.conf sans avoir besoin de créer un script. Si ce fichier existe déjà, c'est que le service igmprt doit exister sur ton routeur. Si t'as un autre service (qui fait la même chose), faudra adapter le script de ce service.
Si ce fichier existe, il faut le "patcher" pour ajouter l'option "altnet" dans l'upstream. Le seul moyen que j'ai trouvé pour le patcher facilement est l'utilisation de "cat" et reprendre tout le contenu en ajoutant l'option "altnet" manuellement. Il existe peut-être un moyen plus propre, mais je ne le connais pas.
Après, rien ne t'interdis de tester l'étape à la main en le modifiant via vi et en relançant le service igmprt. C'est ce que j'ai fais des milliers de fois au début avant de me rendre compte qu'il manquait le TTL.
 

Greg a écrit :


3.c Bon, tout est là mais ça ne marche toujours pas ! Pourquoi :??:
Pour augmenter la TTL, j'ai modifié le vlan à adapter :

Code :
  1. /usr/sbin/iptables -A PREROUTING -t mangle -i vlan1 -d 239.255.255.250 -j TTL --ttl-set 4


J'a mis cette partie dans "firewall".


 
Pour le coup, je ne sais pas dans quel ordre les scripts se lancent réellement. Comme je dis à la fin, mieux vaut pour ton cas essayer d'abord la configuration manuelle, puis essayer l'automatisation via un script une fois la configuration validée.
 

Greg a écrit :


4. Mais pourquoi chez moi ça ne marche pas ???
Je ne sais pas si Video Station peut avoir une limitation identique.


 
Il y a de forte chances que le serveur n'aime pas ça, vu que faire passer de l'IGMP à travers un réseaux, c'est un peu comme essaye de faire passer un paquebot via un péage autoroutier: ce n'est pas prévu pour. Du coup, les concepteurs de serveurs DLNA ne doivent pas tous se casser la tête et supporter les réseaux "exotiques". C'est aussi pour ça que le patch pour minidlna n'est (toujours ?) pas inclus par défaut.
 

Greg a écrit :


Bon, bah voilà. Tu sais tout sur ma config.
Si tu as des pistes, je suis preneur...
Ce que je me demande, c'est comment s'assurer que le multicast arrive sur le DLNA.
Je n'ai pas de tcpdump sur le wrt ou sur le serveur dlna donc suivre les packets me semble difficile (sans matériel spécifique).
 
Merci par avance...
 
a+
Grégory


 
Ah, pour le coup j'ai pas mal utilisé tcpdump depuis le routeur.
J'ai fais fasse aux problèmes suivants en les réglants d'abord en manuel un à un:
- les requêtes de la freebox HD arrivaient mais ne passaient pas => récupération de l'IP de la Freebox, réglage NAT
- les requêtes de la freebox HD arrivaient mais ne passaient toujours pas => autorisation igmprt (igmprt apparaissait dans un ps)
- les requêtes de la freebox HD arrivaient mais ne passaient toujours pas => réglage igmprt avec altnet (modification avec vi + arret/lancement manuel du service) + pleurage
- les requêtes de la freebox HD arrivaient mais ne passaient toujours pas => réglage TTL (commande "iptable" entrée manuellement) + "Allélouia ! Ca passe mais pourquoi ça répond pas ?!"
- les requètes de la freebox HD traversaient (ENFIN!) mais pas de réponses depuis le NAS => analyse des logs du serveur DLNA sur le NAS + limite un coup de pieds dans le tas pour avoir refusé de répondre (il était tard).
Et une fois le problème du NAS résolu, les réponses et tout passaient sans problèmes => au lit, j'ai même fais un beau rêve.
Seulement une fois le problème résolu manuellement, j'ai cherché à automatiser le démarrage. D’où le tuto avec les scripts.
Pour ton cas, essaye de voir d'abord en manuel ce qui se passe.
 
Pour info, chez moi un ifconfig me permet de voir l'interface utilisée sur internet:

Code :
  1. vlan2     Link encap:Ethernet  HWaddr 99:22:55:AA:77:00 
  2.           inet addr:82.X.X.X  Bcast:82.X.X.255  Mask:255.255.255.0


 
Et du coup pour sniffer les requêtes IGMP:

Code :
  1. tcpdump -i vlan2 udp port 1900


 
C'est quand même bien pratique pour se rendre compte de ce qui se passe. Et puis les logs sur le serveur DLNA m'ont permis de voir les requêtes arriver (pour ne jamais y répondre, sauf après le patch).
 
Bon courage !

n°818173
Greg
Posté le 17-12-2014 à 12:02:43  profilanswer
 

Salut Fuli10,
 
Merci d'avoir répondu même en retard !! Ce que je fais aussi à mon tour ^^
Je réveille un peu ce post qui me tenait à coeur mais dont je n'avais toujours pas finalisé le sujet.
 
Alors pour commencer, ça marche et pour ça je t'en remercie beaucoup :)
 
Entre temps, j'ai acheté un nouveau routeur pour remplacer mon wrt54g vieillissant. J'ai acheté un WDR4900 (ya un post sur le sujet!) que je n'avais toujours pas flashé DD-WRT jusqu'à hier soir :)
 
J'ai suivi les étapes indiquées:
1. Premier problème: Identifier sa freebox HD
 - la même pour tous il me semble : 212.27.38.253.
2. Second problème: Router le protocole DLNA depuis la freebox HD vers le serveur
 - j'ai enfin dans le firmware actuel le champ Source qui me manquait sur le firmware de mon wrt54g et effectivement ca me génait d'ouvrir ça à tous.
 - j'utilise plex sur un xpenology. J'ai donc adapté le NAT en fonction des besoins de plex.
3. Configurer le multicast
3.a Autoriser le multicast à passer
 - rien de plus simple : une case à décocher
3.b Mais la freebox HD, elle n'a pas une IP sur internet ! Comment je fais :??:  
 - j'ai pu adapter le script custom.sh en fonction de mon fichier /tmp/igmpproxy.conf (accès ssh pour le voir)
 - cette étape ne pouvait pas être franchi sur mon wrt54g puisque igmprt n'était pas intégré  
3.c Bon, tout est là mais ça ne marche toujours pas ! Pourquoi :??:
 - ajout de la règle iptable indispensable !
 
Et voilà, pas besoin d'étape 4 pour moi.  
 
Merci encore !!
J'espère que ça pourra en intéressé d'autres :))
 
Bonnes fêtes de fin d'année à tous...
Bye

n°818244
Fuli10
Le gras, c'est la vie !
Posté le 17-12-2014 à 16:28:21  profilanswer
 

@Greg:
De rien, content de voir que ça a servit à quelqu'un :D
 
Sinon, je suis tombé sur un 4 par accident: un nouveau problème !
En fait, après avoir rebooté le routeur, je perdais la configuration.
Le problème était tout simple: la NVRAM de mon routeur (32K) était trop petit pour stocker tout ce que dd-wrt avait besoin, et du coup ca saturé la NVRAM. En saturant, la configuration du script qui modifiait igmpproxy a été effacé du system. Resultat, à chaque reboot bye bye le DLNA.
Ma solution: utilisation d'un dd-wrt en mini (bye bye openVPN, HTTPS, et SNMP) mais bonjour JFFS2, ce qui m'a permit de sauver le script en flash et de ne pas saturer la NVRAM.
 
Accessoirement, je regarde si j'ai le temps de tester une autre configuration à base de VLAN, en connectant la freebox HD derrière le routeur au lieu de derrière la Freebox.

n°818261
Greg
Posté le 17-12-2014 à 18:24:44  profilanswer
 

32K !! Outch  :pt1cable:  
 
Dommage pour le SNMP, c'est ce qu'il me manque pour le moment sur mon WDR4900 (firmware beta oblige !).
 
Si tu joues sur les VLAN, ca m'intéresse aussi !! J'avais trouvé ça lors de mes recherches : http://guillaume.vaillant.me/?p=256.
C'est sur une freebox v6 mais ça peut peut-être te servir !??!
 
Je garde un oeil sur ce post ;)
 
++

n°838574
Fuli10
Le gras, c'est la vie !
Posté le 18-03-2015 à 22:32:56  profilanswer
 

Hello,
je déterre un peu ce sujet.
Alors j'ai un peu séché avec la configuration des vlan sous dd-wrt. Du coup je suis passé sous openWRT (barrier breaker) et les VLAN fonctionnent mieux, même si j'ai encore des petits problèmes: je n'arrive pas à faire de tcpdump sur le VLAN.
Alors pour info, il est complètement possible de brancher la box HD derrière un routeur (openWRT dans mon cas) et d'avoir qu'un seul cable entre le port WAN du routeur et la freebox.
En fait c'est trouvable un peu partout sur le net et c'est super simple: il suffit de créer un switch entre le port ou la box HD sera connecté et le port WAN, cet interface étant taggué VLAN 100. Et zou ça marche.
Par contre avec la v5 il n'y a aucune communication sur le VLAN classique qui se fait entre la box TV et le serveur (ou il y a un bug dans openWRT, ce qui est possible). Donc si on regarde la TV, ça utilise du CPU côté routeur, et comme je viens de découvrir que le CPU limite le débit WAN<->LAN, c'est un peu useless si on peu rester connecté à la box.
 
Autrement, je viens de développer une option dans le serveur minidlna qui devrait rendre le serveur capable de traverser un réseau. Mais ça je vais faire un autre tuto pour l'expliquer. J'espère juste que cet option (ou avec un autre nom) sera mis un jour ou l'autre dans la version officielle :jap:

n°851759
Teflon1
Posté le 21-05-2015 à 14:32:50  profilanswer
 

Je cherche justement à faire ce que tu décrit, Fuli10 :

Citation :


Alors pour info, il est complètement possible de brancher la box HD derrière un routeur (openWRT dans mon cas) et d'avoir qu'un seul cable entre le port WAN du routeur et la freebox.
En fait c'est trouvable un peu partout sur le net et c'est super simple: il suffit de créer un switch entre le port ou la box HD sera connecté et le port WAN, cet interface étant taggué VLAN 100. Et zou ça marche.  


 
Sauf que je n'utilise mon routeur que comme un switch (donc box adsl branchée sur un port LAN du switch au lieu du port WAN)
 
J'ai essayé de créer un vlan 100 taggué sur les 2 ports de mon routeur/switch mais la connection Freebox TV / Freebox Adsl ne marche toujours pas. Est-ce qu'il faut créer autre chose comme un bridge entre les 2 ?

n°851785
Fuli10
Le gras, c'est la vie !
Posté le 21-05-2015 à 15:32:43  profilanswer
 

@Teflon1: Normalement si le routeur fonctionne bien comme un switch, il n'y a rien à configurer. Par contre ton problème ne serait pas lié au fait que ton routeur fait serveur DHCP (en conflit avec celui de la box) ?
Le serveur est bien en mode routeur ?

n°851799
Teflon1
Posté le 21-05-2015 à 16:00:23  profilanswer
 

Merci pour ta réponse rapide !
 
J'ai bien désactivé le dhcp et j'ai accès à internet quand je branche un pc sur le routeur (le linksys e1200).
 
Cependant la freebox TV ne veut pas se synchroniser avec la freebox Adsl (en connexion directe ou par freeplay ca marche). J'ai cru comprendre que c'était à cause du Vlan 100 utilisé par les 2 freebox pour communiquer et qu'il fallait configurer un Vlan taggued VID 100 sur les ports du switch.

mood
Publicité
Posté le 21-05-2015 à 16:00:23  profilanswer
 

n°851815
Fuli10
Le gras, c'est la vie !
Posté le 21-05-2015 à 16:30:01  profilanswer
 

Oui, normalement faut créer un bridge taggué avec VID100 entre les 2 ports, mais normalement c'est valable si tu veux passer entre WAN et LAN. La, entre 2 ports du switch LAN ça devrait (normalement) être transparent. Par exemple chez moi j'utilise un bête switch ou ma freebox TV est connecté dessus, puis un routeur entre le switch et le serveur.
Je n'ai RIEN configuré sur le switch (pourtant manageable).
Par contre j'ai créé un bridge sur le routeur entre le LAN et le WAN, sans lui donner d'IP, et ça marche.
En gros chez moi c'est


Freebox HD   ---------+
                      |
PC   -------------- SWITCH ------- LAN/Routeur/WAN ---------- Freebox ---- internet
                      |
Wifi (port LAN) ------+


SWITCH: zero configuration
Routeur:
- configuration réseau tout simple (réseau 192.168.0.X sur le LAN, et DHCP client sur le WAN)
- + bridge entre lan.100 (LAN taggé VIF 100) et wan.100 (WAN taggé VIF 100)
- + la config igmpproxy/iptable du tuto (qui ne marche pas sur mon nouveau routeur, mais là je ne sais pas pourquoi)

n°851832
Teflon1
Posté le 21-05-2015 à 17:23:37  profilanswer
 

OK voici ma config moi
 

Code :
  1. internet
  2. |
  3. Freebox Adsl  --------+ vlan1 taggé et vlan100 taggé
  4.                       |
  5. PC   ------vlan1----- SWITCH (linksys E1200 sans utiliser le port WAN)
  6.                       |
  7. Freebox HD -----------+vlan100 taggé


 
de mon coté je viens de réussir a faire marcher ma TV, pour ca j'ai du installer shibby tomato sur mon E1200 pour pouvoir créer un vlan taggé VID100 sinon ca ne marchait pas, j'imagine que les vlan taggé ne sont pas géré pareil selon les modèles de switch/routeur ...
Par contre j'ai perdu la connection internet sur le PC, qui est pas sur le VLAN 100 mais sur le VLAN par défaut sur lequel j'ai mis aussi la freebox adsl en taggé.
je pense que j'y suis presque  :)  
 
sinon pour ton soucis avec igmpproxy je n'ai pas d'idée à te donner désolé
 
edit : Ok mon dernier soucis est réglé en changeant les parametre de vlan via la CLI pour mettre le vlan1 untagged sur le port freebox adsl.


Message édité par Teflon1 le 21-05-2015 à 18:02:47
n°878045
metamax92
Posté le 17-10-2015 à 19:52:54  profilanswer
 

Bonjour,
 
Je viens d'essayer d'adapter à ma configuration Freebox V5 + Routeur NETGEAR FVX538.
 
J'ai créé les 2 règles NAT sur le routeur afin de rediriger les ports 1900 et 5001-5002 (DLNA SYNOLOGY) de l'IP 212.27.38.253 vers le NAS qui sert le DLNA.
 
Toujours sur le routeur, j'ai une page IGMP où j'ai autorisé le PASS THROUGH.
Je dois aussi spécifier l'adresse de la Freebox qui fera les appels DLNA en précisant son IP et son masque.
Du coup j'entre 212.27.38.253, par contre dans le masque, je ne sais pas quoi entrer.
J'ai fait quelques essais avec 255.255.255.255 ou 255.255.255.0 ou 255.255.255.250 mais cela ne semble pas fonctionner.
 
Merci pour le coup de main !


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Réseaux grand public / SoHo
  Tutoriels

  [Tuto] Freebox v5 en bridge, Freebox HD, routeur dd-wrt et UPnP DLNA

 

Sujets relatifs
Problème de flash Routeur WifiMise en place d'un routeur avec 2 passerelle wan
Pont entres Box et routeurRouteur client VPN PPTP/L2TP + modem
pb reseaux freebox v5Porbleme routeur TP-Link TL-WR1043ND plus freebox v6 mode bridge
Carte micro SD sur routeur 3G Wifi Huawei e5776s 
Plus de sujets relatifs à : [Tuto] Freebox v5 en bridge, Freebox HD, routeur dd-wrt et UPnP DLNA



Copyright © 1997-2016 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR