Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1158 connectés 

 


 Mot :   Pseudo :  
 
 Page :   1  2  3  4
Page Suivante
Auteur Sujet :

[TUTO] Base de données XBMC sous phpMyAdmin ~~ Sauvegarde BDD ~~

n°790256
xbmtof
Posté le 30-08-2014 à 18:16:40  profilanswer
 

Reprise du message précédent :
Bonjour , j'utilise XBMC depuis un an et demi sur un RaspBerry avec openElec.  
Mes films (environ 1500) sont stockés sur un Syno DS212 avec la base se donnée PHP.
Tout comme tu l'expliques dans ton TUTO qui arrive malheureusement un peu tard pour moi (il m'aurait évité bien des recherches à l'époque).
Tout est scrappé, propre, renommé lorsque besoin s'en faisait sentir, ceci afin que les films apparaissent dans l'ordre (exemple, dans le titre du film j'ai pas exemple Rocky 1, Rocky 2 la revanche, ... )
 
Tout a été retravaillé à la main et via requêtes sur PhpMyAdmin afin que l'affichage des listes XBMC sur la TV soit optimal et pratique (j'utilise la télécommande de ma TV via la norme CEC).
Mes films sont tous dans un répertoire unique portant le nom du film.
Ces mêmes répertoires sont repris dans d'autres afin d'avoir une facilité de recherche en passant via le menu VIDEO d'XBMC : exemples FILMS, FILMS_ENFANT, DESSINS_ANIMES, DOCUMENTAIRES, ....
 
Tout fonctionne très bien, et je viens d'ailleurs de passer à la version 4.0.7 (XBMC 13.1 Gotham stable). Je scrape depuis un PC pour la facilité, mais malheureusement je n'ai jamais stocké les images et fanarts dans les répertoires, ce qui fait que ceux-ci se trouve en cache sur le portable et que le Raspberry va les chercher au fur et à mesure sur le net.
J'ai remarqué depuis un certain temps que 2 serveurs d'image étaient souvent répertoriés au niveau du lien des images. Certaines fois un de ces serveurs semble être down, ce qui fait que les images ne s'affichent pas sur ma TV. De plus, ma connexion internet n'est pas des plus véloce ...  
 
Alors voici ma question : quelqu'un connait-il un utilitaire permettant en masse de :
1) télécharger les images (jaquette + fanart) référencées dans DB en C8 et C20
2) de placer ces images (en les renommant si besoin) dans le répertoire du film
3) d'effectuer le remplacement au niveau de la DB des champs C8 et C20 (jaquette et fanart)
 
Vous comprenez qu'avec le nombre de films et le temps déjà passé à scraper, je n'ai pas l'envie de devoir recommencer à scraper film par films avec XBNE, devoir de nouveau sélectionner le fanart, la jaquette, et cela avec le risque de perdre des informations déjà retravaillées (nom du film et parfois résumé).
 
Merci d'avance.

mood
Publicité
Posté le 30-08-2014 à 18:16:40  profilanswer
 

n°790301
frenchieis​verige
Nej, men HEJSAN!
Posté le 30-08-2014 à 21:58:14  profilanswer
 

:hello:
Il y a un truc que je pige pas dans ton histoire...
Ta base de données est stockés sur ton nas ou ton portable ???
Puis un début de piste: tu me dis que tu as fait récemment la mise à jour vers la v13. Or Xbmc à chaque update majeure il change de nom de base de données. C'est passé de myvideo75 à myvideo78 pour la v13.


---------------
Mod: Corsair WATER 540 Aqua Marine || Linux: [TU] Elementary OS | [TU] OpenMediaVault || A/V: ICI
n°790352
xbmtof
Posté le 31-08-2014 à 11:24:57  profilanswer
 

frenchieisverige a écrit :

:hello:  
Il y a un truc que je pige pas dans ton histoire...  
Ta base de données est stockés sur ton nas ou ton portable ???
Puis un début de piste: tu me dis que tu as fait récemment la mise à jour vers la v13. Or Xbmc à chaque update majeure il change de nom de base de données. C'est passé de myvideo75 à myvideo78 pour la v13.


 
Salut frenchieisverige,  
Oui ma DB est sur le NAS. J'ai updaté et j'ai remarqué hier en effet qu'elle était passée de myvideo75 à 78.
Mais cela était totalement transparent, tout fonctionne comme avant.
Je voulais trouver un script permettant de télécharger les photos référencées dans la base de donnée (vignettes et fanarts), de les sauvegarder dans le répertoire du film,
et de remplacer le lien http par un lien local. Ainsi, même sans internet, les images seraient toujours disponibles (car problème sans internet lorsqu’elles ne se trouve pas dans le cache).
Les images seraient alors toujours disponibles sur mon réseau sans besoin d'internet pour les afficher.
 
J'ai effectué des tests hier soir, à chaque film que je survolais avec mon Rasp, je remarquais une latence due au chargement des images.
Si les vignettes et fanarts étaient locaux, leur "téléchargement" serait plus rapide (j'ai une mauvaise connexion internet) et la mise en cache serait plus rapide aussi du coup.
Donc, voila pourquoi je recherche cet utilitaire.
 
J'ai lu que depuis Frodo, les thumbs sont stockés dans un cache local à chaque machine et que le fichier textures13.db était le cache pour les fanarts et vignettes.
Et que de toute manière, textures13.db était prioritaire.
Cependant pour alimenter la première fois le cache, je dois parcourir les films un à un, attendre que les photos s'affichent afin qu'il fasse la mise en cache.
Comme c'est une nouvelle install, me taper le parcours des 1500 films et attendre le chargement c'est long et fastidieux.
N'y aurait-il pas moyen de charger en masse le fichier textures13.db via un utilitaire afin d'éviter tout ce temps perdu ?  
Sais-tu si le fichier textures13.db est limité en taille (hormis l'espace physique sur lequel il se trouve) ?
 
Tak tak d'avance.  ;)


Message édité par xbmtof le 31-08-2014 à 11:27:53
n°793274
matteu
Posté le 11-09-2014 à 15:27:21  profilanswer
 

Alors, petit soucis pour ma part !
je tiens a préciser que je n'ai pas suivi a la lettre le tuto car le passage xbne n'est pas obligatoire.  
donc j'ai bien phpmyadmin le user xbmc ainsi que le fichier advanced etc...
 
Le probleme est que dans un dossier film j'ai 260 dossier dans lesquels un film a chaque fois. Le titre du dossier etant le titre du film.
je passe par le scrapper MDB et dans ma BDD seulement 170entrées sont crées... d'ou pourrait venir le probleme ?


---------------
Mon Feedback---Mes ventes
n°793278
WizardPC
Posté le 11-09-2014 à 15:51:28  profilanswer
 

Est-ce que tu as regroupé tes films en saga ? C'est une option dans XBMC


Message édité par WizardPC le 11-09-2014 à 15:51:54

---------------
Modding/Watercooling : PiBoy! ~ WaterBox // Achat / Vente !!
n°793284
matteu
Posté le 11-09-2014 à 16:20:53  profilanswer
 

Solution trouvé : il fallait mieux renommer mes dossiers.
en gros, enlever la date dans les noms des dossiers OU la mettre entre parenthese mais bambi.2013 c'est pas une bonne idée :) donc ca a donné bambi et la il a tout trouvé impec !
 
sinon je ne sais pas trop ce que tu veux dire par en saga, parce que j'ai xmen1 2 3 4 par exemple, ca apporterait quoi ?


---------------
Mon Feedback---Mes ventes
n°802819
remiXc
Posté le 24-10-2014 à 21:47:09  profilanswer
 

Bonjour,
 
J'espère que quelqu'un verra mon message car je suis un peu perdu.
Je m'explique : je veux créer l'utilisateur xbmc, mais j'obtiens l'erreur suivante :
 

Citation :

#1064 - You have an error in your SQL syntax;
check the manual that corresponds to your MariaDB server version for the right syntax to use near '* TO 'xbmc'@'%" at line 1


 
L'utilisateur se crée tout de même. Si je modifie par la suite les privilèges et que je coche tout, j'obtiens :
 

Citation :


#1045 - Access denied for user 'root'@'localhost' (using password : YES)


 
Après quelques recherches, cela viendrait de la présence d'un utilisateur "vide". Effectivement, j'ai un utilisateur "N'importe quel" avec comme client "DiskStation". Le problème est que je n'arrive pas à supprimer cet utilisateur.
 

Citation :

#1396 - Operation DROP USER failed for "@'diskstation'  
#1064 - You have an error in your SQL syntax;
check the manual that corresponds to your MariaDB server version for the right syntax to use near '* TO 'xbmc'@'%" at line 1


 
 
Quelqu'un a t-il une solution ?
 
Merci d'avance.


Message édité par remiXc le 24-10-2014 à 22:37:54
n°802830
remiXc
Posté le 24-10-2014 à 22:39:08  profilanswer
 

Je réponds moi même car ça peut servir à d'autres personnes!
 
J'ai finalement réussi à supprimer l'utilisateur vide à force d'essayer de le supprimer. C'était bien cet utilisateur qui empêcher la bonne création de l'utilisateur xbmc.
 
Parfait :)

n°802833
WizardPC
Posté le 24-10-2014 à 22:57:24  profilanswer
 

Merci du retour :) par contre comment il est venu cet utilisateur ?


---------------
Modding/Watercooling : PiBoy! ~ WaterBox // Achat / Vente !!
n°802837
remiXc
Posté le 24-10-2014 à 23:11:06  profilanswer
 

Il a surement été créé automatiquement par mon NAS Synology lorsque j'ai créé un petit site web sous wordpress (ou à un autre moment, mais en tout cas, c'est une création automatique !).
 
J'ai une question par rapport à tout ça :
 
C'est possible de tout gérer avec XBMC, mais juste éditer les quelques films non trouvés via XBNE ? (sans tout casser!)
Car je trouve qu'ajouter tous les films un à un et créer des dossiers pour chacun d'eux est un peu exagéré !
 
Merci

mood
Publicité
Posté le 24-10-2014 à 23:11:06  profilanswer
 

n°802857
WizardPC
Posté le 25-10-2014 à 00:01:34  profilanswer
 

Oui bien sur tu peux laisser XBMC scrapper tout seul. C'est comme ça que ça se passe normalement ;) et donc tu ne corrige/ajoute que ceux que tu veux via XBNE, faut juste les supprimer dans XBMC avant ! :o


---------------
Modding/Watercooling : PiBoy! ~ WaterBox // Achat / Vente !!
n°802881
remiXc
Posté le 25-10-2014 à 08:50:48  profilanswer
 

Voici ce que j'ai fait pour l'instant :
 
- Création user xbmc sur phpMyAdmin avec tous les droits
- Création du fichier de configuration sur le raspberry
- Démarrage de XBMC sur le raspberry
- La base de données a bien été créée, et les films y sont bien présents.
 
Mais, ce qui me pose problème, c'est l'utilisation de XBNE. (Sachant que je ne veux pas créer de dossier par film, ni avoir les fichiers nfo et autres sur le NAS)
J'ai essayé de configurer XBNE pour qu'il accède à la bdd, mais j'obtiens une erreur.
 
 
Quelqu'un peut-il me dire, étape par étape, ce que je dois faire depuis XBNE pour pouvoir ajouter les quelques films non trouvés par XBMC (enfin, le scraper n'a rien trouvé sur eux) et que j'ai supprimé d'XBMC ?
 
Merci d'avance :)

n°802987
lekeb
Posté le 25-10-2014 à 15:49:24  profilanswer
 

salou a tous!! super bon tuto!!
donc voilamom probleme!
J'utilise wamp server (pour phpmy admin et mysql), xbmc gotham et xbne!
Apres avoir creer le fichier advanced setting (avec pathsubstitution inclus), ma base de donnee xbmc s'est bien cree et nomme "xbmc_video". Apres le parametrage de xbne, celui-ci me renomme ma BDD mysql en "xbmc_video78" (okpourquoi pas!!). Le probleme est que maintenant quand je reouvre xbmc, il ne charge pas la BDD! j'ai essaye de changer le fichier advancedsetting pour renommer la BDD! Mais xbmc ne la trouve pas!!
avez vous une idee?
merci

n°818042
weyb06
Posté le 16-12-2014 à 17:34:16  profilanswer
 

bsr,
 
il n'y a plus personne depuis le 25/10 ?
quel dommage !!
car j'avais qq questions pour bien comprendre avant de me lancer dans l'aventure...
 
genre :
- j'ai déjà scrappé ma collec' de films et d'albums sur XBMC sur mon PC, dois-je TOUT refaire une fois que j'aurai créé la BDD sur mon NAS ? il n'y a pas moyen de tout récupérer (export + import) ?
- comment organiser les sagas ? "films/<xxx>/<xxxx 1>" <b>obligatoirement</b> ??? ou est-ce facultatif ?
- cette BDD sur le NAS peut aussi gérer les séries + albums ?
 
j'espère que qq saura me répondre car je pense avoir trouvé ici un super tuto...
 
cordt
 

n°818083
Romn
Posté le 16-12-2014 à 21:37:04  profilanswer
 

Si tout est scrappé avec XBMC sur ton PC, tu peux faire un export en différent fichier, il va créer un .nfo dans chaque dossier. Quand tu auras déplacé tes fichiers sur ton NAS, configuré ta bdd comme sur le tuto et que tu rescanneras ta source, il retrouvera toutes les infos directement.
 
Ça fonctionne bien évidemment aussi pour les séries et la musique (même si XBMC pour la musique ... :/ ). En fait toutes les bdd utilisées par XBMC seront sur ton NAS.
 
Pour les sagas je ne sais pas, je n'utilise pas (encore).


---------------
DVD |  Ludothèque: BGG
n°818220
weyb06
Posté le 17-12-2014 à 14:38:48  profilanswer
 

bjr,
mes films sont déjà sur mon NAS :)  
comment fait-on cet "export en différents fichiers" ?
cordt

n°818291
Romn
Posté le 17-12-2014 à 20:21:57  profilanswer
 

Dans XBMC :
Système > Paramètre > Vidéo > Médiathèque > Exporter la médiathèque > Plusieurs fichiers.


---------------
DVD |  Ludothèque: BGG
n°818392
weyb06
Posté le 18-12-2014 à 11:59:30  profilanswer
 

bjr
 
ça n'existe pas/plus sous Gotham...
:-(
(j'avais qd meme un peu cherché...)
 
OUPS : j'étais en mode "standard", ça existe en mode "avancé" !
 
merci !!!

n°819413
weyb06
Posté le 23-12-2014 à 16:13:56  profilanswer
 

bjr,
 
"Le répertoire name correspond au nom que tu vas donner à ta source dans XBMC. Cependant, il n'est pas obligatoire." (frenchieisverige)
 
j'ai tout fait comme on m'a dit (comme disait coluche), et ça ne marche pas... :-(
 
j'ai suivi le tuto pour installer phpmysql, et créer le user xbmc, le xml dans userdata.
j'ai lancé  xbmc gotham, ça m'a créé 2 tables MySQl "xbmc_music46" et "xbmc_video78", mais xbmc ne fait rien, il ne fait aucune analyse...
 
NOTA : j'ai bien exporté ma médiathèque en fichiers séparés (cf posts précédents), ce qui a créé des .nfo et des jpg, mais au démarrage de xbmc, je ne retrouve rien... :??:  
 
j'ai un plugin pour scrapper périodiquement (toutes les heures), mais ça ne fait rien, comme si xbmc ne trouvait rien. Dans "videos" j'ai pourtant mes 2 répertoires de films (étrangers et FR).
Par contre dans "musique" je n'ai plus le répertoire de mes CDs...
pourtant dans "sources.xml" tout est là...
 
Je précise que je suis dans la version "portable" de xbmc (cf tuto video sur youtube), donc mon chemin userdata est "C:\Program Files (x86)\XBMC\portable_data\userdata"
 
contenu de mon xml :
<advancedsettings>
     <videodatabase>
       <type>mysql</type>
       <host>192.168.0.2</host>
       <port>3306</port>
       <user>xbmc</user>
       <pass>xbmc</pass>
 
    </videodatabase>
 
    <musicdatabase>
       <type>mysql</type>
       <host>192.168.0.2</host>
       <port>3306</port>
       <user>xbmc</user>
       <pass>xbmc</pass>
 
    </musicdatabase>
 
</advancedsettings>
 
j'ai supprimé les lignes avec les <name>, relancé xbmc et ça m'a créé "xbmc_music4646" et "xbmc_video7878" :fou:  
 
si qq pouvait me dire ce qui ne va pas, ce serait vraiment super, ca rje galère depuis de nombreuses heures... :pt1cable:  
 
/!\ au fait, comment je fais pour pouvoir citer qq, ou mettre en italique ?? quel paramètre dois-je modifier ds mon profil ? je n'ai pas trouvé...  
pas doué, moi, aujourd'hui... :-(
 
cordt

n°820563
frenchieis​verige
Nej, men HEJSAN!
Posté le 30-12-2014 à 13:30:03  profilanswer
 

weyb06 a écrit :

bjr,
 
"Le répertoire name correspond au nom que tu vas donner à ta source dans XBMC. Cependant, il n'est pas obligatoire." (frenchieisverige)
 
j'ai tout fait comme on m'a dit (comme disait coluche), et ça ne marche pas... :-(
 
j'ai suivi le tuto pour installer phpmysql, et créer le user xbmc, le xml dans userdata.
j'ai lancé  xbmc gotham, ça m'a créé 2 tables MySQl "xbmc_music46" et "xbmc_video78", mais xbmc ne fait rien, il ne fait aucune analyse...
 
NOTA : j'ai bien exporté ma médiathèque en fichiers séparés (cf posts précédents), ce qui a créé des .nfo et des jpg, mais au démarrage de xbmc, je ne retrouve rien... :??:  
 
j'ai un plugin pour scrapper périodiquement (toutes les heures), mais ça ne fait rien, comme si xbmc ne trouvait rien. Dans "videos" j'ai pourtant mes 2 répertoires de films (étrangers et FR).
Par contre dans "musique" je n'ai plus le répertoire de mes CDs...
pourtant dans "sources.xml" tout est là...
 
Je précise que je suis dans la version "portable" de xbmc (cf tuto video sur youtube), donc mon chemin userdata est "C:\Program Files (x86)\XBMC\portable_data\userdata"
 
contenu de mon xml :
<advancedsettings>
     <videodatabase>
       <type>mysql</type>
       <host>192.168.0.2</host>
       <port>3306</port>
       <user>xbmc</user>
       <pass>xbmc</pass>
 
    </videodatabase>
 
    <musicdatabase>
       <type>mysql</type>
       <host>192.168.0.2</host>
       <port>3306</port>
       <user>xbmc</user>
       <pass>xbmc</pass>
 
    </musicdatabase>
 
</advancedsettings>
 
j'ai supprimé les lignes avec les <name>, relancé xbmc et ça m'a créé "xbmc_music4646" et "xbmc_video7878" :fou:  
 
si qq pouvait me dire ce qui ne va pas, ce serait vraiment super, ca rje galère depuis de nombreuses heures... :pt1cable:  
 
/!\ au fait, comment je fais pour pouvoir citer qq, ou mettre en italique ?? quel paramètre dois-je modifier ds mon profil ? je n'ai pas trouvé...  
pas doué, moi, aujourd'hui... :-(
 
cordt


 
:hello:
 
Alors je pense pas avoir la réponse à ta solution, mais je te donner quelques pistes pour essayer de résoudre ton problème.
 
Premièrement, j'utilise (encore) xbmc v12, car j'utilise encore la base de données my_video75. Et honnêtement j'ai la flemme de faire l'upgrade vers xbmc v13 (gotham) qui va recréer un nouvelle base de données my_video78. Va falloir que sauvegarder et transférer les datas, c'est chiant et honnêtement avec xbmc v12 àa marche encore très bien.
Je me concentre sur xbne car TheMovieDb a changé sa facon de se connecter, et donc xbne n'arrive plus à trouver les infos...
 
Bref, quand tu as scrappé pour la première fois, il me semble que c'est normal que XBMC ne "fasse" rien, car tu lui demande de lire les infos vers la BDD, et cette dernière est vide. (enfin j'ai un doute car ça fait longtemps que j'ai pas fait cette manip  :??:)
Donc c'est à toi d'éditer tes films avec xbne.
 
Pour citer quelqu'un, il suffit de cliquer sur l’icône avec un document et une flèche rouge vers la droite. Si tu laisse ta souris dessus, un message "répondre à ce message" apparaitra. :jap:


Message édité par frenchieisverige le 30-12-2014 à 13:32:15

---------------
Mod: Corsair WATER 540 Aqua Marine || Linux: [TU] Elementary OS | [TU] OpenMediaVault || A/V: ICI
n°822809
kaloskagat​os
Posté le 10-01-2015 à 00:25:40  profilanswer
 

Bonjour à tous,

 

J'ai configuré mon NAS avec une BD selon le tuto du topic, merci. Cependant je n'arrive finalement pas à réaliser l'intérêt de la manip, d'autant qu'après un formatage de mon PC quand j'ai tout reconfiguré j'ai perdu l'historique des films "déjà vus", que je pensais enregistré dans la BD...

 

Autre question: existe-t-il autre chose que XBNE pour accéder à cette base, par exemple une page PHP à héberger sur le NAS pour voir sa collection de n'importe où ? edit: genre ça si ça tourne sur synology ce serait pas mal http://forum.kodi.tv/showthread.php?tid=135046 ( https://github.com/3dfx/xbmcDB , https://www.youtube.com/watch?v=AoCFYvUaSm8 )

Message cité 2 fois
Message édité par kaloskagatos le 10-01-2015 à 00:31:33

---------------
« Le hasard, c’est différent de la chance. Parce que la chance, je n'en ai jamais. »
n°822943
Romn
Posté le 11-01-2015 à 08:48:24  profilanswer
 

kaloskagatos a écrit :

Bonjour à tous,
 
J'ai configuré mon NAS avec une BD selon le tuto du topic, merci. Cependant je n'arrive finalement pas à réaliser l'intérêt de la manip, d'autant qu'après un formatage de mon PC quand j'ai tout reconfiguré j'ai perdu l'historique des films "déjà vus", que je pensais enregistré dans la BD...


Tu as du louper quelques choses dans ta configuration, tu dois avoir ceci dans ton advancedsetting.xml:

Code :
  1. <videolibrary>
  2. <importwatchedstate>true</importwatchedstate>
  3. </videolibrary>


kaloskagatos a écrit :

Autre question: existe-t-il autre chose que XBNE pour accéder à cette base, par exemple une page PHP à héberger sur le NAS pour voir sa collection de n'importe où ? edit: genre ça si ça tourne sur synology ce serait pas mal http://forum.kodi.tv/showthread.php?tid=135046 ( https://github.com/3dfx/xbmcDB , https://www.youtube.com/watch?v=AoCFYvUaSm8 )


Tu peux facilement te faire une page web en php, hébergée sur le syno, qui consulte la bdd du syno et t'affiches la liste de tes médias (j'ai commencé à m'en faire une pour moi mais pas fini, faudra que je m'y replonge cet hiver). Après ça a l'air pas mal ce xbmcDB, je ne vois pas pourquoi ça ne marcherait pas sur le NAS.


---------------
DVD |  Ludothèque: BGG
n°823184
aceditnana​r
Posté le 12-01-2015 à 16:09:19  profilanswer
 

Le site de cette appli xbmcDB ne semble pas fonctionner... si ?

n°823804
spoky53
Posté le 15-01-2015 à 09:27:04  profilanswer
 

Bonjour tout le monde,
 
Intéressant ce tuto,
 
Tout est impect sur Windows ( user, bdd, xbmc) mais j'ai un problème.
 
déjà je suis sur kodi helix 14 et non sur gotham et j'ai le PC de salon qui tourne sur kodibuntu.
Je trouve le fichier advancedsettings.xml sous Lubuntu je le modifie mais impossible de relancer kodi après il me ramène toujours sur la page de choix du compte.
Si quelqu'un a une solution je suis preneur. :love:

n°823957
kaloskagat​os
Posté le 15-01-2015 à 18:48:18  profilanswer
 

@romn Merci :jap:


---------------
« Le hasard, c’est différent de la chance. Parce que la chance, je n'en ai jamais. »
n°824971
matteu
Posté le 22-01-2015 à 09:37:08  profilanswer
 

kaloskagatos a écrit :

Bonjour à tous,
 
J'ai configuré mon NAS avec une BD selon le tuto du topic, merci. Cependant je n'arrive finalement pas à réaliser l'intérêt de la manip, d'autant qu'après un formatage de mon PC quand j'ai tout reconfiguré j'ai perdu l'historique des films "déjà vus", que je pensais enregistré dans la BD...
 
Autre question: existe-t-il autre chose que XBNE pour accéder à cette base, par exemple une page PHP à héberger sur le NAS pour voir sa collection de n'importe où ? edit: genre ça si ça tourne sur synology ce serait pas mal http://forum.kodi.tv/showthread.php?tid=135046 ( https://github.com/3dfx/xbmcDB , https://www.youtube.com/watch?v=AoCFYvUaSm8 )


 
 
sinon dans les option d'xbmc il peut faire serveur web tu fais ca et tu te connecte dessus via un navigateur et tu vois tous tes films.


---------------
Mon Feedback---Mes ventes
n°825067
dudulroy
Posté le 22-01-2015 à 17:08:03  profilanswer
 

bonjour,
 
je viens d'acquérir un NAS SYNOLOGY DS 213J pour y mettre mes films.
 
En réseau, j'ai un PC en connecté par fil, un NUC et une tablette en WIFI tous les 2 ans
 
Sur chacun j'ai KODI d'installé.
 
Sur mon NAS, j'ai installé le paquet phpMyAdmin pour y faire une base.
 
J'ai crée un utilisateur avec tous les accés
Sur mon pc, j'ai mis le fichier advancedsettings.xml ici C:\Users\roydudul\AppData\Roaming\Kodi\userdata
Ce fichier contient  
 
<advancedsettings>
<videodatabase>
 
   <type>mysql</type>
   <host>192.168.1.xx</host>
   <port>3306</port>
   <user>xbmc</user>
   <pass>xbmc</pass>
 
   </videodatabase>
</advancedsettings>  
 
La base c'est bien créée...
 
Sur mon NUC qui tourne sous OPENELEC j'ai mis le fichier advancedsettings.xml avec le même contenu ici \\OPENELEC\Userdata.
J'ai relancé mon NUC...
Tous mes films avaient disparu. J'ai donc redéclaré mes chemins... Mais toujours rien...
J'ai ôté le fichier advancedsettings.xml et redémarré le NUC...
Tous les films étaient revenus...
J'ai remis le fichier advancedsettings.xml. Les films n'y étaient plus...
Je me suis dit que comme je suis en WIFI, KODI doit se lancer avant que mon réseau soit opérationnel....
Sous OPENELEC, j'ai donc coché l'option qui fait attendre la connexion au réseau sans fil...  
J'ai même modifié le temps d'attente jusqu'à 100 secondes...
 
Mais c'est toujours pareil !!!!
 
Sur les 2, j'ai bien la même version...
Une solution ?
 
 

n°825162
frenchieis​verige
Nej, men HEJSAN!
Posté le 23-01-2015 à 01:13:10  profilanswer
 

:hello:

 

Bon déjà premièrement ce tutoriel commence à être un peu vieux, réalisé avec xbmc 12. Pas mal de chose ont changés, comme kodi,  le nouveau scrapper de tmdb, xbne etc etc...  Il n'est plus très à jour donc :o

 

Mais, pourrais tu poster ici, ton source.xml ?


---------------
Mod: Corsair WATER 540 Aqua Marine || Linux: [TU] Elementary OS | [TU] OpenMediaVault || A/V: ICI
n°825311
dudulroy
Posté le 23-01-2015 à 17:28:34  profilanswer
 

<sources>
    <programs>
        <default pathversion="1"></default>
    </programs>
    <video>
        <default pathversion="1"></default>
        <source>
            <name>tv series</name>
            <path pathversion="1">smb://DISKSTATION/tv series/</path>
            <allowsharing>true</allowsharing>
        </source>
        <source>
            <name>video</name>
            <path pathversion="1">smb://DISKSTATION/video/</path>
            <allowsharing>true</allowsharing>
        </source>
    </video>
    <music>
        <default pathversion="1"></default>
        <source>
            <name>ipod</name>
            <path pathversion="1">D:\gestion\musique\ipod\</path>
            <allowsharing>true</allowsharing>
        </source>
    </music>
    <pictures>
        <default pathversion="1"></default>
    </pictures>
    <files>
        <default pathversion="1"></default>
    </files>
</sources>

n°826046
frenchieis​verige
Nej, men HEJSAN!
Posté le 26-01-2015 à 23:52:01  profilanswer
 

je comprends pas les balises  <allowsharing>true</allowsharing> , dans mon sources.xml , j'en ai pas et ça marche très bien...


---------------
Mod: Corsair WATER 540 Aqua Marine || Linux: [TU] Elementary OS | [TU] OpenMediaVault || A/V: ICI
n°826199
clads92
Posté le 27-01-2015 à 15:32:47  profilanswer
 

Bonjour,

 

Je vous contacte car je voulais savoir si ce tuto était adaptable de sorte que je puisse utiliser mes fichiers en extérieur via WEBDAV

 

Concretement, j'ai mon UC, ma SP3 que j'utilise à l'extérieur et mon mobile + tablette android que j'utilise en extérieur.

 

En stand alone, pas de problème je passe par le webdav et tout fonctionne, cependant j'aimerai unifier tout cela pour n'avoir qu'une seule BDD sur mon NAS SYNOLOGY.

 

Pour le moment je n'y arrive pas, car quand je lance KODI il ne créé pas ma base MYSQL :(

 

(pour le moment mon advanced setting ressemble à ça)

 
Code :
  1. <advancedsettings>
  2.      <videodatabase>
  3.        <type>mysql</type>
  4.        <host>https://IP DE MON NAS:5001</host>
  5.        <port>3306</port>
  6.        <user>Kodi</user>
  7.        <pass>PASSWORDDUCOMPTE</pass>
  8.        <name>Kodi_video</name>
  9.     </videodatabase>
  10.     <musicdatabase>
  11.        <type>mysql</type>
  12.        <host>https://https://IP DE MON NAS:5001</host>
  13.        <port>3306</port>
  14.        <user>Kodi</user>
  15.        <pass>PASSWORDDUCOMPTE</pass>
  16.        <name>Kodi_music</name>
  17.     </musicdatabase>
  18.     <pathsubstitution>
  19.      <substitute>
  20.       <from>special://masterprofile/Thumbnails/</from>
  21.       <to>https://IP DE MON NAS:5001</to>
  22.      </substitute>
  23.     </pathsubstitution>
  24. </advancedsettings>


Message édité par clads92 le 27-01-2015 à 15:57:52

---------------
Vends Jeux Videos | Collec
n°826201
aceditnana​r
Posté le 27-01-2015 à 16:11:59  profilanswer
 

J'ai trouvé cela :
http://www.popcorn-hour-fr.com/for [...] p?tid=8138
 
Et cela :
http://kodi.wiki/view/MySQL
 
Si ca peut aider... :??:

n°826207
clads92
Posté le 27-01-2015 à 16:48:43  profilanswer
 

Merci, cependant je trouve rien pour le webdav dessus :(


---------------
Vends Jeux Videos | Collec
n°826333
aceditnana​r
Posté le 28-01-2015 à 10:35:28  profilanswer
 
mood
Publicité
Posté le   profilanswer
 

 Page :   1  2  3  4
Page Suivante

Aller à :
Ajouter une réponse
 

Sujets relatifs
NAS Synology vs QnapWindows 7 et Nas Synology
NAS synology DS214 + FreeBox Revolution + Win7-Pro [RESOLU]Synology et routeur asus rt ac68u
Nas Synology DS213j[CONSEIL ACHAT] Synology 213J ou 214SE
NAS Synology DS213j : configurationQuestions nas synology
Dilème synology et asustorSynology + freebox V6 DNLA video ne fonctionne pas
Plus de sujets relatifs à : [TUTO] Base de données XBMC sous phpMyAdmin ~~ Sauvegarde BDD ~~



Copyright © 1997-2016 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR