Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
2084 connectés 

 


 Mot :   Pseudo :  
 
 Page :   1  2  3  4  5  6  7  8  9  10  11  12  13  14
Auteur Sujet :

h264tobox - Lire des vidéos H264 sur Freebox HD et PlayStation 3

n°1173948
samguili
Profil : pas trop cuit
Posté le 22-10-2009 à 13:52:05  profilanswer
 

Reprise du message précédent :

twocats a écrit :

Zut, j'arrive trop tard... [:axellay]


he he, finalement, j'ai encore un petit souci : lorsque la vidéo convertie est jouée, 2 bandes noires verticales de chaque côté de l'écran apparaissent et donc l'image est un peu  étirée. Ce n'est pas trop grave mais si vous avez une idée, au cas ou...
 :jap:


Message édité par samguili le 22-10-2009 à 14:16:23

---------------
La seule chose que je sais,c'est que je ne sais rien / Transacs
mood
Publicité
Posté le 22-10-2009 à 13:52:05  profilanswer
 

n°1174060
twocats
Posté le 22-10-2009 à 18:58:15  profilanswer
 

Lorsque tu convertie le ratio se perd. Ouvre le mkv après conversion avec mkvmergegui, change le ratio dans l'onglet ad hoc, enregistre sous un autre nom pour ne pas écraser ton fichier. Test.


---------------
La réponse est 42
n°1174242
samguili
Profil : pas trop cuit
Posté le 23-10-2009 à 14:28:58  profilanswer
 

merci pour ton aide. Je teste ça ce soir (ah le boulot... :ange: )


---------------
La seule chose que je sais,c'est que je ne sais rien / Transacs
n°1174321
samguili
Profil : pas trop cuit
Posté le 23-10-2009 à 19:00:57  profilanswer
 

super, ca marche au poil !
Un dernier truc bizarre : sur certains mkv (de la meme serie), l'image se décale et prend du retard sur le son et les sous titres. Cela n'arrive pas à chaque fois et peut apparaitre au milieu de la vidéo comme au début. :??:


---------------
La seule chose que je sais,c'est que je ne sais rien / Transacs
n°1174360
twocats
Posté le 23-10-2009 à 23:00:11  profilanswer
 

On s'éloigne du sujet du topic, là.  :o  
Pose plutôt ta question dans la rubrique multimedia.


---------------
La réponse est 42
n°1174479
veens34
Posté le 24-10-2009 à 16:11:43  profilanswer
 

Je viens de découvrir ton script, et il me convient parfaitement.
 
Je l'utilise pour convertir des .mkv en .ts pour pouvoir les lire en streaming sur la PS3 (via PS3 Media Server sur Ubuntu).
 
En revanche, après avoir converti la vidéo, il m'est impossible de faire un avance rapide (aussi bien avec SmPlayer que sur la PS3(ça marche avec VLC mais j'ai pas l'indication de temps non plus)).
 
Y a-t-il un paramètre pour corriger ce petit problème?
 
Merci :)

n°1174564
twocats
Posté le 25-10-2009 à 00:04:06  profilanswer
 

Pas avec le script en tout cas.


---------------
La réponse est 42
n°1174580
veens34
Posté le 25-10-2009 à 09:22:43  profilanswer
 

Ok,  je vais chercher un peu voir si y'a moyen de corriger ça, sinon c'est pas bien grave ;)

n°1175538
sioban44
Posté le 28-10-2009 à 20:15:56  profilanswer
 

Bonne nouvelle.
 
Le firmware 1.6.0 réinstaure la lecture des mkv de plus de 2Go !!!
On va enfin pouvoir avoir des sous titres sur les films HD ^^
 
D'ailleurs elle peut décoder le Dolby Digital Plus maintenant, est-ce qu'il y a moyen de tester ça avec un mkv ?

Message cité 1 fois
Message édité par sioban44 le 28-10-2009 à 20:18:29
n°1177452
Pims
Posté le 05-11-2009 à 23:45:48  profilanswer
 

sioban44 a écrit :

Bonne nouvelle.
 
Le firmware 1.6.0 réinstaure la lecture des mkv de plus de 2Go !!!
On va enfin pouvoir avoir des sous titres sur les films HD ^^
 
D'ailleurs elle peut décoder le Dolby Digital Plus maintenant, est-ce qu'il y a moyen de tester ça avec un mkv ?


 
C'est pas encore Byzance... mes mkv se lisent via upnp mais pas de son... c'est pourquoi je cherchais une manière de transcoder le son mais rien ;(


---------------
Life is like a box of chocolate you never know what you gonna get.
mood
Publicité
Posté le 05-11-2009 à 23:45:48  profilanswer
 

n°1177469
twocats
Posté le 06-11-2009 à 01:06:50  profilanswer
 

Pims a écrit :


 
C'est pas encore Byzance... mes mkv se lisent via upnp mais pas de son... c'est pourquoi je cherchais une manière de transcoder le son mais rien ;(


Euh... :heink:  c'est justement ce que fait ce script. :D


---------------
La réponse est 42
n°1177495
sioban44
Posté le 06-11-2009 à 09:06:16  profilanswer
 

Bah oui, à tout les coups c'est une piste en DTS  :sol:

n°1177864
Pims
Posté le 07-11-2009 à 20:05:26  profilanswer
 

Héhé oui j'avais bien compris, mais j'aimerais éviter de bricoler mes fichiers et utiliser mediatomb ou autre pour transcoder à la volé le son et non pas convertir :)

n°1177905
e_esprit
Posté le 07-11-2009 à 20:59:48  profilanswer
 

Pims a écrit :

Héhé oui j'avais bien compris, mais j'aimerais éviter de bricoler mes fichiers et utiliser mediatomb ou autre pour transcoder à la volé le son et non pas convertir :)


T'as essayé PS3 Media Server (qui dans sa version de dev, supporte bien pas mal d'autre matos que la PS3) ?


---------------
Ce n'est point ma façon de penser qui a fait mon malheur, c'est celle des autres.
n°1178212
florentmai​r
Posté le 08-11-2009 à 18:38:55  profilanswer
 

Bonjour,
 
j'ai un soucis avec certaines vidéos au format mp4, le codec est bien en x264 mais la freebox ne les lit pas ... j'essaie donc de les convertir avec votre appli, mais il me dit que le conteneur mov n'est pas supporté.
 
étrange non ?

n°1178296
twocats
Posté le 09-11-2009 à 00:39:30  profilanswer
 

Renomme tes '.mov' en '.mp4', ça devrait passer. Au pire utilise directement mkvmerge pour en faire des mkv.
 :hello:


---------------
La réponse est 42
n°1178298
florentmai​r
Posté le 09-11-2009 à 02:38:35  profilanswer
 

Merci de ta réponse mais j'ai du mal m'exprimer je recommence ;)
les vidéos sont en .mp4, en les etudiant via le software mediainfo il me confirme que la vidéo est codée en x264
 
en utilisant ton script pr la convertir en .ts ( car la freebox refuse la lire) cela me dit que la format mov n'est pas supporter. En utilisant la commande avec mplayer que tu utilises dans ton script cela pour identifier la vidéo, cela confirme que la vidéo en un format QuickTime/mov
 
auparavant j'utilisais tsMuxerGui pour convertir ces vidéos ( ce sont des mangas en HD pr info ) mais depuis le passage a snow Leopard ça marche plus :( alors ce qui m'étonne c'est que ca ne soit pas supporte via ton script car je pense que ça doit être techniquement possible. As tu une idée ? Veux tu que je te donne une vidéo d'exemple ?

n°1178360
twocats
Posté le 09-11-2009 à 11:34:28  profilanswer
 

Un sample de la vidéo serait effectivement utile. :jap:


---------------
La réponse est 42
n°1178568
florentmai​r
Posté le 09-11-2009 à 20:11:17  profilanswer
 

voici par exemple
http://www.miroriii.com/fichier/81 [...] B-mp4.html
 
merci de ton écoute :jap:

n°1178570
twocats
Posté le 09-11-2009 à 21:47:45  profilanswer
 

Citation :

--------------------------------------------------------------
h264tobox 1.2.5 - (c) 2008-2009 Dominique Biendiné, Sioban.
 
--------------------------------------------------------------
> Traitement du fichier sample.mp4.
 
* Taille du fichier : 170.46 Mo
* Espace de travail nécessaire : 554.13 Mo*
* Espace de travail disponible : 61.21 Go
* Espace de sauvegarde nécessaire : 187.51 Mo*
* Espace de sauvegarde disponible : 61.21 Go
* Ces chiffres sont des estimations.
 
--------------------------------------------------------------
La piste vidéo est au format H264.
 
> On réalise une encapsulation simple en MKV pour traiter le fichier.
Veuillez patienter... Fait.
 
La piste audio est au format AAC, elle ne sera pas convertie.
 
--------------------------------------------------------------
> Extraction des pistes.
Veuillez patienter...
Fait.
 
--------------------------------------------------------------
> Génération du fichier META :
 
MUXOPT --no-pcr-on-video-pid --new-audio-pes --vbr --vbv-len=500
V_MPEG4/ISO/AVC, "VIDEO_TRACK.31674.h264", fps=23.976, level=4.1, insertSEI, contSPS, track=1
A_AAC, "AUDIO_TRACK.31674.aac", track=2
 
--------------------------------------------------------------
> Multiplexage des pistes au format MPEG TS.
Veuillez patienter...
 
Création du fichier sample.ts terminée :-)
Durée du traitement : 17 secondes.


Il n'y a aucun problème pour convertir ce fichier. Il est d'ailleurs inutile de le convertir en ts, une encapsulation en mkv suffit.
De plus il passe parfaitement sur la Freebox. Donc le problème est entièrement de ton coté.


Message édité par twocats le 09-11-2009 à 21:48:06

---------------
La réponse est 42
n°1178804
florentmai​r
Posté le 10-11-2009 à 20:21:21  profilanswer
 

Je suis très étonné !
mais j'ai mon idée, je pense que ça vient de mon mplayer qui souhaite interpréter ce flux comme du mov  
 

Citation :

FloMaC:A Classer Florent$ mplayer -ao null -vo null -frames 0 -nolirc -nocache -identify "/TEMP/[DB]_Naruto_Shippuuden_134_HD_Sub_French_[44C923AB].mp4"  
MPlayer dev-SVN-r25648-4.0.1 (C) 2000-2008 MPlayer Team
CPU: Intel(R) Core(TM)2 Duo CPU     T7700  @ 2.40GHz (Family: 6, Model: 15, Stepping: 10)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
 
Playing /TEMP/[DB]_Naruto_Shippuuden_134_HD_Sub_French_[44C923AB].mp4.
Quicktime/MOV file format detected.
ID_VIDEO_ID=0
[mov] Video stream found, -vid 0
ID_AUDIO_ID=1
[mov] Audio stream found, -aid 1
VIDEO:  [avc1]  1280x720  24bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
ID_FILENAME=/TEMP/[DB]_Naruto_Shippuuden_134_HD_Sub_French_[44C923AB].mp4
ID_DEMUXER=mov
ID_VIDEO_FORMAT=avc1
ID_VIDEO_BITRATE=0
ID_VIDEO_WIDTH=1280
ID_VIDEO_HEIGHT=720
ID_VIDEO_FPS=23.976
ID_VIDEO_ASPECT=0.0000
ID_AUDIO_FORMAT=mp4a
ID_AUDIO_BITRATE=126000
ID_AUDIO_RATE=44100
ID_AUDIO_NCH=2
ID_LENGTH=1389.47
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
ID_VIDEO_CODEC=ffh264
==========================================================================
Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
AUDIO: 44100 Hz, 2 ch, s16le, 126.0 kbit/8.93% (ratio: 15750->176400)
ID_AUDIO_BITRATE=126000
ID_AUDIO_RATE=44100
ID_AUDIO_NCH=2
Selected audio codec: [faad] afm: faad (FAAD AAC (MPEG-2/MPEG-4 Audio) decoder)
==========================================================================
AO: [null] 44100Hz 2ch s16le (2 bytes per sample)
ID_AUDIO_CODEC=faad
Starting playback...
 
 
Exiting... (End of file)


 
peux tu me donner le retour de cette commande si tu as toujours la vidéo, stp ?

n°1178818
twocats
Posté le 10-11-2009 à 22:50:15  profilanswer
 

Version 1.2.6 disponible.
 
- L'identification 'mov' pour 'mp4' est maintenant reconnue (attention, il ne s'agit pas de l'extension).
 
Un retour de test serait apprécié, merci. :jap:  
Je répète :

Citation :

Il est d'ailleurs inutile de le convertir en ts, une encapsulation en mkv suffit.


Il s'agit effectivement d'un problème lié à mplayer. :o  
Je tiens à préciser que le script est prévu pour fonctionner sous Linux et pas sur Mac OS même avec un proc Intel (même si ça marche on dirait). :whistle:


---------------
La réponse est 42
n°1178833
florentmai​r
Posté le 10-11-2009 à 23:49:54  profilanswer
 

alors alors, le mov ça passe, j'ai mon TS :)
c'est marrant c'était exactement ce que j'allais te demander comme rustine possible pour mon cas :)
 
ensuite si mon soucis est liè a mplayer, je vais essayer une autre version, enfin plutôt en compilant plutôt que le dmg.
 
Ton script étant en bash, et ayant les mêmes outils sur linux que sur mac (sauf pour mplayer où j'ai triché sur l'install ) il n'y a pas de raisons que ça ne fonctionne pas :p, après tout ce n'est qu'un bsd avec une belle interface :D
 
Merci  :hello:  
 
Edit : Je confirme avec une version plus à jour de mplayer ca fonctionne ... il faut dire que le projet est pas trop porté sur mac, dc le package du site off utilisait des binaires de 2006 ...


Message édité par florentmair le 11-11-2009 à 00:18:35
n°1179463
sioban44
Posté le 13-11-2009 à 22:36:35  profilanswer
 

Hello, ptit soucis avec une conversion d'un film :
 

Citation :

> mkvinfo film.mkv
+ EBML head
|+ Doc type: matroska
|+ Doc type version: 2
|+ Doc type read version: 2
+ Segment, size 2347143196
|+ Seek head (subentries will be skipped)
|+ EbmlVoid (size: 4027)
|+ Segment information
| + Timecode scale: 1000000
| + Muxing application: libebml v0.7.7 + libmatroska v0.8.1
| + Writing application: mkvmerge v2.7.0 ('Do It Again') built on Apr 15 2009 00:27:10
| + Duration: 4596.933s (01:16:36.933)
| + Date: Wed Jul  1 23:36:41 2009 UTC
| + Segment UID: 0xb9 0xe5 0xd8 0x73 0x3c 0xfd 0x71 0x50 0xa0 0xde 0xc2 0xee 0xfb 0x25 0xe9 0x04
|+ Segment tracks
| + A track
|  + Track number: 1
|  + Track UID: 1
|  + Track type: video
|  + Enabled: 1
|  + Default flag: 1
|  + Forced flag: 0
|  + Lacing flag: 0
|  + MinCache: 1
|  + Timecode scale: 1
|  + Max BlockAddition ID: 0
|  + Codec ID: V_MPEG4/ISO/AVC
|  + Codec decode all: 1
|  + CodecPrivate, length 40
|  + Default duration: 41.708ms (23.976 fps for a video track)
|  + Language: eng
|  + Video track
|   + Pixel width: 1280
|   + Pixel height: 688
|   + Interlaced: 0
|   + Display width: 80
|   + Display height: 43
| + A track
|  + Track number: 2
|  + Track UID: 424048796
|  + Track type: audio
|  + Enabled: 1
|  + Default flag: 1
|  + Forced flag: 0
|  + Lacing flag: 1
|  + MinCache: 0
|  + Timecode scale: 1
|  + Max BlockAddition ID: 0
|  + Codec ID: A_DTS
|  + Codec decode all: 1
|  + Language: fre
|  + Name: DTS
|  + Audio track
|   + Sampling frequency: 48000
|   + Channels: 6
|+ EbmlVoid (size: 1024)
|+ Cluster
 
> mplayer -ao null -vo null -frames 0 -nolirc -nocache -identify film.mkv
MPlayer SVN-r28804-snapshot-4.3.2 (C) 2000-2009 MPlayer Team
 
Playing film.mkv.
ID_VIDEO_ID=0
[mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
ID_AUDIO_ID=0
ID_AID_0_NAME=DTS
ID_AID_0_LANG=fre
[mkv] Track ID 2: audio (A_DTS) "DTS", -aid 0, -alang fre
[mkv] Will play video track 1.
Matroska file format detected.
VIDEO:  [avc1]  1280x688  24bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
ID_FILENAME=film.mkv
ID_DEMUXER=mkv
ID_VIDEO_FORMAT=avc1
ID_VIDEO_BITRATE=0
ID_VIDEO_WIDTH=1280
ID_VIDEO_HEIGHT=688
ID_VIDEO_FPS=23.976
ID_VIDEO_ASPECT=1.8605
ID_AUDIO_FORMAT=8193
ID_AUDIO_BITRATE=0
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=6
ID_LENGTH=4596.93
ID_SEEKABLE=1
ID_CHAPTERS=0
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
ID_VIDEO_CODEC=ffh264
==========================================================================
Opening audio decoder: [libdca] DTS decoding with libdca
Stream with high frequencies VQ coding
AUDIO: 48000 Hz, 2 ch, s16le, 1536.0 kbit/100.00% (ratio: 192000->192000)
ID_AUDIO_BITRATE=1536000
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=2
Selected audio codec: [dts] afm: libdca (DTS-libdca)
==========================================================================
AO: [null] 48000Hz 2ch s16le (2 bytes per sample)
ID_AUDIO_CODEC=dts
Starting playback...
 
 
Exiting... (End of file)
ID_EXIT=EOF


 

Citation :

> h264tobox -o mkv -w 1 -f film.mkv -v -v
 
--------------------------------------------------------------
h264tobox 1.2.4 - (c) 2008-2009 Dominique Biendiné, Sioban.
Mode verbeux excessif enclenché
Le programme optionnel ogmdemux n'a pas été trouvé.
mkdir: ne peut créer le répertoire `film.mkv': Le fichier existe <- C'est quoi ça ???
 
--------------------------------------------------------------
> Traitement du fichier film.mkv.
 
* Taille du fichier : 2.24 Go
* Espace de travail nécessaire : 4.10 Go*
* Espace de travail disponible : 35.18 Go
* Espace de sauvegarde nécessaire : 2.46 Go*
* Espace de sauvegarde disponible : 35.18 Go
* Ces chiffres sont des estimations.
 
--------------------------------------------------------------
La piste vidéo est au format H264.
La piste audio est au format DTS.
Elle peut ne pas être supportée par votre lecteur multimédia.
 
> Voulez-vous :
 
* Garder la piste telle quelle   [ 1 ]
* La convertir au format AC-3   [ 2 ]
* Quitter     [ Q ]
Entrez votre choix [ ou Quitter ] : 2
 
--------------------------------------------------------------
> Extraction des pistes.
Veuillez patienter...
Extracting track 1 with the CodecID 'V_MPEG4/ISO/AVC' to the file 'VIDEO_TRACK.8183.h264'. Container format: AVC/h.264 elementary stream
Extracting track 2 with the CodecID 'A_DTS' to the file 'AUDIO_TRACK.8183.dump'. Container format: Digital Theater System (DTS)
Progress: 100%
Fait.
 
--------------------------------------------------------------
> Conversion de la piste audio DTS vers le format AC-3.
On utilise Mplayer...
Veuillez patienter...
 
MPlayer SVN-r28804-snapshot-4.3.2 (C) 2000-2009 MPlayer Team
 
Playing AUDIO_TRACK.8183.dump.
libavformat file format detected.
[lavf] Audio stream found, -aid 0
==========================================================================
Opening audio decoder: [libdca] DTS decoding with libdca
Stream with high frequencies VQ coding
AUDIO: 48000 Hz, 2 ch, s16le, 1536.0 kbit/100.00% (ratio: 192000->192000)
Selected audio codec: [dts] afm: libdca (DTS-libdca)
==========================================================================
[AO PCM] File: AUDIO_TRACK.8183.wav (WAVE)
PCM: Samplerate: 48000Hz Channels: Stereo Format s16le
[AO PCM] Info: Faster dumping is achieved with -vc null -vo null -ao pcm:fast
[AO PCM] Info: To write WAVE files use -ao pcm:waveheader (default).
AO: [pcm] 48000Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:4515.5 ( 1:15:15.5) of 4516.1 ( 1:15:16.1)  5.5%  
 
Exiting... (End of file)
Décompression effectuée.


 
Et rien... pas de log, il arrête là

n°1179472
twocats
Posté le 13-11-2009 à 23:58:49  profilanswer
 

Citation :

h264tobox -o mkv -w 1 -f film.mkv -v -v


Au lieu d'indiquer le film (-i), tu indique le répertoire de destination (-f)  :pt1cable:  
Je pense que tu voulais écrire :

Citation :

h264tobox -i film.mkv -o mkv -w 1 -vv


---------------
La réponse est 42
n°1179496
sioban44
Posté le 14-11-2009 à 11:48:55  profilanswer
 

Oula je devais être fatigué hier soir...
 
Voilà, la même chose mais corrigée ;)
 

Citation :

h264tobox -o mkv -w 1 -i film.mkv -v -v
 
--------------------------------------------------------------
h264tobox 1.2.4 - (c) 2008-2009 Dominique Biendiné, Sioban.
Mode verbeux excessif enclenché
Le programme optionnel ogmdemux n'a pas été trouvé.
 
--------------------------------------------------------------
> Traitement du fichier film.mkv.
 
* Taille du fichier : 2.24 Go
* Espace de travail nécessaire : 4.10 Go*
* Espace de travail disponible : 34.16 Go
* Espace de sauvegarde nécessaire : 2.46 Go*
* Espace de sauvegarde disponible : 34.16 Go
* Ces chiffres sont des estimations.
 
--------------------------------------------------------------
La piste vidéo est au format H264.
La piste audio est au format DTS.
Elle peut ne pas être supportée par votre lecteur multimédia.
 
> Voulez-vous :
 
* Garder la piste telle quelle   [ 1 ]
* La convertir au format AC-3   [ 2 ]
* Quitter     [ Q ]
Entrez votre choix [ ou Quitter ] : 2
 
--------------------------------------------------------------
> Extraction des pistes.
Veuillez patienter...
Extracting track 1 with the CodecID 'V_MPEG4/ISO/AVC' to the file 'VIDEO_TRACK.27848.h264'. Container format: AVC/h.264 elementary stream
Extracting track 2 with the CodecID 'A_DTS' to the file 'AUDIO_TRACK.27848.dump'. Container format: Digital Theater System (DTS)
Progress: 100%
Fait.
 
--------------------------------------------------------------
> Conversion de la piste audio DTS vers le format AC-3.
On utilise Mplayer...
Veuillez patienter...
 
MPlayer SVN-r28804-snapshot-4.3.2 (C) 2000-2009 MPlayer Team
 
Playing AUDIO_TRACK.27848.dump.
libavformat file format detected.
[lavf] Audio stream found, -aid 0
==========================================================================
Opening audio decoder: [libdca] DTS decoding with libdca
Stream with high frequencies VQ coding
AUDIO: 48000 Hz, 2 ch, s16le, 1536.0 kbit/100.00% (ratio: 192000->192000)
Selected audio codec: [dts] afm: libdca (DTS-libdca)
==========================================================================
[AO PCM] File: AUDIO_TRACK.27848.wav (WAVE)
PCM: Samplerate: 48000Hz Channels: Stereo Format s16le
[AO PCM] Info: Faster dumping is achieved with -vc null -vo null -ao pcm:fast
[AO PCM] Info: To write WAVE files use -ao pcm:waveheader (default).
AO: [pcm] 48000Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:4515.5 ( 1:15:15.5) of 4516.1 ( 1:15:16.1)  5.6%  
 
Exiting... (End of file)
Décompression effectuée.


 

n°1179519
twocats
Posté le 14-11-2009 à 17:20:02  profilanswer
 

Pourrais-tu passer de la 1.2.4 à la 1.2.6, cela ne changeras rien mais permettra de travailler sur la même version.
En l'absence de messages explicites des logs il faut essayer de trouvé d'où vient le problème en refaisant les étapes à la main :
- Démultiplexage des pistes avec mkvextract.
- Décompression de la piste DTS au format WAVE avec mplayer.
- Conversion AC-3 avec Aften (et éventuellement ffmpeg).

 

De plus :

Citation :

bash -x h264tobox -o mkv -w 1 -i film.mkv -v -v


pourrait fournir des indications.

 

EDIT : pourrais-tu également tenter un :

Citation :

h264tobox -o mkv -w 2 -i film.mkv -v -v


Message édité par twocats le 14-11-2009 à 17:23:09

---------------
La réponse est 42
n°1179541
sioban44
Posté le 14-11-2009 à 20:08:38  profilanswer
 

je vais creuser mais j'ai eu exactement le même soucis avec un autre fillm.
 
C'est clairement un problème mplayer (-w 1)
Pour être certains, je vais faire un bash -x comme tu le suggères car le comportement n'est pas le même si j'extraie en .ts (cela marche).
 
EDIT: pour l'instant ce n'est pas clair. Sur les deux films qui me posent problème en -w 1, l'un des deux vient de passer avec un bash -x devant...


Message édité par sioban44 le 14-11-2009 à 20:48:31
n°1179547
sioban44
Posté le 14-11-2009 à 21:38:41  profilanswer
 

Bon il semblerait qu'en fait la version 1.2.6 corrige le soucis, donc plus de problème :D
Je me suis un peu embrumé dans mes tests, j'aurais du commencer par un re-test avec la version 1.2.6
 
il y a effectivement quelques modifs dans la partie -w


Message édité par sioban44 le 14-11-2009 à 21:38:59
n°1179550
sioban44
Posté le 14-11-2009 à 22:19:41  profilanswer
 

ARRRRRRRRRRRRRRRRRRRRR
 
A priori le -w 1 ne produit PAS un AC3 ! Le flux est vu comme un flux stéréo par l'ampli :(
 
C'est bizarre ça
 
je vais retester sans -w mais je vais avoir le problème de piste audio trop longue (probleme aften...)
 
EDIT: sans le -w j'ai le Dolby. C'est donc l'extract mplayer qui ne préserve pas les canaux.
 
EDIT2: A confirmer mais je pense qu'il faut ajouter la directive "-channels 6", je fais le test et je vous dis le résultat.


Message édité par sioban44 le 15-11-2009 à 10:37:22
n°1179565
Indyana
Posté le 15-11-2009 à 11:03:59  profilanswer
 

Bonjour,
Sans utiliser aucune option j'obtiens le même problème : Piste AC3 Stéréo... Je me disait aussi qu'il y avait un soucis quelque part, mais je penchait pour mon ampli ;)
 
Au fait, ca fait un bail que je suis passer ici et je crois bien ne l'avoir jamais dit : Un grand Merci! J'utilise ce diabolique de script tous les jours!...

n°1179567
sioban44
Posté le 15-11-2009 à 11:08:01  profilanswer
 

Ton ampli l'affiche en Dolby Digital ?
 
Chez moi il mettait passait en Prologic II, donc piste stéréo, non AC3

n°1179575
Indyana
Posté le 15-11-2009 à 11:26:36  profilanswer
 

il mettait dolby, mais un "mode virtuel 6 canaux" au lieu de dolby digital. De plus en vérifiant sous nunux, un simple clic droit indique dans les propriétés audio/video Stereo au lieu de 5.1

n°1179576
Indyana
Posté le 15-11-2009 à 11:28:52  profilanswer
 

Je vient de me rendre copte que j'utilisais la 1.2.5, je fait le test avec la 1.2.6 de suite

n°1179589
Indyana
Posté le 15-11-2009 à 12:40:00  profilanswer
 

même problème avec la 1.2.6... ;)

n°1179600
Indyana
Posté le 15-11-2009 à 15:31:15  profilanswer
 

Haha! J'ai pas put attendre une éventuelle nouvelle version, j'ai ajouté l'argument "-channels 6", et cela semble avoir fonctionné parfaitement. le clic droit sous nunux me donne bien dolby AC3 surround 5.1, y'a plus qu'a tester sur l'ampli... test ce soir, mais y'a pas de raisons... ;)

n°1179601
twocats
Posté le 15-11-2009 à 15:40:23  profilanswer
 

J'attends ton retour et je valide. J'adore quand les autres bossent à ma place. :sol:


---------------
La réponse est 42
n°1179604
Indyana
Posté le 15-11-2009 à 16:01:08  profilanswer
 

Je confirme, l'ampli commute bien en dolby Digital 5.1... Haha, scéance cinéma ce soir!!!... ;)

n°1179623
twocats
Posté le 15-11-2009 à 17:10:00  profilanswer
 

Version 1.2.7 disponible.
 
- Les canaux audio sont gérés lors de la décompression avec mplayer.
- Modifications mineures du code.


---------------
La réponse est 42
n°1179631
sioban44
Posté le 15-11-2009 à 19:18:43  profilanswer
 

Je viens de tester le même film décompressé avec dcadec et mplayer avec les 6 canaux.
 
C'est ptet que moi mais j'ai l'impression que le son est plus présent avec mplayer.
 
Je vote pour donc :D

n°1179891
sioban44
Posté le 16-11-2009 à 21:21:52  profilanswer
 

Il y a encore un petit soucis, de temps en temps (2 à 3x par film) J'ai le son et l'image qui déconne.
Comme si il y avait un débit trop important.
Je pense que la freebox est limité en débit

mood
Publicité
Posté le   profilanswer
 

 Page :   1  2  3  4  5  6  7  8  9  10  11  12  13  14

Aller à :
Ajouter une réponse
 

Sujets relatifs
[+ou- résolu] Debian/Ubuntu ne reconnait pas mon HD pendant l'installmkv2box : Lire un mkv h264/x264 sur Freebox sans ré-encoder !
Créer de la vidéo à partir d'images et d'autres vidéos.Lire un mél sous Unix
Programme pour les vidéosvnc + freebox ( des deux cotes )
Plus de sujets relatifs à : h264tobox - Lire des vidéos H264 sur Freebox HD et PlayStation 3



Copyright © 1997-2016 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR