Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1331 connectés 

  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Réseaux

  Probleme VLAN switch cisco 2960

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Probleme VLAN switch cisco 2960

n°38041
tamtam30
Posté le 22-05-2008 à 15:14:31  profilanswer
 

Bonjour
Voila j'ai un switch cisco 2960 relié à un routeur cisco.
J'ai créer 2 VLAN sur le switch, VLAN 1 : fast0/1-12 et VLAN 2 fast0/13-23.
Les 2 VLAN sont bien créer, mais je veux leur donnée l'accès à internet, à partir du port 24 qui est relié au routeur (bien configuré), cela fonctionne avec le VLAN 1, mais pas pour le VLAN 2.
J'ai utilisé la commande :  
int fast 0/24
switchport trunk allowed vlan 2
 
Mais toujours pas d'internet pour le VLAN 2.
J'ai besoin d'aide
Merci
 

mood
Publicité
Posté le 22-05-2008 à 15:14:31  profilanswer
 

n°38043
lessive
Posté le 22-05-2008 à 15:30:20  profilanswer
 

peux tu mettre l'integralité de la config de ton switch et la conf de ton routeur pour le port concerné ? quelle ip mets tu comme passerelle sur ton poste de test ?
 

n°38046
tamtam30
Posté le 22-05-2008 à 15:51:24  profilanswer
 

routeur : fast0/0 192.168.255.250 (sortie pour internet)
            fast0/1 192.168.1.254 (sortie switch)
 
passerelle : 192.168.1.254 sur les postes clients
 
config switch :
vlan internal allocation policy ascending                                          
!  
interface FastEthernet0/1                          
 switchport mode access                        
!  
interface FastEthernet0/2                          
 switchport mode access                        
!  
interface FastEthernet0/3                          
 switchport mode access                        
!  
interface FastEthernet0/4                          
 switchport mode access                        
!  
interface FastEthernet0/5                          
 switchport mode access                        
!  
interface FastEthernet0/6                          
 switchport mode access                        
!  
interface FastEthernet0/7                          
 switchport mode access                        
!  
interface FastEthernet0/8                          
 switchport mode access                        
!  
interface FastEthernet0/9                          
 switchport mode access                        
!  
interface FastEthernet0/10                          
 switchport mode access                        
!  
interface FastEthernet0/11                          
 switchport mode access                        
!  
interface FastEthernet0/12                          
 switchport mode access                        
!  
interface FastEthernet0/13                          
 switchport access vlan 2                          
 switchport mode access                        
!  
interface FastEthernet0/14                          
 switchport access vlan 2                          
 switchport mode access                        
!  
interface FastEthernet0/15                          
 switchport access vlan 2                          
 switchport mode access                        
!  
interface FastEthernet0/16                          
 switchport access vlan 2                          
 switchport mode access                        
!  
interface FastEthernet0/1                        
 switchport access vlan 2                          
 switchport mode access                        
!  
interface FastEthernet0/18                          
 switchport access vlan 2                          
 switchport mode access                        
!  
interface FastEthernet0/19                          
 switchport access vlan 2                          
 switchport mode access                        
!  
interface FastEthernet0/20                          
 switchport access vlan 2                          
 switchport mode access                        
!  
interface FastEthernet0/21                          
 switchport access vlan 2                          
 switchport mode access                        
!  
interface FastEthernet0/22                          
 switchport access vlan 2                          
 switchport mode access                        
!  
interface FastEthernet0/23                          
 switchport access vlan 2                          
 switchport mode access                        
!
interface FastEthernet0/24                          
 switchport mode trunk                      
!  
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 no ip route-cache
!
ip http server
!
control-plane
!
!
line con 0
line vty 0 4
 password cisco
 login
line vty 5 15
 password cisco
 login
!
end

n°38048
tamtam30
Posté le 22-05-2008 à 15:57:15  profilanswer
 

donc je peut avoir internet sur le vlan 1 et le vlan 2 en meme temps!!!!!
C'est abusé!!!!

n°38049
tamtam30
Posté le 22-05-2008 à 15:59:10  profilanswer
 

Ya pas un autre moyen pour que sa marche

n°38050
lessive
Posté le 22-05-2008 à 16:04:28  profilanswer
 

il faudrait declarer les 2 vlans sur le routeur  et faire du trunk (a configurer sur les 2 ports , coté switch et coté routeur). et bien sur mettre une 2eme interface sur le routeur pour ton 2eme vlan. quels sont les reseaux et masques que tu as pris pour tes 2 vlans ?
 
ps : j'ai delete le premier post j'avais mal lu , je pensais pas que tu repondrais aussi vite.


Message édité par lessive le 22-05-2008 à 16:05:19
n°38053
tamtam30
Posté le 22-05-2008 à 16:08:55  profilanswer
 

ok est ce que tu pourrai me donné la commande pour ajouté une 2ème adresse sur le routeur.
Par exemple sur la fast0/1 j'ai 192.168.1.254 et je veux ajouté 192.168.2.254
Merci

n°38054
lessive
Posté le 22-05-2008 à 16:12:28  profilanswer
 

hmmmm m'a pas l'air tres évolué le routeur.
il faudrait creer les 2 vlans , et creer ensuite les interfaces sur ces vlans pas sur l'interface physique.
 
quel est la marque du routeur ?
 
si il ne gere pas le trunk , est ce que tu as eventuellement un autre port physique de libre sur le routeur ?


Message édité par lessive le 22-05-2008 à 16:13:27
n°38055
bluesboy
AOC4EVER
Posté le 22-05-2008 à 16:26:12  profilanswer
 

Il manque pas une encaps dot1q sur le routeur ?
Les 2 VLANS sont ds le meme subnet ?

n°38057
tamtam30
Posté le 22-05-2008 à 16:29:37  profilanswer
 

il faut utiliser cette commande :
interface fast 0/1
encapsulation dot1q 1
ip address 192.168.1.254 255.255.255.0
 
 
interface fast 0/1.1
encapsulation dot1q 2
ip address 192.168.2.254 255.255.255.0


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Réseaux

  Probleme VLAN switch cisco 2960

 

Sujets relatifs
IPSEC Authentification RSA-encr CISCOchercher une IP sur switch Cisco
Probleme : 2 vlan sur un switchProblème de connection en deux HP par ethernet.
Problème Freeradius 2.0 et facility syslog?IPSEC Cisco
Problème de routeur qui répond sur 2 IP 
Plus de sujets relatifs à : Probleme VLAN switch cisco 2960


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR