Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2165 connectés 

  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Management du SI

  [Domaine 2008] copier des fichiers sur postes client depuis un serveur

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Domaine 2008] copier des fichiers sur postes client depuis un serveur

n°106702
Sosogushy
Posté le 17-02-2013 à 10:29:11  profilanswer
 

Bonjour a tous !!!,
j'espère que vous pourrez sauvez ma peau.  
 
 
voici mon problème :  
 
d'ici l'undi 18 février 2013 ,
 
je dois avoir trouvé le moyen pour que au démarrage des postes clients de ma société, des fichiers présents dans un dossier partagé de mon serveur soient copiés dans c:\Program files (x86)\Microsoft\navision\classic et retailored sur les postes des users pas admin de leur poste..... ( UAC activé )
( poste sous xp/vista/seven)
 
 
les fichiers que je dois copier/remplacer se trouvent dans les dossiers :  
 
\\195.178.11.37\MajNav\Classic
 
et  
\\195.178.11.37\MajNav\retailored
 
 
tous le monde a le droit de lecture sur ces dossiers.  
 
 
ces 2 dossiers doivent être copier dans C:\Microsoft Navision\60\classic et retailored
 
 
voici le scripts que j'ai essayé :  
 
 
 
 

Citation :

@echo off
 
rem **************
rem *MAJ navision*
rem **************
 
 
 
echo MISE A JOUR NAVISION
 
cd /
 
 
cd / "C:\Program Files (x86)\Microsoft NAV\"
 
mkdir "sauvegarde fichier navision"    
 
cd /sauvegarde fichier navision
 
mkdir classic
 
 
xcopy /S "C:\Program Files (x86)\Microsoft NAV\60\Classic" "C:\Program Files (x86)\Microsoft NAV\sauvegarde fichier navision\Classic." /i /f /r
 
 
xcopy /S "\\195.178.11.37\MajNav\Classic" "C:\Program Files (x86)\Microsoft NAV\60\Classic." /i /f /r
 
 
xcopy /S "\\195.178.11.37\MajNav\RoleTailored Client" "C:\Program Files (x86)\Microsoft NAV\60\RoleTailored Client." /i /f /r
 
 
echo MISE A JOUR TERMINEE


 
 
Problème : l'UAC bloque la copie des fichier dans C: car les user ne sont pas administrateur.
 
je pensais mettre ce script au démarrage du poste via une GPO mais le problème est identique ! UAC bloque car les users ne sont pas admin de leur poste !  
 
On m'a parlé de Runas , Psexec , mais je ne sais pas comment les utiliser :cry:  :cry: je découvre les joies du scripting ! ( étant en alternance je ne connais pas encore tous :(  mais ca viendra :lol:  :lol:  )  

 
pour psexec , dois-je le déployer sur tous les postes avant de l'utiliser ou non ?  
 
 
je précise que pour le moment les postes son tous éteints et donc je ne peu pas essayer, j'ai seulement accès a mes serveur via teamviewer je dois trouver une solution en OneShoot !  :pt1cable:  :sweat:  :sweat:  
 
 
Si quelqu'un pouvait venir a mon secourt car là je suis bloqué et je dois trouver une solution d'ici lundi matin sans quoi je me prends un blâme car tant que j'aurai pas trouvé la solution l'entreprise ne tournera pas ! donc beaucoup d'euro de perdu et mon contrat de travail arrive a terme a la fin de février... reconduit? pas si je foire cela.
 
 
 
je vous en supplie aidez moi.

mood
Publicité
Posté le 17-02-2013 à 10:29:11  profilanswer
 

n°106703
granta
Quis custodiet ipsos custodes?
Posté le 17-02-2013 à 11:24:15  profilanswer
 

Tu sembles avoir beaucoup de responsabilité pour un contrat d'alternance. S'ils te mettent la pression comme ça c'est soit qu'ils en ont marre que tu ne fasses pas avancer le boulot, depuis quand tu es là-dessus ?, soit qu'ils veulent te planter pour justifier de ne pas te garder à la fin du mois.
Je ne peux pas croire ceci "l'entreprise ne tournera pas" depuis quand un contrat en alternance porte la boîte sur ces épaules ?
Combien de users ? Y a-t-il d'autres informaticiens ?
Louche ton histoire...

n°106704
Sosogushy
Posté le 17-02-2013 à 11:31:20  profilanswer
 

J'ai cette mission depuis lundi dernier.  
 
Environ 50users
 
Mais a l'origine j'avais testé mon script sur un poste utilisateur mais je n'avais pas regardé si le user était admin ou non de son poste... Et il l'étais donc mon script fonctionnait . Donc j'ai di a mon dsi que tou était ok pour lundi prochain..... (mon dsi m'avai di de voir si l'UAC bloquait ou non)...
 
Mais vendredi j'ai fait un autre test sur un autre poste qui n'étais pas admin local et là : zut (pour rester poli)  
 
Et depuis je cherche désespèrément une solution pour copier ces fichiers, j'ai crée une tache planifier avec authentification Admin du domaine , mais je ne peu pas la tester car les postes sont éteints et que je n'ai pas le code de l'alarme du batiment.  
 
Je n'ai que accès a tous les serveurs via teamviewer donc je peux mettre des gpo, fair des scripts , mais je ne peu pas les tester car pa de poste dispo pour essayé.  
 
Please help me
 


Message édité par Sosogushy le 17-02-2013 à 11:33:09
n°106706
Je@nb
Modérateur
Kindly give dime
Posté le 17-02-2013 à 13:25:54  profilanswer
 

GPP et go :o ou au pire déploiement de package dans l'outil de télédis


Message édité par Je@nb le 17-02-2013 à 13:52:41
n°106709
Sosogushy
Posté le 17-02-2013 à 15:37:38  profilanswer
 

J'ai "réussi" a faire en sorte de lancer mon script de copie de fichier mais uniquement avec le compte Administrateur du domaine pas avec un autre compte admin du domaine.
 
Je m'explique :  
 
Dans mon script de connexion j'ai effectué un  
 
runas \user:domaine\administrateur "c:\partage\majnav.bat      De mon script
 
Mais si je prend un autre compte du domaine ca fonctionne pas , il me met le chemin d'accès spécifié introuvable
 
 
Pourtant avec le compte admin du domaine ca fonctionne.  
 
Quand je fais un test juste de la commande , le cmd me met : cmd ne prend pas en charge les chemins UNC ....
 
 
 
Pourquoi ca fonctionne quand je le fait avec le compte Administrateur Originel du domaine...... :??:  :??:  :??:  :??:  :??:  :??:  :fou:  :fou:  :fou:  :fou:


Message édité par Sosogushy le 17-02-2013 à 15:38:57
n°106710
Sosogushy
Posté le 17-02-2013 à 15:43:58  profilanswer
 

Que dois-je mettre comme chemin dans mon scrpit ?  
 
Exemple : ma ressouce ce trouve sur le serveur a la racine de C  
 
J'ai test  
 
\\195.178.11.37\C:\MajNav
 
\\195.178.11.37\MajNav
 
\\le nom du serveur\MajNav  
 
Je me suis dis que cétait parce que cétai dans C: et que ca pouvait poser problème , j'ai essayer en le déplacement de partition sur D:     Idem  :??:  
 
Que faut'il que je mette dans mon script pour avoir acces au fichiers partagés ???
 
Là je ramme


Message édité par Sosogushy le 17-02-2013 à 15:45:11
n°106711
granta
Quis custodiet ipsos custodes?
Posté le 17-02-2013 à 15:55:41  profilanswer
 

Par curiosité tu es en alternance pour préparer quel diplôme/formation ?

n°106716
Quich'Man
No Fat...
Posté le 17-02-2013 à 19:00:56  profilanswer
 

tu mets tout simplement ton script au démarrage du PC mais sur une GPO ordinateur. Ca passera l'UAC.

n°106726
nebulios
Posté le 18-02-2013 à 09:25:56  profilanswer
 

La réponse est au-dessus, fais une GPP plutôt qu'un script :/


Message édité par nebulios le 18-02-2013 à 09:26:33
n°106729
lfs
Posté le 18-02-2013 à 11:20:46  profilanswer
 

Et si GPP pas possible, et si tu connais le nom ou IP de tes machines clientes, tu peux aussi faire un script depuis une machine avec un compte admin du domaine, qui va copier depuis le partage du serveur jusque sur les partages administratif des machines clientes :
 
\serveurMajNav -> \client1c$"Program Files (x86)""Microsoft NAV"60Classic
\serveurMajNav -> \client2c$"Program Files (x86)""Microsoft NAV"60Classic
\serveurMajNav -> \client3c$"Program Files (x86)""Microsoft NAV"60Classic
 
Edit:
Sinon psexec pourrait faire ca aussi, à lancer depuis une autre machine ou le serveur, avec ton script lui-même placé sur un partage, cf http://technet.microsoft.com/fr-fr [...] 97553.aspx

Message cité 1 fois
Message édité par lfs le 18-02-2013 à 11:23:05
mood
Publicité
Posté le 18-02-2013 à 11:20:46  profilanswer
 

n°106731
nebulios
Posté le 18-02-2013 à 11:39:18  profilanswer
 

Y a rien de plus crade qu'un script avec un compte admin du domaine pour modifier des fichiers dans %programfiles% :/

n°106736
lfs
Posté le 18-02-2013 à 11:54:29  profilanswer
 

lfs a écrit :

Et si GPP pas possible


J'ai dit "et si"  :o  
 
Et si c'est du one shot, et si ca lui évite de se faire virer, il trouvera pas ça crade..

n°106737
Je@nb
Modérateur
Kindly give dime
Posté le 18-02-2013 à 12:01:37  profilanswer
 

+1 (de nebulios)


Message édité par Je@nb le 18-02-2013 à 14:15:37
n°106756
Mysterieus​eX
Chieuse
Posté le 18-02-2013 à 14:14:51  profilanswer
 

RunAs dans une GPO/GPP, ou encore montage d'un lecteur réseaux dans un dossier (subst sous xp) via script.

n°106757
nebulios
Posté le 18-02-2013 à 14:19:16  profilanswer
 

[:vyse]

n°106894
Sosogushy
Posté le 19-02-2013 à 16:54:20  profilanswer
 

merci tout le monde !!!
j'ai utilisé un mix de toutes les solutions que l'on ma donné : et ca a fonctionné
 
j'ai créé une tache planifié qui lançais mon script avec le compte administrateur par GPO
 
j'ai intégré le montage d'un lecteur réseau puis je l'ai supprimé .  
 
j'ai intégré une condition (IF ELSE ) pour ce qui est du chemin d'installation de la mise a jour en fonction de la version de windows ( Program files(x86) , programmes)
 
 les commandes
NET USE Z de mon répertoire partagé
 
IF EXISTS "%programFiles(x86)" (
Xcopy de mes fichiers
)
ELSE "%Programmes%
xcopy de mes fichiers
)
 
 
tous est passé sans problème.  
 
 
j'ai eu uniquement des soucis avec 3 utilisateurs sous XP car j'avais intégré une copy du script sur le bureau et j'avais mis Desktop et non Bureau pour ces utilisateurs , mais rien de grave , un coup de teamviewer et 5min après c'était terminé.  
 
 
un grand merci a vous ,au top !!  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:


Message édité par Sosogushy le 19-02-2013 à 16:56:14
n°106898
Je@nb
Modérateur
Kindly give dime
Posté le 19-02-2013 à 17:17:22  profilanswer
 

rappel moi de ne jamais avoir à bosser avec toi :/

n°106905
Sosogushy
Posté le 19-02-2013 à 18:02:42  profilanswer
 

Pourrais tu me dire pourquoi cette réponse ?  
 
J'ai utilisé les GPO comme tu me l'a conseillé , Je n'ai pas utilisé de run as donc pas de compte admin dans la nature ( du moins je ne pense pas ) , mon compte admin est mis dans la tache planifié . Puis cette derniere a été supprimé par une gpo a la fermeture de session.  
 
Je te rappel que je suis encore en alternance nous n'avons pas tous la chance d'avoir tes connaissances.  
 
Pour ce qui est du travail , j'ai ce qu'il me faut et j'ai bien assez de contacte pour ne jamais avoir a en chercher de ma vie et peu importe le pays. :lol:  :lol:  :lol:
Étant actuelement a l'ile maurice aux frais de la princess pour 3semaine je me plaint pas pour un alternant  :sol:  :sol:  :sol:  :sol:


Message édité par Sosogushy le 19-02-2013 à 18:10:01

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Management du SI

  [Domaine 2008] copier des fichiers sur postes client depuis un serveur

 

Sujets relatifs
[GPO] : Remapping lecteurs réseaux vers nouveau serveurServeur web infecté ?
Conseil d'achat serveur NAS pour petite entrepriseHyper-V 2008 R2 SP1 - Plateforme de test et licence
SAN et cluster de basculement 2008 R2Erreur de connexion au serveur WSUS
Serveur SMTP et reverse DNS avec OVHpeut-on desactiver l'utilisation de l'ecran sur un serveur
Problème d'affichage et d'alimentation sur serveur Dell PowerEdge T410 
Plus de sujets relatifs à : [Domaine 2008] copier des fichiers sur postes client depuis un serveur


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR