Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1428 connectés 

  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Infrastructures serveurs

  [Résolu] Problème de Planificateur de Tâches - Win Server 2k8 Standard

 


 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Résolu] Problème de Planificateur de Tâches - Win Server 2k8 Standard

n°120750
john_555
Posté le 06-05-2014 à 10:18:43  profilanswer
 

Bonjour à tous et à toutes!
 
Voilà, je suis face à un problème assez gênant, et même après de nombreuses recherches sur le net, je n'ai pas pu trouver ne serait-ce qu'un début de solution, d'où ce post:
 
Sur l'un des serveurs que j'administre (un Win Server 2k8, donc), diverses tâches sont planifiées (des sauvegardes et un transfert FTP) de façon à s'exécuter tous les soirs. Tout fonctionne impeccablement bien pendant quatre ou cinq jours, et BIM! Voilà que les tâches ne s'exécutent plus toutes seules!!  :ouch:  
 
Cependant, si je les lance manuellement, les scripts sont déclenchés, et si je relance la machine, le planificateur fonctionne à nouveau correctement pendant quatre ou cinq jours, jusqu'à ce que le problème revienne, et que j'aie à nouveau à relancer le serveur...  :heink:  
 
J'ai bien essayé de relancer uniquement le service du planificateur (histoire de ne pas avoir à relancer toute la machine qui est beaucoup utilisée dans la journée), ce qui est impossible car les options de ce service sont toutes grisées (j'ai aussi essayé de stopper des services dont dépendent celui du planificateur de tâches pour le planter, et ainsi forcer sont redémarrage, mais là encore les cases sont grisées   http://stkr.es/s/zp3 );
 
Enfin, je suis allé faire un tour dans l'observateur d'évènements, dans l'espoir de trouver quelque chose qui expliquerait cette défaillance, mais à première vue, rien à signaler de ce côté-là (et j'en suis sûr à près de 99%).
 
Dans l'absolu, ce problème n'est pas vraiment grave, je peux toujours lancer les sauvegardes manuellement et redémarrer le serveur à l'occasion, mais j'aimerais bien pouvoir faire un peu plus confiance à son planificateur, ce serait déjà ça en moins à gérer ^^'.
 
Voilà, si quelqu'un a une petite idée, un début de piste, ou une petite astuce pour résoudre ce problème, je suis preneur!  ;)  
 
En vous remerciant d'avance,
 
John.


Message édité par john_555 le 26-05-2014 à 08:48:29
mood
Publicité
Posté le 06-05-2014 à 10:18:43  profilanswer
 

n°120752
bicoun
Et non pas Bicounet !!!
Posté le 06-05-2014 à 11:52:49  profilanswer
 

Salut,
 
La tâche planifiée apparaît bien dans la colonne "prochaine exécution" ?
Si oui, lorsqu'elle ne s'exécute pas, que dit la colonne "Résultat de la dernière exécution" ?


---------------
Pixel mort -> .
n°120753
john_555
Posté le 06-05-2014 à 12:17:42  profilanswer
 

Oui, la tâche apparaît dans la colonne "prochaine exécution", mais les colonnes "résultats de la dernière exécution" et "date de dernière exécution" ne sont pas mises à jour, vu que la tâche ne s'est pas déclenchée (la colonne résultat affiche "opération réussie" à chaque fois que la tâche est déclenchée).
 
J'ai aussi tenté de (re)créer une tâche, planifiée pour une exécution unique (par exemple, aujourd'hui à 12h00). Ainsi, avant midi, je vois la date de prochaine exécution, mais une fois midi passé, je devrais voir la tâche apparaitre dans la colonne "date de dernière exécution", et la colonne "date de prochaine exécution" devrait être vide. Or, la colonne "dernière exécution" est vide! (au même tire que celle de la prochaine exécution, ce qui est normal...)
 
En fait, c'est un peu comme si le moteur d'exécution automatique avait calé, et comme je ne connais pas encore très bien le fonctionnement du planificateur (ça fait deux mois que je suis dans le métier xD), je suis un peu perdu...

n°120758
NewsletTux
<Insérez ici votre vie />
Posté le 06-05-2014 à 15:08:41  profilanswer
 

salut,
curieux ton truc...
si tu crées une tâche de base, qui fait par exemple un ipconfig > c:\%datedujour%.txt, et que tu exécutes ce script tous les soirs, est-ce que ça fonctionne plus de 4 jours ?
 
y a-t-il une surcharge CPU ou une autorisation qui saute au bout des 4j (genre un dossier qui est supprimé/recréé, ...)


---------------
NewsletTux - outil de mailing list en PHP MySQL
n°120759
john_555
Posté le 06-05-2014 à 15:38:16  profilanswer
 

Je crois que je détiens un cas d'école, là x)
 
Tu veux que je fasse une tâche de base (donc différentes de "Créer une nouvelle tâche" (ce que j'ai utilisé à chaque fois), nous sommes bien d'accord?) comme ipconfig pour tester?
Parce que les tâches que j'ai créées ne sont pas très évoluées... (elles lancent juste un batch à heure fixe, tous les soirs de la semaine).
Malgré ça, j'ai ce problème après quelques jours (généralement 4 ou 5, mais ça peut être un peu plus ou un peu moins, il n'y a -à première vue- aucun élément déclencheur récurrent), et le serveur en question est une belle bête avec pas mal de ressources dans le ventre, donc on doit pouvoir exclure la surcharge CPU (je ne l'ai jamais vu dépasser les 70% d'utilisation, même lors de manips gourmandes en ressources).
 
Niveau autorisations, je ne pense pas, les dossiers destinés à être sauvegardés ne sont jamais modifiés (enfin, leur contenu change régulièrement, bien sûr, mais même mon batch qui m'envoie les logs par transfert FTP est affecté (alors qu'il envoie toujours le contenu d'un dossier qui n'a jamais été renommé/déplacé/recréé))...
 
Quoi qu'il en soit, je vous remercie déjà de vous intéresser à mon problème :)


Message édité par john_555 le 06-05-2014 à 16:21:20
n°120960
john_555
Posté le 15-05-2014 à 09:06:30  profilanswer
 

C'est bon, problème résolu!!  :D
 
En fait, le registre était totalement pourri (6 passes de Ccleaner pour nettoyer plus de 2600 erreurs de registre, merci au précédent admin qui s'est bien occupé de ce système...   http://stkr.es/s/zp5  ), j'ai du intervenir physiquement pour réparer Windows, et le problème semble ne plus être revenu (je suis intervenu sur la machine il y a 5 jours, maintenant ^^)...
 
Au cas où, je vais attendre encore une semaine avant de classer ce post comme étant résolu, on ne sait jamais.


Message édité par john_555 le 16-05-2014 à 15:57:27
n°121181
john_555
Posté le 26-05-2014 à 08:40:04  profilanswer
 

Je confirme que le problème est bel et bien de l'histoire ancienne ^^


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Infrastructures serveurs

  [Résolu] Problème de Planificateur de Tâches - Win Server 2k8 Standard

 

Sujets relatifs
HyperV 2008R2 hébergé OVH : Problème avec le gestionnaire client.VDI Server 2O12 Template desktop
VPN et share - problème avec IPRésoudre un étrange problème d'upload
GPO sous 2008 R2, ne fonctionne pas[ Outil admin ] Gestionnaire connexion terminal server
Faire un test sur server brokerProblème serveur production Vmware ESXI5 ... help ....
Gros problème "internet" sur mon nouveau pcProblème passerelle ethernet (EGX)
Plus de sujets relatifs à : [Résolu] Problème de Planificateur de Tâches - Win Server 2k8 Standard


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR