Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
1622 connectés 

  FORUM HardWare.fr
  Réseaux grand public / SoHo
  Réseaux

  Probleme serveur DHCP sur asus AC-66U

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Probleme serveur DHCP sur asus AC-66U

n°1019201
pierre20
Posté le 08-04-2018 à 18:48:36  profilanswer
 

Coucou à tout le monde  :hello:

 

Voilà j'ai un soucis et j'aimerais avoir votre diagnostique si vous le voulez bien :)

 

Voici ma config qui fonctionnait tres tres bien jusqu'a il y a quelque semaine, sans raison particuliere (personne n'a touché au reseau) je n'ai que des merdes :/

 

ONT fibre orange => asus AC66U (qui remplace la LB donc) => switch 48 ports giga manageable (mais fonctionne en mode auto, rien de configuré) => ordis

 

Le truc c'est que le Dhcp de l'asus (prises rj45 et wifi donc) est paramétré pour donner une IP entre 192.168.2.2 (son adresse propre etant 192.168.2.1) et 192.168.2.254.

 

Et ben vous savez quoi ? je me retrouve avec certaines machines (pas toujours les meme, c'est aleatoire) en 192.168.1.x  :heink:

 

Pourtant toutes les machines sont en Dhcp.

 

Vous auriez une piste à explorer ? de mon coté j'ai l'impression que l'asus est mort mais bon  [:sfgto]

 

PS : info interessante : j'ai aussi un routeur (je sais plus la marque) qui est aussi sur le reseau apres le switch giga, il sert a desservir un autre appart en wifi qui est a coté avec son propre serveur dhcp qui lui est dans la plage 192.168.1.x / 254. Cela dit j'ai bien sur verifié que les machines en 192.168.1.x ne soient pas connectées a ce routeur.

Message cité 1 fois
Message édité par pierre20 le 08-04-2018 à 19:10:01

---------------
Feedback    l'ascenseur social
mood
Publicité
Posté le 08-04-2018 à 18:48:36  profilanswer
 

n°1019205
pierre20
Posté le 08-04-2018 à 18:58:01  profilanswer
 

Voici un extrait de l'historique de l'Asus :
 
Apr  8 18:25:41 dnsmasq-dhcp[13428]: DHCPACK(br0) 192.168.2.207 b8:53:ac:d0:54:c2 iPhone
Apr  8 18:27:41 dnsmasq-dhcp[13428]: DHCPREQUEST(br0) 192.168.2.207 b8:53:ac:d0:54:c2  
Apr  8 18:27:41 dnsmasq-dhcp[13428]: DHCPACK(br0) 192.168.2.207 b8:53:ac:d0:54:c2 iPhone
Apr  8 18:28:08 dnsmasq-dhcp[13428]: DHCPDISCOVER(br0) 30:07:4d:65:a8:b5  
Apr  8 18:28:08 dnsmasq-dhcp[13428]: DHCPOFFER(br0) 192.168.2.26 30:07:4d:65:a8:b5  
Apr  8 18:28:08 dnsmasq-dhcp[13428]: DHCPREQUEST(br0) 192.168.1.13 30:07:4d:65:a8:b5  
Apr  8 18:28:08 dnsmasq-dhcp[13428]: DHCPNAK(br0) 192.168.1.13 30:07:4d:65:a8:b5 wrong server-ID
Apr  8 18:39:16 dnsmasq-dhcp[13428]: DHCPDISCOVER(br0) 192.168.2.14 60:67:20:9e:19:e4  
Apr  8 18:39:16 dnsmasq-dhcp[13428]: DHCPOFFER(br0) 192.168.2.14 60:67:20:9e:19:e4  
Apr  8 18:39:16 dnsmasq-dhcp[13428]: DHCPREQUEST(br0) 192.168.1.16 60:67:20:9e:19:e4  
Apr  8 18:39:16 dnsmasq-dhcp[13428]: DHCPNAK(br0) 192.168.1.16 60:67:20:9e:19:e4 wrong server-ID
Apr  8 18:51:07 dnsmasq-dhcp[13428]: DHCPREQUEST(br0) 192.168.1.16 60:67:20:9e:19:e4  
Apr  8 18:51:07 dnsmasq-dhcp[13428]: DHCPNAK(br0) 192.168.1.16 60:67:20:9e:19:e4 wrong network
Apr  8 18:52:37 dnsmasq-dhcp[13428]: DHCPREQUEST(br0) 192.168.1.16 60:67:20:9e:19:e4  
Apr  8 18:52:37 dnsmasq-dhcp[13428]: DHCPNAK(br0) 192.168.1.16 60:67:20:9e:19:e4 wrong network
Apr  8 18:53:28 dnsmasq-dhcp[13428]: DHCPREQUEST(br0) 192.168.2.189 f0:1d:bc:16:c9:96  
Apr  8 18:53:28 dnsmasq-dhcp[13428]: DHCPACK(br0) 192.168.2.189 f0:1d:bc:16:c9:96 XboxOne
 


---------------
Feedback    l'ascenseur social
n°1019209
HiSpeed
Where is the limit?
Posté le 08-04-2018 à 20:55:44  profilanswer
 

pierre20 a écrit :

j'ai aussi un routeur (je sais plus la marque) qui est aussi sur le reseau apres le switch giga, il sert a desservir un autre appart en wifi qui est a coté avec son propre serveur dhcp qui lui est dans la plage 192.168.1.x / 254. Cela dit j'ai bien sur verifié que les machines en 192.168.1.x ne soient pas connectées a ce routeur.


Salut,
 
Débranche ce second routeur, ça ira surement beaucoup mieux...

n°1019260
slr56
Tout problème a sa solution.
Posté le 09-04-2018 à 10:22:25  profilanswer
 

Bonjour,

 

Vu ton problème, il est évident que les 2 plages DHCP (192.168.1.X et 192.168.2.X) sont accessibles par plusieurs machines. Tu as un problème de cloisonnement des 2 réseaux.

 

Comme tu le dis, le 2ème routeur : est après le switch giga => Donc branché sur le switch gigabit. Or un switch par défaut, il ne fait que réémettre  les trames qu'il reçoit (notamment les trames DHCP...), par conséquent, le premier serveur DHCP qui reçoit une demande DHCP DISCOVER, répondra au client. Donc c'est pile ou face.

 

Pour éviter ça, vu que tu as un switch manageable, tu devrais créer des VLANs. 1 pour le réseau 192.168.1.x et 1 pour le réseau 192.168.2.x. Ensuite, tu places les ports des machines que tu veux dans le bon VLAN. Et chaque VLAN se verra attribué une plage DHCP. Et ça roule/route !

 

Evidemment, le switch fera office de serveur DHCP (donc il faut supprimer ces rôles sur les 2 routeurs).

 

Enfin, sur l'AC66U, tu crées une route (dans les 2 sens) entre le réseau 192.168.1.X et l'ONT. ET sur l'autre routeur tu crées une route  (dans les 2 sens) entre le réseau 192.168.2.X et l'ONT)

 

Et si tu veux autoriser les 2 VLANs à communiquer ensemble, tu crées les routes sur les 2 routeurs.

 

Avec ça, tout est good !


Message édité par slr56 le 09-04-2018 à 10:34:37

---------------
Configurations type du moment : https://forum.hardware.fr/hfr/Hardw [...] 1331_1.htm  https://www.jouannetphotographe.com
n°1019265
pierre20
Posté le 09-04-2018 à 10:59:57  profilanswer
 

Merci de vos reponses a tous 2 !

 

alors dans un premier temps je vais en effet tester de virer le 2eme routeur, voir ce que ça donne.

 

ensuite bon, je suis pas tres tres bon en informatique, les solutions que tu me propose sont certainement les meilleurs, mais je pense que pour moi ça va être compliqué :/

 

Et si betement j'attribuais l'adresse 192.168.2.2 au 2eme routeur et que je partageais le dhcp sur chacun d'entre eux ?

 

Genre l'asus 192.168.2.3 => 192.168.2.125 et le 2eme routeur 192.168.2.126 => 192.168.2.254 ???

 


Ps : Ou alors remplacer le 2eme routeur par un simple point d'accès wifi ?


Message édité par pierre20 le 09-04-2018 à 11:04:15

---------------
Feedback    l'ascenseur social
n°1019292
flash_gord​on
Posté le 09-04-2018 à 13:33:11  profilanswer
 

ça ne changera absolument rien.
 
Quel est ton but avec ce second routeur ? filer un accès wifi "invité" sans accès à ton réseau ? alors c'est simple, il faut le brancher sur le port Wan/internet, et non sur l'un des RJ45 normaux.
 
Si c'est simplement pour étendre ton réseau, il faut couper tout ce qui est DHCP dessus.


Message édité par flash_gordon le 09-04-2018 à 13:33:32
n°1019298
pierre20
Posté le 09-04-2018 à 14:20:47  profilanswer
 

Le but de ce routeur est simplement d'etendre le reseau wifi à la base, je voulais un repeteur wifi un peu couillu (en terme de debit) à l'epoque et il n'y avait que les routeurs pour ça ...


---------------
Feedback    l'ascenseur social
n°1019300
flash_gord​on
Posté le 09-04-2018 à 14:27:13  profilanswer
 

Bah il faut que tu le configures pour désactiver le DHCP.

n°1019334
pierre20
Posté le 09-04-2018 à 19:26:46  profilanswer
 

Bon alors dans un premier temps j'ai deebranché le cable rj45 du 2eme routeur.
 
Resultat c'est du pareil au meme, j'ai testé avec mon portable, ce matin il avait encore une adresse en 19.168.1.x, je l'ai redemarré tout a lh'heure, il est repassé en 192.168.2.x ... youpi tralala.
 
Mais j'ai tenté un ipconfig/release puis ipconfig/renew et patatra il est repassé en 192.168.1.x
 
Et j'ai beau retenter les ipconfigrelease / ipconfigrenew rien n'y fait, il reste EXACTEMENT sur la meme ip en 169.168.1.9  :heink:  :cry:


---------------
Feedback    l'ascenseur social
n°1019335
flash_gord​on
Posté le 09-04-2018 à 19:33:18  profilanswer
 

pierre20 a écrit :

Bon alors dans un premier temps j'ai deebranché le cable rj45 du 2eme routeur.


 
Bah si tu l'as pas éteint, et que tu es en wifi, c'est normal  [:yiipaa:4]

mood
Publicité
Posté le 09-04-2018 à 19:33:18  profilanswer
 

n°1019338
pierre20
Posté le 09-04-2018 à 20:12:57  profilanswer
 

Ben ouais ok, m'enfin mon portable de test est connecté en wifi au 1er routeur hein (le AC66U) :o


---------------
Feedback    l'ascenseur social
n°1019396
slr56
Tout problème a sa solution.
Posté le 10-04-2018 à 10:05:52  profilanswer
 

pierre20 a écrit :

Ben ouais ok, m'enfin mon portable de test est connecté en wifi au 1er routeur hein (le AC66U) :o

 

Bonjour,

 

La partie Wifi est indépendante de la configuration IP. Ce que je veux dire, c'est que la configuration WIFI (SSID, canal...) peut être fournie par un un AP et la configuration IP (IP/mask/DNS, passerelle...) peut être fourni par un autre appareil (serveur, switch...) qui a un rôle DHCP et qui est sur le même réseau.

 

Donc tant que tu auras 2 serveurs DHCP sur un même réseau, ce sera pile ou face. Désactives un rôle DHCP ou alors cloisonnes tes réseaux de façon à n'avoir qu'un serveur DHCP par réseau.

 


cdt,

 

slr56

 


Message édité par slr56 le 10-04-2018 à 10:06:41

---------------
Configurations type du moment : https://forum.hardware.fr/hfr/Hardw [...] 1331_1.htm  https://www.jouannetphotographe.com
n°1019428
pierre20
Posté le 10-04-2018 à 15:35:26  profilanswer
 

bon alors j'ai debranché le 2eme routeur cette fois-ci.
 
Et bin c'est pareil encore une foutue adresse en 192.168.1.x sur mon portable  :fou:  
 
Soit le AC66U deconne plein pot, soit j'ai un margoulin qui a branché un routeur sur l'une des prises rj45 dans un appart :/


---------------
Feedback    l'ascenseur social
n°1019433
slr56
Tout problème a sa solution.
Posté le 10-04-2018 à 15:57:44  profilanswer
 

pierre20 a écrit :

bon alors j'ai debranché le 2eme routeur cette fois-ci.

 

Et bin c'est pareil encore une foutue adresse en 192.168.1.x sur mon portable  :fou:

 

Soit le AC66U deconne plein pot, soit j'ai un margoulin qui a branché un routeur sur l'une des prises rj45 dans un appart :/

 


Quand tu dis "débranché", c'est juste le câble ethernet ou électriquement ? Car si c'est juste le câble ethernet, c'est normal car je suppose que ton routeur a le wifi d'activé, non ?

 

Si tu l'as débranché électriquement. Tu fais un "ipconfig /release" puis un "ipconfig /renew" sur la machine concerné et elle aura une adresse IP fournie par le seul serveur DHCP opérationnel.

 



Message édité par slr56 le 10-04-2018 à 15:58:00

---------------
Configurations type du moment : https://forum.hardware.fr/hfr/Hardw [...] 1331_1.htm  https://www.jouannetphotographe.com
n°1019461
pierre20
Posté le 10-04-2018 à 20:20:06  profilanswer
 

J'ai tout debranché comme ça je suis tranquille :o
 
Ben peau de balle, du coup mon portable à une ip moisie, et maintenant mon fixe aussi, jusqu'a ce que ... ben rien en fait, comme c'est au petit bonheur la chance ... :/
 
 
J'ai beau faire des ipconfig/release puis ipconfig/renew, l'ip de chaque ordi ne change pas d'un poil ... je desactive les cartes reseau puis les reactive, rien n'y fait elles ont toujours l'ip moisie.
 
J'ai meme eu un message dans l'invite de commande, un truc en faisant un ipconfig/renew : "impossible blablabla loopback"


---------------
Feedback    l'ascenseur social
n°1020388
pierre20
Posté le 18-04-2018 à 08:33:58  profilanswer
 

J'ai du nouveau !!

 

J'ai trouvé le fautif : un netgear wnr3500 qui était connecté au reseau ... le gars pensait que c’était un simple switch.

 

Donc plus de soucis de dhcp.

 

Le wifi fonctionne parfaitement avec l'asus, par contre les prises rj45 ça deconne plein but ... faut que je fasse f5 plusieurs fois pour accéder à un site (n'importe lequel).

 

Je pige pas là :/

 


edit : en changeant les dns ça n'est pas mieux


Message édité par pierre20 le 18-04-2018 à 08:34:34

---------------
Feedback    l'ascenseur social

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Réseaux grand public / SoHo
  Réseaux

  Probleme serveur DHCP sur asus AC-66U

 

Sujets relatifs
probleme de connexion uniquement dans les jeux avec bboxprobleme DLNA QNAP TS251+
Problème redirection de portsproblème sécurité avec nas Synology et Chrome
Routeur ASUS AC68U: Ajout/suppression impossible (DHCP et MAC WIFI etcA la recherche d'une offre de serveur dédié ou non sous Windows 10
Problème énigmatique réseau RJ45 (568A ou B ou autre chose)Mise en relation adresse IP publique et serveur (Cisco)
Problème internet prises murales RJ45 / DTI 
Plus de sujets relatifs à : Probleme serveur DHCP sur asus AC-66U


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR