Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1519 connectés 

  FORUM HardWare.fr
  Réseaux grand public / SoHo
  Réseaux

  [Urgent] : OpenVPN - problème de configuration !

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Urgent] : OpenVPN - problème de configuration !

n°434808
vbenner
Posté le 12-10-2009 à 15:24:37  profilanswer
 

Bonjour,
 
Je viens de lire l'excellent tutorial pour configurer OpenVPN et j'ai
généré tous les fichiers .key et autres qui sont bien rangés dans
les répertoires qui vont bien.
 
POURQUOI :
 
Juste pour ajouter des informations, voici ce que je veux faire avec
le OpenVPN. Une collègue utilise un PC sous Windows XP qui se connecte
au serveur de l'entreprise (réseau classique avec un simple switch) pour
accéder à un programme de comptabilité (SAGE). Elle a mappé sur son
PC un disque réseau S: correspondant à l'adresse \\SERVEUR\SAGE, lequel
est D:\SAGE sur le serveur.
 
Cette collègue va faire un peu de télétravail pendant son congé maternité.
Je vais donc aller demain chez elle avec son PC. Je veux qu'elle puisse
continuer à se connecter au serveur de l'entreprise, s'où le OpenVPN.
 
 
 
SERVEUR
 
Mon serveur d'entreprise tourne sous Windows Server 2003 et est
situé derrière une Freebox dont l'IP est 12.34.56.789.
 
La freebox fonctionne comme un routeur DHCP et distribue des
adresses qui vont de 198.168.1.10 à 198.168.1.50
 
J'ai redirigé le port 1194 udp (et tcp) vers 192.168.1.10:1194
(et par précaution, j'ai redirigé aussi sur 192.168.1.1:1194).
 
Le serveur semble fonctionner correctement, les fichiers désirés
sont dans le répertoire /config et ça affiche les informations
suivantes :

Code :
  1. Mon Oct 12 14:17:36 2009 OpenVPN 2.0.9 Win32-MinGW [SSL] [LZO] built on Oct  1 2006
  2. Mon Oct 12 14:17:36 2009 Diffie-Hellman initialized with 1024 bit key
  3. Mon Oct 12 14:17:36 2009 Control Channel Authentication: using 'ta.key' as a OpenVPN static key file
  4. Mon Oct 12 14:17:36 2009 Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
  5. Mon Oct 12 14:17:36 2009 Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
  6. Mon Oct 12 14:17:36 2009 TLS-Auth MTU parms [ L:1542 D:166 EF:66 EB:0 ET:0 EL:0 ]
  7. Mon Oct 12 14:17:36 2009 TAP-WIN32 device [Connexion au réseau local 3] opened: \\.\Global\{5C223125-6E91-40D9-82F3-D1936F2FC9AC}.tap
  8. Mon Oct 12 14:17:36 2009 TAP-Win32 Driver Version 8.4
  9. Mon Oct 12 14:17:36 2009 TAP-Win32 MTU=1500
  10. Mon Oct 12 14:17:36 2009 Notified TAP-Win32 driver to set a DHCP IP/netmask of 10.8.0.1/255.255.255.252 on interface {5C223125-6E91-40D9-82F3-D1936F2FC9AC} [DHCP-serv: 10.8.0.2, lease-time: 31536000]
  11. Mon Oct 12 14:17:36 2009 Sleeping for 10 seconds...
  12. Mon Oct 12 14:17:46 2009 Successful ARP Flush on interface [196612] {5C223125-6E91-40D9-82F3-D1936F2FC9AC}
  13. Mon Oct 12 14:17:46 2009 route ADD 10.8.0.0 MASK 255.255.255.0 10.8.0.2
  14. Mon Oct 12 14:17:46 2009 Route addition via IPAPI succeeded
  15. Mon Oct 12 14:17:46 2009 Data Channel MTU parms [ L:1542 D:1450 EF:42 EB:135 ET:0 EL:0 AF:3/1 ]
  16. Mon Oct 12 14:17:46 2009 UDPv4 link local (bound): [undef]:1194
  17. Mon Oct 12 14:17:46 2009 UDPv4 link remote: [undef]
  18. Mon Oct 12 14:17:46 2009 MULTI: multi_init called, r=256 v=256
  19. Mon Oct 12 14:17:46 2009 IFCONFIG POOL: base=10.8.0.4 size=62
  20. Mon Oct 12 14:17:46 2009 IFCONFIG POOL LIST
  21. Mon Oct 12 14:17:46 2009 Initialization Sequence Completed


 
L'icône du serveur est d'un beau vert après cette manipulation.
Et ça me dit que l'adresse est 10.8.0.1
 
 
CLIENT
 
J'ai ensuite un client, qui est derrière une autre Freebox (mais là, à priori
on s'en fout). J'ai bien mis les fichiers .key et autres dans les bons
répertoire.
 
J'ai édité client.ovpn comme il faut (mais je pense que le problème vient
de là). J'ai indiqué l'adresse de la Freebox du serveur et quand je lance
le client, j'ai ce message :
 
(edit : j'avais oublié de décommenter tls-auth ta.key 1)
 

Code :
  1. Mon Oct 12 15:56:39 2009 OpenVPN 2.0.9 Win32-MinGW [SSL] [LZO] built on Oct  1 2006
  2. Mon Oct 12 15:56:39 2009 IMPORTANT: OpenVPN's default port number is now 1194, based on an official port number assignment by IANA.  OpenVPN 2.0-beta16 and earlier used 5000 as the default port.
  3. Mon Oct 12 15:56:39 2009 Control Channel Authentication: using 'ta.key' as a OpenVPN static key file
  4. Mon Oct 12 15:56:39 2009 Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
  5. Mon Oct 12 15:56:39 2009 Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
  6. Mon Oct 12 15:56:39 2009 LZO compression initialized
  7. Mon Oct 12 15:56:39 2009 Control Channel MTU parms [ L:1542 D:166 EF:66 EB:0 ET:0 EL:0 ]
  8. Mon Oct 12 15:56:39 2009 Data Channel MTU parms [ L:1542 D:1450 EF:42 EB:135 ET:0 EL:0 AF:3/1 ]
  9. Mon Oct 12 15:56:39 2009 Local Options hash (VER=V4): '504e774e'
  10. Mon Oct 12 15:56:39 2009 Expected Remote Options hash (VER=V4): '14168603'
  11. Mon Oct 12 15:56:39 2009 UDPv4 link local: [undef]
  12. Mon Oct 12 15:56:39 2009 UDPv4 link remote: 88.181.145.134:1194


 
Mais rien ne se connecte. Ca reste en jaune...
 
Qu'est ce que je peux faire pour que ça marche ?
 
Merci d'avance. Si quelqu'un s'y connait vraiment très bien, je
peux même l'appeler pour faire les manipulations via téléphone.
 
Vincent


Message édité par vbenner le 12-10-2009 à 15:59:51
mood
Publicité
Posté le 12-10-2009 à 15:24:37  profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Réseaux grand public / SoHo
  Réseaux

  [Urgent] : OpenVPN - problème de configuration !

 

Sujets relatifs
Problème réseau Gigabit bridé à 10 mbitsproblème wifi avec freebox , ne voit pas la freebox , mais la ps3 voit
modem webstar + routeur philips , probleme reseau avec 2 pc + ps 3Problème sur OVH
Probleme routeur bizarre[resolu] Erreur FEC, ya un probleme la non?
Problème antenne 16dbi sur clé wifiProblème Teamviewer sous Proxy
Bewan VPNBooster 32 - problème de connexion VPNprobleme configuration partage internet par softap,besoin d un shema..
Plus de sujets relatifs à : [Urgent] : OpenVPN - problème de configuration !


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR