Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1023 connectés 

  FORUM HardWare.fr
  Windows & Software

  WiFi - Ouvrir une session dans un domaine

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

WiFi - Ouvrir une session dans un domaine

n°2121732
agyar
Posté le 10-08-2005 à 18:37:25  profilanswer
 

Bonjour tous,
 
Amateur de nouveautés (et donc, de prises de têtes), j'ai décidé de changer chez moi le fonctionnement de mon réseau : plutôt que de me contenter d'un groupe de travail, j'ai suivi les avis des "pro-domaines", et me retrouve donc aujourd'hui avec un serveur sous Linux (Debian) qui fait tourner Samba en contrôleur de domaine principal.
 
L'architecture réseau est la suivante : un modem SpeeTouch reçoit la connexion ADSL, qu'li redirige ensuite vers un routeur Linksys WRT54GS. Un PC sous XP est connecté en filaire (RJ45) au routeur, et deux autres PC portables s'y connectent par WiFi (cartes Linksys WPC5GS).
 
Jusque-là tout va bien.
 
Passer en mode "domaine" n'a pas posé de difficulté majeure (enfin, hormis le fait de configurer correctement Samba) pour le PC qui se connecte par fil. Pour les deux portables en revanche, c'est une autre paire de manches : la carte WiFi est bel et bien alimentée au démarrage du PC, mais la configuration du réseau pour ces cartes - via l'utilitaire fourni sur CD avec les cartes - ne se fait qu'après l'ouverture de la session.
Parenthèse au passage : c'est très facile à vérifier. Il suffit de se connecter une première fois avec un compte local du portable, de mapper un lecteur réseau sur le serveur distant avec reconnexion automatique, et de voir ce qu'il se passe quand on redémarre le portable pour se relogger. Une fenêtre apparaît alors pour signaler que le lecteur réseau est indisponible - si le problème provenait d'une authentification échouée, on aurait alors une demande de saisie d'un identifiant / mot de passe... Sans compter que l'interface de visualisation de l'état de la connexion WiFi démarre en gros tout à la fin des programmes lancés au démarrage, et qu'avant d'afficher un signal, elle dit pendant quelques secondes : "Pas de réseau".
 
En gros, quand je demande à me connecter au réseau, les PC me répondent : "Pas de serveur de domaine disponible". Cool.
 
J'ai appelé Linksys (hotline gratuite - ce qui est assez exceptionnel pour le noter) deux fois :
- La première, on m'a suggéré de passer en "Automatique" le service "Configuration sans fil". Sur le coup, et vu le commentaire attaché à ce service, ça m'a paru logique, et puisque mon portable est assez long à démarrer, j'ai dit "Merci monsieur" et j'ai raccroché. Vous avez deviné que ça ne change rien au problème, en fin de compte...
- La deuxième (aujourd'hui), on m'a dit que se connecter à un domaine Windows était effectivement impossible, puisque le logiciel de configuration de la carte se lance bien après l'ouverture de la session. Là où j'ai quand même eu un doute, c'est que le gars supposait également que c'était le cas en filaire (Lui : "la pile TCP n'est peut-être lancée qu'après l'ouverture de session" - Vu que j'avais quand même un vieux doute : "Euh, bah nan, c'est pas possible, sinon on ne pourrait JAMAIS se connecter à un domaine" - "Ah ben oui, tiens" )
 
Bref, la question, vous l'avez deviné (enfin, si vous êtes arrivés jusque-là !) : avez-vous déjà recontré ce cas de figure ? Il me paraît inconcevable que des portables utilisant une carte WiFi ne puissent se connecter à un domaine, surtout quand on voit à quel point le portable est souvent utilisé par les entreprises...
 
Si vous n'y aviez jamais réfléchi mais que le problème vous intéresse, je suis quand même preneur de tout avis, conseil, suggestion, lien, etc.
 
Merci d'avance, comme on dit !


Message édité par agyar le 10-08-2005 à 22:32:21
mood
Publicité
Posté le 10-08-2005 à 18:37:25  profilanswer
 

n°2123453
agyar
Posté le 12-08-2005 à 11:34:56  profilanswer
 

Hem... Ca n'intéresse personne, ou personne ne s'est jamais retrouvé confronté au problème, ou... quoi ?
 
(un genre de UP, quoi :) )

n°2123468
lolos83
Posté le 12-08-2005 à 11:45:13  profilanswer
 

t'es portable il tourne sous quel OS ?

n°2123469
bob306
Veteran HFR
Posté le 12-08-2005 à 11:45:26  profilanswer
 

les portables sont sous xp ?


Message édité par bob306 le 12-08-2005 à 11:45:52

---------------
Maps CS:S - Maps Left 4 Dead - Installation serveurs dediés - Team G.A.S CS:Source
n°2123471
lolos83
Posté le 12-08-2005 à 11:48:00  profilanswer
 

essaye de rajouter ton utilitaire WIFI en tant que "service"
comme ca tu auras ta connextion wifi sans etre obligé de lancer une session .

n°2123492
agyar
Posté le 12-08-2005 à 12:06:05  profilanswer
 

Salut à tous, et merci pour les questions et suggestions.
 
Effectivement, les OS peuvent être utiles :
- Le portable 1 tourne sous Windows 98 SE (vu la config - PII-350 avec 192 Mo de RAM, c'est préférable pour éviter de passer son temps à attendre)
- Le portable 2 tourne sous Windows 2000 Professionnel
 
Les OS des deux portables sont tenus à jour via Windows Update.
 
Je viens de tomber sur une page expliquant comment régler la question avec des portables sous Windows XP SP2, mais bon, ce ne sont clairement pas des bêtes de course, alors leur coller un OS qui réclame 1.5 GHz et 512 Mo de RAM pour pouvoir tourner correctement si on veut faire autre chose qu'admirer le papier-peint du Bureau, j'hésite...
 
Pour lolos83 : si t'as de la doc sur la façon de passer un programme en service, je suis intéressé. Au cours de mes recherches, je n'ai pas trouvé mieux qu'acheter un soft Microsoft pour programmer soi-même un nouveau service... Autant dire que c'est hors de ma portée.

n°2123512
lolos83
Posté le 12-08-2005 à 12:52:19  profilanswer
 

pour le portable en 2000 ca devrait etre bon
il te faut un tools du reskit 2000 qui s'appel instsrv.exe
un lien expliquand tout ici:
 
http://www.ntfaqfr.com/ntfaq/installjc2.htm
 
apres pour ton poste en win98 la je sais pas....un passage en NT 4 peut etre

n°2123571
agyar
Posté le 12-08-2005 à 13:48:22  profilanswer
 

Merci pour le lien expliquant comment passer une appli en service !
 
Pour le coup, je bloque maintenant sur le démarrage du service (le programme de configuration de la carte plante lamentablement quand on le lance :( ), mais je vais continuer à chercher sur cette piste...
 
Pour le W98, j'aimerais bien qu'il existe une autre solution , mais c'est clairement pas gagné...
 
Si quelqu'un a d'autres infos sur la question, qu'il n'hésite pas !


Message édité par agyar le 12-08-2005 à 13:48:45
n°2123619
SylvainDNS
Posté le 12-08-2005 à 14:23:01  profilanswer
 

Avec les carte Intel, t'as un outils qui te permets d'avoir une connexion permanente (avant le loggin) qui te permets le deploiemet des GPO machines et d'application
et un autre utilitaire qui te connecte au moment de le verification du mot de passe.
Ca marche sans probleme, par contre avec les autres marque je sais pas

n°2123699
agyar
Posté le 12-08-2005 à 15:18:41  profilanswer
 

Hem, si j'avais su ça avant, j'aurais probablement acheté de l'Intel. Mais là, pour le coup ça m'aide pas trop. A la rigueur, si tu pouvais me donner le nom des softs, je pourrais toujours aller voir s'ils sont dispo sur leur site... ?
 
Pour le coup du service, j'ai fini par y arriver, surtout grâce à une autre page, dont la méthode est plus radicale (possibilité de défnir un répertoire de travail pour l'appli, et d'autres paramètres, à grands coups d'insertion de clés et de chaînes dans le registre) : http://zoe.omara.ca/RunAsServiceFrench.
 
En revanche, ça ne me sert à rien : le serveur de domaine reste introuvable. Après m'être connecté en local, j'ai bien constaté que le processus principal d'accès au réseau (odhost.exe, signalé comme essentiel pour la connexion par WiFi avec des cartes Linksys par ce site : http://www.processlibrary.com/directory/files/odhost/) est démarré, mais rien à faire : je n'ai pas de réseau.
Au passage, après avoir rétabli la situation d'origine, j'ai tué odhost.exe, pour voir : j'avais toujours accès au réseau... Il y en a donc un autre qui joue un rôle, que je n'ai pas été capable d'identifier.
 
Donc je suis toujours dans le vent... Si j'aimais bien les smileys, j'en aurais mis un qui montre les crocs !
 
D'autres idées, peut-être... ?
 

mood
Publicité
Posté le 12-08-2005 à 15:18:41  profilanswer
 

n°2123724
lolos83
Posté le 12-08-2005 à 15:45:17  profilanswer
 

tout est dit ici:
 
http://www.laboratoire-microsoft.o [...] k/wpa/0/#2
 
en faite il faut utiliser le protocol wap.
 

n°2123737
agyar
Posté le 12-08-2005 à 16:01:25  profilanswer
 

Hem... Tu t'emballes je pense !
 
L'article a l'air méchamment complet, c'est clair. Mais mon problème n'est à l'heure actuelle pas l'authentification (je passe d'ailleurs par du WPA-PSK), puisque cette authentification fonctionne une fois la session ouverte en local. En gros, je peux facilement accéder à mon réseau WiFi, mais seulement une fois la session ouverte...
 
Mon problème étant de faire en sorte que mes cartes WiFi "démarrent" et s'inscrivent sur le réseau WiFi avant l'ouverture de session, histoire que mes clients puissent demander l'autorisation de se connecter au serveur de domaine.
 
J'ai bien vu que la configuration des clients WiFi se fait sous WinXP SP2... celui-ci semble en effet mieux gérer le 802.1x que les prédecesseurs... La question restant : comment faire quand on a "que" W2k et W98 en OS pour les clients ?
 
Merci quand même BEAUCOUP pour ton aide, je sais que ça demande du temps !


Message édité par agyar le 12-08-2005 à 16:02:18
n°2123745
lolos83
Posté le 12-08-2005 à 16:08:10  profilanswer
 

justement le but de cette méthode et de creer une connexion RAS qui te permettras une ouverture de session avec l'acces wifi....si j'ai bien tout compris.

n°2123753
agyar
Posté le 12-08-2005 à 16:17:54  profilanswer
 

Ok, bah je vais me taper les 30 minutes de lecture alors (enfin... 30min, c'est ce que dit la page principale ; vu la complexité du biniou, c'est plutôt un ou deux jours avec les manipulations...).
 
Merci pour ton insistance !!

n°2123768
agyar
Posté le 12-08-2005 à 16:37:13  profilanswer
 

Bon, en fait ça se parcourt assez vite.
 
Plusieurs points font que ça va pas le faire :
- Le premier, le plus gros, c'est que mon contrôleur de domaine n'est pas un Windows, mais un Linux qui fait tourner Samba. Du coup, installer IIS... je vois as trop. Il doit exister des solutions équivalentes, mais bonjour le parcours du combattant rien que pour essayer de faire fonctionner le truc côté serveur.
- Côté client, bah je suis fort aise que Windows XP SP2 fasse facilement tourner du WiFi. L'article mentionne quand même (tout à la fin) qu'il est possible de passer un patch pour les Windows 2000. Arrivé sur le site de Windows qui propose le patch, on voit une petite phrase bien sentie, je cite : "Ce téléchargement est disponible pour les clients sous Microsoft Windows authentique".
Bon, m'en fous tous mes OS sont originaux, mais quand même, je sais pas si vous avez remarqué, ça doit devenir dur de maintenir son OS à jour quand on a une version crackée, nan ?
(Au passage, pourquoi ce patch ne m'a-t-il pas été proposé par le Windows Update lors d'une de mes mises à jour, mystère)
 
Pour ma machine sous W98 en revanche, ça semble définitivement mort...
 
Plus d'info quand j'aurai passé le patch et réussi à faire démarrer la carte !

n°2123770
lolos83
Posté le 12-08-2005 à 16:37:44  profilanswer
 

c vrai que tu es sous linux...c pas dit que ca fonctionne alors

n°2123841
agyar
Posté le 12-08-2005 à 17:24:37  profilanswer
 

Shame on me, j'ai le SP5 et du coup le patch de W2K devient inutile, puisque j'ai bien un onglet "Authentification" dans les Propriétés de ma connexion réseau. Donc, si j'avais un serveur Windows, je pourrais y installer IIS et Radius, afin de pouvoir essayer de connecter mes clients (enfin, seulement le W2K) dans le domaine en ouverture de session.
 
Bon, par contre j'ai trouvé ce lien, qui semble vouloir dire qu'un soft gratuit permettrait de gérer le WPA-PSK (ça tombe bien c'est ce que j'ai fait chez moi)... Reste à voir si c'est jouable en ouverture de session... Plus de nouvelles bientôt (enfin, j'espère).


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software

  WiFi - Ouvrir une session dans un domaine

 

Sujets relatifs
Wifi désynchronise la Freebox après 5 minutes...Extension reseau d'entreprise en wifi
Extension d'un LAN filaire avec un portable WIFI [RESOLU]Routeur wifi ou access point wifi ?
[Outlook2003] Comment ouvrir un exeproblème install carte wifi
Wifi + BlueTooth en meme temps ??carte Wifi PCI et KT7A
avec quoi ouvrir img[CH] conseils ou comparatif routeur WIFI sans modem integré :)
Plus de sujets relatifs à : WiFi - Ouvrir une session dans un domaine


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR