Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1960 connectés 

  FORUM HardWare.fr
  Windows & Software
  Win Vista

  [RESOLU]Clavier/souris ne fonctionnent plus (Code 39 / 10) Vista

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[RESOLU]Clavier/souris ne fonctionnent plus (Code 39 / 10) Vista

n°2818198
Meulator
Si je t'attrape...
Posté le 06-11-2008 à 16:54:25  profilanswer
 

Hello all
 
Help, je vais pèter un cable!!
 
Après avoir installé vmware server 2, je reboot, pas de soucis. Ensuite, probleme, je dois rebooter une nouvelle fois... et là au redémarrage, le clavier ne fonctionne plus (c'est un laptop)  : ni le clavier de base, ni un clavier usb! Et pour le touchpad c'est pareil, mais la souris USB elle fonctionne toujours.
 
En allant faire un tour ds le gestionnaire de périph, j'ai un code 39 sur le clavier, et un code 10 sur la souris... j'ai viré VMware pensant que ça pouvait etre ça, rien à faire....
 
J'ai tenté de supprimer/reboot -> il les redetecte bien mais tjrs les memes codes d erreur...
 
Là je sèche...


Message édité par Meulator le 07-11-2008 à 09:40:59
mood
Publicité
Posté le 06-11-2008 à 16:54:25  profilanswer
 

n°2818221
Meulator
Si je t'attrape...
Posté le 06-11-2008 à 17:35:46  profilanswer
 

help svp... en mode sans echec ça fonctionne pas non plus, par contre quand je fais F8 puis réparer, il me demande le type de clavier puis de rentrer mon login/pass et là ca fonctionne... j'ai beau réparé, quand je reboot, mon clavier souris tjrs HS... j'essaie de mettre a jours les pilotes ça change rien...

n°2818253
Meulator
Si je t'attrape...
Posté le 06-11-2008 à 19:41:29  profilanswer
 

up... ça me rends fou! M'apprendra a rester sous vista... sérieux je pige pas, c'est pas un probleme hardware, et bizarrement je dirais que c'est pas un pb usb non plus, puisque j'ai ma souris qui fonctionne en usb, des clefs usb aussi y compres des cles qui n'avaient pas été préalablement inserées...

n°2818323
Meulator
Si je t'attrape...
Posté le 07-11-2008 à 09:40:14  profilanswer
 

Bande de nazes! :D :D
 
J'ai trouvé la solution, il faut éditer le registre. Je confirme, ça doit venir de vmware : en l'installant, Kaspersky m'a détecté un keylogger (vmkdb.sys) ; je sais pas si il a empecher quelque chose de se faire bien, en tt cas après ça foirais.
 
Il faut éditer les clefs suivantes, et virer "vmkdb" . Attention les clefs ci dessous peuvent varier d'un pc à l'autre (surtout que ça c'est sur un pc XP, mais ce sont les même clef sur Vista)
 

Code :
  1. [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4D36E96B-E325-11CE-BFC1-08002BE10318}]
  2. "UpperFilters"=hex(7):6b,00,62,00,64,00,63,00,6c,00,61,00,73,00,73,00,00,00,00,\
  3.   00
  4.  
  5. [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CriticalDeviceDatabase\root#rdp_kbd]
  6. "UpperFilters"=hex(7):6b,00,62,00,64,00,63,00,6c,00,61,00,73,00,73,00,00,00,00,\
  7.   00
  8.  
  9. [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\RDP_KBD\0000]
  10. "UpperFilters"=hex(7):6b,00,62,00,64,00,63,00,6c,00,61,00,73,00,73,00,00,00,00,\
  11.   00
  12.  
  13. [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Control\Class\{4D36E96B-E325-11CE-BFC1-08002BE10318}]
  14. "UpperFilters"=hex(7):6b,00,62,00,64,00,63,00,6c,00,61,00,73,00,73,00,00,00,00,\
  15.   00
  16.  
  17. [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Control\CriticalDeviceDatabase\root#rdp_kbd]
  18. "UpperFilters"=hex(7):6b,00,62,00,64,00,63,00,6c,00,61,00,73,00,73,00,00,00,00,\
  19.   00
  20.  
  21. [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Enum\Root\RDP_KBD\0000]
  22. "UpperFilters"=hex(7):6b,00,62,00,64,00,63,00,6c,00,61,00,73,00,73,00,00,00,00,\
  23.   00
  24.  
  25. [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96B-E325-11CE-BFC1-08002BE10318}]
  26. "UpperFilters"=hex(7):6b,00,62,00,64,00,63,00,6c,00,61,00,73,00,73,00,00,00,00,\
  27.   00
  28.  
  29. [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\root#rdp_kbd]
  30. "UpperFilters"=hex(7):6b,00,62,00,64,00,63,00,6c,00,61,00,73,00,73,00,00,00,00,\
  31.   00
  32.  
  33. [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\RDP_KBD\0000]
  34. "UpperFilters"=hex(7):6b,00,62,00,64,00,63,00,6c,00,61,00,73,00,73,00,00,00,00,\
  35.   00


 
Source :

Code :
  1. http://blog.ryantadams.com/2008/01 [...] s-code-39/


 
 
 
 

n°3002269
phoneix35
Phoneix035 in game :o
Posté le 27-07-2011 à 20:09:06  profilanswer
 

Salut, :hello:
Je suis désolé d'avoir à relancer un topic vieux de 3 ans (résolu en plus) mais comme j'ai le même problème je pensais que tu pourrais m'aider :)
 
En fait j'arrive pas à trouver les clés registre dont tu parles :/
Apres {4D36E96B...} l'arbre ne correspond plus (je suis sous Xp) et en plus je comprends pas tes modifications :/
 
Encore désolé de remonter et je comprendrais si un modérateur intervient :jap:
 


---------------
Bordel, quand on rentre sur la piste.

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software
  Win Vista

  [RESOLU]Clavier/souris ne fonctionnent plus (Code 39 / 10) Vista

 

Sujets relatifs
[Résolu]KB trojan[Résolu] Outlook Express ne voit pas les pièces jointes
Perte de réseau sous vistaCarte Son Creative Sound Blaster X-Fi Xtreme Audio Compatible Vista ??
[Résolu] HTTPS et .htaccessQuel vista choisir ? 32 ou 64 bits ?
Problème d'icône sous Vista[Résolu] Windows Defender ne démarre pas automatiquement
Windows Vista - Avoir les droits admin sans aller en sans echec 
Plus de sujets relatifs à : [RESOLU]Clavier/souris ne fonctionnent plus (Code 39 / 10) Vista


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR