Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2825 connectés 

  FORUM HardWare.fr
  Windows & Software
  Win NT/2K/XP

  problème avec .msi

 


 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

problème avec .msi

n°1895540
bdg
Posté le 20-01-2005 à 11:32:11  profilanswer
 

J'ai installé un serveur RIS qui fonctionne bien.
 
Je veux maintenant pouvoir déployer des .msi
 
J'ai suivi le tuto sur:
 
http://www.laboratoire-microsoft.o [...] ation_msi/
 
J'ai bien en sortie un .msi, pour l'installation de realone.
 
Le problème est que quand je le lance (que ce soit sur un autre pc ou sur celui utilisé pour la création de ce .msi [apres la désinstallation de realone evidement !]) Il me sort une erreur:
 
Erreur 1406. Impossible d'écrire la valeur ... dans la clé
\....\...
Vérifiez que vous disposez des droits (blablabla)

 
J'ai utilisé Veritas discover avec les droits admin bien sur.  
 Des idées ?
 
(meme erreur pour tous les tests sur différents pc)


Message édité par bdg le 20-01-2005 à 13:28:06
mood
Publicité
Posté le 20-01-2005 à 11:32:11  profilanswer
 

n°1896131
bigbisou
Posté le 20-01-2005 à 16:50:39  profilanswer
 

bdg a écrit :

J'ai installé un serveur RIS qui fonctionne bien.
 
Je veux maintenant pouvoir déployer des .msi
 
J'ai suivi le tuto sur:
 
http://www.laboratoire-microsoft.o [...] ation_msi/
 
J'ai bien en sortie un .msi, pour l'installation de realone.
 
Le problème est que quand je le lance (que ce soit sur un autre pc ou sur celui utilisé pour la création de ce .msi [apres la désinstallation de realone evidement !]) Il me sort une erreur:
 
Erreur 1406. Impossible d'écrire la valeur ... dans la clé
\....\...
Vérifiez que vous disposez des droits (blablabla)

 
J'ai utilisé Veritas discover avec les droits admin bien sur.  
 Des idées ?
 
(meme erreur pour tous les tests sur différents pc)


 
Dans la création de ton msi tu as du capturer des clés de registre ecrite par le system.
Meme l'admin n'a pas tout les droit sur le registre.
Edite lemsi et essaie de filtrer ces cles.
C'est peut etre ca?????

n°1896168
bigbisou
Posté le 20-01-2005 à 17:08:44  profilanswer
 
n°1896900
bdg
Posté le 21-01-2005 à 09:46:10  profilanswer
 

ok je regarde ca!
Sinon en recherchant sur le web je me suis aperçu qu'apparement il y a des problèmes (plutot des difficultés) pour créer des .msi avec un windows XP (xp sp2 dans mon cas)
 
Sur mon XP 'cobaye'  : o  
J'ai installé VERITAS Software,
disponible sur le CD-ROM de Windows 2000 sous le nom de SWIADMLE.MSI suivant le chemin
\VALUEADD\3RDPARTY\MGMT\WINSTLE
 
Y a-t-il une version de cet utilitaire spécialement pour les XP ?
J'ai parcouru le cd et j'ai rien trouvé !
 
thx

n°1896949
bigbisou
Posté le 21-01-2005 à 10:29:20  profilanswer
 

Désolé je ne connais pas Wininstall LE
Mais c'est quoi ces problèmes sur XP SP2? je package sur cet OS et y'a pas de pb particulier.

n°1896968
bdg
Posté le 21-01-2005 à 10:47:10  profilanswer
 

http://www.autourdupc.com/index.ph [...] ackage.htm
 
Mais les packages que tu descends ils sont deja créés ? (du style les .msi connus comme office pour ne citer que lui)
 
Ou alors c'est toi qui les crées ?
 
Mon but c'est d'inclure des packages que je crée a l'installation sans attente d'un pc.
(realone, power archiver java .. enfin tout ce que mon entreprise [ fac xD ] utilise)
 
voila !!


Message édité par bdg le 21-01-2005 à 10:49:14
n°1896995
bigbisou
Posté le 21-01-2005 à 11:15:24  profilanswer
 

je fais les 2, packaginig et repackaging.
Je connais un peu Win LE, il faut avouer que ce n'est pas des outils les plus complet et meme des plus simple.
Peut etre devrais tu faire un test avec un vrai outils de packaging. Je pense que le plus simple c'est installshield.
Mais si tu veux seulement faire des scripts d'installation automatiques, tu dois pouvoir t'en sortir sans créer des msi.

n°1897006
bdg
Posté le 21-01-2005 à 11:27:29  profilanswer
 

Le problème vient des installations qui ne peuvent pas être 'silencieuses'
 
Mon maître de stage m'a donc demandé de juste créer des .msi pour tout ce qu'il faut installer.  
 
J'ai deja réussi a installer des applications qui supportent le mode 'silencieux' avec l'aide de cmdlines.txt.
En l'occurence la c'est du packaging que je cherche.  
 
Je vais donc regarder du coté de installshield !!
Merci je te tiens au courant


Message édité par bdg le 21-01-2005 à 11:28:06
n°1897018
bigbisou
Posté le 21-01-2005 à 11:33:29  profilanswer
 

Ok mais tu peus aussi faire du repackaging en exe, c'est plus simple.
Wise a un outil pour ca

n°1897031
bigbisou
Posté le 21-01-2005 à 11:41:12  profilanswer
 

Wise installation system
http://www.wise.com/dev_evaluations.asp
Ca fait des install silencieuse mais avec un exe et c'est bcp plus simple

mood
Publicité
Posté le 21-01-2005 à 11:41:12  profilanswer
 

n°1897037
bdg
Posté le 21-01-2005 à 11:49:55  profilanswer
 

downloading ...
je test apres manger :p

n°1897045
boomboommu​sic
Posté le 21-01-2005 à 11:54:00  profilanswer
 

Tout depends du parc aussi :)
Qd on commence à avoir un grand nombre de machine...le self healing comment à être trés apreciable :)

n°1897184
bdg
Posté le 21-01-2005 à 13:43:54  profilanswer
 

qu'entends tu par self healing =)
 
je vais essayer de tester wise mais ca ne m'a pas l'air tres facile à utiliser !! du moins juste pour faire un pti .msi !!
 
Win LE ne marche pas mais ct simple à utiliser ;)

n°1897224
boomboommu​sic
Posté le 21-01-2005 à 14:11:39  profilanswer
 

bdg a écrit :

qu'entends tu par self healing =)
 
je vais essayer de tester wise mais ca ne m'a pas l'air tres facile à utiliser !! du moins juste pour faire un pti .msi !!
 
Win LE ne marche pas mais ct simple à utiliser ;)


 
le self healing c'est l'auto réparation :)
En gros tu installes un programme...il fonctionne bien puis les etudiants passe sur la machine et on vient te chercher en te disant qu'il manque la dll machin pour lancer le programme toto...
 
et bien avec le MSI ca n'existe plus la dll est manquante..windows Installer regarde le fichier msi et s'apercois qu'une dll est effectivement manquante...il la replace et voila c est reglé :)

n°1897237
bdg
Posté le 21-01-2005 à 14:20:21  profilanswer
 

puissant ^^
 
je vais me renseigner, a terme ca va etre une solution potentielle. :)

n°1897268
boomboommu​sic
Posté le 21-01-2005 à 14:57:36  profilanswer
 

bdg a écrit :

puissant ^^
 
je vais me renseigner, a terme ca va etre une solution potentielle. :)


 
 
Selon c'est la solution ultime :p
Mais c'est aussi celle qui est la plus compliqué à mettre en place et la moins documenté...

n°1908690
bdg
Posté le 31-01-2005 à 13:56:10  profilanswer
 

pour info les .msi que je tentais de créer n'ont jamais fonctionnées
 
En fait je tentais de les faire sous un pc winXP PRO sp2
Il ne me créait que le .reg, il ne voyait donc que les changements au niveau de la base de registre.
 
Ensuite j'ai créé des .msi a partir d'un win2000 pro sp4 et tout a correctement fonctionné, les  .msi étaient utilisables sous winxp SP2.
 
J'ai créé des .msi avec un winXP sp1 et la aussi ca a focntionné.
 
Conclusion: le SP2 continue de faire parler de lui ... (avec la version 2003 de win install LE ca ne fonctionne pas non plus)


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software
  Win NT/2K/XP

  problème avec .msi

 

Sujets relatifs
Problème avec messenger 6.2 rebootProbleme de script
Probleme tache planifiée par reseauProbleme flashage STH "k" [RESOLU]
Problème avec FirefoxProblème de connexion à "Le Neuf"
Probleme avec Explorerproblème : internet , msn et outlook se ferment
Problème partitionnement....PROBLEME AVEC SP2 (post corrigé)
Plus de sujets relatifs à : problème avec .msi


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR