Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1506 connectés 

  FORUM HardWare.fr
  Windows & Software
  Logiciels

  Macro conditionnel OOo ou Excel

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Macro conditionnel OOo ou Excel

n°2954029
ProGrammeH​eure
Posté le 20-07-2010 à 11:25:00  profilanswer
 

Bonjour,
 
je voudrais savoir si avec une macro OOo clac il serait possible de remplir un tableau de manière conditionnel envers un autre.
un peu vague, alors je vais faire un exemple:
tableau 1 j'ai:
 
colone: A               B    C
           Voiture_A   10  130
           Voiture_B   20  75
           Voiture_C   80  120
            ....

la colone A représente l'identifiant d'une voiture par exemple, la colone B le temps mis pour faire un parcour et C la vitesse moyenne.
tableau 2 j'ai:
 
colone: B               D    
           Voiture_A   ferarri  
           Voiture_C   408  
           Voiture_D   4L  
            ....

la colone B représente l'identifiant d'une voiture, et la D la description de celle ci.
 
ce que je voudrai faire c'est un tableau capable d'aglomérer/ de concaténer ces informations si, et seulement si leur identifiant est le même.
 
en gros j'aimerai faire (je fais un peu une analogie avec du C  :heink:  ):

Ligne_i=1;
Ligne_max=400; // par exemple
 
FAIRE {
 
  SI (identifiant Fichier1.cloneA.ligne_i = Fichier2.coloneB.ligne_i)  
        Fichier2.coloneE.ligne_i=Fichier1.cloneB.ligne_i ;
        Fichier2.coloneF.ligne_i=Fichier1.cloneC.ligne_i ;
  FIN SI
  ligne_i = ligne_i +1;
 
TANT QUE ( ligne_i <Ligne_max);

 
Donc est ce que cela est possible, et si oui comment faire?
--> soit si vous avez un petit exemple
--> soit le bon petit tuto que je trouve pas
--> soit la réponse \o/
--> soit juste une remarque.
 
je ne connais vraiment pas les macro sous excel ou OOo calc, mais j'ai des tableau de millier de lignes alors, je pense fortement m'y mettre plutot que de tout me taper à la main.  :pt1cable:  
 
merci,
 
Bien cordialement,
                                   P.
 
           
 

mood
Publicité
Posté le 20-07-2010 à 11:25:00  profilanswer
 

n°2954266
dje69r
Arme de distraction massive
Posté le 22-07-2010 à 10:49:35  profilanswer
 

Hello
 
Au passage, de ton précédent sujet, je n'ai jamais recu le fichier...
 
Pour celui la, je dirais, aux vues de l'exemple, qu'un simple RechercheV() devait suffire, sans se prendre le choux avec de la progra
 
Si j'ai bien compris, tu voudrais dans ton fichier 2:
colone: B               D               E               F
           Voiture_A   ferarri         10              130
           Voiture_C   408            80              120
           Voiture_D   4L              ?                ?
            ....  
 
Je pars du principe que ton fichier se nomme Classeur1.xls, le second Classeur2.xls (original hein)
Je pars aussi du principe que tes infos commencent a la ligne1
 
Donc en E1 : =RECHERCHEV(B1;[Classeur1]Feuil1!$A$1:$C$65536;2;FAUX)
En F1 : =RECHERCHEV(B1;[Classeur1]Feuil1!$A$1:$C$65536;3;FAUX)
 
Et ca renvoi bien :
colone: B               D               E               F
1          Voiture_A   ferarri         10              130
 
Ensuite tu n'as plus qu'a tirer tes formules vers le bas et ton tableau est fait en 5sc... Il s'actualise tout seul etc. Sans avoir besoin de routine qui passe en revu des milliers de lignes...


Message édité par dje69r le 22-07-2010 à 10:54:11

---------------
Le cas Anne Hidalgo Madame Hidalgo vous êtes Maire d'une ville, pas d'un parcours santé :o Paris c'est la ville du progrès donc ici les couilles c'est une option :o²
n°2954269
ProGrammeH​eure
Posté le 22-07-2010 à 10:53:52  profilanswer
 

merci,
oui finalement, j'ai vu que recherche devrait suffir,
pour ce qui est de mon précédent sujet, j'ai oublier de faire un retour,  je m'en excuse, mais j'ai finalement trouvé un outil de supervision qui fonctionne.


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software
  Logiciels

  Macro conditionnel OOo ou Excel

 

Sujets relatifs
Soucis outlook via VBA excelExcel: Recuperer les 3 meilleurs d'un tableau
Comparaisons excelExtraire des données dans Excel
Excel: chiffre dynamique linké sur un site internetExcel vers Matlab ou équivalent
affecter des mots-clés, tags à une cellule excelC++ et Excel: comment lire dans Excel des valeurs
[Excel 2003] + macros +deleteFolder ?[Excel 2010] Mode de compatibilité ?
Plus de sujets relatifs à : Macro conditionnel OOo ou Excel


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR