Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2172 connectés 

  FORUM HardWare.fr
  Windows & Software
  Logiciels

  excel : formule avec conditions

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

excel : formule avec conditions

n°2801540
lili237
Posté le 28-08-2008 à 11:09:42  profilanswer
 

Bonjour,
 
j'aimerais sous excel écrire une formule avec condition:
 
Voici mon problème :
 
le résultat de ma cellule A2, dépend de celui de la cellule A1.
Si A1=0 ou rien alors A2=0
Sinon (c'est-à-dire A1<>0) alors A2=2.66+(2.33*A1)
 
 
J'ai essayé ces 2 formules (dans la cellule A2)
=SI(A1=0;A2=0;A2=2,66+(2,33*C12))
et l'autre
SI(A1=0;A2=0;SI(A1<>0,A2=2,66+(2,33*C12)))
 
Mais aucune ne fonctionne...
 
Quelqu'un aurait-il la solution SVP ?
 
Merci.

mood
Publicité
Posté le 28-08-2008 à 11:09:42  profilanswer
 

n°2801549
phosphorel​oaded
Posté le 28-08-2008 à 11:23:19  profilanswer
 

Bonjour,
 
tu peux poser ta question dans le Topic Excel ;)
 
Ou lire ce sujet: [EXCEL] Conditions sur cellules ? HELP


Message édité par phosphoreloaded le 28-08-2008 à 11:25:21
n°2801550
Xspawn_Lpc
Posté le 28-08-2008 à 11:30:11  profilanswer
 

en anglais :
=IF(OR(ISBLANK(A1); A1=0);0;"ta formule ici" )
 
en français(je n'ai pas d'excel sous la main...) :
IF =SI
OR = OU
ISBLANK = ??

n°2801587
lili237
Posté le 28-08-2008 à 13:36:01  profilanswer
 

Voilà ce que je viens de mettre.
 
=SI(OU(ESTVIDE(A1); A1=0);0; "(2.66+(2.33*A1))" )
 
La formule fonctionne bien si A1=0 ou est vide
Par contre dans les autres cas, apparaît dans la case A2 la formule au lieu du résultat de cette formule...
 
Où me suis-je trompé ?

n°2801625
lili237
Posté le 28-08-2008 à 16:56:40  profilanswer
 

Personne pour me dépanner ?

n°2801628
Xspawn_Lpc
Posté le 28-08-2008 à 17:16:08  profilanswer
 

enelve les " ;)

n°2801630
lili237
Posté le 28-08-2008 à 17:20:18  profilanswer
 

J'ai déjà essayé : sans les ", j'ai le message "votre formule contient une erreur..."

n°2801631
lili237
Posté le 28-08-2008 à 17:22:34  profilanswer
 

J'ai trouvé, j'avais écrit 2.33 au lieu de 2,33
 
Merci


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software
  Logiciels

  excel : formule avec conditions

 

Sujets relatifs
Fichier excel Fichie Verouilléexcel+calendrier perpétuel+compteur
Pb de mise à jour entre 2 documents excel liéshoraire travail compliqué sur excel
Problème impression des textes en couleur sous ExcelOuverture fichiers excel et word trés lente
Résolu! Excel-Macro de création de liens hypertexte en automatiqueInserer une page web dans excel word ou ppt
[Résolu]Mon fichier Excel affiche des caractères chinois[Excel] Formule à conditions
Plus de sujets relatifs à : excel : formule avec conditions


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR