Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
640 connectés 

  FORUM HardWare.fr
  Windows & Software
  Logiciels

  [EXCEL] Extraire la date la plus tôt d'un mois spécifique

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[EXCEL] Extraire la date la plus tôt d'un mois spécifique

n°3328948
Latiole
Posté le 21-11-2018 à 07:42:06  profilanswer
 

Bonjour :hello: ,
 
J'ai une liste de dates (de différents mois et années) dans la colonne B (de B1 à B8), par exemple:
04.01.2010
15.01.2010
22.01.2010
10.03.2010
22.03.2010
26.03.2010
05.02.2016
15.02.2016
 
Ce que je souhaiterai, c’est une formule qui extrait par exemple la date la plus tôt pour le mois de Janvier 2010 (ici 04.01.2010) ou pour Février 2016 (ici 05.02.2016).
 
J’ai essayé ceci et d’autres formules sans succès

Code :
  1. =min(si(B1:B8=date(2010;1;);B1:B8))


 
Merci beaucoup pour votre aide


Message édité par Latiole le 21-11-2018 à 07:43:36
mood
Publicité
Posté le 21-11-2018 à 07:42:06  profilanswer
 

n°3328982
ge_laf
Posté le 21-11-2018 à 11:31:12  profilanswer
 

L'imbrication de fonction n'est pas possible comme ça. La fonction min cherche dans une plage de donnée, et ne fais pas de test.
A voir du coté de "trouve" ou "recherche"
 
Sinon, en ajoutant une colonne, il y a plusieurs solutions:
 
La première qui me vient, et peut-etre pas la plus simple: Extraire le jour de tes dates selon ton critère, puis de faire le min.
 
 
C1:C8:
=SI(ET(MOIS(B1)=$ref_mois;ANNEE(B1)=$ref_année);JOUR(C1);"" )
 
Ainsi dans ta colonne, tu n'as que les jours de tes dates du mois et de l'année souhaités.
Reste à faire un min (C1:C8)


Message édité par ge_laf le 21-11-2018 à 11:32:58
n°3328989
DjiDji5943​0
Posté le 21-11-2018 à 12:16:02  profilanswer
 

Bonjour,
 
={min(si((mois(B1:B8=1))*(année(B1:B8=2010);B1:B8)}
 
formule matricielle a valider avec shift+ctrl+entrée les trois doigts en meme temps. Apparait alors une accolade a chaque extremite de la formule .
(a refaire a chaque fois qu'on touche a la formulr)

n°3328990
Latiole
Posté le 21-11-2018 à 13:08:03  profilanswer
 

Merci à vous deux pour l'effort.

 
DjiDji59430 a écrit :

Bonjour,

 

={min(si((mois(B1:B8=1))*(année(B1:B8=2010);B1:B8)}

 

formule matricielle a valider avec shift+ctrl+entrée les trois doigts en meme temps. Apparait alors une accolade a chaque extremite de la formule .
(a refaire a chaque fois qu'on touche a la formulr)

 

Mahleureusement, si j'essaie avec Fevrier 2016, ca ne fonctionne pas, ca me renvoie à la plus petite valeur de la serie (04.10.2010).

 

Jusqu'à maintenant, j'utilisais un tableau croise dynamique en sortant les mois et leur valeur "Date" Minimum, mais ce 'est pas super en terme d'automatisation.

  


Message édité par Latiole le 21-11-2018 à 13:10:01
n°3328991
Z_cool
Oups !
Posté le 21-11-2018 à 13:12:55  profilanswer
 

euhh si la colonne est au format date, une simple fonction de tri ne suffirait pas ?
 
ou alors j'ai pas compris la problematique


---------------
On a deux vies, et la deuxième commence quand on se rend compte qu’on n’en a qu’une. ( Confucius )
n°3329033
DjiDji5943​0
Posté le 21-11-2018 à 19:32:30  profilanswer
 
n°3329148
Latiole
Posté le 23-11-2018 à 07:05:46  profilanswer
 

Sinon, j'ai crée une colonne avec :
 
=SI(MOIS(B3)=MOIS(B2);"";B3)  
 
et en descendant cette formule, ca ne sort que les premières dates de chaque mois, ce que je veux. Le problème est qu'il y pleins de lignes vides entre les résultats, je ne sais pas comment lister par formule les occurences dans une autre colonne sans ligne vide entre elles.

n°3329285
DjiDji5943​0
Posté le 24-11-2018 à 16:26:59  profilanswer
 

Si tu veux faire une liste sans vide, il te faudra quand même une matricielle!  
Et ta formule ne fonctionne pas si tes dates sont mélangées...
Crdlmt


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software
  Logiciels

  [EXCEL] Extraire la date la plus tôt d'un mois spécifique

 

Sujets relatifs
Automatiser le changement de date d'un dossier ?Copies fichiers Exel 2003 inexploitable
copie fichier ecel 2003 inexploitableEXCEL extraire une chaîne de caractère irrégulière
extraire des email a partir d'un PDFExtraire fichiers d'une image Ghost
Changer date d'expiration d'un cookieConnaître la date d'une vidéo après import sur le PC ?
Incrémentation automatique de la date en veilleDate d'expiration Windows 10
Plus de sujets relatifs à : [EXCEL] Extraire la date la plus tôt d'un mois spécifique


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR