Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1429 connectés 

  FORUM HardWare.fr
  Windows & Software
  Logiciels

  [Excel] "Créer" une formule à partir de Cellules

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Excel] "Créer" une formule à partir de Cellules

n°2250048
kowalski
Posté le 08-12-2005 à 10:36:34  profilanswer
 

Bonjour j'ai besoin de votre aide pour quelque chose... que je pense faisable, mais que je ne sais pas faire
 
Au lieu d'écrire textuellement par exemple :
 
=SOMME(Feuil2!E4:E19)
 
Je voudrais écrire :
 
=SOMME("A1"!"A2":"A3" )
 
A1 contiendrait : "Feuil2"
A2 : "E4"
A3 : "E19"
 
Please Help !  :)  

mood
Publicité
Posté le 08-12-2005 à 10:36:34  profilanswer
 

n°2250066
trevor
laissez la vie vous étonner...
Posté le 08-12-2005 à 10:46:12  profilanswer
 

tout ce qui est difficilement faisable avec un simple calcul de cellules est en général facilement faisable avec les macros


---------------
TReVoR - http://dev.arqendra.net - http://info.arqendra.net
n°2250080
kowalski
Posté le 08-12-2005 à 10:57:14  profilanswer
 

Bon c'est pas super optimal, mais en gros :
 
Dim Temp As String
 
Temp = "="
Temp = Temp + Worksheets("Resultats" ).Cells(1, 1)
Temp = Temp + "!"
Temp = Temp + Worksheets("Resultats" ).Cells(1, 2)
Temp = Temp + CStr(Worksheets("Resultats" ).Cells(1, 3))
 
 
Worksheets("Resultats" ).Cells(1, 5).Formula = Temp
 
'
 
 
Ca fonctionne
 
Merci :p

n°2250202
JJA64
Posté le 08-12-2005 à 12:54:54  profilanswer
 

Bonjour.
Tu n'es pas forcé d'écrire textuellement. Tu dois taper =somme c'est vrai (et encore) puis tu cliques sur les cellules concernées...
JJA


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software
  Logiciels

  [Excel] "Créer" une formule à partir de Cellules

 

Sujets relatifs
Problème de lien entre Acces et Excel[Excel] Graphique, en apparence facile MAIS...
Retrouver une liaison ExcelMacro sous excel
Créer des iso?Créer une base de donnée à partir des pages jaunes ?
Feuilles pour Excel 2003Utiliser XP PRO a partir d'un DD externe , Possible ou Pas ??
créer un réseau wifi avec un dongle? 
Plus de sujets relatifs à : [Excel] "Créer" une formule à partir de Cellules


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR