Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1267 connectés 

  FORUM HardWare.fr
  Programmation
  VB/VBA/VBS

  utilisation fonction perso sous excel

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

utilisation fonction perso sous excel

n°895274
gothico
Posté le 10-11-2004 à 15:08:37  profilanswer
 

Bonjour,
Je fais actuellement sous excel ceci :

=SI(Feuil1!C1="Machaine";A1;"" )


Quand "Machaine" de la feuille 1 est présente sur C1, cela affiche A1 sinon cela n'affiche rien.
J'aimerais remplacer le n'affiche rien, par un supprime ligne.
 
J'ai donc fais une fonction dans un module de mon classeur qui est la suivante :
 

Public Function SupprLigne()
ActiveCell.EntireRow.Delete
End Function


 
 
et je l'appel comme cela :

=SI(Feuil1!C1="Machaine";A1;SupprLigne())


 
Le probleme est que excel me renvoie #NOM? et j'arrive pas à comprendre pourquoi....... Il trouve pas ma fonction.......
 
Merci pour votre aide.

mood
Publicité
Posté le 10-11-2004 à 15:08:37  profilanswer
 

n°896460
Profil sup​primé
Posté le 11-11-2004 à 23:38:00  answer
 

il faut que tu place ta fonction dans un module et non dans le code de la feuille

n°897338
gothico
Posté le 13-11-2004 à 01:22:15  profilanswer
 

C'est bien ce que j'ai fais  :heink:  

gothico a écrit :

J'ai donc fais une fonction dans un module de mon classeur qui est la suivante :

Public Function SupprLigne()
ActiveCell.EntireRow.Delete
End Function




n°897343
Profil sup​primé
Posté le 13-11-2004 à 01:31:58  answer
 

ah oui ,j'avait pas fait attention :D
 
ce que je comprend pas c'est que chez moi ca marche  [:croquignol]

n°898653
gothico
Posté le 15-11-2004 à 09:31:16  profilanswer
 

gargamail a écrit :

ce que je comprend pas c'est que chez moi ca marche  [:croquignol]


Ha bah, ca, c'est le bouquet   [:lezioul]  
 
Il me semblait bien pas avoir fait de conneries  [:mir45]

n°898681
gothico
Posté le 15-11-2004 à 09:49:41  profilanswer
 

Petite nouvelle, apparement, ca marche maintenant, mais je suis obligé de lancer l'execution de la macro (ca se fait pas tout seul?)
 
Deuxième probleme : ActiveCell.EntireRow.Delete supprimer la ligne seletionnée, or je voudrais que cela supprimer la ligne ou ce trouve la fonction, quand je peux faire ca?

n°899202
Profil sup​primé
Posté le 15-11-2004 à 17:41:18  answer
 

normalement si , ca se fait tout seul ( tu est bien en "calcul automatique" )
 
Range("A1" ).entirerow.delete puisque tu test la cellule A1


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  VB/VBA/VBS

  utilisation fonction perso sous excel

 

Sujets relatifs
fonction exponentielle mauvais résultatune fonction pour supprimer les répétitions dans un formulaire
[VBA] exporter des données excel dans outlook[VBA] excel et userform [ résolu ]
Utilisation des composants Indy 9 sous C++ Builderprob Variable et fonction moyenne
comment rechercher dans toutes les feuilles d'un classeur Excel ?gros pb avec la fonction mail ... help
[batch] saisie param + appel ftp + utilisation ds ftp du param saisifonction mail() -> adresse du messager[resolu]
Plus de sujets relatifs à : utilisation fonction perso sous excel


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR