Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1059 connectés 

  FORUM HardWare.fr
  Programmation
  VB/VBA/VBS

  [excel] Question de noob sur les commandes IF

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[excel] Question de noob sur les commandes IF

n°1877729
sseb22
It is an awful waste of space
Posté le 25-04-2009 à 16:11:15  profilanswer
 

salut
 
J'aide ma copine avec sa compta et elle m'a demande d'utiliser excel pour connaitre le montant qu'elle peut deduire.
 
SI montant > 4,25e ALORS deduction=montant-4,25
SI montant > 16,4e ALORS deduction=12,15
 
pour le moment j'utilise une case intermediaire :
 
A1 : montant
B1 : =SI(A1>4,25;A1-4,25;0)
C1:  =SI(B1>12,15;12,15;B1)
 
 
puis-je faire ca en 2 cases au lieu de 3 ?
bref, en "1 seule passe" ?


---------------
Ma "carrière" de joueur : 114 pages, 25 ans, 1 PDF
mood
Publicité
Posté le 25-04-2009 à 16:11:15  profilanswer
 

n°1877733
seniorpapo​u
Posté le 25-04-2009 à 16:36:45  profilanswer
 

Bonsoir,
 
essaye:
=SI(A1>16,4;12,5;SI(A1>4,25;4,25;0))
 
Cordialement

n°1878098
sseb22
It is an awful waste of space
Posté le 27-04-2009 à 10:17:21  profilanswer
 

merci !!

 


Je ne savais pas qu'on pouvait mettre des commandes en argument :p

 

j'ai mis ça :
=SI(A7>16,4;12,15;SI(A7>4,25;A7-4,25;0))

 

et ça a l'air de marcher


Message édité par sseb22 le 27-04-2009 à 10:18:15

---------------
Ma "carrière" de joueur : 114 pages, 25 ans, 1 PDF
n°1878104
sseb22
It is an awful waste of space
Posté le 27-04-2009 à 10:37:32  profilanswer
 

quand on dit qu'il ne faut pas imbriquer plus de 7 commandes ds excel, c'est ce genre de choses ? (là, y en a 2 imbriquées)


---------------
Ma "carrière" de joueur : 114 pages, 25 ans, 1 PDF
n°1878321
seniorpapo​u
Posté le 27-04-2009 à 15:09:01  profilanswer
 

Bonjour,
oui, mais, en cherchant sur le net, tu trouveras des  astuces pour contourner si c'est nécessaire.
Cordialement

n°1880977
sseb22
It is an awful waste of space
Posté le 05-05-2009 à 10:40:07  profilanswer
 

merci
 
non, ce n'est pas nécessaire
c'était juste pour savoir si je disais des conneries


---------------
Ma "carrière" de joueur : 114 pages, 25 ans, 1 PDF

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  VB/VBA/VBS

  [excel] Question de noob sur les commandes IF

 

Sujets relatifs
VBA Excel: comment créer un sub utilisant des parametres ?Condition If pour ComboBox en AS3
VBA Excel 2003 vs Excel 2007VBA sous excel 2003
Question pour transmettre des varibles à un scritp shellProblème de gestion de stock sous excel 2007
Petit problème macros VBA ExcelQuestion pour Scipt
Export de données Access vers Excel avec formules excel préservéesquestion sur un tableau[résolu]
Plus de sujets relatifs à : [excel] Question de noob sur les commandes IF


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR