Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
2811 connectés 

  FORUM HardWare.fr
  Programmation
  VB/VBA/VBS

  [Résolu]Comment changer automatiquement/manuellement de feuille

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Résolu]Comment changer automatiquement/manuellement de feuille

n°2323527
Gladi75
Posté le 05-11-2018 à 10:26:41  profilanswer
 

Bonjour,
 
Je cherche un moyen de changer automatiquement de feuille par le biais d'une variable/colonne que je met chaque début de mois dans une feuille excel ... Je ne sais pas si je me suis bien exprimé
 
Mais voici comment se présente mon excel :

  • J'ai une feuille pour chaque mois
  • Et une feuille globale qui récupère des chiffres selon les mois dans chaque feuille excel correspondante au mois en cours


Du coup mes formules dans excel ressemble à :  

  • =SOMME(SOMME.SI(Novembre!D:D;"CB";Novembre!C:C)+SOMME.SI(Novembre!D:D;"Virement";Novembre!C:C))
  • =SOMME(C29+Novembre!$H$31)


Du coup chaque mois je dois mettre à jour le mot "Novembre" au mois suivant .. Et ça en fait de plus en plus, surtout il ne faut pas que j'oublie sinon y'aura des loupés !.
 
Y'a t'il un moyen de stocker le mois manuellement dans une cellule et de faire un truc de ce genre :
 

  • C2 = "Novembre"
  • =SOMME(SOMME.SI(C2!D:D;"CB";C2!C:C)+SOMME.SI(C2!D:D;"Virement";C2!C:C))


Enfin je n'y arrive pas :/
 
Pouvez vous me donner une piste .. ou une solution svp
 
Merci


Message édité par Gladi75 le 05-11-2018 à 11:45:29
mood
Publicité
Posté le 05-11-2018 à 10:26:41  profilanswer
 

n°2323531
MaybeEijOr​Not
but someone at least
Posté le 05-11-2018 à 11:34:41  profilanswer
 

Bonjour,
 
Premièrement, petit rappel habituel, Excel n'est pas de la programmation, je pense qu'il doit exister un topic dédié quelque part dans la partie logiciels : https://forum.hardware.fr/hfr/Windo [...] ujet-1.htm
 
Et pour répondre, regarder du côté de la fonction INDIRECT.


---------------
C'est en écrivant n'importe quoi qu'on devient n'importe qui.
n°2323533
Gladi75
Posté le 05-11-2018 à 11:44:27  profilanswer
 

J'ai trouvé sur un autre forum :
 
Je laisse les exemples ici au cas où quelqu'un aurait besoin ;) !
 
Exemple 1 :  
=SOMME.SI(Novembre!D:D;"CB";Novembre!C:C)+I23 donne :

  • =SOMME.SI(INDIRECT(C2&"!D:D" );"CB";INDIRECT(C2&"!C:C" ))+I23

où C2 =TEXTE(AUJOURDHUI();"mmmm" )
 
Example 2 :  
=SOMME(SOMME.SI(Novembre!D:D;"CB";Novembre!C:C)+SOMME.SI(Novembre!D:D;"Virement";Novembre!C:C)) donne  

  • =SOMME(SOMME.SI(INDIRECT(C2&"!D:D" );"CB";INDIRECT(C2&"!C:C" ))+SOMME.SI(INDIRECT(C2&"!D:D" );"Virement";INDIRECT(C2&"!C:C" )))+SOMME.SI(INDIRECT(C2&"!D:D" );"Virement";INDIRECT(C2&"!C:C" )))[/list]

n°2323534
Gladi75
Posté le 05-11-2018 à 11:45:09  profilanswer
 

MaybeEijOrNot a écrit :

Bonjour,
 
Premièrement, petit rappel habituel, Excel n'est pas de la programmation, je pense qu'il doit exister un topic dédié quelque part dans la partie logiciels : https://forum.hardware.fr/hfr/Windo [...] ujet-1.htm
 
Et pour répondre, regarder du côté de la fonction INDIRECT.


 
Oui désolé, je ne savais pas où mettre le topic ;)!
 
J'ai pu trouver sur un autre forum (cf mon post plus haut mais tu as répondu en même temps)
 
Merci à toi


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  VB/VBA/VBS

  [Résolu]Comment changer automatiquement/manuellement de feuille

 

Sujets relatifs
Optimisation Macro remplissage feuille à partir d'autres feuillesChanger de MCU et importation des librairies / composants
[RESOLU] Renseigner automatiquement une donnée de registreCopier coller valeur sur deux feuille avec conditions
Changer l'icone d'un répertoireAfficher automatiquement la somme d'inputs
Copie contenu d'une feuille sur une feuille d'un autre classeurscript pour changer les paramètres windows
comment copier automatiquement ID créé dans une 2ème table ?Excel: changer nom des onglets avec une liste
Plus de sujets relatifs à : [Résolu]Comment changer automatiquement/manuellement de feuille


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR