Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1897 connectés 

  FORUM HardWare.fr
  Programmation
  PHP

  Problème de vitesse Apache/Php sous Windows (p.r. à EasyPHP)

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Problème de vitesse Apache/Php sous Windows (p.r. à EasyPHP)

n°1369798
paillepail​le
Posté le 18-05-2006 à 16:00:38  profilanswer
 

Bonjour.
 
Je vous expose mon problème.
 
Ayant une 'appli' a faire tourner sur un serveur web en production (sous Windows XP PRo SP2), j'ai décidé d'abandonner EasyPHP pour faire une "vraie" belle installation toute propre.
 
Ainsi, j'ai préféré installer Apache 2.0.55, Php 5.1.2 et MySQL 5.0.20 en lieu et place d'EasyPhp 1.8 (qui lui contient Apache 1.3.33, Php 4.3.10 et MySQL 4.1.9).
 
En plus du fait que l'installation devait être en production et qu' un acces en https était demandé, j'ai que pour la rapidité/fiabilité il vallait vraiment mieux pour mois d'installer ces 3 derniers composants séparement.
 
Une fois la mise en place effectuée, j'ai malheureusement pu constater que, lors de la génération de certaines pages (dont je sais qu'elles nécessitent le plus de ressources),
je vois l'utilisation du processeur grimper à 100% (sans pour autant voir de changement particulier sur l'utilisation mémoire) .. enfin rien de trop inquétiant .. si ce n'est son temps d'execution. :cry:  
Une remarque également, dans ce cas l'utilisation mémoire occupée par les deux processus 'Apache.exe' n'augmentent pas durant ce temps.
 
 
J'ai donc bien sur essayé d'influer sur les paramètres suivants:
- dans http.conf : ThreadsPerChild et MaxRequestsPerChild
- php.ini : memory_limit
 
Mais je n'ai pas observé de véritables changements  
 
 
Réalisant là une de mes premières installations manuelles 'AMP', j'ai donc essayé pour tester sur un autre poste (un portable !!) basé sur EasyPHP 1.8, et à ma grande surprise ... la génération de pages qui pouvaient prendre 8-9 secondes sur une installation classique, n'en prenaient alors plus que 3-4 sous EasyPHP !!!
J'ai vraiment été étonné !! et maintenant, j'essaie de chercher d'autre reglages à effectuer mais j'ai quelques difficultés ...
 
Ainsi, si quelqun pouvait avoir une petite idée la dessus, elle serait la bienvenue
 
 
Un gros merci par avance à tous ceux qui ont pris le temps de lire ce message.
 
 
===
 
Informations complémentaires pour les courageux qui souhaiterait en savoir plus sur mon problème:
- le poste 'serveur' est doté d'un P4 2,8GHz, 512Mo de Ram et tourne sous Windows XP Pro SP2
- Apache et MySQL sont bien lancés en tant que services
- le second poste sur lequel j'ai réalisé le test sous easyphp est un Duron 1.6GHz avec 5112Mo de Ram et sous Windows XP Home SP2 ...


Message édité par paillepaille le 19-05-2006 à 13:14:34
mood
Publicité
Posté le 18-05-2006 à 16:00:38  profilanswer
 

n°1370475
paillepail​le
Posté le 19-05-2006 à 12:37:44  profilanswer
 

bon..  
 
le reste du site semble aller .. Mais j'ai toujours le même "problème" sur ma page la plus gourmande !! ( qui m'est quand même presque 2 fois de temps à se générer que sous EasyPHP 1.8 )  :??:  
 
j'ai encore repassé en revue les fichiers de configuration :
- d'Apache : et retenté sans module MPM, avec mpm_winnt, prefork, worker
- de php : en vérifiant les extensions utilisées ..
- de MySQL : en me basant sur les fichiers de configurations proposés comme exemple pour des installations medium et large
 
j'ai pu passer par l'utilisation de MySQLi sous PHP pour intéragir avec ma BD .. (apres avoir du retoucher mon code .. et surtout trouver une petite parade au remplacement de mysql_result() qui n'a pas son pendant sous mysqli ..)
 
mais rien y fait ...  :pfff:  


Message édité par paillepaille le 19-05-2006 à 12:38:37

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  PHP

  Problème de vitesse Apache/Php sous Windows (p.r. à EasyPHP)

 

Sujets relatifs
connexion base de donnee pose problèmeproblème de compatibilité Mozilla....
Problème requête PHPprobleme de dsw
J'ai un problème avec mes feuilles de Style (CSS) !probleme recup champs option dans bbd
probleme de de perte de controle sur la page ASPProblème de symbole dans la bilbiothèque XML::Simple
probleme de recuperation de champs option 
Plus de sujets relatifs à : Problème de vitesse Apache/Php sous Windows (p.r. à EasyPHP)


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR