Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2025 connectés 

  FORUM HardWare.fr
  Programmation
  PHP

  Instalation d'une version récente de php

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Instalation d'une version récente de php

n°2184953
hisokka33
Posté le 09-04-2013 à 14:49:07  profilanswer
 

Bonjour ,
 
Je bloque depuis une petite journée sur un problème de version de PHP.
 
Je m'explique, je travail sur une application qui comporte des morceaux de code en PHP4. L'application fonctionne très bien sur le serveur OVH et j'ai réussi a la faire fonctionner en local ( avec un serveur wamp) mais j'ai du configuré mon serveur local pour que ce soit la version 5.2.5 qui interprète.
 
Jusque la pas de soucis, sauf que j'aimerais intégrer du phpUnit dans mon site, or les version les plus récente doivent avoir comme environnement des versions de php récente ( phpUnit 3.6 doit fonctionné sous PHP5.2.7 minimum ).
 
Voici donc ma questiona, y a t'il un moyen que mon application fonctionne avec du php5.4 (installation d’extensions, ... ) ?

mood
Publicité
Posté le 09-04-2013 à 14:49:07  profilanswer
 

n°2185016
skeye
Posté le 09-04-2013 à 16:55:13  profilanswer
 

J'ai du code qui date de php4 et qui fonctionne sous php5.3.
 
Qu'est-ce qui ne fonctionne pas quand tu déploies sur un php plus récent?


---------------
Can't buy what I want because it's free -
n°2185019
hisokka33
Posté le 09-04-2013 à 17:05:01  profilanswer
 

Lorsque je change de version ( exemple avec la 5.4 ) :
    - php ne reconnais plus certaine index ( Undefined index: p_id)
    - php ne reconnais plus certaine variable (  Undefined variable: link_don)
    - ne reconnait plus certaine variable comme des tableaux ( Undefined offset: 1)  
 
Cela fonctionne normalement en utilisant 5.2.5. J'ai essayé avec du 5.2.7 mais cela me donne les mêmes erreurs.  
J'ai donc cherché un peu, mais entre ma 5.2.5 et ma 5.2.7 j'ai les mêmes extensions d'activé donc je ne vois pas d’où viennent ces erreurs

Message cité 1 fois
Message édité par hisokka33 le 09-04-2013 à 17:05:38
n°2185039
Volkhen
Posté le 09-04-2013 à 18:05:55  profilanswer
 

hisokka33 a écrit :

Lorsque je change de version ( exemple avec la 5.4 ) :
    - php ne reconnais plus certaine index ( Undefined index: p_id)
    - php ne reconnais plus certaine variable (  Undefined variable: link_don)
    - ne reconnait plus certaine variable comme des tableaux ( Undefined offset: 1)

 

Cela fonctionne normalement en utilisant 5.2.5. J'ai essayé avec du 5.2.7 mais cela me donne les mêmes erreurs.
J'ai donc cherché un peu, mais entre ma 5.2.5 et ma 5.2.7 j'ai les mêmes extensions d'activé donc je ne vois pas d’où viennent ces erreurs


- Utilisation d'index sous la forme $lolarray[p_id] au lieu de $lolarray['p_id']
- Compter sur les register_globals pour avoir des valeurs dans $link_don venant soit de formulaires, soit de cookies (une putain de faille de sécurité).
- Globalement, un affichage des warning sur le serveur en php 5.x alors qu'ils sont cachés sur celui en 4.x (google "php error_reporting" ).


Message édité par Volkhen le 09-04-2013 à 18:06:31

---------------
Main/Alt1/Alt2/Alt3
n°2185102
hisokka33
Posté le 10-04-2013 à 10:36:07  profilanswer
 

Merci beaucoup, ça venait en effet de ma configuration du serveur, les E_NOTICE était activé et créé quantités d'erreurs.
 
Je te remercie pour tes réponses

n°2185508
NewsletTux
<Insérez ici votre vie />
Posté le 12-04-2013 à 07:59:58  profilanswer
 

Salut,
En test c'est toujours mieux d'avoir toutes les erreurs activées, ça permet de les résoudre.
Les masquer est une mauvaise idée...
En prod par contre, il vaut mieux les capter.


---------------
NewsletTux - outil de mailing list en PHP MySQL

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  PHP

  Instalation d'une version récente de php

 

Sujets relatifs
[RESOLU] unserialize (depend de la version php ?)question sur l'instalation de opencv 2.3.1 avec vs2010 et CMake 2.8
[RESOLU] Problème de version de PHP (ou ZEND) ?quelle est la procedure qui extraire la version du hadware (firmware)
[Need HELP !] Garder la dernière version dans une liste[SVN] Revenir à une ancienne version tout en gardant ses changements
MSQuery, filtrer à la date la plus récenteExtraire le numéro de version d'un exe
PHP comment comparer des chiffre a 2 point (version)Comment lire la version d'Oracle Client
Plus de sujets relatifs à : Instalation d'une version récente de php


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR