Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2478 connectés 

  FORUM HardWare.fr
  Programmation
  PHP

  Comment faire pour afficher les erreurs PHP4 dans environnement PHP5?

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Comment faire pour afficher les erreurs PHP4 dans environnement PHP5?

n°1931303
zetoune
Posté le 12-10-2009 à 18:58:12  profilanswer
 

Bonjour,
 
J'ai un projet PHP4 que je dois migrer sous PHP5.  
J'essaye de faire afficher sur mes pages les méthodes "DEPRECATED" et mots réservés qui ne sont plus utilisés en PHP5.  
J'ai essayé de changer le error_reporting dans php.ini pour E_ALL | E_DEPRECATED | E_STRICT.
 
Malheureusement aucune erreur ne s'affiche. Même les déclarations du type  

Code :
  1. var maVariable = x;


 
Ça passe dessus sans problème. Comment faire pour que ça affiche ?
 
J'utilise MAMP Pro avec PHP 5.2.6.
Merci.

mood
Publicité
Posté le 12-10-2009 à 18:58:12  profilanswer
 

n°1931320
stealth35
Posté le 12-10-2009 à 20:59:35  profilanswer
 

etrange pour les variable j'ai toujours connu $ ...

n°1931368
zetoune
Posté le 13-10-2009 à 05:59:55  profilanswer
 

excuse,  
J'ai tapé très vite, t'as raison ça devrait être.

Code :
  1. var $maVariable = x;


 
mais bon en php 5, le var n'est plus bon... mais pourtant ça ne m'affiche pas d'erreur..
 

n°1931432
FranceDenB​as
1 dépense = 1 socialiss' :o
Posté le 13-10-2009 à 10:57:33  profilanswer
 

zetoune a écrit :

excuse,  
J'ai tapé très vite, t'as raison ça devrait être.

Code :
  1. var $maVariable = x;


 
mais bon en php 5, le var n'est plus bon... mais pourtant ça ne m'affiche pas d'erreur..
 


 
La constante E_DEPRECATED ne fonctionne qu'à partir de PHP 5.3.0 cf http://fr.php.net/manual/fr/errorfunc.constants.php :jap:


Message édité par FranceDenBas le 13-10-2009 à 10:57:42

---------------
"Il a inventé le bougisme : je bouge donc je suis" :sol: - Dupont-Aignan à propos de Son Altesse Sérénissime Sarkal 1er. Merci Handsome Devil et Meriadeck.
n°1931488
zetoune
Posté le 13-10-2009 à 14:11:02  profilanswer
 

je viens de changer à PHP 5.3 et ça change rien..
Ça ne s'Affiche pas !! :-(

n°1931493
stealth35
Posté le 13-10-2009 à 14:22:22  profilanswer
 

ta peu etre pas d'erreur tout simplement...

n°1931526
zetoune
Posté le 13-10-2009 à 15:45:19  profilanswer
 

Normalement il devrait mettre une erreur sur les déclarations de ce type
non?  


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  PHP

  Comment faire pour afficher les erreurs PHP4 dans environnement PHP5?

 

Sujets relatifs
gestion des erreurs dans un code wordPHP5.3.0/MySQL5.1.36 Impossible de créer un catalogue présentable !!
Gestion d'erreurs php - comment tout cacher ?Afficher JPanel après RemoveAll de la JFrame
Afficher caché des div qui vont par paireAfficher/cacher un texte toggle mootools
Problème livre d'or php5Branchement sous PHP4 vs PHP5
Plus de sujets relatifs à : Comment faire pour afficher les erreurs PHP4 dans environnement PHP5?


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR