Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1556 connectés 

  FORUM HardWare.fr
  Programmation
  HTML/CSS

  [RESOLU] Mes liens ne fonctionnent plus

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[RESOLU] Mes liens ne fonctionnent plus

n°1991468
heracles37
Posté le 08-05-2010 à 18:23:46  profilanswer
 

Bonjour à toutes et à tous,
 
Voilà, je suis en train de créer mon site web en html avec dreamweaver. J'ai créé une page avec plusieurs images réduites créées avec des divs. Plus haut, une image agrandi créée également avec un div. Quand on clic sur une image réduite, toutes les grandes divs s'éteignent et seul la grande div de l'image cliqué reste visible. Seulement je pense qu'il doit y avoir une erreur au niveau du script car plus aucun de mes liens fonctionnent. Et si je supprime le script, je peux de nouveau cliquer sur mes liens.
 
Le script:
<script>
  $(function(){
    var divs = $(".ecran" );
    divs.not("#box1" ).hide();
    $("a" ).click(function(){
      divs.filter(":visible" ).hide();
      $($(this).attr("hrefs" )).show();
      return false;
    });
  });
</script>
 
Merci d'avance pour votre aide ;)


Message édité par heracles37 le 08-05-2010 à 19:54:03

---------------
Un seul combat est perdu d'avance, celui auquel on renonce.
mood
Publicité
Posté le 08-05-2010 à 18:23:46  profilanswer
 

n°1991476
Skopos
Titilleur de nombrils...
Posté le 08-05-2010 à 19:21:08  profilanswer
 

A tout hasard, c'est normal le s à hrefs ?


---------------
userstyles HFR : alléger l'accueil du forum; réduire les img https des quotes. Script AHK ImageFloodHFR
n°1991482
heracles37
Posté le 08-05-2010 à 19:43:40  profilanswer
 

Skopos a écrit :

A tout hasard, c'est normal le s à hrefs ?


A la base, non. Je me suis dis que cela pouvais venir du fait que les liens sont indiqués avec href en code et que pour les divs il valait mieux les différencier. Mais ça ne change rien.
 
Merci de ton aide ;)
 
Ca y est j'ai trouvé. C'est      " return false;"  qui posait problème. Merci d'avoir cherché


Message édité par heracles37 le 08-05-2010 à 19:52:39

---------------
Un seul combat est perdu d'avance, celui auquel on renonce.

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  HTML/CSS

  [RESOLU] Mes liens ne fonctionnent plus

 

Sujets relatifs
[Résolu] Connexion à une BDD en local ET à distance[Résolu] bash - grep et expressions régulières
Probléme selection multiple [Résolu]Problème de boucle [resolu]
[Résolu] Questions Menu déroulant /opacité/IE7[Résolu] Lignes de code CSS venues de Saturne ?
[Résolu] Pertinence. MATCH/AGAINST[RESOLU]Plus de "insérer un commentaire" après la macro
[Résolu][php]récupération de données d'un fichier .txt 
Plus de sujets relatifs à : [RESOLU] Mes liens ne fonctionnent plus


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR