Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1059 connectés 

  FORUM HardWare.fr
  Programmation
  HTML/CSS

  Probleme div xHTML/CSS Firefox IE6

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Probleme div xHTML/CSS Firefox IE6

n°816728
pierre6020
Posté le 06-08-2004 à 16:37:19  profilanswer
 

Bonjour à tous,
je suis en train de refaire complètement un site,
pour le rendre conforme au xHTML.
 
J'ai commencé par nettoyer la bonne soupe de tableaux dans des tableaux,
j'ai placé mes petites / sur mes petits <br>,
et j'ai validé en corrigeant jusqu'à ce que ca passe la validation.
 
Et puis je me suis dit non :
c'est trop bête de faire du xHTML juste pour en faire,
il faut aller jusqu'au bout, respecter la logique.
 
Donc :  
-Exit les tableaux (du moins pour de la presentation).
-Exit toutes les balises de présentation.
-Bonjour les <h1>, les <div>, les <fieldset> et autres alt="".
 
Mais voilà, ca a l'air simple comme ça,
mais j'ai beau essayer,
je me heurte constamment à des problèmes d'interprétation des css entre les navigateurs (IE fait n'importe quoi),
et je n'arrive pas à faire ce que je veux.
 
Je voudrais faire une structure avec une entete,
un menu à gauche et le contenu à droite,
ensuite rajouter un footer mais je n'en suis pas encore la.
 
En fait, ce qui me ferait vraiment plaisir,
ce serait que quelqu'un me donne des conseils du genre :
 
"non, là, fais plutôt comme ça, et ça c'est pas trop conseillé."
 
Je viens tout juste de commencer à me préoccuper du respect des normes,
et j'ai tout à réapprendre,
mais ce serait un peu plus facile avec un peu d'aide.
 
Ah oui, aussi :  
si vous avez de bons didacticiels, je suis preneur.
 
En vous remerciant...
 
EDIT : c'est bien beau tout ca, mais il faudrait peut être rajouter mon code la....  :sarcastic:  
 

Code :
  1. Edit du 09.08 : j'enleve le code, j'ai ajouté un lien plus bas.


 
 
Le menu, par exemple, ne descend pas jusqu'en bas sous IE...
Le formulaire, lui, n'est pas bien centré sous Firefox.


Message édité par pierre6020 le 09-08-2004 à 10:29:01
mood
Publicité
Posté le 06-08-2004 à 16:37:19  profilanswer
 

n°817125
EpoK
Let's burn
Posté le 07-08-2004 à 14:13:47  profilanswer
 

on pourrai avoir un url pour tester ?

n°817164
busOman
Hiver.
Posté le 07-08-2004 à 15:50:53  profilanswer
 

+1 : il nous faut une URL...

n°817463
nicoasne
Posté le 08-08-2004 à 12:32:59  profilanswer
 

Salut
 
moi aussi je viens de me mettre au développement d'un site web en respectant les normes W3C
 
Je te conseil ce site pour ton apprentissage :
http://www.openweb.eu.org/
 
Un lien serait bien pour se faire une idée de tes problèmes ;)


Message édité par nicoasne le 08-08-2004 à 12:34:00
n°817821
pierre6020
Posté le 09-08-2004 à 10:09:10  profilanswer
 

Bonjour, merci d'avoir répondu,
en ce qui concerne openweb.org,
j'ai bien sur déjà consulté cette mine d'information,
je consulte également assez régulierement pompage.net.
 
En fait, en théorie, ca va, j'ai seulement du mal à appliquer tout ça  
(j'ai pris vraiment de tres tres mauvaises habitudes en html des le depart,
et c'est une facon completement nouvelle d'aborder la conception de sites pour moi)
 
Voici donc le petit lien :
http://www.cosmosoft.fr/sitetype
 
Merci d'avance.

n°817843
Mjules
Parle dans le vide
Posté le 09-08-2004 à 10:36:43  profilanswer
 

pour ton menu, regarde ce lien :
http://alsacreations.com/articles/cellules/
 
et essayes plutôt de faire du xhtml strict


Message édité par Mjules le 09-08-2004 à 10:38:08

---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°817904
pierre6020
Posté le 09-08-2004 à 11:21:54  profilanswer
 

Merci pour le lien,
je pense que ca va m'aider.
 
Pour le xHTML strict,
je pensais d'abord faire du transitionnal tout en essayant de respecter le strict (le 1.1 tant qu'à faire, la différence est minime il me semble),
puis passer au xHTML 1.1 en changeant simplement la DTD,
quand je serais bien rodé.

n°817913
Mjules
Parle dans le vide
Posté le 09-08-2004 à 11:31:27  profilanswer
 

j'avais commencé comme ça mais en fait, ça m'a posé plus de pb qu'autres choses ; donc en fait j'ai tout repris directement en xhtml 1.1 (avec jedit et la correction automatique du code c'est assez facile en fait) et ça a mieux été


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°817923
pierre6020
Posté le 09-08-2004 à 11:38:12  profilanswer
 

D'accord, merci du conseil,
je vais essayer jEdit alors.

n°818662
pierre6020
Posté le 10-08-2004 à 09:27:21  profilanswer
 

Ca commence serieusement à me gonfler la,
des que je modifie un truc, ca marche avec IE,
mais ca deconne sous FF ou alors c'est l'inverse...
 
quelqu'un connaitrait-il un site avec tous les problemes connus des deux navigateurs?

mood
Publicité
Posté le 10-08-2004 à 09:27:21  profilanswer
 

n°818667
pierre6020
Posté le 10-08-2004 à 09:33:55  profilanswer
 

exemple :  
 
http://www.cosmosoft.fr/sitetype/accueil/index.php
 
pourquoi ca me met une marge en bas sous IE alors que  
 
li {
margin: 0;
}
a {
margin: 0;
}
 
 :pt1cable:  :pt1cable:  :pt1cable:


Message édité par pierre6020 le 10-08-2004 à 09:34:18
n°818677
gatsusat
Posté le 10-08-2004 à 09:45:25  profilanswer
 

margin-bottom
et non pas magin.
 
et puis c'est pas sur li ni sur A k'il faut travailler mais sur ul :  
 

Code :
  1. <html>
  2. <head>
  3. <style>
  4. ul {
  5. margin-bottom : 0px;
  6. }
  7. </style>
  8. </head>
  9. <body>
  10. <ul>
  11. <li>ma puce1
  12. <li>ma puce1
  13. <li>ma puce1
  14. </ul>
  15. texte a la con juste en dessous
  16. </body>
  17. </html>


Message édité par gatsusat le 10-08-2004 à 09:48:06
n°818682
pierre6020
Posté le 10-08-2004 à 09:49:47  profilanswer
 

non ca ne marche pas.
 
Si je mets margin tout seul,
c'est comme si je mettais  
margin-top
margin-bottom
margin-left
margin-right
 
non?

n°818684
pierre6020
Posté le 10-08-2004 à 09:50:49  profilanswer
 

donc je suis obligé de placer mon ul dans un div si je veux decaler tout ca?

n°818687
pierre6020
Posté le 10-08-2004 à 09:53:18  profilanswer
 

Et pourquoi travailler uniquement sur ul?
 
Si je veux faire des boutons, avec border et background,
je suis bien obligé de me servir de li ou de a,
tu fais comment toi?

n°820005
pierre6020
Posté le 11-08-2004 à 10:19:05  profilanswer
 

Pour le probleme de saut de ligne sous IE,
ca fonctionne si je mets une largeur (width) à <a>.

n°820252
gatsusat
Posté le 11-08-2004 à 13:32:19  profilanswer
 

ouais mais moi j'avais mis un style à ul avec un padding-bottom : 0 ou un Margin-bottom : 0px, je sais plus
c'est pour ca ke je te parlais qu'il fallait mettre le style pour UL et non LI et A


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  HTML/CSS

  Probleme div xHTML/CSS Firefox IE6

 

Sujets relatifs
Empty-cells sous IE6 2 css pour un un même média d'une page web
probleme de modélisation meriseprobleme de concaténation requete mysql
[DEVC++] Problème de linkage??[PHP/MySQL] - Problème d'insertion dans BDD
HELP!!!!!!!!Problème Sql Server sous vb.net!!!!!!!![Java] Problème de taille mémoire avec un JTree
problème avec for_eachTable ou Div+Styles CSS
Plus de sujets relatifs à : Probleme div xHTML/CSS Firefox IE6


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR