Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1325 connectés 

  FORUM HardWare.fr
  Programmation
  HTML/CSS

  Problème de validation XHTML 1.1 avec un tableau

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Problème de validation XHTML 1.1 avec un tableau

n°889217
fafane84
Posté le 03-11-2004 à 09:43:37  profilanswer
 

Salut à tous  :hello:  
 
J'ai essayé de refaire le look de mon site, mais j'ai un problème de validation.
 
voici l'adresse de ma page test : http://pagesperso.laposte.net/divx [...] /index.php
 
Pouvez-vous m'aidez ?
 
Merci d'avance.
 
[:fafane84]


---------------
Mon Topic de Vente Hardware
mood
Publicité
Posté le 03-11-2004 à 09:43:37  profilanswer
 

n°889285
antp
Super Administrateur
Champion des excuses bidons
Posté le 03-11-2004 à 11:14:18  profilanswer
 

La table doit être dans un div ou un paragraphe je suppose :??:


---------------
mes programmes ·· les voitures dans les films ·· apprenez à écrire
n°889569
Hermes le ​Messager
Breton Quiétiste
Posté le 03-11-2004 à 15:58:21  profilanswer
 

fafane84 a écrit :

Salut à tous  :hello:  
 
J'ai essayé de refaire le look de mon site, mais j'ai un problème de validation.
 
voici l'adresse de ma page test : http://pagesperso.laposte.net/divx [...] /index.php
 
Pouvez-vous m'aidez ?
 
Merci d'avance.
 
[:fafane84]


 

Code :
  1. <link href="index.php_fichiers/normal.css" rel="stylesheet" type="text/css" media="screen">
  2. <link href="index.php_fichiers/print.css" rel="stylesheet" type="text/css" media="print">


 
Ne sont pas fermés.
 
ainsi que tous les META qui précèdent...  :o  
 
les balises img ne sont pas fermées...
 

Code :
  1. <table cellspacing="0" cellpadding="0" class="fond">
  2. </table>


 
N'est pas permis. Il faut au moins une ligne et une colonne pour une table.
 
Les balises <br> doivent êyte fermées. ( <br /> )
 
Et j'en passe et des meilleurs...

n°889614
antp
Super Administrateur
Champion des excuses bidons
Posté le 03-11-2004 à 16:37:03  profilanswer
 

chez moi ils apparaissent fermés ces tags :??:


---------------
mes programmes ·· les voitures dans les films ·· apprenez à écrire
n°889710
Hermes le ​Messager
Breton Quiétiste
Posté le 03-11-2004 à 18:23:55  profilanswer
 

antp a écrit :

chez moi ils apparaissent fermés ces tags :??:


 
ça alors, je viens de découvrir que quand on enregistre la page avec Mozilla, ça vire toutes les fermetures XHTML des tags...  :heink:

n°889720
antp
Super Administrateur
Champion des excuses bidons
Posté le 03-11-2004 à 18:51:49  profilanswer
 

Ouais il fait d'autres choses en cachette :D
Même le "view source" n'est pas fiable : il modifie parfois la casse des balises HTML.


---------------
mes programmes ·· les voitures dans les films ·· apprenez à écrire
n°890332
fafane84
Posté le 04-11-2004 à 16:22:02  profilanswer
 

Oooups !!!
 
Excusez-moi j'avais oublié ce post car mon problème est résolu.
 
J'avais très bêtement imbriquées 2 balises <table> l'une dans l'autre.
 
Par contre Hermes le Messager, je ne comprend pas pourquoi tu dis qu'elles ne sont pas fermées mes balises car elles le sont , même sous Firefox.  :??:  
 
Et depuis toutes mes pages sont valides XHTML 1.1
 
 [:fafane84]


---------------
Mon Topic de Vente Hardware
n°890334
Hermes le ​Messager
Breton Quiétiste
Posté le 04-11-2004 à 16:24:08  profilanswer
 

fafane84 a écrit :


 
Par contre Hermes le Messager, je ne comprend pas pourquoi tu dis qu'elles ne sont pas fermées mes balises car elles le sont , même sous Firefox.  :??:  
 
 
 [:fafane84]


 
Non, laisse tomber, c'est de ma faute (enfin celle de mozilla quand il enregistre les pages :/ )


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  HTML/CSS

  Problème de validation XHTML 1.1 avec un tableau

 

Sujets relatifs
Petit problème sous c++[PHP] Récupérer le dernier tableau d'un fichier HTML
[ VBA ] question con : remplir une lioste avec un tableauProbleme d'installation Visual Studio 6 sous Windows XP SP2
problème avec MySQL chez infomaniakProbleme fonction et tableau d'objet
probleme de redefinition avec #includeProblème de requête
Probleme en programmation, langage C !!! Aidez moi svp!!! 
Plus de sujets relatifs à : Problème de validation XHTML 1.1 avec un tableau


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR