Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
1868 connectés 

  FORUM HardWare.fr
  Programmation
  HTML/CSS

  internet explorer n'affiche rien

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

internet explorer n'affiche rien

n°1586200
Pulsar-
Posté le 13-07-2007 à 14:35:29  profilanswer
 

J'ai honte de demander ca mais ca me gonfle de chercher 2 plombes le problème.
 
Alors voilà Firefox et Opera affiche impecablement la page mais pas Internet explorer 6.0

Code :
  1. <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
  2. <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="fr" >
  3.         <head>
  4.                 <title>titre</title>
  5.    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
  6.    <style type="text/css">
  7.    <link rel="stylesheet" media="screen" type="text/css" title="Style" href="../img/style.css" />
  8.         </head>
  9.         <body>
  10. saloperie d'ie !
  11. </body>
  12. </html>


 
D'où vient le problème ?


Message édité par Pulsar- le 13-07-2007 à 14:35:45
mood
Publicité
Posté le 13-07-2007 à 14:35:29  profilanswer
 

n°1586212
omega2
Posté le 13-07-2007 à 14:46:49  profilanswer
 

La question est idiote, mais t'es sur qu'IE à bien chargé la page (que t'as bien le code source quand tu fais "Affichage/source" ) ?

n°1586235
cgo2
Dum spiro spero
Posté le 13-07-2007 à 15:07:24  profilanswer
 

Et sinon, que dirais-tu de fermer la balise <style> du header ?


---------------
When it's from Finland it's good.  - Mon blog
n°1586237
FlorentG
Unité de Masse
Posté le 13-07-2007 à 15:08:05  profilanswer
 

Déjà la DTD xhtml1.1 servira à rien, faut obligatoirement envoyer la page avec le type mime application/xhtml+xml. Là en plus t'as une meta content-type à virer, en xhtml1.1 on utilise la PI xml en début de fichier.
 
Ensuite t'as une balise style ouverte.... Sans fermeture, alors forcément ça risque pas de marcher. D'ailleur elle sert à rien, garde juste le link.
 
Pour finir, t'as du texte brut dans le body, ce qui est invalide. Il faut au moins un conteneur de type block style div, p, etc.... :)


---------------
last.fmflickr
n°1586256
Pulsar-
Posté le 13-07-2007 à 15:23:52  profilanswer
 

Merci messieurs, c'etait effectivement la balise </style> qui faisait tout coincer.

 

En réalité j'ai developpé tout mon site web en testant par firefox et tout fonctionnait impeccablement jusqu'à ce que je teste sur ie et là je m'appercois que ce navigateur est beaucoup moins indulgent :)

 

Sinon concernant la dtd je l'ai mise en xhtml1.0 et laissé le type mime comme il etait.


Message édité par Pulsar- le 13-07-2007 à 15:25:30

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  HTML/CSS

  internet explorer n'affiche rien

 

Sujets relatifs
Réduction taille image, Internet ExplorerCacluler le poids d'un site internet
réalisation avec Xpage internet studio 5[CSS] Faire une info-bulle avec internet explorer...
[Java web start]Programme qui ne donne rien.Utiliser PHP sans navigateur internet
Petite erreur de rien du tout , header('location[AIDE](z moi)Simulation de Clavier à partir de rien
Plus de sujets relatifs à : internet explorer n'affiche rien


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR