Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1653 connectés 

  FORUM HardWare.fr
  Programmation
  C#/.NET managed

  [c#][1.1] Probleme WMI demande non valide

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[c#][1.1] Probleme WMI demande non valide

n°1439094
supalou
Posté le 08-09-2006 à 14:25:34  profilanswer
 

Bonjour tout le monde.
 
J'ai un problème très étrange: J'essaye de récupérer des évènements dans le journale d'évènements de plusieurs serveurs distant. Pour ceci j'utilise donc WMI et la classe Win32_NTLogEvent mais évidement j'ai un petit soucis. Voici ma requête WQL: "
 
Select EventType, TimeWritten, SourceName, Message from Win32_NTLogEvent where Logfile = 'Application' and (EventType = '1' or EventType = '2')" Jai pu la tester avec l'outil WMI Cim studios et celle ci marche parfaitement. Mais j'ai un petit soucis quand même. Lorsque je j'exécute mon code j'arrive à récupérer mes évènements mes que pour certain serveur et pas pour les autres car j'obtiens une demande non valide. D'après moi cette erreur survient quand la requête WQL n'est pas bonne hors ce n'est pas le cas puisque pour certain serveur cela marche niquel. Je précise que mes serveurs sont en NT4 et Windows 2000 que WMI est installé sur tous etc. En effet je fais d'autres requêtes WQL sur l'intégralité de mes serveurs et celles ci marchent toutes correctement.
 
Ma question est alors pourquoi j'obtient l'erreur demande non valide lorsque j'exécute cette requête mais uniquement sur certain serveur???
 
Merci pour votre aide

mood
Publicité
Posté le 08-09-2006 à 14:25:34  profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  C#/.NET managed

  [c#][1.1] Probleme WMI demande non valide

 

Sujets relatifs
Problème avec vb range et boutonProblème avec Mysql et Show processlist
probleme avec la syntax "If not"Problème de calcul en double précision
Probleme avec un Backup batch file with LOG[Ruby]Problème de Thread + Retry
[Résolu] Problème de syntaxe avec un define[CSS] Onglets + Cadre: probleme avec FF
[Résolu)]Problème affectation chaine de caractère[XML] Problème pour lire l'attribut xml:lang d'un élement
Plus de sujets relatifs à : [c#][1.1] Probleme WMI demande non valide


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR