Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1893 connectés 

  FORUM HardWare.fr
  Programmation
  C++

  Probleme avec des champs EDIT [ RESOLU ]

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Probleme avec des champs EDIT [ RESOLU ]

n°1511405
point
Posté le 06-02-2007 à 15:17:01  profilanswer
 

Bonjour,
 
Je deviens FOUUUU avec une histoire de champs EDITBOX dans une application MFC.
 
 
 
Voilà, j'ai une application basée sur une CDialog dans laquelle j'ai créé des champs EDIT à la volée.
 
Tout va bien, sauf quand un message WM_PAINT arrive :  
 - Les champs texte sont vidés ( à l'écran ).
 - Si je clique sur un de ces champs, sa valeur réapparait !!?!!!!!
 
Je ne sais pas quoi faire  :cry:  :cry:  :cry:  
 
HELPPP


Message édité par point le 06-02-2007 à 23:54:19
mood
Publicité
Posté le 06-02-2007 à 15:17:01  profilanswer
 

n°1511525
point
Posté le 06-02-2007 à 18:20:37  profilanswer
 

Je précise que je fais un dessin en BitBlt sur toute la surface de la CDialog

n°1511615
point
Posté le 06-02-2007 à 23:54:01  profilanswer
 

RESOLU !!!
 
 
En fait pour ceux que ça intéresse, il m'a suffit de passer la valeur "ClipChildren" sur ma fenetre parent à TRUE, et hop !  
 
pfffffiioouuu, 4h de galère pour un ptit TRUE de rien du tout...
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  C++

  Probleme avec des champs EDIT [ RESOLU ]

 

Sujets relatifs
[MSSQL et PHP] Problème de boucle...[batch] problème avec mon batch d'insertion
[PERL] tache cron [résolu]Problème pour récuperer une image dans une variable
Flash, probleme pour les sonsvitesse d'éxecution sur différents ordinateurs (Résolu)
Probleme d'URL tinyMCE[Résolu][VBS Débutant Boucle Do-While-Loop Active Directory]
problème mmap avec un deamon [résolu] 
Plus de sujets relatifs à : Probleme avec des champs EDIT [ RESOLU ]


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR