Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1812 connectés 

  FORUM HardWare.fr
  Programmation
  ASP

  [ASP] Jai un ptit souci dans mon moteur de recherche , help me please

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[ASP] Jai un ptit souci dans mon moteur de recherche , help me please

n°394761
alucard17
Amen
Posté le 15-05-2003 à 11:03:00  profilanswer
 

salut a tous , pour commencer je suis tres nul en prog donc pas de terme trop technik , merci :)
 
voila mon cas : - une base de données access
                - une page asp qui fais moteur de recherche dans cette base.
 
le probleme est le suivant : par exemple , lorsque je veux des infos relatives a un pc ( un dell dimension 4500 par ex ) , je suis obligé de taper dell dimension 4500, si je tape juste dell , il me trouve rien.
je suppose que ca viens du = , car mon code est du genre : si la variable k jai tapé = un truc dans ma base de données , alors affiché ca....
 
désolé c pa tres technique , mais chui nul

mood
Publicité
Posté le 15-05-2003 à 11:03:00  profilanswer
 

n°394768
harrysauce
Miaaaooou!
Posté le 15-05-2003 à 11:10:07  profilanswer
 

Alucard17 a écrit :

salut a tous , pour commencer je suis tres nul en prog donc pas de terme trop technik , merci :)
 
voila mon cas : - une base de données access
                - une page asp qui fais moteur de recherche dans cette base.
 
le probleme est le suivant : par exemple , lorsque je veux des infos relatives a un pc ( un dell dimension 4500 par ex ) , je suis obligé de taper dell dimension 4500, si je tape juste dell , il me trouve rien.
je suppose que ca viens du = , car mon code est du genre : si la variable k jai tapé = un truc dans ma base de données , alors affiché ca....
 
désolé c pa tres technique , mais chui nul


j'ai pas capté la moitié de ce que tu as dit, mais si tu veux retrouver ton dell machinchose 4500 avec juste la chaine "dell" il faut que tu utilises "LIKE"
 
SELECT * FROM ordis
WHERE nom LIKE "DELL*";

n°394789
alucard17
Amen
Posté le 15-05-2003 à 11:17:47  profilanswer
 

oups.... voici mon code :
 
objRecordset.Open "SELECT * FROM tout WHERE noinventaire='"&Nom&"' or service='"&Nom&"' or nomutilisateur='"&Nom&"'
 
ma variable est "nom".

n°394795
harrysauce
Miaaaooou!
Posté le 15-05-2003 à 11:22:44  profilanswer
 

Alucard17 a écrit :

oups.... voici mon code :
 
objRecordset.Open "SELECT * FROM tout WHERE noinventaire='"&Nom&"' or service='"&Nom&"' or nomutilisateur='"&Nom&"'
 
ma variable est "nom".


 

Citation :

objRecordset.Open "SELECT * FROM tout
WHERE noinventaire LIKE '"&Nom&"*'
   or service LIKE '"&Nom&"*'
   or nomutilisateur LIKE '"&Nom&"*'


ca marche ca??

n°394809
alucard17
Amen
Posté le 15-05-2003 à 11:33:38  profilanswer
 

et non ca marche pas mieux...

n°394860
harrysauce
Miaaaooou!
Posté le 15-05-2003 à 12:03:02  profilanswer
 

Alucard17 a écrit :

et non ca marche pas mieux...


....
c'est a dire?
essaie de mettre une * avant le nom aussi.....

n°394884
ethernal
Chercheur de vérité...
Posté le 15-05-2003 à 12:14:20  profilanswer
 

ce serait pas des % à la place des * ? (ou sont mes bouquins d'sql ??)

Code :
  1. objRecordset.Open "SELECT * FROM tout
  2. WHERE noinventaire LIKE '%" & Nom & "%'
  3.   or service LIKE '%" & Nom & "%'
  4.   or nomutilisateur LIKE '%" & Nom & "%'


---------------
...oups kernel error...
n°394901
alucard17
Amen
Posté le 15-05-2003 à 12:27:54  profilanswer
 

ethernal a écrit :

ce serait pas des % à la place des * ? (ou sont mes bouquins d'sql ??)

Code :
  1. objRecordset.Open "SELECT * FROM tout
  2. WHERE noinventaire LIKE '%" & Nom & "%'
  3.   or service LIKE '%" & Nom & "%'
  4.   or nomutilisateur LIKE '%" & Nom & "%'




 
ca marche impecc ! merci a vous deux :)

n°394948
harrysauce
Miaaaooou!
Posté le 15-05-2003 à 13:07:42  profilanswer
 

ethernal a écrit :

ce serait pas des % à la place des * ? (ou sont mes bouquins d'sql ??)

Code :
  1. objRecordset.Open "SELECT * FROM tout
  2. WHERE noinventaire LIKE '%" & Nom & "%'
  3.   or service LIKE '%" & Nom & "%'
  4.   or nomutilisateur LIKE '%" & Nom & "%'




rhooo bien vu :D
 
je suis en train de bosser sur access pour mon stage et voila que je prends deja les mauvaises habitudes!!!! (dans access le % a été remplacé par *)...

n°394949
ethernal
Chercheur de vérité...
Posté le 15-05-2003 à 13:10:04  profilanswer
 

ha bon ? Alucard17 bosse sur Access aussi.
Encore un M$ bug ?


---------------
...oups kernel error...
mood
Publicité
Posté le 15-05-2003 à 13:10:04  profilanswer
 

n°394952
harrysauce
Miaaaooou!
Posté le 15-05-2003 à 13:15:44  profilanswer
 

ethernal a écrit :

ha bon ? Alucard17 bosse sur Access aussi.
Encore un M$ bug ?


En effet c'est plutot bizarre!!!!
Je viens de verifier a l'instant et si je met "%" ca marche pas!!! Access il lui faut "*"
 
Alucard17 => tu bosses avec quelle version d'access???
t'es sur que tu serais pas sous SQL Server par hasard???

n°395170
alucard17
Amen
Posté le 15-05-2003 à 15:05:36  profilanswer
 

salut , la oui je suis certain , je suis bien sous access xp.


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  ASP

  [ASP] Jai un ptit souci dans mon moteur de recherche , help me please

 

Sujets relatifs
[Help] Album photo "phpGraphy" et fichier ".welcome"[ASP] Scripts
[PHP] help fonction fopen,...etc...[ASP] Erreur ADODB.Recorset
A la recherche d'un composant genre dbgrid mais sans db ;-)Recherche composant Borland c++ builder 6
[ASP] fonction suppr espace fin de chaineVB.NET A la recherche d'une méthode !
[ASP] demande de mot de passe et aiguillage en fonction de celui ciliste deroulante dynamique [HELP]
Plus de sujets relatifs à : [ASP] Jai un ptit souci dans mon moteur de recherche , help me please


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR