Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1829 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  [Mandrake] Etrange problème de configuration réseau

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Mandrake] Etrange problème de configuration réseau

n°626989
mr simon
Posté le 26-01-2005 à 19:24:18  profilanswer
 

Bonjour,
 
Hier, j'ai voulu mettre mon pc (debian sid) en réseau avec le portable d'un pote (mandrake 9.2), pour echanger des fichiers. Je n'ai eu aucun problème.
 
Cette aprem, j'ai voulu recommencer, mais ya rien a faire, ça ne vaut plus marcher. Voici ma config :
 
Pc sous Debian:
eth0 ip : 192.168.1.1, Passerelle : 255.255.255.0
 
Portable mdk9.2:
eth0 ip : 192.168.1.2 Passerelle : 255.255.255.0
 
(ifconfig eth0 198.168.1.2 netmask 255.255.255.0 up)
 
et je n'ai aucun ping qui marche, alors que ifconfig, m'affiche tout correctement.  
 
J'ai essayer de passer par l'utilitaire de mandrake, mais celui ci se bloque lors de la detection des composants, donc imposible de l'utiliser. lors d'un /etc/init.d/network restart, a chaque fois j'ai un echec sur l'activation de eth0
 
J'ai essayé également de connecter ma neuf box sur le portable, afin de tester internet, et pareil ça ne veut pas marcher. Du coup je ne pense pas que ce soir un problème de cable de cable, mais plutot un problème due a l'interface eth0. Mais j'avour ne pas savoir quoi faire pour résoudre ce problème !!!
 
 
Merci pour votre aide.

mood
Publicité
Posté le 26-01-2005 à 19:24:18  profilanswer
 

n°626996
goldyfruit
Je me lève et je confirme !
Posté le 26-01-2005 à 19:30:16  profilanswer
 

mr simon a écrit :

Bonjour,
 
Hier, j'ai voulu mettre mon pc (debian sid) en réseau avec le portable d'un pote (mandrake 9.2), pour echanger des fichiers. Je n'ai eu aucun problème.
 
Cette aprem, j'ai voulu recommencer, mais ya rien a faire, ça ne vaut plus marcher. Voici ma config :
 
Pc sous Debian:
eth0 ip : 192.168.1.1, Passerelle : 255.255.255.0
 
Portable mdk9.2:
eth0 ip : 192.168.1.2 Passerelle : 255.255.255.0
 
(ifconfig eth0 198.168.1.2 netmask 255.255.255.0 up)
 
et je n'ai aucun ping qui marche, alors que ifconfig, m'affiche tout correctement.  
 
J'ai essayer de passer par l'utilitaire de mandrake, mais celui ci se bloque lors de la detection des composants, donc imposible de l'utiliser. lors d'un /etc/init.d/network restart, a chaque fois j'ai un echec sur l'activation de eth0
 
J'ai essayé également de connecter ma neuf box sur le portable, afin de tester internet, et pareil ça ne veut pas marcher. Du coup je ne pense pas que ce soir un problème de cable de cable, mais plutot un problème due a l'interface eth0. Mais j'avour ne pas savoir quoi faire pour résoudre ce problème !!!
 
 
Merci pour votre aide.


Euh tu es sure de ta passerelle ? Parce que la c'est bizarre tu as la meme chose que ton masque. :??:


Message édité par goldyfruit le 26-01-2005 à 19:30:57

---------------
http://wiki.incloudus.com/display/DOC | http://blog.incloudus.com | http://wiki.goldzoneweb.info | http://www.stendhalclub.fr
n°627012
mr simon
Posté le 26-01-2005 à 19:48:13  profilanswer
 

oups pardon c pas ma passerelle que j'ai indiqué mais mon masque.

n°627026
Dark_Schne​ider
Close the World, Open the Net
Posté le 26-01-2005 à 20:07:39  profilanswer
 

sur la mdk donne le résultat des commandes suivantes :


lspcidrake
ifconfig
route -n
iptables -L


 
sache que le firewall mdk désactive les pings


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°627047
mr simon
Posté le 26-01-2005 à 20:34:19  profilanswer
 

Voila ce que j'obtiens
 
 
ipconfig :

Code :
  1. eth0      Lien encap:Ethernet  HWaddr 00:0B:CD:85:3A:8E 
  2.           inet adr:192.168.1.2  Bcast:192.168.1.255  Masque:255.255.255.0
  3.           UP BROADCAST MULTICAST  MTU:1500  Metric:1
  4.           RX packets:0 errors:0 dropped:0 overruns:0 frame:0
  5.           TX packets:15 errors:0 dropped:0 overruns:0 carrier:0
  6.           collisions:0 lg file transmission:100
  7.           RX bytes:0 (0.0 b)  TX bytes:600 (600.0 b)
  8.           Interruption:10 Adresse de base:0x7000
  9. lo        Lien encap:Boucle locale 
  10.           inet adr:127.0.0.1  Masque:255.0.0.0
  11.           UP LOOPBACK RUNNING  MTU:16436  Metric:1
  12.           RX packets:74 errors:0 dropped:0 overruns:0 frame:0
  13.           TX packets:74 errors:0 dropped:0 overruns:0 carrier:0
  14.           collisions:0 lg file transmission:0
  15.           RX bytes:5258 (5.1 Kb)  TX bytes:5258 (5.1 Kb)


 
 
lspcidrake :

Code :
  1. unknown         : unknown (1002/cbb2/ffff/ffff) [BRIDGE_HOST]
  2. unknown         : ATI|PCI Bridge [IGP 340M] [BRIDGE_PCI]
  3. usb-ohci        : Acer Laboratories Inc. [ALi]|M5237 (USB) [SERIAL_USB]
  4. usb-ohci        : Acer Laboratories Inc. [ALi]|M5237 (USB) [SERIAL_USB]
  5. snd-ali5451     : Acer Laboratories Inc. [ALi]|M5451 PCI South Bridge Audio [MULTIMEDIA_AUDIO]
  6. unknown         : Acer Laboratories Inc. [ALi]|M1533 PCI to ISA Bridge [Aladdin IV] [BRIDGE_ISA]
  7. unknown         : Acer Laboratories Inc. [ALi]|M5457 AC-Link Modem Interface Controller [COMMUNICATION_MODEM]
  8. yenta_socket    : O2Micro Inc|OZ6912 CardBus Controller [BRIDGE_CARDBUS]
  9. ohci1394        : Texas Instruments|TSB43AB21 IEEE-1394 Controller (PHY/Link) 1394a-2000 [SERIAL_FIREWIRE]
  10. unknown         : Acer Laboratories Inc. [ALi]|M5229 IDE [STORAGE_IDE]
  11. unknown         : Acer Laboratories Inc. [ALi]|M7101 PMU [BRIDGE_OTHER]
  12. natsemi         : National Semi|DP83810 10/100 Ethernet [NETWORK_ETHERNET]
  13. Card:ATI Radeon : ATI Technologies Inc|Radeon IGP 340M [DISPLAY_VGA]
  14. unknown         : Unknown|USB OHCI Root Hub [Hub|Root Hub]
  15. Mouse:USB|Wheel : Microsoft Corp.|IntelliMouse Optical [Human Interface Devices|Boot Interface Subclass|Mouse]
  16. unknown         : Unknown|USB OHCI Root Hub [Hub|Root Hub]


 
 
route -n :

Code :
  1. Table de routage IP du noyau
  2. Destination     Passerelle      Genmask         Indic Metric Ref    Use Iface
  3. 192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
  4. 127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo


 
En ce qui concerne iptables, il semble qu'il ne soit pas installé.

n°627054
Dark_Schne​ider
Close the World, Open the Net
Posté le 26-01-2005 à 20:44:39  profilanswer
 

hmmmm, du firewire ...
 
http://qa.mandrakesoft.com/twiki/b [...] after_upgr
 
je pense que le firewire prend la place de ta carte réseau
 
mets dans /etc/modprobe.conf la ligne suivante :


alias eth1394 off


 
reboot et vois ce que cela donne.
 
check qu'aucun firewall ne tourne sur aucune bécane ( iptables -L )
 
donne le résultat de lsmod aussi


Message édité par Dark_Schneider le 26-01-2005 à 20:45:12

---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°627085
mr simon
Posté le 26-01-2005 à 21:09:00  profilanswer
 

ce que je trouve bizarre c'est qu'hier, tout a marché nikel, sans que je fasses quoi que ce soit.
 
lsmod :

Code :
  1. mount -t ext2 /floppy/


 
 
Ya bien un firewall qui tourne sous ma debian, mais hier ça marchait sans soucis,
 
iptables -L (debian)

Code :
  1. Chain FORWARD (policy ACCEPT)
  2. target     prot opt source               destination
  3. TCPMSS     tcp  --  anywhere             anywhere            tcp flags:SYN,RST/SYN tcpmss match 1400:1536 TCPMSS clamp to PMTU
  4. TCPMSS     tcp  --  anywhere             anywhere            tcp flags:SYN,RST/SYN tcpmss match 1400:1536 TCPMSS clamp to PMTU
  5. TCPMSS     tcp  --  anywhere             anywhere            tcp flags:SYN,RST/SYN tcpmss match 1400:1536 TCPMSS clamp to PMTU
  6. TCPMSS     tcp  --  anywhere             anywhere            tcp flags:SYN,RST/SYN tcpmss match 1400:1536 TCPMSS clamp to PMTU
  7. Chain OUTPUT (policy ACCEPT)
  8. target     prot opt source               destination

n°627104
mr simon
Posté le 26-01-2005 à 21:18:01  profilanswer
 

Sinon, je viens d'essayer de brancher mon modem 9box sur la mandrake, ça ne marche toujours pas, mais j'ai remarque que dans dmesg rien n'apparait; alors que sur ma debian, j'obtiens "eth0: link up, 100Mbps, full-duplex, lpa 0x41E1".  
Donc ça pourrait confirmer que l'interface eth0 sous mdk a quelques problèmes.

n°627434
Dark_Schne​ider
Close the World, Open the Net
Posté le 27-01-2005 à 15:41:54  profilanswer
 

tu as fait ce que je t'ai dit ?


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°627452
mr simon
Posté le 27-01-2005 à 16:50:36  profilanswer
 

J'ai laissé tombé, j'ai rendu le portable a mon pote.
 
Merci pour votre aide.

mood
Publicité
Posté le 27-01-2005 à 16:50:36  profilanswer
 

n°627457
Dark_Schne​ider
Close the World, Open the Net
Posté le 27-01-2005 à 17:00:41  profilanswer
 

dommage, il suffisait juste de désactive le support ethenret over firewire ( qui permet d'utiliser le port firewire comme une carte réseau ).


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°627464
mr simon
Posté le 27-01-2005 à 17:05:04  profilanswer
 

bah j'ai rajouter alias eth1394 off , mais ça n'a rien changé.
 
Et je ne vois vraiment pas pkoi, sans rien touché du jour au lendemain, ça me marche plus !!!

n°627515
Dark_Schne​ider
Close the World, Open the Net
Posté le 27-01-2005 à 18:07:03  profilanswer
 

montre moi le contenu du fichier /etc/modprobe.conf et /etc/sysconfig/network-scripts/ifcfg-eth0


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°627572
mr simon
Posté le 27-01-2005 à 19:44:04  profilanswer
 

dsl mais j'ai rendu le pc a mon pot !!!
Merci beaucoup pour ton aide, c tres gentil de ta part.


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  [Mandrake] Etrange problème de configuration réseau

 

Sujets relatifs
[QoS] - Problème de fonctionnement.[MANDRAKE] probleme instalation
[DEBIAN]Probleme d'installationproblème d'installation de linux
Probleme serveur smtpProblème de DNS avec bind
Pb Lecture DVD saccadé sous Mandrake 10.1Probleme d'accent sur Fedora ( serveur )
Debian : probleme couleurs et probleme conf term 
Plus de sujets relatifs à : [Mandrake] Etrange problème de configuration réseau


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR