Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
885 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  Les mystères de l'informatique : connexion internet rebelle

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Les mystères de l'informatique : connexion internet rebelle

n°527366
THRAK
- THR4K -
Posté le 25-07-2004 à 21:46:43  profilanswer
 

Salut
 
ça vous est déjà arrivé de rencontrer des problèmes inexplicables ? Moi oui et aujourd'hui j'en ai un bel exemplaire ; y'a des jours comme ça où quoique l'on fasse ça coince... :pfff:  
Comme je suis patient et rationnaliste, je me dis qu'une explication doit bien exister mais quelle m'échappe jusqu'ici, donc voilà mes aventures au cas où quelqu'un aurait une idée :
 
Système -> Debian Stable 3.0r2
 
- hier comme d'habitude je décide de faire un tour sur le net, j'active donc ma connection (je ne la laisse pas active en permanence, donc je n'ai pas automatisé le démarrage). Je lance donc un pon dsl-provider, rien d'anormal. J'ouvre Mozilla et là impossible d'accèder aux sites (je peux voir le message Recherche de l'hôte...). Bon je me dis que Mozilla a peut être buggé, je le relance pareil. Je stoppe la connexion et la redémarre (poff puis à nouveau pon dsl-provider), retourne sous Mozilla ok, ça marche, bref je cherche pas à en savoir plus.  :sweat:  
 
- aujourd'hui, même histoire  :fou: : je lance ma connexion, rien à faire. Je la stopppe et la redémarre et c'est bon. Je décide alors de faire un test : j'arrête ma connexion pendant un bon moment et décide de la relancer à nouveau : le problème se reproduit. Sauf que cette fois-ci je suis obligé de faire plusieurs tentatives infructueuses pour finir par devoir redémarrer la machine...  
J'ai alors fais plein de tests pour trouver le coupable et bien tout à l'air OK, c'est vraiment bizarre  :( :
 
- ni Mozilla, ni Links et pas même un ping ne parvient jusqu'à un hôte distant alors qu'un ifconfig ppp0 m'affiche bien que la connexion est établie (ip attribuée, etc... tout est correct)
 
- les logs ne présentent aucun message anormal (je les ai comparés à plusieurs logs antérieurs)
 
- je n'ai rien touché au niveau du réseau où de la connexion ces derniers temps, qui plus est je n'ai jamais rencontré le moindre souci de connexion à Internet jusqu'à présent
 
- j'ai jeté un oeil sur la connectique et le modem (ethernet), tout à l'air normal à première vue
 
- dans le même temps, alors que ma connexion échoue sur ma bécane fixe, j'arrive à me connecter immédiatement depuis mon portable (sous Gentoo)
 
- j'ai tenté un dpkg-reconfigure pppoeconf, puis un pppoeconf en redéfinissant les paramètres de connexion
 
 
Enfin c'est fou : j'ai l'impression que ça se connecte vraiment quand ça veut...  :sarcastic:


---------------
THRAK (def.) : 1) A sudden and precise impact moving from intention, direction and commitment, in service of an aim. 2) 117 guitars almost striking the same chord simultaneously.
mood
Publicité
Posté le 25-07-2004 à 21:46:43  profilanswer
 

n°527367
mikala
Souviens toi du 5 Novembre...
Posté le 25-07-2004 à 21:53:21  profilanswer
 

il faudrait peut etre faire un traceroute .

n°527368
sharlaan
Posté le 25-07-2004 à 21:56:27  profilanswer
 

T'as une résolution DNS ?


---------------
"Deux chose sont infinies, l'univers et la sotise humaine. Mais je ne suis pas sûr de ce j'affirme quant à l'univers." Albert Einstein
n°527372
THRAK
- THR4K -
Posté le 25-07-2004 à 22:08:20  profilanswer
 

une résolution DNS ? non je ne crois pas
ma machine ne fait pas office de serveur DNS en tous cas et les adresses IP sont attribuées par les serveurs de mon FAI.


---------------
THRAK (def.) : 1) A sudden and precise impact moving from intention, direction and commitment, in service of an aim. 2) 117 guitars almost striking the same chord simultaneously.
n°527453
THRAK
- THR4K -
Posté le 26-07-2004 à 04:18:20  profilanswer
 

J'ai beau chercher là je vois toujours pas.
 
J'ai encore fait pas mal de tests (ce sacré problème a bien décidé de rester et se reproduire  :fou: ) sans résultat...
 
J'ai épluché des docs debian sur la config réseau, et les connexions via pppoe et tout est normal (c'est d'ailleurs logique puisque cela fonctionnait comme tel auparavant)...
 
- la connexion s'établie (le ifconfig est positif, j'obtiens bien une IP de mon fournisseur d'accès) en revanche impossible de me connecter à une hôte distant du premier coup. Je suis obligé de réesayer jusqu'à ce que pppoe veuille bien
 
- j'ai d'abord pensé à un problème lié au MTU, mais la taille est correctement définie (1492)
 
- j'ai ensuite tenté un traceroute vers un hôte distant (google) et ben y trace pas grand chose  :D  (message www.google.fr unknown host)
 
- j'arrive à pinger mon adresse ip (encore heureux) et à pinger l'adresse de mon modem ethernet (speedtouch home) ; de même que je parviens à afficher la page de config du modem dans un navigateur.
 
- j'ai également pensé à un problème avec le firewall (iptables + régle perso) mais en le désactivant ça ne change rien
 
- pour un éventuel problème de résolution des DNS je ne crois pas que cela vienne de là (j'arrive non plus pas à pinguer un hôte distant à partir de son adresse ip)
 
- j'ai aussi vérifié la liste des modules liés à pppoe et tous sont bien chargés correctement
 
- enfin j'ai vu qu'il était conseillé de désactiver TCP ECN (pose des problèmes d'accès à certains sites en fonction des routeurs employés) ce qui était déjà fait par défaut après vérification
 
 
Bref, moi je nage total dans le flou là, y a t-il des spécialistes de pppoe et des réseaux dans la salle  :??:  :hello:


Message édité par THRAK le 26-07-2004 à 04:24:01

---------------
THRAK (def.) : 1) A sudden and precise impact moving from intention, direction and commitment, in service of an aim. 2) 117 guitars almost striking the same chord simultaneously.
n°527454
nulix
Posté le 26-07-2004 à 05:21:52  profilanswer
 

ta verifié beaucoup de chose la ...
ton ip est etablie , donc de ce coté la pas de pb. Ta route par default est elle bien inséré ?  
si oui, le pb peut venir de la passerelle FAI aussi, spa impossible ...
 
bon soluce  pour etre sur que ca viens psa de chez toi :  tu lance ton pppd en mode debug  et tu zieute le log .
 
inutile de te demandé si ta reussit a pingé le poste FAI par ip ? parceque la a priorie , tu a rien du tout.
verifie que tes paquets passe bien par ta carte eth quant tu ping et cie .
moi jvois bien un pb de routage, car si ya PtP etablie alors ...


Message édité par nulix le 26-07-2004 à 05:25:03
n°527458
mikala
Souviens toi du 5 Novembre...
Posté le 26-07-2004 à 07:44:12  profilanswer
 

THRAK a écrit :


 
- j'ai ensuite tenté un traceroute vers un hôte distant (google) et ben y trace pas grand chose  :D  (message www.google.fr unknown host)


bon il y a au moins un problème de résolution dns dans un premier temps

THRAK a écrit :


- pour un éventuel problème de résolution des DNS je ne crois pas que cela vienne de là (j'arrive non plus pas à pinguer un hôte distant à partir de son adresse ip)


arrives tu a les tracerouter a ce moment la , et _ou_ cela s'arrete il ?
 

THRAK a écrit :


- j'ai aussi vérifié la liste des modules liés à pppoe et tous sont bien chargés correctement
 
-


ppp se met bien en place comme route par défault ?
ta machine a bien comme route par défault ta passerrelle ?

n°527975
THRAK
- THR4K -
Posté le 26-07-2004 à 21:45:16  profilanswer
 

Suite de mes problemes (la je poste en console depuis mon pc portable)
 
j'ai continue mes tentatives pour identifier le probleme je suis parvenu  
2 fois d'affilee a me connecter puis la troisieme tentative s'est soldee  
par un echec. J'ai donc profite pour refaire des tests:
- ping avec un nom d'hote -> echec
- ping avec l'adresse IP de l'hote -> paquets transmis mais 100 % perdus
- traceroute avec nom d'hote -> echec (unknown host ...)
- traceroute avec IP de l'hote -> aboutit jusqu'a l'adresse 193.253.171.22
 
Dans le dernier cas, le traceroute parvient jusqu'a cette adresse IP qui
se revele etre celle d'un serveur francetelecom.net de ma ville ; apres
plus rien, le traceroute ne trace plus rien apres cette adresse
A noter que je parvient a chaque fois a me connecter depuis mon portable
alors que sur ma station fixe c'est vraiment aleatoire ce qui me fait
penser qu'il serait bizarre que cela vienne purement du FAI. Pour un
probleme de routage aucune idee (mes connaissances en reseau sont basiques)
comment puis-je verifier le routage ? je n'utilise pas de passerelle,
ma machine accede direct au modem via un switch (idem pour le portable).
 
Merci de votre aide

n°528094
THRAK
- THR4K -
Posté le 26-07-2004 à 22:59:26  profilanswer
 

Sacre nom de nom, je crois avoir trouve le coupable !
Bon ben quel hasard ! je viens d'avoir exactement le meme probleme avec mon portable :)
Je suis sous Gentoo et j'utilise Roaring Penguin, en faisant un tracepath sur 66.102.9.104 (une ip de google.fr) j'obtiens :
- 1?: LOCALHOST          pmtu 1492
  1 : 193.253.171.22     assym 2 138.794ms
  2 : no reply
  3 : no reply
  4 : " etc
 
Bref ca s'arrete toujours sur 193.253.171.22, ce qui correspond au serveur suivant
(avec un tracepath quand ca fonctionne): bsstr251-net1Lo3.francetelecom.net (193.253.171.22)
 
A present ai-je de bonne raison de croire que cela vient bien de mon FAI ?
Si c'est le cas il faut que je leur signale le prob (pas gagne avec les hotlines
je vais avoir droit a "vous avez reinstalle le pack wanad** v9 special pour windows xp ?
comment vous etes sous quoi ? debian ? hein ??? :)


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  Les mystères de l'informatique : connexion internet rebelle

 

Sujets relatifs
Problème accès reseau / internetProb. mandrake 10.0 et connexion internet
[mandrake10]prob reseau et internetConnexion SSH, erreur authentifiction
Partage de fichier sur internetSMTP privé et Club-internet
Connexion sans mot de passe via login AD ou SAMBAModem Ethernet ou usb pour un partage de connexion
Partage de connexion 
Plus de sujets relatifs à : Les mystères de l'informatique : connexion internet rebelle


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR