Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2565 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  [Fedora 4] Connexion en SSH sans mot de passe impossible ! [résolu]

 


Sujet(s) à lire :
    - [cle ssh] qui ne marche pas RESOLU
 

 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Fedora 4] Connexion en SSH sans mot de passe impossible ! [résolu]

n°725425
benj63
Posté le 05-09-2005 à 12:07:38  profilanswer
 

Bonjour, j'ai déjà posté une partie de mon problème dans ce topic, mais comme l'auteur a résolu son souci, je pense que ça doit venir d'ailleurs.
 
J'ai récemment installé Fedora 4 (2.6.11-1.1369_FC4smp) sur une machine, et je souhaiterais pouvoir m'y connecter sans mot de passe.  
 
J'ai créé un utilisateur chef, puis :  

ssh chef@machine  
(mot de passe)  
mkdir .ssh  
cd .ssh  
ssh-keygen -t rsa  
(nom du fichier) identity  
(pas de passphrase)  
cat identity.pub > authorized_keys


 
Modification de /etc/ssh/sshd_config en tant que root :  
(je n'ai laissé ici que les lignes non commentées)  

Protocol 2  
SyslogFacility AUTHPRIV  
RSAAuthentication yes  
PubkeyAuthentication yes  
AuthorizedKeysFile ~/.ssh/authorized_keys  
PasswordAuthentication yes  
ChallengeResponseAuthentication no  
GSSAPIAuthentication yes  
GSSAPICleanupCredentials yes  
UsePAM yes  
X11Forwarding yes  
X11DisplayOffset 10  
Subsystem sftp /usr/libexec/openssh/sftp-server


 
J'ai redémarré le serveur ssh : /etc/init.d/sshd restart  
 
...eh bien lorsque je tape ssh chef@localhost il me demande toujours mon mot de passe  !  :(  
 
J'ai réessayé en utilisant un fichier id_dsa, un fichier id_rsa, et en mettant toutes ces clés dans le /authorized_keys... Rien n'y fait !!!   :fou:  
 
Voici un ssh -v chef@localhost :  

OpenSSH_4.0p1, OpenSSL 0.9.7f 22 Mar 2005  
debug1: Reading configuration data /etc/ssh/ssh_config  
debug1: Applying options for *  
debug1: Connecting to localhost [127.0.0.1] port 22.  
debug1: Connection established.  
debug1: identity file /home/chef/.ssh/identity type -1  
debug1: identity file /home/chef/.ssh/id_rsa type 1  
debug1: identity file /home/chef/.ssh/id_dsa type 2  
debug1: Remote protocol version 2.0, remote software version OpenSSH_4.0  
debug1: match: OpenSSH_4.0 pat OpenSSH*  
debug1: Enabling compatibility mode for protocol 2.0  
debug1: Local version string SSH-2.0-OpenSSH_4.0  
debug1: SSH2_MSG_KEXINIT sent  
debug1: SSH2_MSG_KEXINIT received  
debug1: kex: server->client aes128-cbc hmac-md5 none  
debug1: kex: client->server aes128-cbc hmac-md5 none  
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent  
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP  
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent  
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY  
debug1: Host 'localhost' is known and matches the RSA host key.  
debug1: Found key in /home/chef/.ssh/known_hosts:1  
debug1: ssh_rsa_verify: signature correct  
debug1: SSH2_MSG_NEWKEYS sent  
debug1: expecting SSH2_MSG_NEWKEYS  
debug1: SSH2_MSG_NEWKEYS received  
debug1: SSH2_MSG_SERVICE_REQUEST sent  
debug1: SSH2_MSG_SERVICE_ACCEPT received  
debug1: Authentications that can continue: publickey,gssapi-with-mic,password  
debug1: Next authentication method: gssapi-with-mic  
debug1: Authentications that can continue: publickey,gssapi-with-mic,password  
debug1: Authentications that can continue: publickey,gssapi-with-mic,password  
debug1: Next authentication method: publickey  
debug1: Trying private key: /home/chef/.ssh/identity  
debug1: Offering public key: /home/chef/.ssh/id_rsa  
debug1: Authentications that can continue: publickey,gssapi-with-mic,password  
debug1: Offering public key: /home/chef/.ssh/id_dsa  
debug1: Authentications that can continue: publickey,gssapi-with-mic,password  
debug1: Next authentication method: password  
chef@localhost's password:


 
Il me demande toujours le mot de passe. J'ai réussi à faire fonctionner tout cela en tant que root (connexion sans mot de passe à root@localhost), mais pas en tant qu'utilisateur chef ou autre (j'ai même essayé de recréer l'utilisateur etc).  
 
J'ai déjà fait cette manip 50 fois sous RedHat 9 sur d'autres postes, et elle ne m'a jamais posé de problèmes jusqu'à présent... Aurais-je oublié quelque chose cette fois-ci ? Est-ce qu'il y a des soucis avec le parefeu intégré à Fedora 4 ?
 
Merci par avance pour vos idées...


Message édité par benj63 le 06-09-2005 à 14:09:45

---------------
Projet d'aquarium low-tech (menuiserie, élec et aquascaping) | Zelda - Breath of the Wild
mood
Publicité
Posté le 05-09-2005 à 12:07:38  profilanswer
 

n°725437
l0ky
Posté le 05-09-2005 à 12:27:04  profilanswer
 

si tu arrives a te connecter avec mot de passe, le firewall n'y est pour rien.
essayes en spécifiant sur la ligne de commande le -i qui va bien sur la ligne de commande de ssh

n°725459
af_airone
Posté le 05-09-2005 à 13:20:31  profilanswer
 

si tu y arrives en root je suppose que ce sont des problemes de droits sur les clés ou les répertoires.

n°725486
benj63
Posté le 05-09-2005 à 14:37:56  profilanswer
 

af_airone a écrit :

si tu y arrives en root je suppose que ce sont des problemes de droits sur les clés ou les répertoires.


 
Je précise que je parviens à me connecter en étant root, à root@localhost.
Par contre, je ne parviens pas à me connecter en étant root, à chef@localhost (même en copiant identity.pub de root dans /home/chef/.ssh/authorized_keys).
 
J'ai essayé ssh -i mais ça ne change rien... Quelles permissions et quel propriétaire dois-je donner à mes fichiers (authorized_keys, identity.pub et identity, ~/.ssh/, ...) ? Je n'ai vraiment pas d'autres idées pour la raison de ce problème...


Message édité par benj63 le 05-09-2005 à 14:38:26

---------------
Projet d'aquarium low-tech (menuiserie, élec et aquascaping) | Zelda - Breath of the Wild
n°725490
l0ky
Posté le 05-09-2005 à 14:51:35  profilanswer
 

tu peux donner les permissions de ton homedir, de ~/ssh et de tout ce qui se trouve dans ~/.ssh

n°725494
benj63
Posté le 05-09-2005 à 14:55:35  profilanswer
 

répertoire /home/ :

drwxr-xr-x    3 root root  4096 sep  5 09:53 home


 
répertoire /home/chef/ :

drwx------  14 chef chef 4096 sep  5 10:06 chef


 
répertoire /home/chef/.ssh/ :

drwxrwxr-x   2 chef chef 4096 sep  5 14:31 .ssh


 
contenu du répertoire /home/chef/.ssh/ :

-rw-rw-r--   1 chef chef 462 sep  5 14:33 authorized_keys
-rw-------   1 chef chef 883 sep  5 14:31 identity
-rw-r--r--   1 chef chef 231 sep  5 14:31 identity.pub
-rw-r--r--   1 chef chef 443 sep  5 12:28 known_hosts


 
normalement, ce sont les droits par défaut, je n'ai rien modifié...


---------------
Projet d'aquarium low-tech (menuiserie, élec et aquascaping) | Zelda - Breath of the Wild
n°725497
l0ky
Posté le 05-09-2005 à 15:12:07  profilanswer
 

le répertoire .ssh est "group writable", je pense que ssh ne le veux pas. mets le en 700 (ie: rwx------)
idem pour authorized_keys


Message édité par l0ky le 05-09-2005 à 15:12:24
n°725504
benj63
Posté le 05-09-2005 à 15:25:28  profilanswer
 

merci pour l'idée, mais après modification :

drwx------   2 chef chef 4096 sep  5 14:31 .ssh
-rwx------   1 chef chef 462 sep  5 14:33 .ssh/authorized_keys


 

ssh chef@localhost
chef@localhost's password:

 :cry:  
 
Plus précisément :

[chef@data1 .ssh]$ ssh -v chef@localhost
OpenSSH_4.0p1, OpenSSL 0.9.7f 22 Mar 2005
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to localhost [127.0.0.1] port 22.
debug1: Connection established.
debug1: identity file /home/chef/.ssh/identity type 1
debug1: identity file /home/chef/.ssh/id_rsa type -1
debug1: identity file /home/chef/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_4.0
debug1: match: OpenSSH_4.0 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_4.0
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'localhost' is known and matches the RSA host key.
debug1: Found key in /home/chef/.ssh/known_hosts:1
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,gssapi-with-mic,password
debug1: Next authentication method: gssapi-with-mic
debug1: Authentications that can continue: publickey,gssapi-with-mic,password
debug1: Authentications that can continue: publickey,gssapi-with-mic,password
debug1: Next authentication method: publickey
debug1: Offering public key: /home/chef/.ssh/identity
debug1: Authentications that can continue: publickey,gssapi-with-mic,password
debug1: Trying private key: /home/chef/.ssh/id_rsa
debug1: Trying private key: /home/chef/.ssh/id_dsa
debug1: Next authentication method: password
chef@localhost's password:


---------------
Projet d'aquarium low-tech (menuiserie, élec et aquascaping) | Zelda - Breath of the Wild
n°725536
af_airone
Posté le 05-09-2005 à 16:33:30  profilanswer
 

je vais peut etre dire une bêtise
mais tu nommes tes clés identity avec ton ssh-keygen quand tu les génères
or j ai l impression que lors de la tentative de connexion ilessaie de pointer vers id_rsa et id_dsa qui doivent etre les noms de clé par défaut.
 
donc la solution serait peut etre quand tu génère avec ssh-keygen des nouvelles clés de les appeler id_rsa ou id_dsa pour voir si ca resoud le problem

n°725545
benj63
Posté le 05-09-2005 à 16:57:31  profilanswer
 

il semble d'abord regarder identity :

debug1: Offering public key: /home/chef/.ssh/identity


avant de regarder id_rsa et id_dsa...  
 
J'ai pensé comme toi au début, mais en créant des fichiers id_rsa et id_dsa ça n'a rien corrigé, il me demandait toujours le mot de passe.


---------------
Projet d'aquarium low-tech (menuiserie, élec et aquascaping) | Zelda - Breath of the Wild
mood
Publicité
Posté le 05-09-2005 à 16:57:31  profilanswer
 

n°725739
benj63
Posté le 06-09-2005 à 10:59:19  profilanswer
 

Bon, ça semblait bien être un problème de droits.
 

  • répertoire .ssh situé dans /home/chef/ :  drwxr--r-- (744)  chef : chef
  • fichier identity situé dans /home/chef/.ssh/ : -rw-------- (600)  chef : chef
  • fichier identity.pub situé dans /home/chef/.ssh/ :  -rw-r--r-- (644)  chef : chef
  • fichier known_hosts situé dans /home/chef/.ssh/ : -rw-r--r-- (644)  chef : chef
  • fichier authorized_keys situé dans / :  -rw-r--r-- (644)  root : root


Ca marche à présent. Merci pour votre aide !


---------------
Projet d'aquarium low-tech (menuiserie, élec et aquascaping) | Zelda - Breath of the Wild
n°725741
chaica
Posté le 06-09-2005 à 11:05:38  profilanswer
 

Y'a un topic sur ce sujet par semaine, faudrait voir à un peu chercher. En plus y'a de la doc sur lea-linux.


---------------
Du taf dans le Logiciel Libre : https://www.linuxjobs.fr
n°725750
benj63
Posté le 06-09-2005 à 11:24:51  profilanswer
 

chaica a écrit :

Y'a un topic sur ce sujet par semaine, faudrait voir à un peu chercher. En plus y'a de la doc sur lea-linux.


Merci de ton intransigeance à mon égard. :o  
 
Sache que j'ai tout d'abord cherché et posté dans un autre sujet avant d'ouvrir celui-ci. L'auteur de l'autre sujet ayant fermé son topik car son problème était résolu, je me suis permis d'en créer un nouveau.
 
Après, je ne vois pas en quoi cela te gène qu'il y ait un topik de + ou de - sur ce sujet. D'ailleurs il n'y en a pas tant que ça...
 
D'autre part, j'aurais très bien pu supprimer mon topik après résolution du problème, ou le laisser sans même poster la solution.  :o
 
edit : et enfin, sache que je n'ai pas posté ce problème uniquement sur ce forum. Regarde justement du côté de LeaLinux, et de Fedora-France...


Message édité par benj63 le 06-09-2005 à 11:25:29

---------------
Projet d'aquarium low-tech (menuiserie, élec et aquascaping) | Zelda - Breath of the Wild
n°725769
chaica
Posté le 06-09-2005 à 12:01:47  profilanswer
 

Merci de ta grande générosité de nous faire partager ton retour d'expérience :D
A la base je dis ça pour toi, afin d'éviter que tu perdes du temps à attendre un e réponse qui existe déjà. Maintenant comme tu dis, ça me fait rien que tu postes une n-ième fois, y'a déjà 40 réponses sur le sujet, donc une de plus ou de moins...


---------------
Du taf dans le Logiciel Libre : https://www.linuxjobs.fr
n°725836
benj63
Posté le 06-09-2005 à 14:09:28  profilanswer
 

chaica a écrit :

Merci de ta grande générosité de nous faire partager ton retour d'expérience :D
A la base je dis ça pour toi, afin d'éviter que tu perdes du temps à attendre un e réponse qui existe déjà. Maintenant comme tu dis, ça me fait rien que tu postes une n-ième fois, y'a déjà 40 réponses sur le sujet, donc une de plus ou de moins...


donc c'est parfait à présent, tout est résolu ;)


---------------
Projet d'aquarium low-tech (menuiserie, élec et aquascaping) | Zelda - Breath of the Wild

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  [Fedora 4] Connexion en SSH sans mot de passe impossible ! [résolu]

 

Sujets relatifs
IPsec + pptp pour sécuriser une connexion wifi/mettre en place 1 VPNSECUITE MOT DE PASSE
[RESOLU Un petit problème avec le pilote ATI - Mandriva LE2005[Debian] Connexion freebox
[RESOLU] [Debian]Sarge 3.1 AMD64 et Ndiswrapper[ FEDORA ] acces à internet tès lent
Installation de Fedora 4 impossible sur congif détailléelirc : installation via yum et impossible de tester !!!
installation de fedora sur un DELL GX270 
Plus de sujets relatifs à : [Fedora 4] Connexion en SSH sans mot de passe impossible ! [résolu]


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR