Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
808 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  Probleme configuration réseau Debian

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Probleme configuration réseau Debian

n°997837
Mickael P
Le mieux est l'ennemi du bien
Posté le 04-01-2008 à 14:25:50  profilanswer
 

Bonjour tout le monde !!! Et bonne année  ;)  
 
Je me décide a poster parce que je commence a perdre patience ...
 
Alors voila, sur mon réseau local j'ai un IPCop (les différentes IP 192.168.0.6 -> GREEN 192.168.2.1 ->ORANGE 192.168.1.2 (DHCP) -> RED).
J'ai récupéré une machine il y a peu que je suis en train de monter en FTP (donc sur ORANGE) j'ai fait l'install sans probleme et j'ai configurer l'interface réseau en fixe 192.168.2.2 ; 255.255.255.0 le ping loopback est OK, le ping sur l'interface ORANGE de IPCop est OK et a partir du réseau GREEN (192.168.0.0) je peux pinger sur le FTP.
Mais je n'arrive pas a pinger sur l'extérieur a partir du FTP :( le ping sur le GREEN ou meme sur www.google.fr ne fonctionne pas ...
J'ai essayé de modifier /etc/network/interfaces pour mettre gateway 192.168.2.1 mais ca ne fonctionne pas ...
J'ai aussi essayé de rentrer une nouvelle ligne de routage "route add default 192.168.2.1" mais ca ne fonctionne pas non plus :'(
 
Quelqu'un aurait-il une idée ???
 
Merci d'avance bonne journée ;)

mood
Publicité
Posté le 04-01-2008 à 14:25:50  profilanswer
 

n°997841
o'gure
Modérateur
Multi grognon de B_L
Posté le 04-01-2008 à 14:32:18  profilanswer
 

As tu configuré ton /etc/resolv.conf ?


---------------
Ton Antoine commence à me les briser menus !
n°997844
Mickael P
Le mieux est l'ennemi du bien
Posté le 04-01-2008 à 14:36:11  profilanswer
 

ouai j'ai nameserver 192.168.1.1

n°997846
o'gure
Modérateur
Multi grognon de B_L
Posté le 04-01-2008 à 14:40:32  profilanswer
 

- La résolution de nom se fait t'elle correctement ?
tu peux ne pas pouvoir pinguer mais pouvoir atteindre des équipements sur internet avec d'autre protocoles.
- un wget http://www.google.fr te retourne une erreur ?
- As tu mis des règles de filtrage sur ton IPcop ?


Message édité par o'gure le 04-01-2008 à 14:40:43

---------------
Ton Antoine commence à me les briser menus !
n°997847
Mickael P
Le mieux est l'ennemi du bien
Posté le 04-01-2008 à 14:40:47  profilanswer
 

Je ne sais pas si ca peut etre la cause du probleme mais la connexion semble etre en half-duplex ...
 
Lorsque je rentre mon "route add default 192.168.2.1" si je redémarre l'interface réseau la ligne de routage disparait je ne sais pas si c'est normal ...

n°997849
o'gure
Modérateur
Multi grognon de B_L
Posté le 04-01-2008 à 14:42:44  profilanswer
 

C'est normal que tu perdes ta ligne... il faut indiquer la gateway dans la conf de ton interface /etc/network/interfaces (cf man interfaces)pour que ta route persiste au reboot, et up/down des interfaces réseaux.


---------------
Ton Antoine commence à me les briser menus !
n°997850
Mickael P
Le mieux est l'ennemi du bien
Posté le 04-01-2008 à 14:43:02  profilanswer
 

Lorsque j'execute wget il me dis "Echec temporaire dans la résolution du nom"
 
Non je pense pas avoir mis de règles sur mon IPCop, juste un port mapping.

n°997852
Mickael P
Le mieux est l'ennemi du bien
Posté le 04-01-2008 à 14:43:47  profilanswer
 

ba j'ai dans interfaces gateway 192.168.2.1 mais si je rentre pas la ligne par route avec un route -n je ne la vois pas :(

n°997856
o'gure
Modérateur
Multi grognon de B_L
Posté le 04-01-2008 à 14:48:51  profilanswer
 

=> problème de DNS [:spamafote]
mets 192.168.2.1 plutôt.


---------------
Ton Antoine commence à me les briser menus !
n°997859
Mickael P
Le mieux est l'ennemi du bien
Posté le 04-01-2008 à 14:49:52  profilanswer
 

Pardon ??? Je mets 192.168.2.1 où ???

mood
Publicité
Posté le 04-01-2008 à 14:49:52  profilanswer
 

n°997860
o'gure
Modérateur
Multi grognon de B_L
Posté le 04-01-2008 à 14:50:30  profilanswer
 

Mickael P a écrit :

ba j'ai dans interfaces gateway 192.168.2.1 mais si je rentre pas la ligne par route avec un route -n je ne la vois pas :(


:heink:
Tu peux montrer ton fichier ?


---------------
Ton Antoine commence à me les briser menus !
n°997861
o'gure
Modérateur
Multi grognon de B_L
Posté le 04-01-2008 à 14:51:31  profilanswer
 

Mickael P a écrit :

Pardon ??? Je mets 192.168.2.1 où ???


:heink:
T'as un problème de résolution de nom => problème de conf DNS, il n'arrive pas à joindre ton serveur probablement
 
=> /etc/resolv.conf  
 
Logique non ?


---------------
Ton Antoine commence à me les briser menus !
n°997862
Mickael P
Le mieux est l'ennemi du bien
Posté le 04-01-2008 à 14:54:42  profilanswer
 

Citation :

iface eth0 inet static
                        address 192.168.2.2
                        netmask 255.255.255.0
                        network 192.168.2.0
                        broadcast 192.168.2.255
                        gateway 192.168.2.1
                        dns-nameservers 192.168.2.1


 

n°997863
Mickael P
Le mieux est l'ennemi du bien
Posté le 04-01-2008 à 14:56:16  profilanswer
 

J'ai pas l'impression que ce soit un probleme de résolution de nom mais plutot un probleme de passerelle.
Pour rappel mon resolv.conf me dit nameserver 192.168.2.1

n°997865
o'gure
Modérateur
Multi grognon de B_L
Posté le 04-01-2008 à 15:01:34  profilanswer
 


Mickael P a écrit :

J'ai pas l'impression que ce soit un probleme de résolution de nom mais plutot un probleme de passerelle.
Pour rappel mon resolv.conf me dit nameserver 192.168.2.1

 
Mickael P a écrit :

ouai j'ai nameserver 192.168.1.1


Mickael P a écrit :

Lorsque j'execute wget il me dis "Echec temporaire dans la résolution du nom".

 

Tu me dis au départ que c'est 192.168.1.1 et le message d'erreur dit clairement que c'est un problème dans la résolution du nom. Je me dis juste que le firewall n'accepte pas le trafic dans le sens Orange -> Green mais seulement Green -> Orange (c'est le principe d'une DMZ en théorie). Si depuis ton serveur tu ne peux pas résoudre de nom, tu ne pourras pas pinguer une adresse du style www.google.fr [:spamafote]

 

Donc pour l'instant, pour moi, c'est une erreur de résolution DNS [:spamafote]

 

Pour ta route qui ne persiste pas, je ne sais pas d'où ca vient, ton fichier me semble correct pourtant.

 

Avec 192.168.2.1 en tant que serveur DNS (soit écris manuellement dans /etc/resolv.conf, soit dans ton fichier interface avec un "redémarrage" de ton interface), est ce que tu as une résolution DNS ?

 

Par exemple que donne :
host www.google.fr
ping 64.233.183.104


Message édité par o'gure le 04-01-2008 à 15:03:14

---------------
Ton Antoine commence à me les briser menus !
n°997867
Mickael P
Le mieux est l'ennemi du bien
Posté le 04-01-2008 à 15:12:12  profilanswer
 

Oui désolé j'ai fait une faute de frappe tout a l'heure dans resolv.conf c'est bien 192.168.2.1 :$ désolé ...
 
Alors pour host www.google.fr j'ai

Citation :

NET: Registered protocol family 10
                                                                  lo: Disabled Privacy Extensions
                                                                  IPv6 over IPv4 tunneling driver
                                                                  ;; connection timed out; no server could be reached


et pour ping 64.233.183.104

Citation :

connect: Network is unreachable


 
Vu que j'ai rajouter aucune règle de filtrage IPCop et que cela me parait bizarre que par défaut une DMZ n'ai pas accès a l'interface RED c'est pour ca que je pensais plus a un probleme de passerelle sur le FTP ... Mais si tu dis que c'est résolution de nom alors c'est résolution de nom ;)

n°997870
Mickael P
Le mieux est l'ennemi du bien
Posté le 04-01-2008 à 15:16:18  profilanswer
 

Après avoir fait un "route add default gw 192.168.2.1" quand je ping il me met juste 100% packets lost

n°997887
Mickael P
Le mieux est l'ennemi du bien
Posté le 04-01-2008 à 15:30:38  profilanswer
 

Tu seches o'gure ???

n°997889
o'gure
Modérateur
Multi grognon de B_L
Posté le 04-01-2008 à 15:34:00  profilanswer
 

Ben là je dirais que tu as du filtrage sur ton IPcop, ca fait un bail que je ne l'ai pas utilisé et jamais avec une DMZ, donc je ne peux plus trop t'aider pour l'instant (pas le temps de creuser), désolé.


Message édité par o'gure le 04-01-2008 à 15:34:11

---------------
Ton Antoine commence à me les briser menus !
n°997892
Mickael P
Le mieux est l'ennemi du bien
Posté le 04-01-2008 à 15:36:04  profilanswer
 

ok merci quand meme o'gure ;)
 
Si quelqu'un a des idées ???

n°997933
Mickael P
Le mieux est l'ennemi du bien
Posté le 04-01-2008 à 16:33:31  profilanswer
 

Solution : http://linuxfr.org/forums/10/14199.html
 
Merci a toi o'gure ;)

mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  Probleme configuration réseau Debian

 

Sujets relatifs
Problème installation carte wifi sous Mandriva 2008[Pas résolu !] Problème de script Bash dans script Perl
Probléme avec munin.Tomcat + Apache + Debian Etch: Howto Dispo
Probleme swap lors de l'installation ubuntuBesoin d'un expert debian. Erreur de changement de droits
probleme windows XP sur raid > drivers sata nvraid[VPN] Netgear problème de connexion et d'accès partage
Debian - net install problème reconnaissance disque dur 
Plus de sujets relatifs à : Probleme configuration réseau Debian


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR