Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1830 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs

  règle pour shorewall

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

règle pour shorewall

n°477696
felix007
Posté le 13-05-2004 à 02:13:45  profilanswer
 

Bonjour,
Voilà je veux partager la connexion internet de ma mandrake 10 official avec un ordi sous windows XP. J'ai réglé le partage des fichiers avec Samba, pas de problème. Par contre, lorsque Shorewall est activé j'arrive bien à partager les fichiers mais pas à partager la connexion internet : quel est le numéro du port à faire accepter à shorewall pour qu'il partage la connexion internet ?


---------------
Pingouin un jour, Pingouin... ?
mood
Publicité
Posté le 13-05-2004 à 02:13:45  profilanswer
 

n°477712
leto
Posté le 13-05-2004 à 07:31:17  profilanswer
 

Ca depend ce que tu veux autoriser aux clients . Mais normalement qd tu passe par le centre de controle mandrake , Shorewall est automatiquement configuré .

n°477836
felix007
Posté le 13-05-2004 à 10:57:19  profilanswer
 

leto3 a écrit :

normalement qd tu passe par le centre de controle mandrake , Shorewall est automatiquement configuré .


le résultat en tout cas est que : le partage de fichiers marche mais la connexion internet partagée ne marche pas
Je veux bien donner beaucoup, énormément de droits aux clients, mais lorsque je desactive le firewall, ça ne marche pas non pluq (car je crois sans en être sûr que ça desactive le partage de connexion automatiquement)


---------------
Pingouin un jour, Pingouin... ?
n°477901
felix007
Posté le 13-05-2004 à 11:44:27  profilanswer
 

quel est le numéro du port à faire accepter à shorewall pour qu'il partage la connexion internet ?
 
 


---------------
Pingouin un jour, Pingouin... ?
n°478037
174flo
Posté le 13-05-2004 à 13:28:16  profilanswer
 

As tu mis ppp+ comme peripherique reseau?

n°478179
felix007
Posté le 13-05-2004 à 14:52:06  profilanswer
 

oui oui


---------------
Pingouin un jour, Pingouin... ?
n°478229
Dark_Schne​ider
Close the World, Open the Net
Posté le 13-05-2004 à 15:35:49  profilanswer
 

pour partager une connexion on utilise le NAT, ce n'est pas une question de port.
 
l'utilitaire pour paratger une connexion internet est dans la partie "Réseau & Internet".
tu peux le lancer en console avec la cmmande : drakgw


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°479953
felix007
Posté le 15-05-2004 à 21:38:18  profilanswer
 

oui oui je l'ai fait mais voilà.
J'arrive sans problème à me connecter à internet, puis je lance drakgw et je partage la connexion. Ok tout a l'air bien sauf qu'en même temps ça lance le firewall, qui bloque la connexion internet. Du coup (vu que je ne connais pas le numéro du port à faire accepter à shorewall), je me retrouve obligé de desactiver le firewall ce qui desactive automatiquement le partage de connexion. C'est un cercle. Vous faites comment vous?


Message édité par felix007 le 15-05-2004 à 22:51:29
n°480170
leto
Posté le 16-05-2004 à 12:47:16  profilanswer
 

Normalement l'activation de Shorewall ne bloque pas tout, j'ai tjours partagé ma connexion comme ca , et ca laisse les clients plus ou moins libre .  
Les regles shorewall peuvent etre reglées / assouplies dans le fichier :  
/etc/shorewall/rules
 

n°480205
felix007
Posté le 16-05-2004 à 14:03:36  profilanswer
 

oui mais  peux tu m'expliquer comment tu as partagé ta connexion ? après avoir déjà configuré shorewall ou avant?
moi je suis formel sur ce que j'ai dis plus haut ça se passe comme ça (sur mandrake 10 official)


---------------
Pingouin un jour, Pingouin... ?
mood
Publicité
Posté le 16-05-2004 à 14:03:36  profilanswer
 

n°480222
leto
Posté le 16-05-2004 à 14:31:47  profilanswer
 

normalement tu va dans le mandrake control center, tu lui dit d'activer le partage de connexion et apres ca marche .  
Sur les postes clients, tu mets attribution automatique d'adresse ip

n°481462
felix007
Posté le 18-05-2004 à 12:35:37  profilanswer
 

je suis formel, j'ai déjà fait tout ça mais ça marche pas. Le partage des fichiers marche, mais pas le partage de connexion internet. Vous êtes sûr que c'est pas lié à Shorewall?

n°481465
felix007
Posté le 18-05-2004 à 12:39:56  profilanswer
 

je précise que le deuxième ordi (client) est sous XP home, et que le partage de connexion internet fonctionne parfaitement lorsque j'utilise le premier ordi (serveur) sous XP

n°481489
Dark_Schne​ider
Close the World, Open the Net
Posté le 18-05-2004 à 13:55:37  profilanswer
 

qu'as tu comme paramètre sur le 2è ordi ?
 
sur le 2e ordi il faut préciser :
- l'Ip de la passerelle : 192.168.0.1 ( normalement )
- les DNS : 192.168.0.1 ou ceux de ton FAI
 
 
si c'est une community, il y a un bug dans l'outil de partage de connexion ( notamment avec le proxy transparent squid qui est installé ) et pour corrigé ce bug il faut mettre à jour les outils mdk. dans ce cas tu passe en official.
 
- d'abord tu ajoutes les sources pour une 10.0 Official -> http://www.urpmi.org/easyurpmi/ind [...] 586#second
 
 
- tu désactives les sources venant de test CD.
 
- puis tu mets à jours le système :
> urpmi urpmi
> urpmi --auto-select --auto --keep --no-verify-rpm
 
- tu désinstalles shorewall et squid :
> urpme squid shrewall
 
- tu lances le partage de connexion internet :
> drakgw --expert
 
- tu choisis la bonne internface internet ( ppp+ pour une connexion via un modem/ADSL ) et l'interface interne ( souvent eth1 )


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°481753
felix007
Posté le 18-05-2004 à 17:23:27  profilanswer
 

Je vais essayer tout ça. Merci beaucoup en tout cas pour le temps que tu as passé à écrire ce message


---------------
Pingouin un jour, Pingouin... ?
n°490583
jogrey
Posté le 30-05-2004 à 13:47:28  profilanswer
 

Une question, j'ai fais des urpmi --excludemedia cdrom1, cdrom2, cdrom3, mais il me demande toujours les cds, ai-je fais la bonne commande ?

n°490586
jogrey
Posté le 30-05-2004 à 13:51:31  profilanswer
 

en fait urpmi.removemedia -a marche mieux :)

n°490638
Slee
Posté le 30-05-2004 à 16:34:19  profilanswer
 

En fait, j'ai le même soucis.
Sous Mandrake 10.0 official, lorsque je lance le partage automatique, le firewall/proxy fait tout foirer (shorewall/squid).
Je peux même plus pinger le réseau local.
 
Ma config:
Ordi fixe, sous linux mandrake 10.0 official
- ip réseau: IP_FIXE_REZO 192.168.0.1
- ip internet: IP_FIXE_INTERNET (style free dégroupé)
- ip AP wifi: 192.168.0.5
 
Laptop, sous winxp pro
- ip en dhcp: IP_LAPTOP 192.168.0.209 (exemple)
 
Sans partage de connexion (en tout cas il me dit que c'est désactivé), j'arrive à pinger le modem Sagem USB, mais pas l'extérieur.
Si j'installe le partage de connexion, ca marche pas mieux, et en plus je perds internet sur l'ordi fixe.
 
Voici ma table de routage:
 
Destination     Passerelle      Genmask         Indic Metric Ref    Use Iface
192.168.0.0     *               255.255.255.0   U     0      0        0 eth0
IP_FIXE_INTERNET (xx.xx.xx.0)      *               255.255.255.0   U     0      0        0 eth1
127.0.0.0       *               255.0.0.0       U     0      0        0 lo
default         HOSTNAME_INTERNET 0.0.0.0         UG    0      0        0 eth1
 
Une idée?

n°490648
leto
Posté le 30-05-2004 à 16:47:23  profilanswer
 

Normal , qd tu active le partage de connexion, Shorewall bloque les pings .  
Suffit d'ajouter une ligne dans /etc/shorewall/rules  pour changer ca:
 
ACCEPT  fw      XXX     icmp    -       -
 
Remplace XXX par la zone vers laquelle tu veux autoriser les pings (cf /etc/shorewall/interfaces

n°490734
Slee
Posté le 30-05-2004 à 18:25:29  profilanswer
 

Voici ce que j'ai mis. Pour le moment, je cherche pas à mettre en place le firewall, mais juste à ce que ca marche.
J'arrive à pinger le modem depuis le portable, mais pas plus.
 
Dans /etc/shorewall/policy :
loc     net     ACCEPT
fw      net     ACCEPT
net    all     ACCEPT
all    all     ACCEPT
 
Dans /etc/shorewall/masq :  
ppp+    192.168.0.0/255.255.255.0
 
Dans /etc/shorewall/interfaces
net     ppp+    detect
loc     eth0    detect
net     eth1    detect

n°490903
Slee
Posté le 30-05-2004 à 23:18:15  profilanswer
 

Bon, j'ai trouvé le problème, j'ai dû mettre les mains dans iptables, DNAT/SNAT, etc... C'est pas aussi simple qu'il y parait une Mandrake... je suis un peu déçu sur ce coup là.
Il ne manque plus que la webcam, la carte son, et le module Bluetooth, et tout marchera...  :D

n°490991
doucettom
Dedicated Angler
Posté le 31-05-2004 à 08:40:36  profilanswer
 

Salut moi jai le meme trouble que vous ... excepter que moi si le partage de connexion fonctionne ... Samba ne fonctionne plus du tout meme si jai configurer pour que le firewall laisse le serveur SMB ouvert ??? croyez vous que jai oublier de setter la passerelle et les DNS ??? je suis configurer avec un serveur dhcp et les autres postes sont sous Windows 2000/XP

n°490992
doucettom
Dedicated Angler
Posté le 31-05-2004 à 08:46:15  profilanswer
 

De plus vous savez pas par hasard comment faire pour que les droits de samba s'appliquent aux sous dossiers ...
Vla mon smb.conf
 
#====Paramètres globaux====
[global]
 
 
   workgroup = Tomnet
   server string =
   log file = /var/log/samba/log.%m
   max log size = 50
   map to guest = bad user
   security = share
   encrypt passwords = yes
   smb passwd file = /etc/samba/smbpasswd
   socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
   dns proxy = no
 
#====Définitions des partages====
 
[Disque Linux]
   path = /mnt/Partage/
   public = yes
   only guest = yes
   writable = yes
   read only = no
   browseable = yes
   printable = no
 
Ce sont les sous répertoire de Partage qui chient des belles pelles

n°493703
felix007
Posté le 03-06-2004 à 01:03:42  profilanswer
 

ce qui serait bien, vu que personne ne semble y arriver, c'est qu'un barbu ayany réussi à partager sa connexion publie ses fichiers shorewall.
 
Merci d'avance à ce barbu très poilu


---------------
Pingouin un jour, Pingouin... ?
n°496861
174flo
Posté le 06-06-2004 à 20:45:12  profilanswer
 

Allez les barbus quoi, venez!!!!

n°496889
splurf
Rm -Rf / && oops :o
Posté le 06-06-2004 à 20:55:58  profilanswer
 

les barbus ça utilise pas Mandrake ;)

n°496893
174flo
Posté le 06-06-2004 à 21:02:08  profilanswer
 

Shorewall existe aussi pour d'autre distro ;)  
 
J'ai rajouter ca dans /etc/shorewall/masq

eth1    192.168.1.0/24


 
mais quand je fait #shorewall restart, j'ai:

Loading /usr/share/shorewall/functions...
Processing /etc/shorewall/params ...
Processing /etc/shorewall/shorewall.conf...
Shorewall Not Currently Running
Starting Shorewall...
Loading Modules...
Initializing...
Shorewall has detected the following iptables/netfilter capabilities:
   NAT: Available
   Packet Mangling: Available
   Multi-port Match: Available
   Connection Tracking Match: Available
Determining Zones...
   Zones: net loc
Validating interfaces file...
Validating hosts file...
Validating Policy file...
Determining Hosts in Zones...
   Net Zone: ppp+:0.0.0.0/0
   Local Zone: eth0:0.0.0.0/0 eth1:0.0.0.0/0
Processing /etc/shorewall/init ...
Deleting user chains...
Setting up Accounting...
Setting up User Sets...
Creating Interface Chains...
Configuring Proxy ARP
Setting up NAT...
Adding Common Rules
IP Forwarding Enabled
Processing /etc/shorewall/tunnels...
Processing /etc/shorewall/rules...
Processing /etc/shorewall/policy...
   Policy ACCEPT for fw to net using chain fw2net
   Policy ACCEPT for loc to net using chain loc2net
Masqueraded Subnets and Hosts:
   To 0.0.0.0/0 from 192.168.1.0/24 through eth1
Processing /etc/shorewall/tos...
   Rule "all all tcp - ssh 16" added.
   Rule "all all tcp ssh - 16" added.
   Rule "all all tcp - ftp 16" added.
   Rule "all all tcp ftp - 16" added.
   Rule "all all tcp ftp-data - 8" added.
   Rule "all all tcp - ftp-data 8" added.
Processing /etc/shorewall/ecn...
Activating Rules...
Processing /etc/shorewall/start ...
Shorewall Started


Apparement il ne fonctionnait pas, alors qu'au demarage la distro indique qu'il est lancer (l4), quelqu'un a une idée?

n°496948
174flo
Posté le 06-06-2004 à 22:08:54  profilanswer
 

bon, si sa interresse quelqu'un, j'ai reussis! :sol:  
J'ai tout simplement rajouter

ppp+    eth0

dans /etc/shorewall/masq et apres #shorewall restart.  
D'ailleure je deconseille d'utiliser drakgw parcequ'il installe un peu de tout et n'importe quoi (comme squid... :o ), il vaut mieu configurer shorewall à la main (contrairement à drakconf, je n'ai pas eu besoin d'installer de programme suplementaire... :pfff: ). Aller demain je m'attaque au probleme du ping et à SAMBA ;) .

n°502271
felix007
Posté le 12-06-2004 à 03:06:03  profilanswer
 

Rien à faire, moi ça ne marche toujours pas. j'ai bien suivi les conseils de Dark_Schneider mais ça ne suffit pas. J'ai un sagem USB en connexion ADSL (PPP+) et une carte ethernet classique pour mon réseau local. Dès que je lance le partage de connexion, shorewall bloque absolument tout : je ne peux même plus aller sur internet depuis mandrake. Pouvez vous me montrer vos fichiers shorewall svp?

n°502335
felix007
Posté le 12-06-2004 à 11:23:01  profilanswer
 

?

n°506639
felix007
Posté le 18-06-2004 à 22:59:53  profilanswer
 

?

n°506674
174flo
Posté le 19-06-2004 à 09:16:11  profilanswer
 

Pour partager ma connexion j'ai mis ce qu'il y a dans mon dernier poste: ppp+ pour indiquer ma connexion à internet, et eth0 pour indiquer ma connexion au réseau local. Depuis j'ai un peu modifier, l'autre PC et le mien on une IP fixe: Donc, comme mettre eth0 provoquer des problème avec shorewall si l'autre pc était éteint, j'ai mis dans le fichier /etc/shorewall/masq:  

ppp+    192.168.1.0/24


Mon réseau étant de la forme 192.168.1.0. Pour plus d'information, lit les excellent commentaire des fichiers de conf de shorewall.
Il faut aussi donner à l'ordinateur client l'adresse de celui qui est conecter à internet comme adresse de passerelle.


Message édité par -Cugel- le 19-06-2004 à 09:36:19
mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs

  règle pour shorewall

 

Sujets relatifs
explorer le reseau avec kde de mandrake 10 [reglé 80%]installer imprimante a encre solide Xerox 8400 sur mandrake [réglé]
utiliser la partiition data en fat32 comme /home pour linux [reglé][Bind] Port 53 fantome ? [réglé] [Mais encore une petite question]
pb pour lancer kmail, korganiser... sous mandrake10 [reglé]pb apres install mandrake 10 community [réglé]
[SHOREWALL + IPTABLES] utiliser des regles de filtrage mais ou ?iptables : règle OUTPUT sur une passelle pour accès au net
probleme iptables - shorewall[FreeBSD 5.1] Kernel upgrade raté : Réglé par maj compl. -> 5.2
Plus de sujets relatifs à : règle pour shorewall


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR