Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1774 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs

  Problème installation SB audigy LS et souris USB sous Mandrake 10.1

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Problème installation SB audigy LS et souris USB sous Mandrake 10.1

n°635410
jason
Posté le 12-02-2005 à 15:04:42  profilanswer
 

Bonjour,
 
J'ai récement installé Mandrake 10.1 Official, sur mon PC. Mais j'ai deux problèmes assez ennuyants. En faisant des recherches sous google et sur HFR, j'ai vu que c'était apparement des problèmes assez récurrents. Mais après avoir lu les différentes solution proposés sur différents forum, je n'y suis pas arrivé. C'est pourquoi je cré ce topic.
 
 
1) Problème au démarrage de Mandrake avec souris USB Logitech MX510:
 
Lors de l'installation de Mandrake, la souris est bien reconnue et je n'ai aucun soucis pour l'utiliser. Une fois l'installation terminée, je boot et je m'apercois que la souris ne fonctionne pas. Avec le clavier je me dirige vers le centre de configuration et j'arrive à faire marcher la souris en allant bidouiller la configuration. J'explique ma méthode:
Je choisit donc "Souris" dans le centre de configuration. Je valide "N'importe quelle souris USB/PS2" mais ça ne marche toujours pas. Je retourne sous ce menu et je choisit "Roulette" dans "USB" et je valide. La fenêtre de test s'ouvre mais ça ne marche pas. Je retourne une nouvelle fois dans  le menu "Souris" et je choisit "N'importe quelle souris USB/PS2". La fenêtre de test s'ouvre et cette fois la souris marche correctement.
J'arrive donc a faire fonctionner ma souris mais c'est un peu chiant de devoir faire ça a chaque boot.
 
Petite précision, j'ai refait une installation de Mandrake et lors de la configuration de la connexion internet (Modem Sagem USB F@st 800), j'ai décoché l'option de connexion automatique au démarrage, et cette fois ci, la souris marchait au boot. Mais depuis que j'ai recoché l'option de connexion automatique, elle ne marche plus.
 
Que faire???
 
 
2) Pas de pilote pour carte son Sound Blaster Audigy LS:
Comme je l'ai lu sur différents forum, ce type de carte son est rarement(ou jamais?) détécté correctement. Plusieur solutions sont proposés comme l'installation de emu10k1 ou la compilation du kernel. Etant débutant sous linux, j'ai essayer de trouver des package de emu10k1 que j'ai installer mais rien n'y fait. J'ai également essyé d'installer un nouveau kernel sous forme de package mais je suis pas sûr de m'y etre pris correctement. J'ai rebooter sous le nouveau kernel mais rien de mieux.  
 
Voici ce qu'inscrit la fenetre de configuration matériel:
 
 
 
Identification
Vendeur: ‎Creative Labs
 
Description: ‎SB Audigy LS
 
Classe de matériel: ‎MULTIMEDIA_AUDIO
 
Pilote
Module: ‎inconnu
 
Connexion
Bus: ‎PCI
 
Bus PCI n°: ‎1
 
Périphérique PCI n°: ‎8
 
Fonction PCI n°: ‎0
 
Identifiant du Vendeur: ‎4354
 
Identifiant du périphérique: ‎7
 
Identifiant secondaire du vendeur: ‎4354
 
Identifiant secondaire du périphérique: ‎4098
 
 
 
Comme je l'ai dit, je suis assez nouveau sous linux donc il est possible que je m'y soit mal pris. Les différent forum ou je me suis rendu n'indiquant pas tous les même solutions, je suis un peu perdu.
 
Quelqu'un aurait-il la bonté d'éclaircir mon esprit.
 
 
PS:
Deux autres questions en bonus.
Lors du démarrage en mode détaillé. Lors de initialisation de eth0, ça marque échec mais je pense que c'est dû au fait que rien de connecté à ma carte reseau.
Lors de l'initialisation de ppp0 (relatif a la connexion internet je crois???) c'est assez long avant de continuer (à peu près 30s). Est ce que tout ceci est normal?

mood
Publicité
Posté le 12-02-2005 à 15:04:42  profilanswer
 

n°635621
DDT
Posté le 12-02-2005 à 23:10:57  profilanswer
 

Pour ta carte son il te faut le module alsa audigyls, ou ca0106 avec la dernière version d'alsa, c'est pas de l'emu10k...
après sous mdk je sais pas comment ça se passe pour choisir un module particulier.
 
essaye un modprobe snd-audigyls en root (ou snd-ca0106)

n°636376
Dark_Schne​ider
Close the World, Open the Net
Posté le 14-02-2005 à 16:36:17  profilanswer
 

je ne pense pas que le module soit dispo sous mdk 10.1
 
fais voir le résultat des commandes suivantes :
[fixed]
lspcidrake
cat /proc/interrupts
cat /proc/cmdline
grep Protocol /etc/X11/xorg.conf
grep Device /etc/X11/xorg.conf
[fixed]
 
http://www.linux-wizard.net/faq.ph [...] tte_souris
http://qa.mandrakesoft.com/twiki/b [...] Cartes_son


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°636491
jason
Posté le 14-02-2005 à 20:15:49  profilanswer
 

Merci pour vos réponses. Voilà les différents résultats obtenus avec les commandes que vous m'avez indiqué:
 
 
modprobe snd-audigyls
FATAL: Module snd-audigyls not found.
 
 
lspcidrake
nvidia-agp      : nVidia Corp.|nForce2 AGP Controller [BRIDGE_HOST]
unknown         : nVidia Corp.|nForce2 Memory Controller [MEMORY_RAM]
unknown         : nVidia Corp.|nForce2 Memory Controller [MEMORY_RAM]
unknown         : nVidia Corp.|nForce2 Memory Controller [MEMORY_RAM]
unknown         : nVidia Corp.|nForce2 Memory Controller [MEMORY_RAM]
unknown         : nVidia Corp.|nForce2 Memory Controller [MEMORY_RAM]
unknown         : nVidia Corp.|nForce2 LPC / Legacy / System Management [BRIDGE_ISA]
unknown         : nVidia Corp.|nForce2 SMBus 2.0 Controller [SERIAL_SMBUS]
usb-ohci        : nVidia Corp.|nForce2 USB 1.0 OHCI Controller [SERIAL_USB]
usb-ohci        : nVidia Corp.|nForce2 USB 1.0 OHCI Controller [SERIAL_USB]
ehci-hcd        : nVidia Corp.|nForce2 USB 2.0 Enhanced Controller [SERIAL_USB]
forcedeth       : nVidia Corp.|nForce2 MCP Networking Adapter [NETWORK_ETHERNET]
unknown         : nVidia Corp.|nForce2 External PCI Bridge [BRIDGE_PCI]
unknown         : nVidia Corp.|nForce2 UDMA 100/133 IDE Controller [STORAGE_IDE]
ohci1394        : nVidia Corp.|nForce2 Firewire Controller [SERIAL_FIREWIRE]
unknown         : nVidia Corp.|nForce2 AGP Host to PCI Bridge [BRIDGE_PCI]
sk98lin         : Marvell Semiconductor, Inc.|88E8001 Gigabit Lan PCI Controller [NETWORK_ETHERNET]
unknown         : Creative Labs|SB Audigy LS [MULTIMEDIA_AUDIO]
unknown         : Creative Labs|SB Audigy LS MIDI/Game port [INPUT_OTHER]
sata_sil        : Silicon Image|Sil3112A Serial ATA [STORAGE_RAID]
Card:NVIDIA GeForce4 (generic): nVidia|NV25 GeForce4 Ti4200 [DISPLAY_VGA]
hub             : Linux 2.6.8.1-12mdk ehci_hcd|EHCI Host Controller [Hub]
hub             : Linux 2.6.8.1-12mdk ohci_hcd|OHCI Host Controller [Hub]
adiusbadsl      : Analog Devices Inc.|USB ADSL modem [Communications|ATM Networking]
usbhid          : Logitech|USB-PS/2 Optical Mouse [Human Interface Devices|Boot Interface Subclass|Mouse]
scanner         : Hewlett-Packard|ScanJet 4300C
hub             : Linux 2.6.8.1-12mdk ohci_hcd|OHCI Host Controller [Hub]
 
 
cat /proc/interrupts
           CPU0
  0:    2154216          XT-PIC  timer
  1:        610          XT-PIC  i8042
  2:          0          XT-PIC  cascade
  5:     432620          XT-PIC  ohci_hcd, SysKonnect SK-98xx
  9:          3          XT-PIC  ohci_hcd, ohci1394
 11:       9699          XT-PIC  libata
 12:     214774          XT-PIC  ehci_hcd, eth0
 14:         56          XT-PIC  ide0
 15:      43869          XT-PIC  ide1
NMI:          0
LOC:    2154265
ERR:       2590
MIS:          0
 
 
cat /proc/cmdline
BOOT_IMAGE=Mandrake_10.1 ro root=808 acpi=ht resume=/dev/sda9 splash=silent
 
 
grep Protocol /etc/X11/xorg.conf
Option "Protocol" "ExplorerPS/2"
 
 
grep Device /etc/X11/xorg.conf
Section "InputDevice"
Section "InputDevice"
    Option "Device" "/dev/mouse"
Section "Device"
    Device "device1"
    InputDevice "Keyboard1" "CoreKeyboard"
    InputDevice "Mouse1" "CorePointer"
 
 
A part ça, j'ai essayé de lancer alsaconf pour configurer alsa 1.0.6 qui est fournit avec mdk 10.1 mais il ne reconnait pas ma carte. J'ai essayé de trouver un package de la version 1.0.8 mais j'ai pas trouvé alors j'ai essayé de compiler les sources mais je dois pas être pret pour ce genre de chose puisque j'ai quelques messages d'erreur.
 
Je vais jeté un oeil aux liens que tu m'a donné. Merci


Message édité par jason le 14-02-2005 à 20:16:26
n°636949
Dark_Schne​ider
Close the World, Open the Net
Posté le 15-02-2005 à 19:14:52  profilanswer
 

normalement la souris devrait marcher.
 
essaie certaines options dans : http://www.linux-wizard.net/faq.ph [...] ption_list
et désactive l'APIC


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°645291
jason
Posté le 05-03-2005 à 13:50:53  profilanswer
 

Delsolé pour cete reponse un peu tardive.
 
Eh bien non ça ne marche toujours pas. Ni le son si la souris USB.
 
J'ai bien deasctivé l'APIC dans lilo mais ça n'a rien changé.
 
Pour le son, j'ai egalement suivi les indication de ce topic mais ça n'a pas marché non lus.
http://forum.hardware.fr/forum2.ph [...] 0&subcat=0
 
Par contre, je viens de voir que USB legagy mouse support etait disabled dans mon BIOS. Est ce que ça peut poser problème.


Message édité par jason le 05-03-2005 à 13:55:28
n°645293
Mjules
Modérateur
Parle dans le vide
Posté le 05-03-2005 à 14:00:54  profilanswer
 

Pour la souris, essaye de la brancher en PS/2
 


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°645294
jason
Posté le 05-03-2005 à 14:04:08  profilanswer
 

Oui j'avais imaginé que ca resoudrai le problème mais j'avais pas envie. J'essaye tout de suite.

n°645296
jason
Posté le 05-03-2005 à 14:12:12  profilanswer
 

Bon pour la souris en PS/2, ça marche.

n°645300
Mjules
Modérateur
Parle dans le vide
Posté le 05-03-2005 à 14:19:32  profilanswer
 

pour la carte son, à part compiler tes propres drivers ALSA, je sais pas si il y a d'autres solutions. :/
 
c'est pas d'une complexité insurmontable mais si tu maitrise pas, ça va être un peu tendu


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
mood
Publicité
Posté le 05-03-2005 à 14:19:32  profilanswer
 

n°645301
Mjules
Modérateur
Parle dans le vide
Posté le 05-03-2005 à 14:21:41  profilanswer
 

peut-être en utilisant OSS mais sans certitude


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs

  Problème installation SB audigy LS et souris USB sous Mandrake 10.1

 

Sujets relatifs
Souris "multi-boutons" et Mac OS XProbleme toshiba m30x 115 et linux
Problème lecture audio real avec le plugin RealPlayer sur FirefoxProbleme Install drivers NVidia sur Mandrake 10.1
creer des cd d'installation debianinstallation debian i386 3 rc4 sur dd sata
probleme serveur ftp derriere routeur[mandrake 9.2] kernel panic apres coupure de courant
probleme graphique sous mandrake 10.1 
Plus de sujets relatifs à : Problème installation SB audigy LS et souris USB sous Mandrake 10.1


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR