Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2240 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs

  probleme connexion à localhost

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

probleme connexion à localhost

n°669150
korel
Posté le 27-04-2005 à 21:58:15  profilanswer
 

bonjour,
depuis 15 jours j'ai un problème de connexion à localhost avec certaines applications (ksysguard,webmin,webhttrack) avec mandrake 10.1
par exemple ksysguard se lance sous mon profile utilisateur par kdesu ksysguard uniquement je me log en root ça ne marche pas non plus,
message "La connexion à localhost a été coupée".
je n'ai rien trouvé par google ni sur les forums.
quelqu'un pourrait il m'aider?

mood
Publicité
Posté le 27-04-2005 à 21:58:15  profilanswer
 

n°670719
korel
Posté le 01-05-2005 à 00:17:44  profilanswer
 

est-ce je dois tout reinstaller?

n°670767
syl94
Ni!
Posté le 01-05-2005 à 10:46:53  profilanswer
 

korel a écrit :

est-ce je dois tout reinstaller?


 
non! faut oublier le reflex windowzien de reinstaller dès qu'il y a un truc qui fonctionne plus :fou:  
 
- tape dans une console
 
1/ netstat -puant (c'est pas une blague) et regarde les ports ouverts
2/ ping localhost (ca doit répondre)
3/ ping 127.0.0.1
4/ cat /etc/hosts doit de retourner quelque chose comme :
 
127.0.0.1       localhost
 
plus d'autre trucs, mais 127.0.0.1 DOIT etre localhost
 
5/ par rapport aux ports ouverts via la commande netstat, essaye de faire un telnet dessus. Pour le port 80 par exemple :
 
telnet localhost 80
 
Essaye deja ca, et donne nous les résultats/erreurs si il y en a
 
bon courage!
 
EDIT: et flush ton firewall
 
iptables -F


Message édité par syl94 le 01-05-2005 à 10:49:00
n°671042
korel
Posté le 01-05-2005 à 21:59:03  profilanswer
 

pour point 1 à 4 c'est ok
par contre mes connaissances sont trop faibles pour reconnaitre les ports ouverts,
netstat -puant
Connexions Internet actives (serveurs et établies)
Proto Recv-Q Send-Q Adresse locale          Adresse distante        Etat        PID/Program name
tcp        0      0 0.0.0.0:32768           0.0.0.0:*               LISTEN      8018/hpiod
tcp        0      0 127.0.0.1:32769         0.0.0.0:*               LISTEN      8030/python
tcp        0      0 0.0.0.0:631             0.0.0.0:*               LISTEN      8079/cupsd
tcp        0      0 84.4.162.166:44880      66.102.9.147:80         ESTABLISHED 10825/mozilla-firef
tcp        0      0 84.4.162.166:44879      66.102.9.147:80         ESTABLISHED 10825/mozilla-firef
tcp        0      0 127.0.0.1:37566         127.0.0.1:32768         ESTABLISHED 8030/python
tcp        1      0 84.4.162.166:33394      66.102.9.99:80          CLOSE_WAIT  10825/mozilla-firef
tcp        0      0 84.4.162.166:44301      213.248.112.116:80      ESTABLISHED 10825/mozilla-firef
tcp        0      0 127.0.0.1:32768         127.0.0.1:37566         ESTABLISHED 8018/hpiod
udp        0      0 0.0.0.0:631             0.0.0.0:*                           8079/cupsd
 
# telnet localhost 32769
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
 
msg=messageerror
result-code=5

n°671140
syl94
Ni!
Posté le 02-05-2005 à 09:35:26  profilanswer
 

le probleme semble etre la :  
tcp        0      0 0.0.0.0:631             0.0.0.0:*               LISTEN      8079/cupsd
 
protocole : tcp
0.0.0.0:631 indique que cupsd a ouvert sont port (631) sur ton ip publique (84.4.162.166 peut etre...).  
 
Verifie la conf de cups, tu dois avoir une section qui specifie l'ip sur laquelle ecouter. Désolé je n'ai pas cups d'installer :/
 
sinon essaye sur ton navigateur http://84.4.162.166:631 ... si ca marche c'est chaud :)


Message édité par syl94 le 02-05-2005 à 09:35:41
n°671530
korel
Posté le 02-05-2005 à 21:42:58  profilanswer
 

j'ai trouve une page sur la commande nmap et j'ai lançé ça:
nmap localhost
 
Starting nmap 3.81 ( http://www.insecure.org/nmap/ ) at 2005-05-02 21:36 CEST
Interesting ports on localhost (127.0.0.1):
(The 1662 ports scanned but not shown below are in state: closed)
PORT    STATE SERVICE
631/tcp open  ipp
 
Nmap finished: 1 IP address (1 host up) scanned in 0.257 seconds
 
si c'est mon port 631 qui est ouvert est ce je dois le fermer  
pour résoudre le pb?

n°671534
korel
Posté le 02-05-2005 à 21:51:23  profilanswer
 

sino dans la config de cups j'ai effectivement ça
# Listen to (Port/Listen)
#  
# Ports/addresses that are listened to.  The default port 631 is reserved
# for the Internet Printing Protocol (IPP) and is what is used here.
#  
# You can have multiple Port/Listen lines to listen to more than one
# port or address, or to restrict access.
#  
# Note: Unfortunately, most web browsers don't support TLS or HTTP Upgrades
# for encryption.  If you want to support web-based encryption you will
# probably need to listen on port 443 (the "HTTPS" port...).
#  
# ex: 631, myhost:80, 1.2.3.4:631
#
#    Port 80
#    Port 631
#    Listen hostname
#    Listen hostname:80
#    Listen hostname:631
#    Listen 1.2.3.4
#    Listen 1.2.3.4:631
#
#Port 631
 
Listen *:631
 
j'ai essayé de mettre un # devant listen -:631  
mais ça change rien

n°671538
syl94
Ni!
Posté le 02-05-2005 à 22:06:47  profilanswer
 

essaye de mettre  
 
Listen 127.0.0.1:631 puis relance cupsd via /etc/init.d puis via ton navigateur http://127.0.0.1:631
 
Si ca passe pas, test un acces via telnet 127.0.0.1 631
 
bizarre quand meme :/


Message édité par syl94 le 02-05-2005 à 22:06:55
n°671542
korel
Posté le 02-05-2005 à 22:28:03  profilanswer
 

http://127.0.0.1:631
m'envoie sur les docs de cups
 
# telnet 127.0.0.1 631
Trying 127.0.0.1...
Connected to 127.0.0.1.
Escape character is '^]'.
 
Connection closed by foreign host.
 
Ca commence a faire trop compliqué pour simple utilisateur
j'utilise mandrake depuis la 9.0 qui me satisfait completement pour toutes les utilisations dont j'ai besoin avec mon PC et je n'avait jamais rencontrer ce pb  

n°671546
korel
Posté le 02-05-2005 à 22:52:15  profilanswer
 

il y a du mieux:
http://127.0.0.1:10000/  
en root et webmin fonctionne

mood
Publicité
Posté le 02-05-2005 à 22:52:15  profilanswer
 

n°671567
syl94
Ni!
Posté le 02-05-2005 à 23:28:16  profilanswer
 

et pour tes autres applis  ? ksysguard,webhttrack .. ca fonctionne ? nmap est un excellent outil. Sans option, tu n'aura que les ports tcp. Pour avoir les ports UDP et TCP, utilise : nmap -v -sU -sT 127.0.0.1
 
Va te chercher un café et patiente car ce peut prendre du temps mais tu aura un apercu de TOUT les ports ouverts ou filtrés :) le -v c'est pour le mode verbeux. Tu peux eventuellement rediriger le résultat vers un fichier pour pouvoir le consulter plus facilement :nmap -v -sU -sT 127.0.0.1 > ~/nmap_localhost.txt

n°671573
korel
Posté le 02-05-2005 à 23:56:33  profilanswer
 

en fait webmin fonctionne avec
http://127.0.0.1:10000/
mais me remet le message Impossible de se connecter à l'hôte localhost (port 10000) avec
https://127.0.0.1:10000/
qui est normalement préconisé pour lancer webmin
les autres applis ne fonctionnent toujours pas .
 
  nmap -v -sU -sT 127.0.0.1
 
Starting nmap 3.81 ( http://www.insecure.org/nmap/ ) at 2005-05-02 23:57 CEST
Initiating UDP Scan against localhost (127.0.0.1) [1478 ports] at 23:57
The UDP Scan took 1.23s to scan 1478 total ports.
Initiating Connect() Scan against localhost (127.0.0.1) [1663 ports] at 23:57
Discovered open port 10000/tcp on 127.0.0.1
Discovered open port 631/tcp on 127.0.0.1
The Connect() Scan took 0.07s to scan 1663 total ports.
Host localhost (127.0.0.1) appears to be up ... good.
Interesting ports on localhost (127.0.0.1):
(The 3138 ports scanned but not shown below are in state: closed)
PORT      STATE         SERVICE
631/tcp   open          ipp
631/udp   open|filtered unknown
10000/tcp open          snet-sensor-mgmt
 
Nmap finished: 1 IP address (1 host up) scanned in 1.431 seconds
               Raw packets sent: 1481 (41.5KB) | Rcvd: 2958 (124KB)
 
 
il faudrait que je me trouve une doc sur le fonctionnement de Localhost
 
en tout cas maintenant je verrais ça demain soir
 

n°672797
korel
Posté le 04-05-2005 à 23:49:48  profilanswer
 

j'ai desinstallé mon firewall au cas ou..
mais ça change rien.


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs

  probleme connexion à localhost

 

Sujets relatifs
Problème redimensionnement partitionProbleme gdesklets
[Ubuntu] wifi+dhcp problemeconnexion bureau a distance sous mac os X
problème d'installation de squidguardprobleme install mandrake 10.1
Probleme pour l'installation de Debian[Debian] Vitesse de connexion eth0 - Pauses durant les transferts...
problème de lissage des polices [résolu] 
Plus de sujets relatifs à : probleme connexion à localhost


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR