Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
201 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs

  [MDK] 10.1 communauty install des drivers NVidia

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[MDK] 10.1 communauty install des drivers NVidia

n°570515
Lepcfou
Posté le 11-10-2004 à 21:35:11  profilanswer
 

Salut,
 
Alors j'essaye d'installer les drivers nvidia pour jouer à unreal 2004 par exemple
 
alors si j'installe ceux de NVidia, ça marche pas, il me dit qu'il doit compiler car il reconnait pas mon noyau puis aprés il fait un message d'erreur.
 
par contre sur le cd5 j'ai les drivers en .rpm
je me suis débrouillé pour les installés mais apparament ça ne fait rien, dans glxinfo c'est toujours vide
 
que dois-je faire ?
 
merci

mood
Publicité
Posté le 11-10-2004 à 21:35:11  profilanswer
 

n°570518
mikala
Souviens toi du 5 Novembre...
Posté le 11-10-2004 à 21:40:55  profilanswer
 

t'assurer qu'ils sont :
1) chargé
2) utilisé dans la conf de xorg

n°570519
Lepcfou
Posté le 11-10-2004 à 21:41:56  profilanswer
 

mikala a écrit :

t'assurer qu'ils sont :
1) chargé
2) utilisé dans la conf de xorg


 
merci de répondre !  
comment on fait pour s'assurer qu'ils sont chargés ?

n°570520
mikala
Souviens toi du 5 Novembre...
Posté le 11-10-2004 à 21:42:08  profilanswer
 

bon je ferme vu que tu poses ta question a plusieurs endroits :o

n°570521
mikala
Souviens toi du 5 Novembre...
Posté le 11-10-2004 à 21:42:20  profilanswer
 

lsmod | grep nvidia

n°570542
Lepcfou
Posté le 11-10-2004 à 22:06:23  profilanswer
 

[ludo@localhost ludo]$ lsmod | grep nvidia
bash: lsmod: command not found
[ludo@localhost ludo]$
 
commande not found !!
 
non mais les drivers ne sont pas installés en fait car j'ai une erreur pendant l'install, ça arrive pas à compilé ou un truc comme ça

n°570543
mikala
Souviens toi du 5 Novembre...
Posté le 11-10-2004 à 22:07:15  profilanswer
 

tu n'es pas sencé avoir installer les drivers disponibles sur le cd 5 ?

n°570544
Lepcfou
Posté le 11-10-2004 à 22:08:01  profilanswer
 

ha si c'est vrais ceux là oui je les ais installés

n°570547
Lepcfou
Posté le 11-10-2004 à 22:09:56  profilanswer
 

ha oui je viens de vérifier ils sont dans la liste des packages que je peux supprimer : j'ai nvidia-kernel-2.6.8.1-10mdksmp-6111-1mdk

n°570562
mikala
Souviens toi du 5 Novembre...
Posté le 11-10-2004 à 22:15:11  profilanswer
 

et ils correspondent a ton kernel ?
tu as un fait un modprobe nvidia ?
nvidia est bien précisé dans le fichier de conf de xorg ?

mood
Publicité
Posté le 11-10-2004 à 22:15:11  profilanswer
 

n°570571
Lepcfou
Posté le 11-10-2004 à 22:21:09  profilanswer
 

mikala a écrit :

et ils correspondent a ton kernel ?
tu as un fait un modprobe nvidia ?
nvidia est bien précisé dans le fichier de conf de xorg ?


 
oui ça correspond au kernel
 
Modprobe qu'est ce que c'est ?
 
si je précise nvidia dans le fichier conf de xorg, l'interface graphique ne se lance plus ! ( heureusement je connais le vi c'est comme ça que j'ai pu remettre nv )

n°570572
mikala
Souviens toi du 5 Novembre...
Posté le 11-10-2004 à 22:22:24  profilanswer
 

modprobe sert a charger en mémoire un module ici les drivers nvidia.


Message édité par mikala le 11-10-2004 à 22:23:13
n°570593
Lepcfou
Posté le 11-10-2004 à 22:35:39  profilanswer
 

oui je l'ai fais !!
dans le fichier /etc/modprobe.conf ( noyau 2.6 ). : j'ai rajouté  alias /dev/nvidia* nvidia :)
 
non mais j'ai l'impression que les drivers rpm ne marchent pas

n°570596
mikala
Souviens toi du 5 Novembre...
Posté le 11-10-2004 à 22:36:37  profilanswer
 

si tu fais modprobe nvidia .
tu as le module visible en faisant le lsmod | grep nvidia ?

n°570601
Lepcfou
Posté le 11-10-2004 à 22:43:37  profilanswer
 

mikala a écrit :

si tu fais modprobe nvidia .
tu as le module visible en faisant le lsmod | grep nvidia ?


 
ça a pas l'air de marcher. voilà ce que ça fait ( je sais pas si il faut être en root ou pas )
 
[ludo@localhost ludo]$ lsmod | grep nvidia
bash: lsmod: command not found
[ludo@localhost ludo]$ su
Password:
[root@localhost ludo]# lsmod | grep nvidia
[root@localhost ludo]# exit
exit

n°570606
mikala
Souviens toi du 5 Novembre...
Posté le 11-10-2004 à 22:46:20  profilanswer
 

il faut etre root , faire le modprobe nvidia et ensuite tu regardes si le module est bien chargé en mémoire .

n°570609
Lepcfou
Posté le 11-10-2004 à 22:47:18  profilanswer
 

c'est fait !
 
j'ai fait le modrpobe nvidia et ensuite le module n'est pas chargé en mémoire

n°570621
Lepcfou
Posté le 11-10-2004 à 23:18:01  profilanswer
 

en fait voila le message d'erreur que j'ai quand j'installe les drivers du site NVidia "unable to build Kernel module"

n°570629
Lepcfou
Posté le 11-10-2004 à 23:39:17  profilanswer
 

je pense que le probléme viens du Kernel !
mais je ne sais pas comment on change
 
Est-ce que quelqu'un peut m'expliquer comment passer au Kernel 2.4 svp ?

n°570641
Tomake
Posté le 12-10-2004 à 00:10:30  profilanswer
 

Je suppose que tu as mis les sources du kernel ??
Sinon tu as quoi comme noyau ??


Message édité par Tomake le 12-10-2004 à 00:14:07
n°570681
Lepcfou
Posté le 12-10-2004 à 04:54:30  profilanswer
 

2.6.8.1-10mdksmp
 
et oui j'ai installé kernel-source :)


Message édité par Lepcfou le 12-10-2004 à 04:55:44
n°570880
Lepcfou
Posté le 12-10-2004 à 13:06:35  profilanswer
 

j'ai trouvé !!
 
il faut utiliser ces drivers là http://www.sh.nu/download/nvidia/linux-2.6/
et ça marche :)

n°570887
JerryCrazy
Le plus crazy des crazy
Posté le 12-10-2004 à 13:14:15  profilanswer
 

sauf qu'on est quand même au 61.11 :whistle:


---------------
JerryCrazy - My Digital Life - Ferrovia.be - Jeux Linux
n°570910
Lepcfou
Posté le 12-10-2004 à 13:58:55  profilanswer
 

Alors là bizarre, j"ai installé les drivers, tout marchait j'ai méme pu jouer à ut2004, et ensuite j'ai rebooté et là ça marchait plus :/

n°570911
Dark_Schne​ider
Close the World, Open the Net
Posté le 12-10-2004 à 13:59:53  profilanswer
 

il faut patcher les drivers nvidia car ils ne sont pas compatibles avec le noyau 2.6.8


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°570912
jotenakis
Posté le 12-10-2004 à 14:00:54  profilanswer
 

pour ceux qui recompilent leur noyau voici un patch qui rend compatible les derniers binaires nvidia :  
http://ck.kolivas.org/patches/2.6/ [...] ompat.diff
 
c'est pour le 2.6.9-rc4 mais ça doit exister pour les autres...


---------------
Achetez du café zapatiste - CADTM
n°570920
Lepcfou
Posté le 12-10-2004 à 14:08:43  profilanswer
 

Dark_Schneider a écrit :

il faut patcher les drivers nvidia car ils ne sont pas compatibles avec le noyau 2.6.8


 
ok mais comment on fait svp ?

n°570927
Dark_Schne​ider
Close the World, Open the Net
Posté le 12-10-2004 à 14:14:45  profilanswer
 

cherche sur le net, c'est expliqué


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°570929
Lepcfou
Posté le 12-10-2004 à 14:19:35  profilanswer
 

Dark_Schneider a écrit :

cherche sur le net, c'est expliqué


 
je trouve pas  :cry:

n°570936
Dark_Schne​ider
Close the World, Open the Net
Posté le 12-10-2004 à 14:26:24  profilanswer
 

http://lkml.org/lkml/2004/8/20/209
http://linuxfr.org/forums/14/3277.html
http://qa.mandrakesoft.com/show_bug.cgi?id=11060
 
résultat d'un http://www.google.fr/linux?q=nvidi [...] ISO-8859-1


Message édité par Dark_Schneider le 12-10-2004 à 14:26:54

---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°570977
Lepcfou
Posté le 12-10-2004 à 15:00:36  profilanswer
 

merci ça marche maintenant

n°571063
foul
Amiga forever...
Posté le 12-10-2004 à 16:01:11  profilanswer
 

en parlant de driver nvidia, j'ai installé les Nforces sans prob ... par contre quand je lance le nvmixer sous nunux, il est par defaut en 5.1 et le son ne sort pas (je suis en 2.0) Je suis obligé à chaque fois de le relancer à chaque démarrage et de le re-configurer.
 
y'a un moyen que ca le fasse tout seul ?


Message édité par foul le 12-10-2004 à 16:01:47
mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs

  [MDK] 10.1 communauty install des drivers NVidia

 

Sujets relatifs
OpenGL + drivers nvidiaMdk 10 plantage! (fsck aussi!!) [Résolu]
[Resolu]Install de SuperKarambaDrivers audio sous linux
[reglé] [mdk 10] Mozilla, Firefox, Thunderbird : plantage automatique[Mdk 10] Carte Ethernet Echec
[mdk] Configuration et performances urpmiPas de son sous ma MDK 10.1
compilateur c++ sous MDK 
Plus de sujets relatifs à : [MDK] 10.1 communauty install des drivers NVidia


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR