Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1175 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  Postfix : configuration bonne, mais je ne recois aucun mail

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Postfix : configuration bonne, mais je ne recois aucun mail

n°594204
skylight
Made in France.
Posté le 21-11-2004 à 21:03:35  profilanswer
 

Hello,
 
J'essaie de me monter un petit serveur de mail sur mon powerbook G4 histoire d'eviter de jongler entre différents serveurs SMTP quand je suis en deplacement.
 
J'ai suivi à la lettre cette procédure :
http://www.labo-apple.com/fr/artic [...] anther-32/
 
Malheureusement, bien que postfix se lance
 

G4:/Users/laurent root# postfix start
postfix/postfix-script: starting the Postfix mail system


 
J'envoie 2 mails de test sur 2 boites mail différentes (dont moi meme), l'envoie se passe correctement dixit le logiciel de mail, mais je ne recois rien :/
 
Je vais faire un tour dans la "queue" de postfix
et je trouve ceci :  
 
 
(apparement le mail qui m'est destiné dans ma  boite)
 


G4:/private/var/spool/postfix/deferred/A root# cat A31F8EE960  
C/            541             277               1T
1101065964SMONMAIL@wanadoo.frAclient_name=localhostAclient_address=127.0.0.1A#message_origin=localhost[127.0.0.1]Ahelo_name=[127.0.0.1]Aprotocol_name=ESMTPOMONMAIL@wanadoo.frRMONMAIL@wanadoo.frM            818N2Received: from [127.0.0.1] (localhost [127.0.0.1])N/  by G4.local (Postfix) with ESMTP id A31F8EE960NC        for <MONMAIL@wanadoo.fr>; Sun, 21 Nov 2004 20:39:23 +0100 (CET)N0Mime-Version: 1.0 (Apple Message framework v619)NContent-Transfer-Encoding: 7bitN=Message-Id: <0B792856-3BF5-11D9-B1AD-000A95DA8B90@wanadoo.fr>N9Content-Type: text/plain; charset=US-ASCII; format=flowedNTo: Sky <MONMAIL@wanadoo.fr>N%From: Laurent <MONMAIL@wanadSubject: testN%Date: Sun, 21 Nov 2004 20:39:22 +0100NX-Mailer: Apple Mail (2.619)NNtestNXreMONMAIL@wanadoo.frEG4:/private/var/spool/postfix/deferred/A root#  


 
et un deuxieme (sur l'autre boite mail)
 


G4:/private/var/spool/postfix/deferred/D root# cat DCC2BEE96A  
C/            544             277               1T
1101065994SMONMAIL@wanadoo.frAclient_name=localhostAclient_address=127.0.0.1A#message_origin=localhost[127.0.0.1]Ahelo_name=[127.0.0.1]Aprotocol_name=ESMTPODESTINATAIRE@hotmail.comRDESTINATAIRE@hotmail.comM            821N2Received: from [127.0.0.1] (localhost [127.0.0.1])N/  by G4.local (Postfix) with ESMTP id DCC2BEE96ANC        for <DESTINATAIRE@hotmail.com>; Sun, 21 Nov 2004 20:39:54 +0100 (CET)N0Mime-Version: 1.0 (Apple Message framework v619)N!Content-Transfer-Encoding: base64N=Message-Id: <1E62823E-3BF5-11D9-B1AD-000A95DA8B90@wanadoo.fr>N;Content-Type: text/plain; charset=ISO-8859-1; format=flowedNTo: DESTINATAIRE@hotmail.comN%From: Laurent <MONMAIL@wanadoo.fr>NSubject: salutN%Date: Sun, 21 Nov 2004 20:39:54 +0100NX-Mailer: Apple Mail (2.619)NaOlo6Q==NXreMONMAIL@wanadoo.frEG4:/private/var/spool/postfix/deferred/D root#  
 


 
 
Une idée :??:
 
Voici ma configuration :  
 


G4:/var/log laurent$ postconf -n
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
debug_peer_level = 2
inet_interfaces = localhost
mail_owner = postfix
mailq_path = /usr/bin/mailq
manpage_directory = /usr/share/man
mydomain_fallback = localhost
mynetworks_style = host
newaliases_path = /usr/bin/newaliases
queue_directory = /private/var/spool/postfix
readme_directory = /usr/share/doc/postfix
sample_directory = /usr/share/doc/postfix/examples
sendmail_path = /usr/sbin/sendmail
setgid_group = postdrop
unknown_local_recipient_reject_code = 450
G4:/var/log laurent$  
 


 
Je vois pas ce qui cloche :/


Message édité par skylight le 22-11-2004 à 21:13:26
mood
Publicité
Posté le 21-11-2004 à 21:03:35  profilanswer
 

n°594481
skylight
Made in France.
Posté le 22-11-2004 à 15:47:22  profilanswer
 

up ! :(

n°594482
Tomate
Posté le 22-11-2004 à 15:48:13  profilanswer
 

c'est illisible :/


---------------
:: Light is Right ::
n°594487
skylight
Made in France.
Posté le 22-11-2004 à 15:58:41  profilanswer
 

un ptit mailq me dit que les mails ne sont pas partis car absence de NX..... Kezako ?

n°594609
skylight
Made in France.
Posté le 22-11-2004 à 19:07:25  profilanswer
 

uppe
 


G4:~ laurent$ mailq
-Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
A31F8EE960      541 Sun Nov 21 20:39:24  mfezfzeeam@wanadoo.fr
   (Name service error for name=wanadoo.fr type=MX: Host not found, try again)
                                         mfzefzefzezfz@wanadoo.fr
 
DCC2BEE96A      544 Sun Nov 21 20:39:54  mfzfzm@wanadoo.fr
  (Name service error for name=hotmail.com type=MX: Host not found, try again)
                                         zofzfzfzfzfl@hotmail.com
 
-- 1 Kbytes in 2 Requests.
G4:~ laurent$  
 


Message édité par skylight le 22-11-2004 à 21:12:51
n°594634
Tomate
Posté le 22-11-2004 à 19:59:28  profilanswer
 

tu peux utiliser les balises fixed stp ;)
car là on comprend rien


---------------
:: Light is Right ::
n°594657
void_ppc
Posté le 22-11-2004 à 21:13:32  profilanswer
 

skylight a écrit :

Hello,
 
J'essaie de me monter un petit serveur de mail sur mon powerbook G4 histoire d'eviter de jongler entre différents serveurs SMTP quand je suis en deplacement.
 


 
Déjà à partir de là ca ne marchera pas.
 
De plus en plus de serveurs smtp refusent les connexions depuis une ip d'un accès  "résidentiel" (ie adsl par ex), à cause des worms qui spamment et des serveurs mal configurés qui servent de relai.
 
Certains fait n'autorisent pas non plus la connexion vers un serveur smtp directement (télé2 ?)
 
Le mieux à faire c'est encore d'avoir un serveur de mail sur une ligne non résidentielle, avec authentification pour envoyer un message (login smtp donc)

n°594658
skylight
Made in France.
Posté le 22-11-2004 à 21:13:44  profilanswer
 

Euh ... [:autobot] c'est la meme chose....

n°594662
skylight
Made in France.
Posté le 22-11-2004 à 21:15:12  profilanswer
 

void_ppc a écrit :

Déjà à partir de là ca ne marchera pas.
 
De plus en plus de serveurs smtp refusent les connexions depuis une ip d'un accès  "résidentiel" (ie adsl par ex), à cause des worms qui spamment et des serveurs mal configurés qui servent de relai.
 
Certains fait n'autorisent pas non plus la connexion vers un serveur smtp directement (télé2 ?)
 
Le mieux à faire c'est encore d'avoir un serveur de mail sur une ligne non résidentielle, avec authentification pour envoyer un message (login smtp donc)

Ah bon c'est nouveau et ca vient de sortir :??: Jamais entendu parler de ca.

n°594665
void_ppc
Posté le 22-11-2004 à 21:21:24  profilanswer
 

skylight a écrit :

Ah bon c'est nouveau et ca vient de sortir :??: Jamais entendu parler de ca.


 
non, non, faut juste se renseigner :D
 
j'ai eu le problème il y a un moment, avec par ex le smtp du fai allemand t-online qui refuse les connexions de certaines "tranches" d'ip free.
 
Donc ca faisait qu'avec un smtp sur une connexion free le mail bouncait, mais une en utilisant le smtp de free plus de problèmes.
 
Ca arrive de plus en plus dans le but de lutter contre le spam.
 
Cherche un peu sur les newsgroups, tu verras que c'est pas si rare


Message édité par void_ppc le 22-11-2004 à 21:22:25
mood
Publicité
Posté le 22-11-2004 à 21:21:24  profilanswer
 

n°594667
void_ppc
Posté le 22-11-2004 à 21:24:05  profilanswer
 

Par exemple c'est expliqué chez aol :
 
http://postmaster.info.aol.com/errors/index.html

Citation :


AOL works with many ISPs to maintain lists of dynamic and residential IP addresses. Per our E-mail Guidelines, we do not accept mail from these addresses, as it is difficult to determine who is responsible for mail being generated by these IP's.


Message édité par void_ppc le 22-11-2004 à 21:24:28
n°594686
skylight
Made in France.
Posté le 22-11-2004 à 21:50:17  profilanswer
 

Mmmm... OK. Dommage... Surtout que j'ai pas les moyens de m'offrir un serveur juste pour mon petit plaisir personnel du SMTP perso :D :/

n°594688
void_ppc
Posté le 22-11-2004 à 21:56:08  profilanswer
 

skylight a écrit :

Mmmm... OK. Dommage... Surtout que j'ai pas les moyens de m'offrir un serveur juste pour mon petit plaisir personnel du SMTP perso :D :/


 
si tu as une ip fixe et possibilité de mettre un serveur mail, demande juste une authentication pour envoyer des mails à partir de n'importe où via ce serveur

n°594691
skylight
Made in France.
Posté le 22-11-2004 à 21:58:38  profilanswer
 

j'ai une ip fixe chez moi, mais bon ca m'interesse pas, le but étant d'avoir mon propre serveur SMTP sur mon portable, comme ca, dès que je suis connecté au net n'importe ou que ce soit, je pouvais envoyer des mails...
 
 
Et la demande pour pouvoir envoyer des mails depuis mon IP fixe, je dois la faire a mon FAI ?
Bizarre d'avoir recours a ce genre de pratiques.
 
Mais bon, je pense que ca n'a pas de rapport avec le problème que j'ai plus haut (cf mailq, et problèmes de NX ? kezako ? :D )

n°596282
void_ppc
Posté le 26-11-2004 à 12:46:17  profilanswer
 

skylight a écrit :

j'ai une ip fixe chez moi, mais bon ca m'interesse pas, le but étant d'avoir mon propre serveur SMTP sur mon portable, comme ca, dès que je suis connecté au net n'importe ou que ce soit, je pouvais envoyer des mails...


 
Pour les raisons que j'ai données plus haut, ca ne marchera pas partout.
 

skylight a écrit :


Et la demande pour pouvoir envoyer des mails depuis mon IP fixe, je dois la faire a mon FAI ?
Bizarre d'avoir recours a ce genre de pratiques.


 
S'il ne filtre pas les connexions cheztoi->autrepart:25 pas de problèmes. A ma connaissance seul télé2 fait cela
 

skylight a écrit :


Mais bon, je pense que ca n'a pas de rapport avec le problème que j'ai plus haut (cf mailq, et problèmes de NX ? kezako ? :D )


 
Tu as mis quoi dans /etc/resolv.conf ?


Message édité par void_ppc le 26-11-2004 à 12:47:48
n°596341
mikala
Souviens toi du 5 Novembre...
Posté le 26-11-2004 à 14:28:32  profilanswer
 

j'aurais plutôt dis dans /var/spool/postfix/etc/resolv.conf ;)

n°596358
Tomate
Posté le 26-11-2004 à 14:42:07  profilanswer
 

mikala a écrit :

j'aurais plutôt dis dans /var/spool/postfix/etc/resolv.conf ;)

certes mais autant que ce soit homogène, et postfix te le dis si les 2 fichiers ne sont pas identiques :)


---------------
:: Light is Right ::
n°596370
mikala
Souviens toi du 5 Novembre...
Posté le 26-11-2004 à 14:50:57  profilanswer
 

tomate a écrit :

certes mais autant que ce soit homogène, et postfix te le dis si les 2 fichiers ne sont pas identiques :)


je ne suis pas certain qu'il le dise systématiquement =]

n°596383
Tomate
Posté le 26-11-2004 à 15:00:34  profilanswer
 

mikala a écrit :

je ne suis pas certain qu'il le dise systématiquement =]

en tout cas il me l'a dit au moins une fois, et effectivement il avait raison [:god]


---------------
:: Light is Right ::

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  Postfix : configuration bonne, mais je ne recois aucun mail

 

Sujets relatifs
Utilisateur virtuel avec postfix[Squid] quelle configuration matérielle pour un squid dans un lycée ?
Postfix + Mysqlconfiguration de Pdf Generator sous samba
configuration minimale pour installer la freeboxConfiguration micro casque
Configuration du menu.lst pour installer Mandrake depuis mon HDD3 ordinateur et 3 client mail ...
Postfix et SASL [RESOLU] 
Plus de sujets relatifs à : Postfix : configuration bonne, mais je ne recois aucun mail


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR