Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
493 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  Installer un navigateur à jour sous Debian 6.0 (Squeeze) en 2017

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Installer un navigateur à jour sous Debian 6.0 (Squeeze) en 2017

n°1410689
felix158
glop glop
Posté le 29-11-2017 à 14:43:31  profilanswer
 

Bonjour,
 
j'ai un proche qui fonctionne sous Debian 6
Il a un système assez personnalisé, avec notamment une tonne de logiciels et différents claviers qu'on a eu du mal à installer (pour écrire en arabe littéraire, en grec ancien avec les "accents" bizarres, etc), et donc on veut à tout prix éviter d'avoir à réinstaller ou mettre à jour.
le seul problème : le navigateur intégré (Iceweasel / Firefox) est complètement dépassé.  
 
Question : comment installer une version à jour de Firefox sur sa machine ?
Je précise que je ne fait que transmettre sa question, je n'ai pas pour l'instant eu accès à sa machine, mais le gars (plutôt débrouillard d'ordinaire) me dit qu'il n'y arrive pas du tout.  
 
Avez vous des conseils que je puisse lui faire suivre ?
 
Merci d'avance à tous !

mood
Publicité
Posté le 29-11-2017 à 14:43:31  profilanswer
 

n°1410706
Mjules
Modérateur
Parle dans le vide
Posté le 29-11-2017 à 21:09:26  profilanswer
 

Squeeze, c'est pas tout récent donc ça élimine les backports officiels, et les trucs genre flatpak.

 

Le plus simple, c'est peut être de télécharger la dernière version de firefox directement depuis chez mozilla :
https://ftp.mozilla.org/pub/firefox/releases/57.0/

 

c'est une simple archive tar.
Il décompresse ça dans le dossier qui lui convient le mieux (perso c'est dans /home/mon_user/bin/firefox)

 

et ensuite dans le dossier, il peut lancer le programme via l'éxécutable firefox.

 

après, il peut créer un fichier .desktop pour qu'il apparaisse dans le menu, par exemple (j'ai rajouté une icone de firefox dans ~/images) :

 

[Desktop Entry]
Version=1.0
Name=Firefox
GenericName=Web Browser
Exec=/home/mon_user/bin/firefox/firefox %u
Icon=/home/mon_user/Images/mozicon128.png
Terminal=false
Type=Application
StartupWMClass=Firefox
MimeType=text/html;text/xml;application/xhtml+xml;application/xml;application/rss+xml;application/rdf+xml;x-scheme-handler/http;x-scheme-handler/https;
Categories=GTK;Network;WebBrowser;

  

après, plus qu'à le placer le fichier (ici firefox.desktop) dans ~/.local/share/applications  et le menu sera mis à jour.


Message édité par Mjules le 29-11-2017 à 21:10:33

---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°1410780
felix158
glop glop
Posté le 02-12-2017 à 10:54:52  profilanswer
 

Merci beaucoup pour ta réponse détaillée !
Je vais essayer de lui installer ça la semaine prochaine.

n°1410792
Priareos
Gruiiiiiik
Posté le 02-12-2017 à 18:26:21  profilanswer
 

/opt n'est pas justement fait pour ça?

n°1410903
felix158
glop glop
Posté le 05-12-2017 à 11:01:57  profilanswer
 

Priareos a écrit :

/opt n'est pas justement fait pour ça?


 
Ca marche comment /opt ?  
 

n°1410921
Mjules
Modérateur
Parle dans le vide
Posté le 05-12-2017 à 15:39:36  profilanswer
 

/opt est un emplacement généralement utilisé pour installer des logiciels non fournis par la distribution.
 
Perso, pour des softs comme firefox qui se mettent à jour fréquemment et étant donné que je suis le seul utilisateur de ma machine, je préfère les installer dans mon dossier utilisateur plutôt que de jouer avec les droits pour qu'il puisse se mettre à jour automatiquement.


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°1411576
felix158
glop glop
Posté le 19-12-2017 à 19:15:17  profilanswer
 

Bon, je galère à mort.
Je ne suis pas un linuxien, je ne comprends pas pourquoi il n'est pas possible de lancer un programme par un double clic... Mais bon
Voilà ce que ça donne dans le terminal :
En gras ce que je tape

 

"user@ordi:~$ cd firefox/
user@ordi:~/firefox$ ./firefox
XPCOMGlueLoad error for file /home/user/firefox/libmozgtk.so:
libgtk-3.so.0: cannot open shared object file: No such file or directory
Couldn't load XPCOM."

 


J'y suis depuis 15 minutes j'en peux déjà plus. C'est vraiment hyper frustrant pour les débutants de pas pouvoir simplement télécharger un truc et le lancer.


Message édité par felix158 le 19-12-2017 à 19:16:55
n°1411581
Mjules
Modérateur
Parle dans le vide
Posté le 19-12-2017 à 20:53:50  profilanswer
 

hmm, il te manque gtk3 et  debian 6 (squeeze) n'a pas cette bibliothèque (la première version est sortie quelques jours après cette version de debian).
 
Le firefox de mozilla nécessite cette bibliothèque depuis la v46, donc à moins de trouver une version compilée pour gtk2 ou le faire toi même (bonne chance), AMHA, c'est mort.


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°1411605
felix158
glop glop
Posté le 20-12-2017 à 09:12:28  profilanswer
 

Merci pour tes réponses
Un autre navigateur à jour ?
Sinon Firefox 45 ?

n°1412790
felix158
glop glop
Posté le 12-01-2018 à 10:24:32  profilanswer
 

Bon c'est vraiment galère. Je vais lui installer la dernière version de Debian la semaine prochaine.
 
L'idéal serait de pouvoir faire une mise à jour (pour lui garder ses claviers).
 
À moins que je puisse sauvegarder les claviers avant de formater et les remettre simplement dans Debian 9. Si vous savez comment faire ça, ça m'intéresse !

mood
Publicité
Posté le 12-01-2018 à 10:24:32  profilanswer
 

n°1412837
mirtouf
Light is right !
Posté le 12-01-2018 à 22:57:51  profilanswer
 

Tout est fichier texte pour la configuration donc il faut:
- trouver où ceux-ci sont situés
- s'assurer que les logiciels employés sont encore dans les dépôts ou trouver des alternatives
- lire les notes de version s'il faut au besoin modifier la configuration


---------------
-~- Libérez Datoune ! -~- Camarade, toi aussi rejoins le FLD pour que la flamme de la Révolution ne s'éteigne pas ! -~- A VENDRE -
n°1412844
j_c_p
Linux user
Posté le 13-01-2018 à 12:09:01  profilanswer
 

Et via wine ? (genre Firefox ou Chrome Windows)
Bon, c'est moins bien qu'une version Linux, mais si ça fonctionne bien, pourquoi pas.


Message édité par j_c_p le 13-01-2018 à 12:10:00
n°1414809
starlyte
Posté le 18-02-2018 à 19:41:45  profilanswer
 

J'ai installé FF 57 sur leQuiurky Linux de mon ami, quand mon PSU etait en panne, ( oops!) et franchement, c'est la galere, pour ceux qui utilise Firefox depuis des années, AMA. Il y a tous les addons qui vont pas, ils sont changés pour des autres, pas de tout aussi biens.
Beaucoup trop manque pour fairs ce que tu veut sur le 57. En plus ils ont sorti le 58 maintenant. Est ce que c'est mieux, ou aussi "improuvé" que le 57?
J'ai pas trop envie de l'installer sans avoir un copie de mon Firefox-54, mais si je fait comme ca, mon manageur des packets est perturbé!


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  Installer un navigateur à jour sous Debian 6.0 (Squeeze) en 2017

 

Sujets relatifs
GlusterFS et ZFS (Debian 9 Stretch)Impossible d'installer de nouveaux paquets
comment installer acestream sur lubuntu 17.10Installer Kali Linux par VirtualBox
debian sur imac[Debian 8] Nagios et Moodle
installer ubounetou sur mon grille painDebian 9 problème fichier source & dépots
Plus de sujets relatifs à : Installer un navigateur à jour sous Debian 6.0 (Squeeze) en 2017


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR