Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1399 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  Impossibilité d'installation OpenOffice :s

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Impossibilité d'installation OpenOffice :s

n°892104
trouble_fe​te
Posté le 04-03-2007 à 14:52:51  profilanswer
 

Bonjour, je n'arrive pas a installer OpenOffice sous Gentoo profil 2007.0 en ~amd64  :??:  
 
si quelqu'un peut m'aider ce serait sympa les gars  :)  
 

Citation :

/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.1/../../../../x86_64-pc-linux-gnu/bin/ld: obj/gcc/so/dll_main.o: relocation R_X86_64_32 against `stlp_std::_Atomic_swap_struct<1>::_S_swap_lock' can not be used when making a shared object; recompile with -fPIC
obj/gcc/so/dll_main.o: ne peut lire les symboles: Mauvaise valeur
collect2: ld a retourné 1 code d'état d'exécution
make: *** [obj/gcc/so/libstlport.so.5.1.0] Erreur 1
make: Leaving directory `/var/tmp/portage/dev-libs/STLport-5.1.0/work/STLport-5.1.0/build/lib'
 
!!! ERROR: dev-libs/STLport-5.1.0 failed.
Call stack:
  ebuild.sh, line 1614:   Called dyn_compile
  ebuild.sh, line 971:   Called qa_call 'src_compile'
  environment, line 3549:   Called src_compile
  STLport-5.1.0.ebuild, line 80:   Called die
 
!!! Compile failed
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/dev-libs/STLport-5.1.0/temp/build.log'.


 
Et encore merci d'avance car je ne vois pas quoi faire  :)

mood
Publicité
Posté le 04-03-2007 à 14:52:51  profilanswer
 

n°892109
Mjules
Modérateur
Parle dans le vide
Posté le 04-03-2007 à 15:07:20  profilanswer
 

je sais pas quelle version de OOo tu es en train de compiler mais la compilation en 64bits est encore loin d'être parfaite.


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°892110
trouble_fe​te
Posté le 04-03-2007 à 15:09:24  profilanswer
 

Citation :

ACCEPT_KEYWORDS="~amd64" emerge --pretend openoffice
 
These are the packages that would be merged, in order:
 
Calculating dependencies... done!
[ebuild  N    ] dev-libs/STLport-5.1.0  USE="-boost"
[ebuild  NS   ] sys-libs/db-4.3.29-r2  USE="tcl -bootstrap -doc -java -nocxx -test"
[ebuild  N    ] app-office/openoffice-2.1.0  USE="cairo cups dbus eds firefox gnome gstreamer gtk kde ldap pam -binfilter -branding -debug -java -odk -seamonkey -sound -webdav" LINGUAS="fr -af -ar -as_IN -be_BY -bg -bn -bs -ca -cs -cy -da -de -el -en -en_GB -en_US -en_ZA -es -et -fa -fi -gu_IN -he -hi_IN -hr -hu -it -ja -km -ko -lt -lv -mk -nb -nl -nn -nr -ns -or_IN -pa_IN -pl -pt -pt_BR -ru -rw -sh_YU -sk -sl -sr_CS -st -sv -sw_TZ -ta_IN -te_IN -tg -th -ti_ER -tn -tr -ts -ur_IN -ve -vi -xh -zh_CN -zh_TW -zu"


 
 :??:
 
Edit: oups j'ai oublié de préciser que c'est le paquet dev-libs/STLport-5.1.0 qui foire


Message édité par trouble_fete le 04-03-2007 à 15:10:57
n°892384
trouble_fe​te
Posté le 05-03-2007 à 15:39:39  profilanswer
 

:??:  help
 
Je ne comprends pas pourquoi OpenOffice n'existe pas dans la branche stable aussi
 
emerge openoffice
Calculating dependencies -
!!! All ebuilds that could satisfy "openoffice" have been masked.
!!! One of the following masked packages is required to complete your request:
- app-office/openoffice-2.1.0 (masked by: ~amd64 keyword)
- app-office/openoffice-2.0.4 (masked by: ~amd64 keyword)
 
For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
 
Est-ce que quelqu'un est parvenu a installer OpenOffice en ~amd64 please, que je suive ses précieux conseils  :??:  
 
 :sweat:

n°892395
trouble_fe​te
Posté le 05-03-2007 à 15:57:36  profilanswer
 

Je commence a me dire que j'aurais pas du me précipiter sur le stage 3 amd64, j'aurais du prendre un i686 générique, pas encore mur le 64 bits visiblement  :??:
 
C'est dommage  ...
 
je pense que je vais tout recompiler mais a partir d'un stage3 i686 cette fois  :cry: OpenOffice me manque et là je peux plus attendre une hypotétique solution  :??:  
 
Merci d'avoir essayé de m'aider

n°892442
trouble_fe​te
Posté le 05-03-2007 à 17:29:13  profilanswer
 

Bon j'ai trouvé un gros gros indice sur le net: OpenOffice ne compile PAS en 64 bits, il faut installer la version 32 bits et l'émulation 32 bits étant en dépendance elle s'installe automatiquement
 
ouf je pourrais garder ma Gentoo en 64 bits même si pleins de logiciels ont du etre installé en version 32 bits :??: heureusement grace au système d'émulation ils arrivent a tourner sur une Gentoo qui elle est en 64 bits  :sol:  
 
sauvé !

n°892466
Mjules
Modérateur
Parle dans le vide
Posté le 05-03-2007 à 18:33:20  profilanswer
 

Mjules a écrit :

je sais pas quelle version de OOo tu es en train de compiler mais la compilation en 64bits est encore loin d'être parfaite.

 

genre je te l'ai pas dit à la première réponse (et OOo compile en 64bits dans ses dernières versions)

Message cité 1 fois
Message édité par Mjules le 05-03-2007 à 18:33:27

---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°892472
trouble_fe​te
Posté le 05-03-2007 à 18:55:52  profilanswer
 

Mjules a écrit :

genre je te l'ai pas dit à la première réponse (et OOo compile en 64bits dans ses dernières versions)

 

Ah j'avais lu que OOo ne compilait pas du tout en 64 bits sur le net, faut dire c'est chaud pour avoir ce genre d'info  :??:

 

c'est là 2.1.0 que je n'arrive pas a "émerger" en 64 bits, enfin j'ai la 32 bits c'est déjà bien en attendant une solution pour compiler la 64 bits  :)

 

Merci a vous en tout cas  :)


Message édité par trouble_fete le 05-03-2007 à 18:56:10
n°892475
Mjules
Modérateur
Parle dans le vide
Posté le 05-03-2007 à 19:01:30  profilanswer
 

ça compile mais c'est encore très instable à l'utilisation. Une version utilisable devrait arriver pour la 2.2 ou plus vraisemblablement la 2.3.
c'est pas à jour mais ça donne quelques indications :
http://wiki.services.openoffice.or [...] C_EM64T%29


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°892476
Tom_
Posté le 05-03-2007 à 19:01:47  profilanswer
 

Perso j'ai une Gentoo ~amd64 et OpenOffice-2.1 a compilé sans aucun problème pourtant je n'ai rien fait de spécial. Et à l'usgae, je trouve qu'il marche plutôt bien.
 

trouble_fete a écrit :

Je commence a me dire que j'aurais pas du me précipiter sur le stage 3 amd64, j'aurais du prendre un i686 générique, pas encore mur le 64 bits visiblement  :??:


Ca marche vachement bien quand même une Gentoo en 64 bits. :) Moi j'ai quasiment aucun problème.


Message édité par Tom_ le 05-03-2007 à 19:03:16
mood
Publicité
Posté le 05-03-2007 à 19:01:47  profilanswer
 

n°892484
trouble_fe​te
Posté le 05-03-2007 à 19:10:47  profilanswer
 

Ok, dans quelques temps je devrais pouvoir avoir un OpenOffice qui se compile nickel en 64 bits
 
attention...Synchronisation des...heu, de Portage  :D  
 
emerge --sync  :sol:

n°893168
trouble_fe​te
Posté le 07-03-2007 à 13:27:09  profilanswer
 

Re !
Je viens de mettre a jour gcc en suivant le tutoriel officiel sur gentoo.org, avec gcc-4.1.2, et donc bien sur j'ai recompiler l'intégralité de ma Gentoo, résultat:
 
un peu plus de FPS dans glxgears (2000 contre 1750/1800 avant...) et ...
 
dev-libs/STLport-5.1.0 s'est parfaitement compilé ! j'en suis a OOo lui même là  :sol:  
yes !! j'aurais du mettre a jour gcc des le départ :D

n°893292
trouble_fe​te
Posté le 07-03-2007 à 18:18:56  profilanswer
 

Merde raté ça a foiré :??: sur OOo lui même cette fois...
 
Bon, je vais désoverclocker (  :D ) rebooter, et relancer la compil' mais sous X cette fois pour vous donner le message d'erreur précis...
 
enfin le message ne fait pas précis mais bon bref  :sweat:  
 
morceaux choisi:
 
raise_error(int, char const*)
 
ou encore:
 
ERROR: error 65280 Occured while making /var/tmp/portage/app-office/openoffice-2.1.0/work/ooo/build/OOE680_m6/desktop/source/deployment
 
 :??:


Message édité par trouble_fete le 07-03-2007 à 18:27:09
n°901408
trouble_fe​te
Posté le 08-04-2007 à 19:34:43  profilanswer
 

J'avais abadonné sur mon PC mais là après avoir changé carte mère et disque dur et réinstaller une nouvelle Gentoo amd64, jme suis dit tient je vais retenter la compil' d'OpenOffice et ça a marché  :??:  
 
voila donc c'est bon même si j'ai rien compris

n°903764
enfoiro
a nickname is just a nickname
Posté le 16-04-2007 à 13:38:21  profilanswer
 

une idée : l'overclock sauvage peut générer des erreurs matérielles et donc faire foirer ta compilation, et les erreurs peuvent être assez subtiles, donc difficiles à détecter

n°903767
trouble_fe​te
Posté le 16-04-2007 à 13:42:45  profilanswer
 

Salut enfoiro, en effet j'avais déjà eu des soucis de ce genre lié a l'o/c du coup là j'avais tout désoverclocké :)
 
ça me rappel ma 1ere install de Gentoo...(ce devait etre la 2005.1)  j'avais bien suivi le tuto officiel de gentoo.org et tout pas une erreur de ma part, et hop arrivé au bout de 5 heures de compilation de kde, le PC avait planté et le plus étonnant pour moi c'est que dans ma tty y avait un msg qui était très explicite sur le problème...(pourtant complètement freezé...) yavait CPU ds le msg d'erreur...
 
comme quoi c'est pas parce que ça tient 2 heure de compil' que ça en tiendra forcément plus :D étonnant toussa...
 
Edit: pour info le processeur qui m'avait tout planté au bout de 5 heure de compil' etait un Athlon XP 2700+ o/c de 2150 a 2340Mhz, bien refroidi...(un TBRED...)

Message cité 1 fois
Message édité par trouble_fete le 16-04-2007 à 13:45:32
n°903788
enfoiro
a nickname is just a nickname
Posté le 16-04-2007 à 14:52:11  profilanswer
 

trouble_fete a écrit :


comme quoi c'est pas parce que ça tient 2 heure de compil' que ça en tiendra forcément plus :D étonnant toussa...
 
Edit: pour info le processeur qui m'avait tout planté au bout de 5 heure de compil' etait un Athlon XP 2700+ o/c de 2150 a 2340Mhz, bien refroidi...(un TBRED...)


 
ouep, c'est le coté aléatoire des erreurs liées à l'overclock. La gentoo est reconnue pour sa capacité à détecter les overclockeurs fous  :lol:  
 
les derniers athlons xp avaient une marge d'o/c très faible, liée au fait que c'est une archi en fin de vie : au début, l'archi permet un o/c, ensuite les concepteurs poussent la fréquence au max... Avant de passer sur une nouvelle architecture plus efficace. D'ailleurs ton o/c était très modéré, cqfd :)

n°903790
trouble_fe​te
Posté le 16-04-2007 à 14:59:14  profilanswer
 

C'est clair, l'Athlon XP 2700+ TBRED m'avait totalement déçu  :pfff:


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  Impossibilité d'installation OpenOffice :s

 

Sujets relatifs
Installation des pilotes NVIDIA KUbuntu[Fedora Core 6]Installation du wifi
[linux] installation d'un périphérique usb avec udevproblème a l'installation de freebsd 6.2
installation mandriva 2007installation ntfs-3g [résolu]
Installation d'une carte Wifi Proxim chipset atheros sous LinuxLinux Mandriva 2007 PowerPack : problème installation
erreur a l'installation du kernel 2.6.20espace disque pour installation fedora 6
Plus de sujets relatifs à : Impossibilité d'installation OpenOffice :s


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR