Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
1033 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  [Apache/Debian] Mod SSL / Impossible a faire fonctionner...

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Apache/Debian] Mod SSL / Impossible a faire fonctionner...

n°968727
naeh
Posté le 24-10-2007 à 11:43:00  profilanswer
 

Salut tout le monde :)
 
je viens vous voir aujourd'hui pour un bug que je n'arrive pas a résoudre et malheusement je n'ai trouvé de réponses nul part :(
 
donc il s'agit d'apache2 et son module ssl sous un debian etch.
 
j'explique le contexte :
 
le serveur est hébergé chez moi, il est derriere une freebox, je fais pointer mon nom de domaine (naeh.info) dessus.
 
j'ai quelques vhosts qui fonctionnent très bien, jusqu'a ce que je décide de passer l'un d'entre eux en https  
 
donc ce que j'ai fait :
- a2enmod ssl
- création des .crt et .key en suivant des tutos sur le net
- modifi mon vhosts (et je pense que c'est la que ça plante !) en ajoutant les directives SSEngine on et les path vers .crt et .key
- ajout de Listen 443 dans ports.conf
 
en fait c'est pas vraiment un plantage mais une erreur dans les logs :

Code :
  1. [Wed Oct 24 11:17:36 2007] [error] (9)Bad file descriptor: apr_socket_accept: (client socket)


 
et bien sur le vhost en question est inaccessible en httpS et du coup tout tombe dans l'eau.
 
le probleme c'est que meme après avoir viré toutes ces modifs (jusqu'a désactiver mod_ssl) bah l'erreur persiste dans les logs d'apache :( (elle n y etait ps avant)
 
avez vous des idées ?
est-ce possible de faire cohabiter des sites en http et https sur le meme serveur, meme ip avec des vhosts ?
 
Merci par avance.


Message édité par naeh le 24-10-2007 à 11:46:11
mood
Publicité
Posté le 24-10-2007 à 11:43:00  profilanswer
 

n°970079
fdaniel
Have you got a 27B/6 ?
Posté le 26-10-2007 à 14:08:49  profilanswer
 

Ton message d'erreur est peut-être lié à ce bug :
 
http://issues.apache.org/bugzilla/ [...] i?id=42829
 
As-tu essayé de faire un arrêt complet d'Apache, en vérifiant avant de relancer que tous les processus étaient arrêtés ?
 
Pour le vhost qui ne fonctionne pas il faudrait que tu détailles plus la configuration mise en place (du moins si ça ne fonctionne toujours pas après l'A/R complet).


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  [Apache/Debian] Mod SSL / Impossible a faire fonctionner...

 

Sujets relatifs
[Apache] Démarrage KO : Unable to open logs[Debian] dpkg-buildpackage Erreur 63
debian, forcer l'installation d'un paquet "stable"[debian Etch] pas de resolution wide avec intel
Installation windows XP impossible (?)nut sous une debian 64
[RESOLU] [Apache] Horde + ReverseProxyEspace disque sur debian
Debian & Intel 2200BGImpossible de monter le lecteur ...
Plus de sujets relatifs à : [Apache/Debian] Mod SSL / Impossible a faire fonctionner...


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR