Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
1647 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  [résolu] Net snmp fonctionne sans fonctionner :o

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[résolu] Net snmp fonctionne sans fonctionner :o

n°1032932
de@thm@ste​r of hell
D.o.H pour les zintimeuh ^^
Posté le 13-04-2008 à 10:37:53  profilanswer
 

Salut a tous :)  :hello:  
 
désolé de poster ici, j'ai hésité entre le forum reseau.. mais c est vous que j'ai choisi :o ^^
 
voila j'ai un serveur Lamp avec Nagios et centreon que je test pour faire un tutoriel,
je voulais ajouter ma station de travail qui est sous Ubuntu 7.04  
 
donc j'ai installé avec le gestionnaire de paquet net-snmp.
 
il s'est installé, et se lance automatiquement au démarrage

ps aux |grep snmp
snmp      5375  0.0  0.3   7100  4004 ?        S    10:11   0:00 /usr/sbin/snmpd -Lsd -Lf /dev/null -u snmp -I -smux -p /var/run/snmpd.pid 127.0.0.1


 
 
dans le fichier de conf  /etc/snmp/snmpd.conf
j'ai mis ceci

syscontact d@d.d
syslocation Fr
com2sec Local       localhost      interne
com2sec LocalNet    192.168.1.0/24 public
group   RWGroup     v1             Local
group   ROGroup     v1             LocalNet
view    tout        included      .1
access  ROGroup     ""        v1          noauth exact tout none none
access  RWGroup     ""        v1          noauth exact tout tout none


 
 
normalement cela devrait fonctionner :o  et bien non :o
le test de plugin de nagios me dit

./check_centreon_snmp_remote_storage -H 192.168.1.10
ERROR:  No response from remote host '192.168.1.10'.


 
donc ca marche pas :/
 
 
par contre .. si j'arrete le client, et que je le relance comme ceci
snmpd -c /etc/snmpd/snmpd.conf
le monsieur se lance bien :)

/etc/snmp$ ps aux |grep snmp
root      7146  5.0  0.3   7300  4012 ?        S    10:32   0:00 snmpd -c /etc/snmpd/snmpd.conf


 
 
et la .. magie .. le plugin de nagios reçoit une réponse :)
 

./check_centreon_snmp_remote_storage -H 192.168.1.10
Disk CRITICAL - Real Memory TOTAL: 0.987 Go USED: 98% : 0.968 Go|size=1060171776o used=1039339520o;93540556800;98737254400


 
 
donc on peut dire que par défaut .. snmpd ne charge pas le fichier de config.
pourtant quand j'ouvre le fichier /etc/init.d/snmpd il y a bien ecrit que si l'option SNMPDRUN = yes alors il recharge le daemon en utilisant le fichier de conf.
 
par contre j'ai trouvé une autre petite chose..  
il ya un fichier /Etc/default/snmpd, quand je le supprime et que je relance le service /etc/init.d/snmpd et bien cela fonctionne aussi, il tient bien compte du fichier de conf.
alors je suis un peut perdu :/
comment ca se fait qu'il prenne pas compte du fichier de conf??  
est ce une bonne idée de supprimer le fichier de conf dans le dossier default?
(je pense pas mais bon [:ddr555])
je vous remercie :)


Message édité par de@thm@ster of hell le 13-04-2008 à 19:45:15
mood
Publicité
Posté le 13-04-2008 à 10:37:53  profilanswer
 

n°1033018
the_fireba​ll
Walk with knowledge wisely
Posté le 13-04-2008 à 18:11:36  profilanswer
 

je pense qu'avec la ligne suivante
 
/usr/sbin/snmpd -Lsd -Lf /dev/null -u snmp -I -smux -p /var/run/snmpd.pid 127.0.0.1
 
snmpd est bindé sur l'adresse 127.0.0.1 (vérifie avec netstat) donc quand toi tu cherches à y accéder par l'ip 192.168.1.10, ça ne fonctionne pas
 
Si c'est ça, il faut donc que tu trouves où est définie l'interface sur laquelle se binde snmpd (/etc/default/snmpd ou un truc du genre sur debian et dérivées)


---------------
Two thousand years of misery, of torture in my name, hypocrisy made paramount, paranoia the law, my name is called religion, sadistic, sacred whore.
n°1033034
black_lord
Modérateur
Truth speaks from peacefulness
Posté le 13-04-2008 à 19:39:40  profilanswer
 

c'est exactement ça :jap:


---------------
uptime is for lousy system administrators what Viagra is for impotent people - mes unixeries - github me
n°1033038
de@thm@ste​r of hell
D.o.H pour les zintimeuh ^^
Posté le 13-04-2008 à 19:44:48  profilanswer
 

^^ big michi :jap:
 
donc dans /etc/default/snmpd
on retrouve bien la ligne
# snmpd options (use syslog, close stdin/out/err).
SNMPDOPTS='-Lsd -Lf /dev/null -u snmp -I -smux -p /var/run/snmpd.pid 127.0.0.1'
 
sur le wiki de debian (je connaissais pas :) )
http://wiki.debian.org/SNMP
on apprends que par défaut snmp écoute sur toutes les interfaces et pour la fixer sur une interface on pouvait mettre son adresse
 
en modifiant en:
SNMPDOPTS='-Lsd -Lf /dev/null -u snmp -I -smux -p /var/run/snmpd.pid'
 
puis en redemarrant le service
ça marche impec ! :)
 
merci beaucoup !  

n°1160743
eni
Posté le 03-09-2009 à 15:53:23  profilanswer
 

edit : oups non rien en fait  :sweat:


Message édité par eni le 03-09-2009 à 16:23:15

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  [résolu] Net snmp fonctionne sans fonctionner :o

 

Sujets relatifs
[Résolu] Bootmenu avec 4 OSSaloperie de Windows: passage ext3 en fat16 [resolu]
[UBUNTU] L'économiseur d'écran ne se lance pas [RESOLU][Résolu]Probleme de connexion mysql avec php
[résolu]Suppression régulière de /var/tmp ?[resolu]
[RESOLU] SSH /etcscanner reconnu par Debian 4.0 ???? ( résolu )
plus aucune installation ne fonctionne ubuntu 7.10Activité anormale sur mon réseau (Résolu]
Plus de sujets relatifs à : [résolu] Net snmp fonctionne sans fonctionner :o


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR