Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
1576 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  scanner reconnu par Debian 4.0 ???? ( résolu )

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

scanner reconnu par Debian 4.0 ???? ( résolu )

n°1030233
sagamore
Posté le 06-04-2008 à 19:17:06  profilanswer
 

Bonjour.
Je jete l'éponge pour installer mon scanner Epson Perfection 1670.
J'y ai passé un temps trés long sans aucun succés.
Quel scanner s'installe sans probléme  ?
Je tourne sous Debian 4.0.
Merci.


Message édité par sagamore le 14-04-2008 à 23:06:25
mood
Publicité
Posté le 06-04-2008 à 19:17:06  profilanswer
 

n°1030234
sagamore
Posté le 06-04-2008 à 19:20:39  profilanswer
 

En USB s'il vous plait.
Merci.

n°1030237
o'gure
Modérateur
Multi grognon de B_L
Posté le 06-04-2008 à 19:23:12  profilanswer
 

Jette un goup d'oeil au projet SANE :
http://www.sane-project.org/sane-mfgs.html

 

Ton scanner est normalement supporté
http://www.sane-project.org/sane-mfgs.html#Z-EPSON
>> Good [:spamafote]

 

Si tu décrivais qu'est ce qui pose problème, ce que tu as fait, les messages d'erreurs, et ce que tu veux faire... on pourrait peut etre t'aider


Message édité par o'gure le 06-04-2008 à 19:26:24

---------------
Ton Antoine commence à me les briser menus !
n°1030350
sagamore
Posté le 07-04-2008 à 08:47:15  profilanswer
 


Merci de ta réponse.
J'ai déjà posté à ce sujet.
Le post est ci dessous.
 
http://forum.hardware.fr/hfr/OSAlt [...] 5568_1.htm
 
Et comme maintenant je suis à la retraite, j'ai un peu de temps à y consacrer.
 
Lorsque je lance : programme d'aquisition d'image Xsane il me répond :
 
Aucun périphérique disponible.
 
Merci d'avance.

n°1030364
sagamore
Posté le 07-04-2008 à 09:14:41  profilanswer
 

J'ai lancé sane-find-scanner et j'obtiens ça :
 
found USB scanner (vendor=0x04b8 [EPSON], product=0x011f [EPSON Scanner]) at libusb:005:002

n°1030476
j_c_p
Linux user
Posté le 07-04-2008 à 11:56:54  profilanswer
 

Bonjour,
 
déjà, le scanner est détecté (le contraire aurait été étonnant, vu que ce scanner est supporté), ensuite, c'est peut-être un souci de permission : tu es bien dans le grouper scanner pour pouvoir l'utiliser ?
 
Peut-être une régle udev à ajouter, mais comme je te le dis plus bas, je ne connais pas Debian sur ce point.
 
Tu as testé xsane via l'user root, pour voir s'il lance l'interface.
 
Sinon, j'ai un Epson 2400 chez moi, il fonctionne parfaitement (mais je ne suis pas sous Debian, je ne connais pas les subtilités de ta distribution).


Message édité par j_c_p le 07-04-2008 à 11:57:30
n°1030723
blackhawke​r
IWH and almost anywhere
Posté le 07-04-2008 à 23:09:11  profilanswer
 

j'ai le perfection 1200U sous ubuntu et c'est très bien reconnu par xsane


---------------
création de site - photo
n°1030727
sagamore
Posté le 08-04-2008 à 00:21:01  profilanswer
 

Bonjour.
 
J'ai suivi tout ce qui est indiqué dans le lien ci dessous.
 
http://blog.sietch-tabr.com/index. [...] ous-debian
 
Bien sur mon fichier binaire c'est ESFW30.BIN que j'ai mis dans /usr/share/sane/snapscan/
 
J'ai ensuite modifié le fichier /etc/sane.d/snapscan.conf sous vi afin de lui indiquer l'emplacement du firmware : pour cela j'ai rentré :
 
firmware /usr/share/sane/snapscan/ESFW30.bin
 
Ca donne ça.
 
#------------------------------ General -----------------------------------
 
# Change to the fully qualified filename of your firmware file, if
# firmware upload is needed by the scanner
 
 
 
 
 
 firmware /usr/share/sane/snapscan/ESFW30.BIN
 
# If not automatically found you may manually specify a device name.
 
# For USB scanners also specify bus=usb, e.g.
# /dev/usb/scanner0 bus=usb
 
# For SCSI scanners specify the generic device, e.g. /dev/sg0 on Linux.
# /dev/sg0
 
#---------------------------------------------------------------------------
# No changes should be necessary below this line
 
Ca ne marche pas. Toujours pas de scanner !
 
Merci de votre aide.

n°1031128
sagamore
Posté le 08-04-2008 à 20:57:40  profilanswer
 

Bonjour.
Je progresse petit à petit.
Car je tape en console :
$ scanimage -L
J'ai comme réponse :
Erreur d'ouverture du périphérique " snapscan:libusb:005:002 " / Argument invalide.
 
Ca veut dire quoi ?
 
Merci.
 

n°1031239
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 09-04-2008 à 09:09:36  profilanswer
 

Es-tu dans le group scanner, on insiste.
 
tape "id" et dit nous ce qui s'affiche.

mood
Publicité
Posté le 09-04-2008 à 09:09:36  profilanswer
 

n°1031243
sagamore
Posté le 09-04-2008 à 09:16:13  profilanswer
 


Bonjour.
Encore merci pour votre patience.
Dans la console ça donne ça :
 
daniel@debian:~$ id
uid=1000(daniel) gid=1000(daniel) groupes=20(dialout),24(cdrom),25(floppy),29(audio),44(video),46(plugdev),106(netdev),109(powerdev),110(scanner),1000(daniel)
 
Sous root, ça donne ça :
 
debian:/home/daniel# id
uid=0(root) gid=0(root) groupes=0(root)
debian:/home/daniel#
 
Merci encore.
 
@+

n°1031781
sagamore
Posté le 10-04-2008 à 10:13:10  profilanswer
 

Je tourne en rond.
Pourtant je suis sur de ne rien avoir oublié.
J'ai tapé id en console.
Dans scanner il y a 110 .
Ca veut dire quoi ?
Vous me le direz quoi.
 
Merci.
 
@+
 
PS : sinon le reste fonctionne bien, petit réseau WiFi ( avec un portable XP et un PC de jeux XP ), imprimante sur serveur WiFi, partage de connection internet.

n°1032455
sagamore
Posté le 11-04-2008 à 18:56:08  profilanswer
 

Bonjour.
Toujours sur le tas..........:-(

 

daniel@debian:~$ ls -l /etc/hotplug/usb
total 116
-rwxr-xr-x 1 root root    249 2007-01-23 15:13 libgphoto2
-rw-r--r-- 1 root root 107712 2007-12-14 18:02 libgphoto2.usermap

 

Merci.


Message édité par sagamore le 11-04-2008 à 18:57:09
n°1032484
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 11-04-2008 à 19:56:25  profilanswer
 

Tu as quel noyau ? Il s'agit d'un combo scanner/autre chose ?

n°1032502
sagamore
Posté le 11-04-2008 à 20:41:05  profilanswer
 

Bonjour.
Merci pour ta réponse.
Bon le scanner est un Epson Perfection 1670, donc pas un combo.
Pour le noyau.................je ne sais pas.
Lors de mes tentatives, j'ai un fichier " cassé ". J'ai essayé de le retrouver en utilisant le filtre. Mais voila, je n'y arrive pas non plus.
 
Merci.

n°1032513
sagamore
Posté le 11-04-2008 à 21:16:16  profilanswer
 

Bon le fichier cassé est réparé.
Pour le scanner.......................c'est une autre histoire.

n°1032518
sagamore
Posté le 11-04-2008 à 21:26:41  profilanswer
 

Noyau 2.6.18-6.k7

n°1033385
sagamore
Posté le 14-04-2008 à 22:52:48  profilanswer
 

Bonjour.
 
Ca y est, ça marche.
Je suis allé sur la page Ubuntu.fr
http://doc.ubuntu-fr.org:81//scanner_epson?redirect=1
Ils y disent :
Un script shell qui automatise l'installation du scanner epson Perfection 1670 est telechargable ici. Il reste à lancer "installation.sh"(double clic puis lancer ) et à confirmer l'installation
J'ai téléchargé le fichier epson_1670_photo.tar.gz
Une fois extrait, j'ai lancé le script.
Tout fonctionne parfaitement.


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  scanner reconnu par Debian 4.0 ???? ( résolu )

 

Sujets relatifs
Disque dur sata non vu par debianActivité anormale sur mon réseau (Résolu]
installation tomcat5 debian[Debian] Problème iptables et Nat
[Résolu]Réinitialiser KnetworManager[RESOLU] Pas de partition primaire : grave ?
[résolu] FreeBSD Probleme avec df[RESOLU] Monitoring avec WG511T [RESOLU]
[Résolu] Bind ne démarre pas tout seul[RESOLU] Paramétrage SAMBA : Accès refusé !
Plus de sujets relatifs à : scanner reconnu par Debian 4.0 ???? ( résolu )


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR