Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
2037 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  apache n'utilise pas le nom de domaine de postfix

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

apache n'utilise pas le nom de domaine de postfix

n°1001681
dams78
développateur
Posté le 14-01-2008 à 20:16:15  profilanswer
 

bonjour,
j'ai configurer mon apache il y a un certain temps, avec comme option que lors de l'envoi d'un mail,
l'expéditeur soit, webmaster@...-no-ip.org
maintenant que j'ai mon nom de domaine j'ai renseigné celui-ci dans postfix (ça marche niquel)
seulement je ne me rappel plus du fichier à modifier pour faire pareil avec apache (et je ne retrouve plus la doc sur le net)
 
donc si vous connaissez ce fichier ou alors mieux, un moyen d'ailler postfix et apache (avec la même variable hostname)
merci de votre aide


---------------
dam's (debianer), ma galerie Flickr
mood
Publicité
Posté le 14-01-2008 à 20:16:15  profilanswer
 

n°1001866
fighting_f​alcon
Posté le 15-01-2008 à 14:16:43  profilanswer
 

apache qui envoie un mail ??????????????????????????????
 
tu ne confonds pas un peu avec PHP ou consort ?
 
dans apache (/etc/apache2/apache2.conf, /etc/httpd/httpd.conf, /etc/apache/httpd.conf selon la version et la distrib), ce que tu peux configurer c'est le "ServerName" (le nom principal sous lequel devra répondre apache) et le "ServerAdmin" (l'adresse mail de l'administrateur, adresse affichée sur les pages d'erreur) ...

n°1001992
dams78
développateur
Posté le 15-01-2008 à 19:43:31  profilanswer
 

oui désolé je parlais de php


---------------
dam's (debianer), ma galerie Flickr
n°1002116
fighting_f​alcon
Posté le 16-01-2008 à 08:40:19  profilanswer
 

si debian, dans /etc/php5/apache2/php.ini, section mail function, tu as du bidouillé la variable sendmail_path pour lui passer un argument -F toto ou -f toto@chezmoi.fr
 
l'autre solution, tu laisses la variable sendmail_path dans la conf de PHP sans option -F ou -f est tu configures ton postfix pour faire de la réécriture d'adresse expéditeur :

Citation :


sender_canonical_maps = hash:/etc/postfix/canonical


dans /etc/postfix/main.cf
 
et

Citation :


www-data@tamachine.tondomaine     toto@cheztoi.fr


dans /etc/postfix/canonical
 
puis :

Code :
  1. postmap /etc/postfix/canonical (pour générer le fichier haché)
  2. /etc/init.d/postfix restart


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  apache n'utilise pas le nom de domaine de postfix

 

Sujets relatifs
Quel versions de PHP, Mysql et apache sous Redhat 5?[RESOLU] Apache : redirection vers un poste du LAN
[Apache] : les liens ne prennent pas en compte le ServerNameRéécriture de domaine et ajout de domaine avec sendmail.
[POSTFIX] Probleme de ConfigurationPostfix, envoyer un mail à l'exterieur sur le meme domaine
Rediriger mon postfix vers un autre serveur SMTPTomcat + Apache + Debian Etch: Howto Dispo
Ajout d'utilisateur par Apache 
Plus de sujets relatifs à : apache n'utilise pas le nom de domaine de postfix


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR