Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2088 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  Debian unstable Xorg 7.1 et matrox G400 = plus de X

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Debian unstable Xorg 7.1 et matrox G400 = plus de X

n°848135
FlamM
comme tarte flambée bien sûr !
Posté le 03-10-2006 à 15:44:33  profilanswer
 

J'ai fait un dist-upgrade de la mort (en gros j'avais pas mis à jour depuis près de 8 mois, c'est l'ordi de mes parents) et donc depuis que je suis passé de xorg 6.8.2 à xorg 7.1.0 je n'ai plus de X fonctionnel :
 
Il semble y avoir un gros problème dans le choix des modelines, parce que quand je lance X, j'obtiens un petit message de la part de mon écran m'indiquant que le mode utilisé est au delà de ses capacités.  
voilà la boite que m'affiche l'écran :

Signal d'invalidité  
82.0 KHz 102.0 Hz


 
pourtant je n'ai pas d'erreur dans mon Xorg.0.log les modes choisis semblent être dans plages valides des specs de l'écran.
 
J'ai essayé de forcer un modline avec des specs correctes mais il ne semble pas être pris en compte.
 

Code :
  1. Section "Device"
  2.         Identifier      "Matrox Graphics, Inc. Millennium G400"
  3.         Driver          "mga"
  4. EndSection
  5. Section "Monitor"
  6.         Identifier      "CTX:7053"
  7.         HorizSync       30-72
  8.         VertRefresh     50-130
  9.         Option          "DPMS"
  10.         ModeLine        "1024x768h" 78.80 1024 1040 1136 1312 768 769 772 800 +hsync  +vsync
  11. EndSection
  12. Section "Screen"
  13.         Identifier      "Default Screen"
  14.         Device          "Matrox Graphics, Inc. Millennium G400"
  15.         Monitor         "CTX:7053"
  16.         DefaultDepth    24
  17.         SubSection "Display"
  18.                 Depth           1
  19.                 Modes           "1024x768" "800x600" "640x480"
  20.         EndSubSection
  21.         SubSection "Display"
  22.                 Depth           4
  23.                 Modes           "1024x768" "800x600" "640x480"
  24.         EndSubSection
  25.         SubSection "Display"
  26.                 Depth           8
  27.                 Modes           "1024x768" "800x600" "640x480"
  28.         EndSubSection
  29.         SubSection "Display"
  30.                 Depth           15
  31.                 Modes           "1024x768" "800x600" "640x480"
  32.         EndSubSection
  33.         SubSection "Display"
  34.                 Depth           16
  35.                 Modes           "1024x768" "800x600" "640x480"
  36.         EndSubSection
  37.         SubSection "Display"
  38.                 Depth           24
  39.                 Modes           "1024x768" "800x600" "640x480"
  40.         EndSubSection
  41. EndSection


 
 
 
 
Du coup pour l'instant je suis obligé d'utiliser le pilote vesa, qui d'ailleurs ne veut pas afficher à plus de 800x600 alors que le modeline demandé par défaut est "1024x768".
 
pour info l'écran est un CTX VL700 reconnu comme un "CTX  Model: 5370" via les EDID par X
 
 
et voilà 2 liens vers  
http://flamms.free.fr/nimp/xorg.conf.mga
http://flamms.free.fr/nimp/Xorg.0.log
 
 
Et dans le cas où on n'arriverait pas à faire fonctionner xorg 7.1 y a un moyen de revenir à une version antérieure ?


Message édité par FlamM le 03-10-2006 à 16:46:37
mood
Publicité
Posté le 03-10-2006 à 15:44:33  profilanswer
 

n°848157
mirtouf
Light is right !
Posté le 03-10-2006 à 16:33:29  profilanswer
 

quelles erreurs ?


---------------
-~- Libérez Datoune ! -~- Camarade, toi aussi rejoins le FLD pour que la flamme de la Révolution ne s'éteigne pas ! -~- A VENDRE
n°848163
FlamM
comme tarte flambée bien sûr !
Posté le 03-10-2006 à 16:44:15  profilanswer
 

comment ça quelles erreurs ?
 
au niveau des logs tout est normal, me semble-t-il.

n°848164
wedgeant
Da penguin inside
Posté le 03-10-2006 à 16:45:34  profilanswer
 

FlamM a écrit :

comment ça quelles erreurs ?
 
au niveau des logs tout est normal, me semble-t-il.


 
L'erreur de ton écran ...  :whistle:

Citation :

j'obtiens un petit message de la part de mon écran m'indiquant que le mode utilisé est au delà de ses capacités.


Message édité par wedgeant le 03-10-2006 à 16:45:55

---------------
Wedge#2487 @HS -#- PW: +∞ -#- Khaz-Modan/Boltiz @WoW
n°848165
FlamM
comme tarte flambée bien sûr !
Posté le 03-10-2006 à 16:47:52  profilanswer
 

voilà le message d'erreur de l'écran  
 
c'est une boite similaire à l'OSD qui dit :
 

Signal d'invalidité
82.0 KHz   102 Hz


 
 
et 82 kHz c'est bien au delà de la limite de 72 kHz pour HorizSync indiquée dans les specs de l'écran et que j'ai renseignée correctement dans xorg.conf


Message édité par FlamM le 03-10-2006 à 16:50:15
n°848207
FlamM
comme tarte flambée bien sûr !
Posté le 03-10-2006 à 19:15:04  profilanswer
 

moralité je suis revenu en testing et avec xorg 7.0 et les mêmes fichiers de conf tout est rentré dans l'ordre.
 
faudra ptet que je fasse un rapport de bug.

n°851759
FlamM
comme tarte flambée bien sûr !
Posté le 15-10-2006 à 04:22:46  profilanswer
 

quelqu'un s'est chargé de faire le rapport de bug pour moi  
 
http://bugs.debian.org/cgi-bin/bug [...] bug=390739
 
par contre je ne peux pas tester si la version 1.4.2 du package, qui vient d'être uploadée dans unstable, résout le problème vu que je ne suis plus chez mes parents.
 
en espérant que ça puisse donner des tuyaux à certains vu le référencement de hfr dans google ;)


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  Debian unstable Xorg 7.1 et matrox G400 = plus de X

 

Sujets relatifs
xorg : je suis concé en 50Hz et 1024*768[RESOLU][DEBIAN] Deux sites sur Apache2 : problème de virtualhost.
carte wifi intel wireless pro 3945 ABG de toshiba U200-163 pour debianDebian/sarge a ni rien comprendre...
debian, client dhcp[Resolu] Récupérer des logins
[DEBIAN] installer apache2 php5 mysql5probleme avec nouveau portable toshiba U200-163 sous debian
PPTP sous debian sarge en kernel 2.6.18debian configurer le fichier sources.list
Plus de sujets relatifs à : Debian unstable Xorg 7.1 et matrox G400 = plus de X


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR