Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1029 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  Debian Sid 64 bits : Problème alsa-oss

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Debian Sid 64 bits : Problème alsa-oss

n°1116064
spydemon
Posté le 23-02-2009 à 19:52:11  profilanswer
 

Salut tout le monde :-)
 
Je voulais vous demandez votre avis face à un problème assez bizarre.
En effet quand je veux lancer alsa-oss (un programme qui sert à faire passer les flux oss d'un programme à travers alsa) j'ai une erreur :
 

Citation :

[19:34:15 >> spydemon@SP-WORKSTATION:~]$ aoss /opt/TeamSpeak2RC2/TeamSpeak
ERROR: ld.so: object '/usr/$LIB/libaoss.so' from LD_PRELOAD cannot be preloaded: ignored.


 
Il semblerait que le problème vienne du fait que j'utilise Debian en 64 bits, les paquets nécessaire à alsa-oss ne sont donc plus présent (ou du moins, pas au bon endroit)..
Ensuite je trouve ici : http://ubuntuforums.org/showthread.php?t=425327
Un paquet qui contient justement ces fichiers tant utile à alsa-oss  :D  Comme tout ceux qui le teste son ravis, je me dis que ça ne peu qu'être la solution  :sol:  Evidament, chez moi ça ne fonctionne pas, tout est encore exactement comme avant  :sweat:  
Je pense donc que aoss ne va toujours encore pas chercher son ld.so au bon endroit. Je ne sais pas trop ce que représente le $LIB dans l'adresse ou est sensé se trouver le fichier, mais si c'est un synonyme de lib qui est un lien symbolique vers lib64, ça expliquerait pas mal de chose car théoriquement, si le paquet contenant les fichiers 32 bits de aoss est bien consu, ceux si devraient êtres installé dans "lib32" or mon aoss n'y met pas le nez dedans..
 
Voila, voila, donc si quelqu'un de plus expérimenté que moi (ou pas  ;) ) a la soluce à mon ennuie, je suis prenneur !
 
Merci d'avance  :wahoo:  

mood
Publicité
Posté le 23-02-2009 à 19:52:11  profilanswer
 

n°1116067
Riot
Buy me a riot
Posté le 23-02-2009 à 20:05:38  profilanswer
 

Tu as installé ia32-libs ?


---------------
Be the one with the flames.
n°1116068
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 23-02-2009 à 20:09:35  profilanswer
 

Aie oui, le binaire teamspeak est en 32bits donc alsa-oss va chercher la lib dans /usr/lib32
 
Bon moi ce que je ferais:
Tu install alsa-oss.
Tu récupère le deb de alsa-oss 32bits et tu l'extrait (dpkg --extract)
Tu copie tout ce que tu as dans /usr/lib dans ce paquet vers /usr/lib32
 
=> enjoy :)

n°1116069
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 23-02-2009 à 20:10:32  profilanswer
 

Au passage teamspeak est dispo dans les paquets, je vois donc absolument pas pourquoi le tien est dans /opt
 
http://packages.debian.org/search?keywords=teamspeak

n°1116092
spydemon
Posté le 23-02-2009 à 21:19:38  profilanswer
 

Citation :

Tu as installé ia32-libs ?


Oui, ça m'a aidé pour pas mal de truc, mais la non.. Dommage  :sweat:  
 

Citation :

Bon moi ce que je ferais:
Tu install alsa-oss.
Tu récupère le deb de alsa-oss 32bits et tu l'extrait (dpkg --extract)
Tu copie tout ce que tu as dans /usr/lib dans ce paquet vers /usr/lib32


 
Ca ne marche toujours encore pas..  
Pourtant le dossier contient bien le .so qui fait sa loi :

SP-WORKSTATION:/home/spydemon/Desktop/alsa/usr/lib# ls
libalsatoss.a libalsatoss.so.0      libaoss.la    libaoss.so.0.0.0
libalsatoss.la libalsatoss.so.0.0.0  libaoss.so    libossredir.a
libalsatoss.so libaoss.a       libaoss.so.0  libossredir.la
SP-WORKSTATION:/home/spydemon/Desktop/alsa/usr/lib# cp * /usr/lib32/
SP-WORKSTATION:/home/spydemon/Desktop/alsa/usr/lib# cp * /usr/lib64/


Ouais, comme ou peu voir, j'ai aussi copié les fichiers dans lib64 au cas ou justement aoss allait chercher dans le dossier là, mais non plus..
 

Citation :

 Au passage teamspeak est dispo dans les paquets, je vois donc absolument pas pourquoi le tien est dans /opt
 
http://packages.debian.org/search?keywords=teamspeak


Oui j'avais déjà vu, mais comme je le trouvais pas avec apt-get j'ai préféré le prendre dirrectement sur le site. Du coup j'ai installer la version que tu m'as proposé par paquet, mais c'est toujours encore pareil.
 
Il n'y aurait pas un moyen de forcer aoss à chercher ces fichiers à des endroits précis ? Comme ça au moins, je serais ou copier tout ça  :lol:  
Merci d'avance :D

n°1116093
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 23-02-2009 à 21:27:01  profilanswer
 

Bah regarde /usr/bin/aoss c'est un simple script shell :D

n°1116099
spydemon
Posté le 23-02-2009 à 21:57:01  profilanswer
 

Merci M300A, j'ai réussi à changer :-)
Mais ça devient de plus en plus tordu :
 

[21:49:41 >> spydemon@SP-WORKSTATION:/usr/lib32]$ aoss /usr/bin/teamspeak  
ERROR: ld.so: object '/usr/lib32/libaoss.so' from LD_PRELOAD cannot be preloaded: ignored.
 
[21:49:49 >> spydemon@SP-WORKSTATION:/usr/lib32]$ ls | grep libaoss.so
libaoss.so
libaoss.so.0
libaoss.so.0.0.0


Je comprend pas trop.. Soit aoss ne sait plus lire, soit grep à des hallucinations, dans les deux cas c'est pourtant que peu probable  :pt1cable:  
 
Donc j'en déduis que aoss trouve quand même son libaoss.so, mais refuserais de le charger ?

n°1116138
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 24-02-2009 à 07:57:08  profilanswer
 

ldd /usr/lib32/libaoss.so.0 svp...

n°1116450
spydemon
Posté le 24-02-2009 à 17:25:31  profilanswer
 

[17:22:42 >> spydemon@SP-WORKSTATION:/usr/lib32]$ ldd libaoss.so.0
 linux-gate.so.1 =>  (0xf7f92000)
 libalsatoss.so.0 => /usr/lib/libalsatoss.so.0 (0xf7f70000)
 libc.so.6 => /lib32/libc.so.6 (0xf7e1e000)
 libasound.so.2 => /usr/lib32/libasound.so.2 (0xf7d5b000)
 libm.so.6 => /lib32/libm.so.6 (0xf7d37000)
 libdl.so.2 => /lib32/libdl.so.2 (0xf7d32000)
 libpthread.so.0 => /lib32/libpthread.so.0 (0xf7d1b000)
 /lib/ld-linux.so.2 (0xf7f93000)
 librt.so.1 => /lib32/librt.so.1 (0xf7d12000)


 
 
J'en déduis que je dois trouver linux-gate.so.1 et ld-linux.so.2 ?


Message édité par spydemon le 24-02-2009 à 17:26:19
n°1116905
spydemon
Posté le 25-02-2009 à 21:02:23  profilanswer
 

C'est possible que le problème vien de Teamspeak ?
 
Quand j'exécute amsn avec aoss, j'ai pas de problèmes :
 

[20:39:13 >> spydemon@SP-WORKSTATION:~]$ aoss amsn
Playing WAVE '/home/spydemon/.amsn/skins/Dark Matter/sounds/newemail.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo


Message édité par spydemon le 25-02-2009 à 21:02:52

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  Debian Sid 64 bits : Problème alsa-oss

 

Sujets relatifs
Problème de configuration DNSDebian Live plante au démarrage
Debian Etch n'utilise pas toute la RAM malgré une bonne détection BIOSBind9 logging "category security" = probleme.
problème partage connexion internet sous debianProbleme Installation FEDORA 10
[Problème RESOLUT]/dev/ttyS : permission denied sous linux[mandriva2009]probleme de login
Probleme de GRUB... 
Plus de sujets relatifs à : Debian Sid 64 bits : Problème alsa-oss


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR