Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
1655 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  squid très lent

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

squid très lent

n°952998
rkonan
Posté le 13-09-2007 à 02:16:56  profilanswer
 

Bonsoir à tous,
Je viens de terminer la config d'un serveur proxy sous debian etch pour le partage d'une connexion internet.
J'ai utilisé squid et squidGuard.
Mon soucis est que la connexion sur un poste client est très lent.
Voici un extrait de mes log ***** squidguard.log
 
2007-09-12 23:55:13 [3186] destblock local missing active content, set inactive
2007-09-12 23:55:13 [3186] init domainlist /var/lib/squidguard/db/adult/domains
2007-09-12 23:55:13 [3188] destblock good missing active content, set inactive
2007-09-12 23:55:13 [3185] destblock good missing active content, set inactive
2007-09-12 23:55:13 [3188] destblock local missing active content, set inactive
2007-09-12 23:55:13 [3185] destblock local missing active content, set inactive
2007-09-12 23:55:13 [3188] init domainlist /var/lib/squidguard/db/adult/domains
2007-09-12 23:55:13 [3185] init domainlist /var/lib/squidguard/db/adult/domains
2007-09-12 23:55:13 [3187] destblock local missing active content, set inactive
2007-09-12 23:55:13 [3187] init domainlist /var/lib/squidguard/db/adult/domains
2007-09-13 00:01:37 [3185] init urllist /var/lib/squidguard/db/adult/urls
2007-09-13 00:01:38 [3185] init expressionlist /var/lib/squidguard/db/adult/expressions
2007-09-13 00:01:38 [3185] init domainlist /var/lib/squidguard/db/agressif/domains
2007-09-13 00:01:38 [3185] init urllist /var/lib/squidguard/db/agressif/urls
2007-09-13 00:01:38 [3185] init expressionlist /var/lib/squidguard/db/agressif/expressions
2007-09-13 00:01:38 [3185] /var/lib/squidguard/db/agressif/expressions: Permission denied
2007-09-13 00:04:07 [3188] init urllist /var/lib/squidguard/db/adult/urls
2007-09-13 00:04:08 [3188] init expressionlist /var/lib/squidguard/db/adult/expressions
2007-09-13 00:04:08 [3188] init domainlist /var/lib/squidguard/db/agressif/domains
2007-09-13 00:04:08 [3188] init urllist /var/lib/squidguard/db/agressif/urls
2007-09-13 00:04:08 [3188] init expressionlist /var/lib/squidguard/db/agressif/expressions
2007-09-13 00:04:08 [3188] /var/lib/squidguard/db/agressif/expressions: Permission denied
 
Quelqu'un pourrait il me donner un coup de main.
Merci à tous

mood
Publicité
Posté le 13-09-2007 à 02:16:56  profilanswer
 

n°953002
black_lord
Modérateur
Truth speaks from peacefulness
Posté le 13-09-2007 à 05:43:33  profilanswer
 

problème de droits sur les fichiers


---------------
uptime is for lousy system administrators what Viagra is for impotent people - mes unixeries - github me
n°953053
rkonan
Posté le 13-09-2007 à 09:58:54  profilanswer
 

Ok merci c'est cool.
Mon fichier est bon sans erreur mais la lenteur demeure.

n°953055
boobaka
Posté le 13-09-2007 à 10:02:02  profilanswer
 

Possibilité de desactiver squidguard ?
Peut etre trop de parametres dans tes db de filtres...
++


Message édité par boobaka le 13-09-2007 à 11:13:34
n°953098
Taz
bisounours-codeur
Posté le 13-09-2007 à 12:34:03  profilanswer
 

nan. redonne nous des logs pour voir

n°953136
rkonan
Posté le 13-09-2007 à 14:54:45  profilanswer
 

proxy:~# tail -f /var/log/squid/squidGuard.log
2007-09-13 12:51:02 [4683] init domainlist /var/lib/squidguard/db/adult/domains
2007-09-13 12:51:02 [4680] destblock good missing active content, set inactive
2007-09-13 12:51:02 [4680] destblock local missing active content, set inactive
2007-09-13 12:51:02 [4680] init domainlist /var/lib/squidguard/db/adult/domains
2007-09-13 12:51:02 [4684] destblock good missing active content, set inactive
2007-09-13 12:51:02 [4684] destblock local missing active content, set inactive
2007-09-13 12:51:02 [4684] init domainlist /var/lib/squidguard/db/adult/domains
2007-09-13 12:51:02 [4685] destblock good missing active content, set inactive
2007-09-13 12:51:02 [4685] destblock local missing active content, set inactive
2007-09-13 12:51:02 [4685] init domainlist /var/lib/squidguard/db/adult/domains

n°953345
rkonan
Posté le 14-09-2007 à 09:00:01  profilanswer
 

Les choses vont de mieux en mieux.
Je veux de l'aide sur autre chose:
Comment faire pour avoir des logs sur le détail des heures de connexion des mes clients.
access.log ne me donne pas ce détail.
Merci

n°953753
rkonan
Posté le 15-09-2007 à 12:06:50  profilanswer
 

Quelqu'un pourrait me donner un coup de main sur le log des détail de connexion.
Merci

n°953760
o'gure
Modérateur
Multi grognon de B_L
Posté le 15-09-2007 à 12:23:25  profilanswer
 

l'heure est indiqué dans la ligne de log si tu n'as pas modifié le format. Normalement c'est le premier champ
http://wiki.squid-cache.org/SquidF [...] e217a4108b


---------------
Ton Antoine commence à me les briser menus !
n°953767
rkonan
Posté le 15-09-2007 à 12:28:35  profilanswer
 

Voici un morceau de mon access.log
1189844519.353    612 192.168.200.182 TCP_MISS/200 1562 GET http://ad.weblogy.net/advertpro/servlet/file? rkonan DIRECT/64.65.63.9 image/gif
1189844520.434   1662 192.168.200.182 TCP_MISS/200 858 GET http://logv1.xiti.com/hit.xiti? rkonan DIRECT/130.117.119.125 image/GIF
1189844520.484   1700 192.168.200.182 TCP_MISS/304 404 GET http://logp.hit-parade.com/logohp1.gif? rkonan DIRECT/194.98.19.242 -
1189844688.843   1257 192.168.200.150 TCP_MISS/200 2765 GET http://ad.weblogy.net/advertpro/se [...] /url/zone? rkonan DIRECT/64.65.63.9 text/html
1189844741.001   1231 192.168.200.171 TCP_MISS/200 2765 GET http://ad.weblogy.net/advertpro/se [...] /url/zone? akroma DIRECT/64.65.63.9 text/html
 

mood
Publicité
Posté le 15-09-2007 à 12:28:35  profilanswer
 

n°953769
o'gure
Modérateur
Multi grognon de B_L
Posté le 15-09-2007 à 12:35:17  profilanswer
 

t'as regardé mon lien ? :heink:
Le premier champ c'est le timestamp !


Message édité par o'gure le 15-09-2007 à 12:36:12

---------------
Ton Antoine commence à me les briser menus !
n°953775
rkonan
Posté le 15-09-2007 à 12:47:50  profilanswer
 

Excuse moi si je t'embête un peu,  
comment utilise t on le petit scrip perl  
 
! /usr/bin/perl -p
s/^\d+\.\d+/localtime $&/e;
 
En fait je l'execute et il ne me donne rien.
Je m'y prend mal certainement.

n°953778
o'gure
Modérateur
Multi grognon de B_L
Posté le 15-09-2007 à 12:56:34  profilanswer
 

[ o'gure@mano ~ ]
> cat access.log
1189844519.353    612 192.168.200.182 TCP_MISS/200 1562 GET http://ad.weblogy.net/advertpro/servlet/file? rkonan DIRECT/64.65.63.9 image/gif
1189844520.434   1662 192.168.200.182 TCP_MISS/200 858 GET http://logv1.xiti.com/hit.xiti? rkonan DIRECT/130.117.119.125 image/GIF
[ o'gure@mano ~ ]
> cat test.pl
#!/usr/bin/perl -p
s/^\d+\.\d+/localtime $&/e;
[ o'gure@mano ~ ]
> ./test.pl < access.log
Sat Sep 15 10:21:59 2007    612 192.168.200.182 TCP_MISS/200 1562 GET http://ad.weblogy.net/advertpro/servlet/file? rkonan DIRECT/64.65.63.9 image/gif
Sat Sep 15 10:22:00 2007   1662 192.168.200.182 TCP_MISS/200 858 GET http://logv1.xiti.com/hit.xiti? rkonan DIRECT/130.117.119.125 image/GIF


N'exécute pas bêtement le script. Essaye de le comprendre...

Message cité 1 fois
Message édité par o'gure le 29-08-2010 à 15:05:06

---------------
Ton Antoine commence à me les briser menus !
n°953811
P-Y
Posté le 15-09-2007 à 16:08:31  profilanswer
 

rkonan a écrit :

Excuse moi si je t'embête un peu,
comment utilise t on le petit scrip perl

 

! /usr/bin/perl -p
s/^\d+\.\d+/localtime $&/e;

 

En fait je l'execute et il ne me donne rien.
Je m'y prend mal certainement.


Dans le fichier il te faut un # devant le ! en premiere ligne, c'est ce qu'on appelle le shebang et ca indique avec quel programme le script doit etre interprete.

 
o'gure a écrit :

[ ogure@mano ~ ]
> cat access.log
1189844519.353    612 192.168.200.182 TCP_MISS/200 1562 GET http://ad.weblogy.net/advertpro/servlet/file? rkonan DIRECT/64.65.63.9 image/gif
1189844520.434   1662 192.168.200.182 TCP_MISS/200 858 GET http://logv1.xiti.com/hit.xiti? rkonan DIRECT/130.117.119.125 image/GIF
[ ogure@mano ~ ]
> cat test.pl
#!/usr/bin/perl -p
s/^\d+\.\d+/localtime $&/e;
[ ogure@mano ~ ]
> ./test.pl < access.log
Sat Sep 15 10:21:59 2007    612 192.168.200.182 TCP_MISS/200 1562 GET http://ad.weblogy.net/advertpro/servlet/file? rkonan DIRECT/64.65.63.9 image/gif
Sat Sep 15 10:22:00 2007   1662 192.168.200.182 TCP_MISS/200 858 GET http://logv1.xiti.com/hit.xiti? rkonan DIRECT/130.117.119.125 image/GIF


N'exécute pas bêtement le script. Essaye de le comprendre...


En meme temps quand t'as jamais fait de Perl, c'est pas ce qu'il ya de plus intuitif a comprendre...


Message édité par o'gure le 15-12-2010 à 19:24:05
n°953863
o'gure
Modérateur
Multi grognon de B_L
Posté le 15-09-2007 à 19:57:57  profilanswer
 

Je dis pas le contraire, je dis qu'exécuter un script sur internet pour obtenir quelque chose c'est bien, le comprendre c'est mieux [:spamafote]


---------------
Ton Antoine commence à me les briser menus !

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  squid très lent

 

Sujets relatifs
[UBUNTU] Demarrage excessivement lent sur un Amilo V7010Proxy Squid avec authentification AD
Alerte Squid httpReadReply: Excess data from[squid] cacher des objets gros ???
|squid - iwss] Zero Sized ReplySQUID + VHOSTS : Problème d'accès...
SQUID + LDAP sur Debian EtchReverse proxy Squid
squid, utilisateurs ou ip sans restrictionsInstallation Squid 2.6 stable 13
Plus de sujets relatifs à : squid très lent


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR