Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
1831 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  Proxy Squid avec authentification AD

 



 Mot :   Pseudo :  
 
 Page :   1  2
Page Précédente
Auteur Sujet :

Proxy Squid avec authentification AD

n°947553
Zboss
Si tu doutes, reboot...
Posté le 28-08-2007 à 10:18:23  profilanswer
 

Bonjour à tous  :hello:  
 
  Je suis en train de suivre ce guide qui est pas mal fait, et qui concerne la mise en place d'un proxy Squid avec Authentification AD et logs par utilisateurs : http://www.apt-rtfm.info/index.php/archives/23 .
 
Appelons mon domaine "domaine.machin.com", et mon serveur AD sous Windows 2003 Server "SRV2003".
En me basant sur le guide, j'obtiens un fichier "krb5.conf" comme ci-dessous :
 

Code :
  1. [libdefaults]
  2.         default_realm = DOMAINE.MACHIN.COM.LOCAL
  3.         clock_skew = 300
  4.         ticket_lifetime = 24000
  5.         default_tkt_enctypes = des3-hmac-sha1 des-cbc-crc
  6.         default_tgs_enctypes = des3-hmac-sha1 des-cbc-crc
  7.         dns_lookup_realm = false
  8.         dns_lookup_kdc = true
  9. [realms]
  10.         DOMAINE.MACHIN.COM.LOCAL = {
  11.                 kdc = SRV2003.domaine.machin.com
  12.                 admin_server = SRV2003
  13.                 default_domain = DOMAINE.MACHIN.COM.LOCAL
  14.                 }
  15. [domain_realm]
  16.         .domaine.machin.com = DOMAINE.MACHIN.COM
  17.         domaine.machin.com = DOMAINE.MACHIN.COM


 
Jusque là tout va bien, je peux faire "kinit un_user@DOMAINE.MACHIN.COM", et ça fonctionne.
 
La suite du tutorial explique donc comment configurer samba, et j'ai donc le fichier "smb.conf" comme suit :
 

Code :
  1. [global]
  2.    workgroup = domaine.machin.com
  3.    realm = DOMAINE.MACHIN.COM.LOCAL
  4.    security = ads
  5.    encrypt passwords = yes
  6.    password server = SRV2003.domaine.machin.com.local
  7.    idmap uid = 10000-20000
  8.    idmap gid = 10000-20000
  9.    winbind enum groups = yes
  10.    winbind enum users = yes
  11.    winbind use default domain = yes


 
Mais lorsque j'essaye de rejoindre le domaine par "net join -U administrateur", j'obtiens les lignes suivantes :
 

Code :
  1. [2007/08/28 10:16:47, 0] utils/net_ads.c:ads_startup(289)
  2.   ads_connect: Aucun fichier ou répertoire de ce type
  3. ADS join did not work, falling back to RPC...
  4. Joined domain DOMAINE.GIE.COM.


 
Et à partir de là je suis perdu. Je pense que ce n'est pas grand chose, mais je n'arrive pas à trouver où se situe l'erreur. Donc si vous voyez une erreur dans mes fichiers "krb5.conf" ou "smb.conf", ou si l'erreur est tout autre, merci de me l'indiquer  :jap: .
 
Merci de m'avoir lu jusque là  :hello: .
 


---------------
Mario Kart for Ever
mood
Publicité
Posté le 28-08-2007 à 10:18:23  profilanswer
 

n°947567
boobaka
Posté le 28-08-2007 à 11:15:04  profilanswer
 

Salut,
au niveau de ton krb5.conf tu n'as pas mis de zone de log?

Code :
  1. logging]
  2.    default = FILE:/var/log/krb5libs.log
  3.    kdc = FILE:/var/log/krb5kdc.log
  4.    admin_server = FILE:/var/log/ksadmind.log


 te permettant de trouver la provenance de ton soucis?
 
sinon que te donne un  

Citation :

kinit administrateur@tondomaine


 
Tente pour rejoindre ton domaine un :

Citation :

net ads join -U administrateur@tondomaine


 
 
++


Message édité par boobaka le 28-08-2007 à 11:18:29

---------------
www.google.fr  
n°947597
Zboss
Si tu doutes, reboot...
Posté le 28-08-2007 à 12:21:45  profilanswer
 

Citation :

Salut,
au niveau de ton krb5.conf tu n'as pas mis de zone de log?


 
Je vais faire ça tout de suite.
 

Citation :

kinit administrateur@tondomaine


 
FRKPAP02:~# kinit administrateur@DOMAINE.MACHIN.COM
kinit(v5): KDC has no support for encryption type while getting initial credentials
 
Avec mon login utilisateur :
 
FRKPAP02:~# kinit mon_login@DOMAINE.MACHIN.COM
Password for mon_login@DOMAINE.MACHIN.COM:
 
FRKPAP02:~# klist
Ticket cache: FILE:/tmp/krb5cc_0
Default principal: mon_login@DOMAINE.MACHIN.COM
 
Valid starting     Expires            Service principal
08/28/07 12:19:19  08/28/07 18:59:19  krbtgt/DOMAINE.MACHIN.COM@DOMAINE.MACHIN.COM
 
 
Kerberos 4 ticket cache: /tmp/tkt0
klist: You have no tickets cached
 
 

Citation :

net ads join -U administrateur@tondomaine


 
FRKPAP02:~# net ads join -U administrateur@DOMAINE.MACHIN.COM
administrateur@DOMAINE.MACHIN.COM's password:
[2007/08/28 12:21:14, 0] utils/net_ads.c:ads_startup(289)
  ads_connect: Aucun fichier ou répertoire de ce type
 
 
Même plus de "Joined domain DOMAINE.MACHIN.COM." à la fin avec "ads" en plus.
 


---------------
Mario Kart for Ever
n°947631
boobaka
Posté le 28-08-2007 à 14:06:18  profilanswer
 

Je te propose ce lien
 
 


---------------
www.google.fr  
n°947679
Zboss
Si tu doutes, reboot...
Posté le 28-08-2007 à 15:33:55  profilanswer
 

J'ai un peu avancé, en modifiant les fichiers krb5.conf et smb.conf, en écrivant à chaque fois le domaine en majuscules, et en enlevant les ".local". J'arrive maintenant à ça :
 

Code :
  1. MON_PROXY:/var# net join -U mon_login
  2. mon_login's password:
  3. Using short domain name -- domaine.machin.com
  4. Failed to set servicePrincipalNames. Please ensure that
  5. the DNS domain of this server matches the AD domain,
  6. Or rejoin with using Domain Admin credentials.
  7. Disabled account for 'MON_PROXY' in realm 'DOMAINE.MACHIN.COM'
  8. ADS join did not work, falling back to RPC...
  9. Joined domain DOMAINE.MACHIN.COM.


 
Erreur un peu différente que d'habitude, sauf que là :  
 

Code :
  1. MON_PROXY:/var# net ads testjoin
  2. Join is OK


 
Ce qui ne fonctionnait pas avant.
De même, je peux voir la liste des groupes et des utilisateurs du domaine, avec les commandes wbinfo -g et wbinfo -u.
 
Donc je peux en déduire que ça fonctionne ?  :??:  
 
Autre question, au niveau des log, bien qu'ayant rajouté les lignes indiquées plus haut, les fichiers ne sont pas créés, il faut faire qqch d'autre pour activer les logs ? (pas trop l'habitude de Linux, donc ma question est probablement bête ?  :??: )


---------------
Mario Kart for Ever
n°947729
Zboss
Si tu doutes, reboot...
Posté le 28-08-2007 à 17:26:53  profilanswer
 

On avance, j'ai installé et configuré Squid. Maintenant, lorsque je tente d'accès à Internet depuis un poste relié au domaine, j'obtiens :
 

Code :
  1. [2007/08/28 17:24:53, 0] utils/ntlm_auth.c:winbind_pw_check(429)
  2.   Login for user [DOMAINE.MACHIN.COM]\[mon_login]@[mon_PC] failed due to [winbind client not authorized to use winbindd_pam_auth_crap.
  3. Ensure permissions on /var/run/samba/winbindd_privileged are set correctly.]
  4. [2007/08/28 17:24:53, 0] utils/ntlm_auth.c:manage_squid_ntlmssp_request(603)
  5.   NTLMSSP BH: NT_STATUS_ACCESS_DENIED
  6. 2007/08/28 17:24:53| authenticateNTLMHandleReply: Error validating user via NTLM. Error returned 'BH NT_STATUS_ACCESS_DENIED'


 
Et une fenêtre me demadant un login et un mot de passe s'ouvre.

Message cité 1 fois
Message édité par Zboss le 28-08-2007 à 17:27:41

---------------
Mario Kart for Ever
n°947733
boobaka
Posté le 28-08-2007 à 17:40:57  profilanswer
 

Par defaut squid refuse toutes les connections... Peut etre faut il lui specifier quel compte est autoriser à acceder à Internet.
++


---------------
www.google.fr  
n°947739
Zboss
Si tu doutes, reboot...
Posté le 28-08-2007 à 17:48:48  profilanswer
 

Voici ce que m'affiche IE :
 

Code :
  1. ERROR
  2. Cache Access Denied
  3. --------------------------------------------------------------------------------
  4. While trying to retrieve the URL: http://www.google.fr/
  5. The following error was encountered:
  6. Cache Access Denied.
  7. Sorry, you are not currently allowed to request:
  8.     http://www.google.fr/from this cache until you have authenticated yourself.
  9. You need to use Netscape version 2.0 or greater, or Microsoft Internet Explorer 3.0,
  10. or an HTTP/1.1 compliant browser for this to work. Please contact the cache administrator
  11. if you have difficulties authenticating yourself or change your default password.
  12. --------------------------------------------------------------------------------
  13. Generated Tue, 28 Aug 2007 15:46:00 GMT by FRKPAP02 (squid/2.6.STABLE5)


 
Il y a donc encore probablement un gros problème avec l'authentification.  :sweat:


Message édité par Zboss le 28-08-2007 à 17:49:05

---------------
Mario Kart for Ever
n°947749
Hub_qc
Posté le 28-08-2007 à 18:19:29  profilanswer
 

Zboss a écrit :

On avance, j'ai installé et configuré Squid. Maintenant, lorsque je tente d'accès à Internet depuis un poste relié au domaine, j'obtiens :
 

Code :
  1. [2007/08/28 17:24:53, 0] utils/ntlm_auth.c:winbind_pw_check(429)
  2.   Login for user [DOMAINE.MACHIN.COM]\[mon_login]@[mon_PC] failed due to [winbind client not authorized to use winbindd_pam_auth_crap.
  3. Ensure permissions on /var/run/samba/winbindd_privileged are set correctly.]
  4. [2007/08/28 17:24:53, 0] utils/ntlm_auth.c:manage_squid_ntlmssp_request(603)
  5.   NTLMSSP BH: NT_STATUS_ACCESS_DENIED
  6. 2007/08/28 17:24:53| authenticateNTLMHandleReply: Error validating user via NTLM. Error returned 'BH NT_STATUS_ACCESS_DENIED'


 
Et une fenêtre me demadant un login et un mot de passe s'ouvre.


 
Les droits sur le répertoire suivant doivent être modifier:
 
chmod 750 /var/db/samba/winbindd_privileged
chgrp squid /var/db/samba/winbindd_privileged

 
(sur ta distribution c'est probablement /var/run/samba/winbindd_privileged)
 
Avant d'essayer de joindre ton serveur squid a ton domaine 2K3, es-ce que l'heure était synchro avec le domaine? Sinon c'était peut-etre la source de tes problèmes.
 
ntpdate toncontroleurdedomaine
 
Es-ce que ton module NTLM fonctionne?
 
/usr/local/bin/ntlm_auth –helper-protocol=squid-2.5-basic
usager <mot_de_passe>

n°947751
Zboss
Si tu doutes, reboot...
Posté le 28-08-2007 à 18:23:15  profilanswer
 

Merci pour ton aide, l'erreur venait tout simplement d'un problème dans les lignes "auth_param" à copier dans le squid.conf.
 
Maintenant je suis à l'étape suivante, installation et configuration de SARG, pour avoir des statistiques détaillées par utilisateurs. Mais après avoir fait un "apt-get install sarg", je ne trouve nulle trace de SARG nulle part  :??: .


---------------
Mario Kart for Ever
mood
Publicité
Posté le 28-08-2007 à 18:23:15  profilanswer
 

n°947762
Hub_qc
Posté le 28-08-2007 à 18:57:45  profilanswer
 

Zboss a écrit :

Merci pour ton aide, l'erreur venait tout simplement d'un problème dans les lignes "auth_param" à copier dans le squid.conf.
 
Maintenant je suis à l'étape suivante, installation et configuration de SARG, pour avoir des statistiques détaillées par utilisateurs. Mais après avoir fait un "apt-get install sarg", je ne trouve nulle trace de SARG nulle part  :??: .


 
Ta essayé par Webmin?

n°947766
Zboss
Si tu doutes, reboot...
Posté le 28-08-2007 à 19:21:43  profilanswer
 

J'ai pas installé Webmin encore, et je me demande d'ailleurs si il ne va pas foutre la merde avec toute mes histoires d'authentification. C'est pas déconseillé Webmin dans ce cas là ?


---------------
Mario Kart for Ever
n°947770
Hub_qc
Posté le 28-08-2007 à 19:40:49  profilanswer
 

Zboss a écrit :

J'ai pas installé Webmin encore, et je me demande d'ailleurs si il ne va pas foutre la merde avec toute mes histoires d'authentification. C'est pas déconseillé Webmin dans ce cas là ?


 
Présentement ce que j'ai d'installé sur deux serveurs dans deux domaines différents:
 
OS: FreeBSD 5.5 ou 6.2
Webmin
Samba (pour la connection avec l'AD 2K3)
Squid et authentification NTLM (transparent)
 
Le tout marche numéro 1; je vois pas pourquoi ca fouterait le bordel puisque ce n'est qu'une interface. Tu vas voir, ca facilite grandement les config de tout les services! En commencant par Squid.

n°947775
Zboss
Si tu doutes, reboot...
Posté le 28-08-2007 à 20:06:48  profilanswer
 

Oui je suis d'accord que ça facilite grandement la configuration  :D .
 
Bon bah je verrai ça demain.
 
Pour mon problème concernant SARG, apparemment c'est peu être simplement les paquets Debian qui ne se sont pas installés correctement, et je vais les installer autrement.


---------------
Mario Kart for Ever
n°948110
boobaka
Posté le 29-08-2007 à 17:57:33  profilanswer
 

Citation :

Code :
[2007/08/28 17:24:53, 0] utils/ntlm_auth.c:winbind_pw_check(429)  Login for user [DOMAINE.MACHIN.COM][mon_login]@[mon_PC] failed due to [winbind client not authorized to use winbindd_pam_auth_crap. Ensure permissions on /var/run/samba/winbindd_privileged are set correctly.][2007/08/28 17:24:53, 0] utils/ntlm_auth.c:manage_squid_ntlmssp_request(603)  NTLMSSP BH: NT_STATUS_ACCESS_DENIED2007/08/28 17:24:53| authenticateNTLMHandleReply: Error validating user via NTLM. Error returned 'BH NT_STATUS_ACCESS_DENIED'


 
J'ai exactement le meme message dans mes logs sur ma VM.... Une indication sur ta resolution?
 
Merci.
 
++

Message cité 1 fois
Message édité par boobaka le 29-08-2007 à 17:58:59

---------------
www.google.fr  
n°948220
Zboss
Si tu doutes, reboot...
Posté le 30-08-2007 à 09:27:00  profilanswer
 

Je crois que j'avais laissé au début la ligne :
 
"auth_param basic realm Squid AD" dans le /etc/squid/squid.conf
que j'ai simplement remplacée par  
"auth_param basic realm DOMAINE.MACHIN.COM".


Message édité par Zboss le 30-08-2007 à 09:32:00

---------------
Mario Kart for Ever
n°948279
boobaka
Posté le 30-08-2007 à 12:18:12  profilanswer
 

Ok merci pour ta reponse... ca n'avait rien a voir pour moi, seulement le /var/run/samba/winbindd_pam qui n'appartenait pas au groupe  proxy...
 
Bon ca roule maintenant.
++


---------------
www.google.fr  
n°948398
Zboss
Si tu doutes, reboot...
Posté le 30-08-2007 à 18:17:12  profilanswer
 

Ah merde, je viens de voir que mon authentification fonctionne dans les logs en cas de réussite d'accès, mais dès que j'essaye d'accéder à un site refusé, c'est mon IP qui apparaît, et plus mon login  :cry: .


---------------
Mario Kart for Ever
n°948577
Zboss
Si tu doutes, reboot...
Posté le 31-08-2007 à 10:24:59  profilanswer
 

Ah bah ça s'améliore pas :  
 

Code :
  1. Now generating Sarg report from Squid log file /var/log/squid/access.log and all rotated versions ..
  2. sarg -l /var/log/squid/access.log.2.gz
  3. SARG: Decompression du journal: /var/log/squid/access.log.2.gz > /tmp/sarg-file.in (zcat)
  4. SARG: (html11) Impossible d'ouvrir le fichier: /var/www/squid-reports/2007Aug29-2007Aug29/users
  5. .. Sarg failed! See the output above for details.


 
 
J'ai rien touché depuis hier pourtant  :cry: .


Message édité par Zboss le 20-09-2007 à 13:47:53

---------------
Mario Kart for Ever
n°955526
Zboss
Si tu doutes, reboot...
Posté le 20-09-2007 à 13:47:33  profilanswer
 

Je n'ai toujours pas réussi à refaire fonctionner mes logs avec sarg  :( . (Bon ok, ça fait pas 15 jours que je suis dessus, je viens de reprendre le problème  :D ).
 
Bref, tout fonctionnait bien jusqu'à ce que je tente d'activer la génération automatique des logs (toutes les nuits à minuit), par l'intermédiaire de webmin. Le lendemain, rien n'avait été généré, et lorsque je clique maintenant sur "Generate Report Now" (toujours dans webmin), j'obtiens ça :
 

Code :
  1. Now generating Sarg report from Squid log file /var/log/squid/access.log and all rotated versions ..
  2. sarg -l /var/log/squid/access.log.2.gz
  3. SARG: Decompression du journal: /var/log/squid/access.log.2.gz > /tmp/sarg-file.in (zcat)
  4. SARG: Aucun enregistrement trouvé
  5. SARG: Fin
  6. sarg -l /var/log/squid/access.log.1
  7. sort: open failed: /tmp/sarg/.htmp: No such file or directory
  8. SARG: (totday) Impossible d'ouvrir le journal: /tmp/sarg/.sort
  9. .. Sarg failed! See the output above for details.


 
Je ne vois pas ce qu'il essaye de chercher dans /tmp/sarg/ , le fichier ".sort" n'existe pas en tout cas.
 
Une idée pour résoudre ce problème ?  :sweat:  
 


---------------
Mario Kart for Ever
n°956905
Zboss
Si tu doutes, reboot...
Posté le 24-09-2007 à 14:16:36  profilanswer
 

Je me permets de upper encore une fois car mon problème n'est toujours pas résolu  :( .
 
Quand je veux générer mes logs en cliquant sur le bouton "Generate Now" de Squid, j'obtiens :
 
sarg -l /var/log/squid/access.log  
sort: open failed: /tmp/sarg/.htmp: No such file or directory
SARG: (totday) Impossible d'ouvrir le journal: /tmp/sarg/.sort
 
Une idée ?  :cry:


---------------
Mario Kart for Ever
n°961953
boobaka
Posté le 08-10-2007 à 18:27:47  profilanswer
 

Salut,
bon sarg testé et validé...
aptitude install sarg
Aucun soucis en etch
 
Un soucis a la generation des fichiers ou Sarg essaie de supprimer un fichier temp qui n'existe pas...d'ou changement de la variable dans /etc/squid/sarg.conf de remove_temp_file de yes en No ...
Et pas de soucis, la generation du report s'effectue bien sous /var/www/ et via mail
 
La reponse est dans /etc/squid/sarg.conf
 
++
 

n°962136
Zboss
Si tu doutes, reboot...
Posté le 09-10-2007 à 10:17:26  profilanswer
 

En réponse à ton message sur le topic des informaticiens aigris :
 
Oui j'ai installé Sarg par aptitude, et qd mon problème est apparu et que je n'arrivais pas à le résoudre (ça a fonctionné au début je le rappelle), j'ai fais une désinstallation "clean" avant de tout réinstaller.
 
En exécutant Sarg en ligne de commandes, j'obtiens :
 
FRKPAP02:/etc/squid# sarg -l /var/log/squid/access.log -x
SARG: Init
SARG: Loading configuration from: /etc/squid/sarg.conf
SARG: Chargement des exclusions depuis: /etc/squid/sarg.hosts
SARG: Chargement des exclusions depuis: /etc/squid/sarg.users
SARG: Paramètres:
SARG:
SARG:         Nom de l'hôte ou adresse IP (-a) =
SARG:     Journal des agents utilisateurs (-b) =
SARG:              Fichier des exclusions (-c) = /etc/squid/sarg.hosts
SARG:                      Date début-fin (-d) =
SARG: Adresse e-mail destinataire des statistiques (-e) =
SARG:            Fichier de configuration (-f) = /etc/squid/sarg.conf
SARG:                      Format de date (-g) = USA (mm/dd/yyyy)
SARG:        Statistiques des adresses IP (-i) = Non
SARG:                    Journal d'entrée (-l) = /var/log/squid/access.log
SARG:          Résolution des adresses IP (-n) = Non
SARG:                Répertoire de sortie (-o) = /var/www/squid-reports/
SARG: Utiliser l'adresse IP au lieu de l'identifiant utilisateur (-p) = Non
SARG:                         Site accédé (-s) =
SARG:                               Heure (-t) =
SARG:                         Utilisateur (-u) =
SARG:               Répertoire temporaire (-w) = /tmp
SARG:                Messages de débogage (-x) = Oui
SARG:              Messages des processus (-z) = Non
SARG:
SARG: sarg version: 2.2.2 Aug-29-2006
SARG: Maximum file descriptor: cur=1024 max=1024, changed to cur=20000 max=20000
SARG: Loading User table: /etc/squid/sarg.usertab
SARG: Lecture du journal des accès: /var/log/squid/access.log
SARG:    Enregistrements lus: 17, écrits: 17, exclus: 0
SARG: Format Squid du journal
SARG: Période: 2007Sep25-2007Sep25
SARG: Tri du fichier /tmp/sarg/denied.log.unsort
SARG: Tri du fichier /tmp/sarg/192.168.2.3.unsort
SARG: Création du fichier de l'intervalle
SARG: Création du fichier: /tmp/sarg/192.168.2.3
sort: Ãchec d'ouverture: /tmp/sarg/.htmp: Aucun fichier ou répertoire de ce type
SARG: (totday) Impossible d'ouvrir le journal: /tmp/sarg/.sort
 
Il semblerait donc que le problème vienne d'un problème de "droits" au niveau du dossier "/temp" voire "/temp/sarg" non ?
 
Tu as quoi comme droits sur ces dossiers toi ?
 


---------------
Mario Kart for Ever
n°962139
boobaka
Posté le 09-10-2007 à 10:27:55  profilanswer
 

Amha il ne s'agit pas d'un probleme sur /tmp puisque c'est un repetoire "particulier" sur lequel tout le monde a logiquement le droit d'ecrire...
 
Pour l'avoir juste tester, je te conseille de le reinstaller proprement (purge à la desinstallation) ...
Puis de ne modifier que la variable remove_temp_file
Ca doit tourner sans soucis..
++

n°962301
Zboss
Si tu doutes, reboot...
Posté le 09-10-2007 à 16:55:29  profilanswer
 

J'ai finalement redésinstallé Sarg et j'ai viré les fichiers sarg.* qui étaient dans mon /etc/squid, ce que apparemment je n'aurais pas du faire car ils n'ont pas été recrées lors de la réinstallation de Sarg, alors ils viennent d'où ces fichiers ???  :fou:


---------------
Mario Kart for Ever
n°962343
boobaka
Posté le 09-10-2007 à 17:56:54  profilanswer
 

apt-get remove --purge sarg
rm /var/cache/apt/archive sarg*.deb
apt-get install sarg


ca recrera les fichiers de conf..
P'tet pas ce qu'il y a de plus propre...
++

n°962475
Zboss
Si tu doutes, reboot...
Posté le 10-10-2007 à 11:13:45  profilanswer
 

Ok merci, effectivement, j'ai récupérer les fichiers .conf de Sarg.
 
J'ai juste modifié la variable "remove_temp_file", mais l'erreur reste la même...


---------------
Mario Kart for Ever
n°962481
boobaka
Posté le 10-10-2007 à 11:28:05  profilanswer
 

Tu lances sarg avec quel user?
C'est quoi ce "sort" dans tes logs? Perso tu bloques sur la ligne qui contient sort, ligne que je n'ai pas..
Peux tu poster ton sarg.conf sans les commentaires? As tu remplis les autres fichiers sarg.users, sarg.hosts ... ?
++

n°962517
Zboss
Si tu doutes, reboot...
Posté le 10-10-2007 à 12:07:57  profilanswer
 

Qd je teste en lignes de commandes, je le lance en root :
 

Code :
  1. FRKPAP02:/var/log/squid# sarg -l /var/log/squid/access.log -x
  2. SARG: Init
  3. SARG: Loading configuration from: /etc/squid/sarg.conf
  4. SARG: Loading exclude file from: /etc/squid/sarg.hosts
  5. SARG: Loading exclude file from: /etc/squid/sarg.users
  6. SARG: Parameters:
  7. SARG:
  8. SARG:              Hostname or IP address (-a) =
  9. SARG:                       Useragent log (-b) =
  10. SARG:                        Exclude file (-c) = /etc/squid/sarg.hosts
  11. SARG:                     Date from-until (-d) =
  12. SARG:       Email address to send reports (-e) =
  13. SARG:                         Config file (-f) = /etc/squid/sarg.conf
  14. SARG:                         Date format (-g) = USA (mm/dd/yyyy)
  15. SARG:                           IP report (-i) = No
  16. SARG:                           Input log (-l) = /var/log/squid/access.log
  17. SARG:                  Resolve IP Address (-n) = No
  18. SARG:                          Output dir (-o) = /var/www/squid-reports/
  19. SARG:    Use Ip Address instead of userid (-p) = No
  20. SARG:                       Accessed site (-s) =
  21. SARG:                                Time (-t) =
  22. SARG:                                User (-u) =
  23. SARG:                       Temporary dir (-w) = /tmp
  24. SARG:                      Debug messages (-x) = Yes
  25. SARG:                    Process messages (-z) = No
  26. SARG:
  27. SARG: sarg version: 2.2.2 Aug-29-2006
  28. SARG: Maximum file descriptor: cur=1024 max=1024, changed to cur=20000 max=20000
  29. SARG: Loading User table: /etc/squid/sarg.usertab
  30. SARG: Reading access log file: /var/log/squid/access.log
  31. SARG:    Records read: 17, written: 17, excluded: 0
  32. SARG: Squid log format
  33. SARG: Period: 2007Sep25-2007Sep25
  34. SARG: Sorting file /tmp/sarg/denied.log.unsort
  35. SARG: Sorting file /tmp/sarg/192.168.2.3.unsort
  36. SARG: Making period file
  37. SARG: Making file: /tmp/sarg/192.168.2.3
  38. sort: Ãchec d'ouverture: /tmp/sarg/.htmp: Aucun fichier ou répertoire de ce type
  39. SARG: (totday) Cannot open log file: /tmp/sarg/.sort


 
Quand je le lance depuis Squid, bonne question, je ne sais pas comment ça se passe  :??: .
 
 
Le "sort", pas la moindre idée d'où il vient  :sweat: .
 
Je poste mon sarg.conf tout à l'heure.


---------------
Mario Kart for Ever
n°962564
boobaka
Posté le 10-10-2007 à 14:10:31  profilanswer
 

Re,
tu as quelque chose dans tes fichier sarg.users/sarg.hosts... ?

n°962587
Zboss
Si tu doutes, reboot...
Posté le 10-10-2007 à 14:28:48  profilanswer
 

sarg.conf :
 

Code :
  1. language English
  2. access_log /var/log/squid/access.log
  3. title "Squid User Access Reports"
  4. font_face Tahoma,Verdana,Arial
  5. header_color darkblue
  6. header_bgcolor blanchedalmond
  7. font_size 9px
  8. background_color white
  9. text_color #000000
  10. text_bgcolor lavender
  11. title_color green
  12. temporary_dir /tmp
  13. output_dir /var/www/squid-reports
  14. resolve_ip
  15. user_ip no
  16. topuser_sort_field BYTES reverse
  17. user_sort_field BYTES reverse
  18. exclude_users /etc/squid/sarg.users
  19. exclude_hosts /etc/squid/sarg.hosts
  20. date_format u
  21. lastlog 0
  22. remove_temp_files no
  23. index yes
  24. index_tree file
  25. overwrite_report yes
  26. records_without_userid ip
  27. use_comma yes
  28. mail_utility mailx
  29. topsites_num 100
  30. topsites_sort_order CONNECT D  <--------------------- !!!!
  31. index_sort_order D  <------------ !!!!
  32. exclude_codes /etc/squid/sarg.exclude_codes
  33. max_elapsed 28800000
  34. report_type topusers topsites sites_users users_sites date_time denied auth_failures site_user_time_date downloads
  35. usertab /etc/squid/sarg.usertab
  36. long_url no
  37. date_time_by bytes
  38. charset Latin1
  39. show_successful_message no
  40. show_read_statistics no
  41. topuser_fields NUM DATE_TIME USERID CONNECT BYTES %BYTES IN-CACHE-OUT USED_TIME MILISEC %TIME TOTAL AVERAGE
  42. user_report_fields CONNECT BYTES %BYTES IN-CACHE-OUT USED_TIME MILISEC %TIME TOTAL AVERAGE
  43. topuser_num n
  44. topuser num 0
  45. site_user_time_date_type table
  46. download_suffix "zip,arj,bzip,gz,ace,doc,iso,adt,bin,cab,com,dot,drv$,lha,lzh,mdb,mso,ppt,rtf,src,shs,sys,exe,dll,mp3,avi,mpg,mpeg"


 
Tiens tiens, voici peut être mon fameux "sort"... (cf <------------- !!!! ) Je vais voir ça...
 
sarg.users et sarg.hosts sont vides.


Message édité par Zboss le 10-10-2007 à 14:31:30

---------------
Mario Kart for Ever
n°962598
Zboss
Si tu doutes, reboot...
Posté le 10-10-2007 à 14:51:51  profilanswer
 

Non ça ne change rien, je suis toujours dans le brouillard total... :(


---------------
Mario Kart for Ever
n°962612
boobaka
Posté le 10-10-2007 à 15:06:16  profilanswer
 

Re,
 
ta version de squid?
 
Perso:

sarg -v
SARG Version: 2.2.2


 
Meme conf que toi,  
 

sarg -x
SARG: Init
SARG: Loading configuration from: /etc/squid/sarg.conf
SARG: Chargement des exclusions depuis: /etc/squid/sarg.hosts
SARG: Chargement des exclusions depuis: /etc/squid/sarg.users
SARG: Paramètres:
SARG:
SARG:         Nom de l'hôte ou adresse IP (-a) =
SARG:     Journal des agents utilisateurs (-b) =
SARG:              Fichier des exclusions (-c) = /etc/squid/sarg.hosts
SARG:                      Date début-fin (-d) =
SARG: Adresse e-mail destinataire des statistiques (-e) = MyAdress@home.org
SARG:            Fichier de configuration (-f) = /etc/squid/sarg.conf
SARG:                      Format de date (-g) = USA (mm/dd/yyyy)
SARG:        Statistiques des adresses IP (-i) = Non
SARG:                    Journal d'entrée (-l) = /var/log/squid/access.log
SARG:          Résolution des adresses IP (-n) = Non
SARG:                Répertoire de sortie (-o) = /tmp/sarg_tmp/
SARG: Utiliser l'adresse IP au lieu de l'identifiant utilisateur (-p) = Non
SARG:                         Site accédé (-s) =
SARG:                               Heure (-t) =
SARG:                         Utilisateur (-u) =
SARG:               Répertoire temporaire (-w) = /tmp
SARG:                Messages de débogage (-x) = Oui
SARG:              Messages des processus (-z) = Non
SARG:
SARG: sarg version: 2.2.2 Aug-29-2006
SARG: Maximum file descriptor: cur=1024 max=1024, changed to cur=20000 max=20000
SARG: Loading User table: /etc/squid/sarg.usertab
SARG: Lecture du journal des accès: /var/log/squid/access.log
SARG:    Enregistrements lus: 13597, écrits: 13596, exclus: 1
SARG: Format Squid du journal
SARG: Période: 2007Oct10-2007Oct10
SARG: Tri du fichier /tmp/sarg/denied.log.unsort
SARG: Tri du fichier /tmp/sarg/X.X.X.X.unsort
SARG: Création du fichier de l'intervalle
SARG: Création du fichier: /tmp/sarg/X.X.X.X
SARG: Fin
 


++

n°962617
Zboss
Si tu doutes, reboot...
Posté le 10-10-2007 à 15:09:06  profilanswer
 

Même version de sarg que toi (2-2-2).
Et Squid 2.6 stable.
 
Si j'étais sur place j'aurais reformaté et réinstallé tout le bordel depuis lgtps (quoique si ça fonctionne un seul jour comme l'autre fois...), mais là j'y accéde seulement via SSH, je suis pas du tout sur le site en question  :sweat: .


Message édité par Zboss le 10-10-2007 à 15:09:28

---------------
Mario Kart for Ever
n°969626
Zboss
Si tu doutes, reboot...
Posté le 25-10-2007 à 16:18:31  profilanswer
 

J'ai de nouveau tenté en effaçant tous les fichiers access.log, j'utilise un peu le proxy histoire de le re-remplir, mais dès la première génération, même erreur :
 
sarg -l /var/log/squid/access.log  
sort: open failed: /tmp/sarg/.htmp: No such file or directory
SARG: (totday) Cannot open log file: /tmp/sarg/.sort
 
 
Ca me rend diiiiiiiiiiiiingueeee !!!!!!!!!!!!!!


---------------
Mario Kart for Ever
n°971652
Walk_Man
To live is to die.
Posté le 30-10-2007 à 10:44:08  profilanswer
 

Le repertoire /tmp/sarg est bien crée ? Quels droits sont donnés dessus ?


---------------
¡ Viva la Revolución !
n°971682
Zboss
Si tu doutes, reboot...
Posté le 30-10-2007 à 10:54:14  profilanswer
 

drwxr-xr-x  root root  pour /tmp/sarg


Message édité par Zboss le 30-10-2007 à 10:54:36

---------------
Mario Kart for Ever
n°973522
Walk_Man
To live is to die.
Posté le 02-11-2007 à 21:48:58  profilanswer
 

et en faisant le temps du test comme un gros porc chmod 777 sur les fichiers contenus dans /tmp/sarg ? :D


---------------
¡ Viva la Revolución !
n°973534
Zboss
Si tu doutes, reboot...
Posté le 02-11-2007 à 22:02:35  profilanswer
 

Déjà fait je crois :D .
 
J'vais formater tout ça, ça va fonctionner un jour comme l'autre fois, et ensuite je me barre en courant :D .


---------------
Mario Kart for Ever
n°973548
Walk_Man
To live is to die.
Posté le 03-11-2007 à 01:40:07  profilanswer
 

Bah écoute, avant de formater, lundi pour rigoler je vais sur un serveur refoutre un squid + squidguard et tenter de mettre sarg voir ce que ca donne.


---------------
¡ Viva la Revolución !
mood
Publicité
Posté le   profilanswer
 

 Page :   1  2
Page Précédente

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  Proxy Squid avec authentification AD

 

Sujets relatifs
Alerte Squid httpReadReply: Excess data from[squid] cacher des objets gros ???
Identifier le proxyauthentification SVN avec LDAP (Active Directory)
|squid - iwss] Zero Sized ReplySQUID + VHOSTS : Problème d'accès...
[Apache proxy] externe https, interne httpServeur mail Postfix+Cyrus-IMAP avec authentification Cyrus-SASL
SQUID + LDAP sur Debian EtchReverse proxy Squid
Plus de sujets relatifs à : Proxy Squid avec authentification AD


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR