Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1997 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  [debian] problème avec souris USB

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[debian] problème avec souris USB

n°228559
666 -PPC-
Posté le 25-02-2003 à 18:55:13  profilanswer
 

je suis en train d'installer une testing
j'ai compilé 2.4.20 qui vient directement de Debian
 
dmesg :

usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb-ohci.c: USB OHCI at membase 0xe0856000, IRQ 9
usb-ohci.c: usb-00:02.2, Silicon Integrated Systems [SiS] 7001
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 3 ports detected
SiS pirq: advanced IDE/ACPI/DAQ mapping not yet implemented
advanced SiS pirq mapping not yet implemented
usb-ohci.c: USB OHCI at membase 0xe0858000, IRQ 5
usb-ohci.c: usb-00:02.3, Silicon Integrated Systems [SiS] 7001 (#2)
usb.c: new USB bus registered, assigned bus number 2
hub.c: USB hub found
hub.c: 3 ports detected
PCI: Found IRQ 11 for device 00:0c.0
3c59x: Donald Becker and others. www.scyld.com/network/vortex.html
00:0c.0: 3Com PCI 3c905C Tornado at 0xe000. Vers LK1.1.16
hub.c: new USB device 00:02.2-2, assigned address 2
usb.c: USB device 2 (vend/prod 0x45e/0x47) is not claimed by any active driver.
Serial driver version 5.05c (2001-07-08) with MANY_PORTS SHARE_IRQ SERIAL_PCI enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
usb.c: registered new driver hid
: USB HID v1.10 Mouse [Microsoft Microsoft 5-Button Mouse with IntelliEye(TM)] on usb1:2.0
hid-core.c: v1.8.1 Andreas Gal, Vojtech Pavlik <vojtech@suse.cz>
hid-core.c: USB HID support drivers
mice: PS/2 mouse device common for all mice


 
lsmod :

Module                  Size  Used by    Not tainted
cs46xx                 54768   0 (autoclean)
ac97_codec             10184   0 (autoclean) [cs46xx]
soundcore               3556   3 (autoclean) [cs46xx]
mousedev                3864   0
input                   3360   0 [mousedev]
hid                     8828   0 (unused)
serial                 44132   0 (autoclean)
3c59x                  25264   1 (autoclean)
usb-ohci               17832   0 (unused)
usbcore                56704   1 [hid usb-ohci]
rtc                     5948   0 (autoclean)


 
j'ai fait comme expliqué ICI

usbdevfs /proc/bus/usb usbdevfs defaults 0 0

dans le fstab
 
j'ai installé hotplug et usbutils
 
mais si je fais un
cat /dev/input/mice il se passe rien :'(
 
pourtant sous woody avec la même config pour le kernel ça fonctionnait du premier coup
 
qu'est-ce que j'ai bien pu merder :??:

mood
Publicité
Posté le 25-02-2003 à 18:55:13  profilanswer
 

n°228582
HuGoBioS
Posté le 25-02-2003 à 19:29:54  profilanswer
 

Et dans /dev/usb/...(je sais pas ou exactement) tu as pas une device qui correspondrait a ta souris .? parceque d'apres dmesg, c'est bon, elle est reconnue et elle marche (l'optik doit bien etre allumé, non ?)
donc moi je regarderai bien dans /dev/usb ou /dev/input tu devrai trouver je pense


---------------
-= In Kik00 101 I trust :o =-
n°228591
666 -PPC-
Posté le 25-02-2003 à 19:43:41  profilanswer
 

là je suis sous windows (poster avec w3m spa super pratique) donc je peux pas trop vérifier pour /dev/usb ...
 
oui elle est bien allumée
j'ai essayé d'unloader les modules puis les reloader
sans les modules le /dev/input/mice n'existe même pas
 
j'ai pas encore essayé gpm, logiquement je me dis que si le cat /dev/input/mice donne rien quand je bouge la souris, ça fonctionnera pas


Message édité par a la peche le 25-02-2003 à 19:44:50
n°229419
666 -PPC-
Posté le 26-02-2003 à 20:40:37  profilanswer
 

bon, j'ai downloadé le .deb des sources du 2.4.18, recompil avec le fichier de conf de ma woody, et ça roule :pt1cable:

n°229422
HuGoBioS
Posté le 26-02-2003 à 20:46:30  profilanswer
 

tu avais du oublier de compiler un truc dans le noyau !
Y'a un truc a activer dans les input core
et apres effectivement y'a his dans la section usb, et y'a celui qui apparait juste sous hid aussi a prendre


---------------
-= In Kik00 101 I trust :o =-
n°229433
666 -PPC-
Posté le 26-02-2003 à 21:02:56  profilanswer
 

:heink: j'ai utilisé le même fichier de config
 
dans input et USB y a exactement la même configuration j'ai vérifié

n°229438
HuGoBioS
Posté le 26-02-2003 à 21:21:00  profilanswer
 

666 -PPC- a écrit :

:heink: j'ai utilisé le même fichier de config
 
dans input et USB y a exactement la même configuration j'ai vérifié


Le meme fichier de config entre koi et koi ? le 2.4.18 et le 2.4.20 ? y'a des trucs qu'on changé entre temps peut-etre ...  
enfin si tu as verifié, c'est p'tet un bug du 2.4.20 ...
 
moi dans mon .config j'ai
 
 

CONFIG_INPUT=y
CONFIG_INPUT_MOUSEDEV=y
CONFIG_USB_HID=y
CONFIG_USB_HIDINPUT=y
 


Message édité par HuGoBioS le 26-02-2003 à 21:22:37

---------------
-= In Kik00 101 I trust :o =-
n°230245
666 -PPC-
Posté le 27-02-2003 à 20:10:44  profilanswer
 

:jap: au temps pour moi, c'était bien ça, j'avais pas vu CONFIG_USB_HIDINPUT, avant HID regroupait tout...


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  [debian] problème avec souris USB

 

Sujets relatifs
Problème avec X server ?[ProFtpD] Probleme de login
Quel est le probléme, je vaux juste me débarasser de cette page de[IPROUTE - IPTABLES] problème de filtres avec marquage
PB Startx debianproblème avec mon routeur et iptables
probleme avec la croi directionnel du MS sidewinder pad (le basique)Probleme au lancement de Mozilla
pb connexion internet Red Hat 8.0 et modem USB[PROJET] "Serveur" sous Debian | Sueurs froides finies : )
Plus de sujets relatifs à : [debian] problème avec souris USB


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR