Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
822 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  PB Startx debian

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

PB Startx debian

n°228383
xwilly
Posté le 25-02-2003 à 14:44:34  profilanswer
 

Je viens d'installer une debian woody avec gnome 1.4 et sawfish.
 
J'ai un pb quand je lance statx j'arrive sur un fond d'écran marron et plus rien. En fesant ctrl+alt+f1 j'ai vu que le lancement de xfree86 s'arréte à cette erreur :
 

Citation :


could not init font path element unix/:7100, removing from list

 
 
comment je fait pour ne plus avoir cette erreur et lancer gnome correctement ??


Message édité par xwilly le 25-02-2003 à 14:45:24
mood
Publicité
Posté le 25-02-2003 à 14:44:34  profilanswer
 

n°228394
the_fireba​ll
I have fucking failed
Posté le 25-02-2003 à 14:52:47  profilanswer
 

ce n'est pas une erreur à proprement parler. C'est juste qu'il cherche à se connecter au server de fonts et qu'il ne peut pas donc il le vire de sa liste.
 
Apres pour ton fond d'écran, c peut etre TWM. Tu as essayé les boutons de la souris pour voir si des menus apparaissent ?
 
sinon
apt-get install openbox
 
par exemple
 
edit j'avais pas vu que tu voulais utiliser gnome.
 
apt-get install gnome


Message édité par the_fireball le 25-02-2003 à 14:53:17

---------------
Two thousand years of misery, of torture in my name, hypocrisy made paramount, paranoia the law, my name is called religion, sadistic, sacred whore.
n°228398
lucaramel
Posté le 25-02-2003 à 14:55:20  profilanswer
 

Xwilly a écrit :

Je viens d'installer une debian woody avec gnome 1.4 et sawfish.
 
J'ai un pb quand je lance statx j'arrive sur un fond d'écran marron et plus rien. En fesant ctrl+alt+f1 j'ai vu que le lancement de xfree86 s'arréte à cette erreur :
 

Citation :


could not init font path element unix/:7100, removing from list

 
 
comment je fait pour ne plus avoir cette erreur et lancer gnome correctement ??


Ce n'est pas très grave, il suffit de cocher la ligne correspondante dans ton XF86Config-4. Par contre, si X refuse de se lancer, c'est un autre problème.

n°228495
xwilly
Posté le 25-02-2003 à 16:55:08  profilanswer
 

Merci, j'ai reinstaller gnome et ca marche mais,
j ai un petit pb de fenetre quand je bouge les fenetre l'affichage se fige pendant 1 ou 2 sec ; ou quand je bouge une fenedre l'affichage saccade monstrueusement:(.
Ca peux venir d'ou j'ai un geforce mx 440 noname avec les driver libre de nvidia

n°228496
e_esprit
Posté le 25-02-2003 à 16:58:15  profilanswer
 

Xwilly a écrit :

Merci, j'ai reinstaller gnome et ca marche mais,
j ai un petit pb de fenetre quand je bouge les fenetre l'affichage se fige pendant 1 ou 2 sec ; ou quand je bouge une fenedre l'affichage saccade monstrueusement:(.
Ca peux venir d'ou j'ai un geforce mx 440 noname avec les driver libre de nvidia


 :non: les drivers de nvidia ne sont pas libres...

n°228584
xwilly
Posté le 25-02-2003 à 19:31:17  profilanswer
 

les driver nvidia 'nv' dans xfree86 il ne sont pas libre ??
j'ai foutu les drivers propriaitaire de nvidia et tous marche now :)  
merci pour votrte aide

n°228592
xwilly
Posté le 25-02-2003 à 19:43:45  profilanswer
 

Nouveau petit PB  
 
Je me suis bie mis dans le groupe video mais je peux pourtant pas utiliser l'opengl comme par exemple 'glxgears' il me dit que :

Citation :


Error: Could not open /dev/nvidiactl because the permissions
are too resticitive.  Please see the FREQUENTLY ASKED QUESTIONS
section of /usr/share/doc/NVIDIA_GLX-1.0/README for steps
to correct.

 
 
Je dois me mettre dans un autre groupe encore ??


Message édité par xwilly le 25-02-2003 à 19:44:48
n°228595
Mjules
Modérateur
Parle dans le vide
Posté le 25-02-2003 à 19:53:48  profilanswer
 

bon, je lis un peu l'anglais et je vois marqué :
 
Erreur : ne peut pas ouvrir /dev/nvidiactl parce que les permissions sont trop restrictive.
SVP, reportez vous à la scetion FAQ du fichier /usr/share/doc/NVIDIA_GLX-1.0/README for trouver les étapes permettant de corriger le pb.
 
je fais donc ce qu'il me dit et là je vois :

Citation :


It is likely that a security module for the PAM system may be
   changing the permissions on the NVIDIA device files.  In most cases
   this security system works, but it can get confused.  To correct this
   problem it is recommended that you disable this security feature.
   Different Linux distributions have different files to control this;
   please consult with your distributor for the correct method of
   disabling this security feature.  As an example, if your system has
   the file
        /etc/security/console.perms
   then you should edit the file and remove the line that starts with
   "<dri>" (we have also received reports that additional references to
   <dri> in console.perms must be removed, but this has not been verified
   by NVIDIA).  If instead your system has the file
        /etc/logindevperms
   then you should edit the file and remove the line that lists
   /dev/nvidiactl.  The above steps will prevent the PAM security system
   from modifying the permissions on the NVIDIA device files.  Next,
   you will need to reset the permissions on the device files back
   to their original permissions and owner.  You can do that with the
   following commands:
        chmod 0666 /dev/nvidia* chown root /dev/nvidia*


 
où miracle, je lis la solution.
 
conclusion : RTFM


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°228634
e_esprit
Posté le 25-02-2003 à 20:52:21  profilanswer
 

Xwilly a écrit :

les driver nvidia 'nv' dans xfree86 il ne sont pas libre ??


Bah ceux la ils sont pas de nvidia que je sache...


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  PB Startx debian

 

Sujets relatifs
[PROJET] "Serveur" sous Debian | Sueurs froides finies : )[Debian] Redéfinir sa table de caractères
[debian] prob "bizar" adsl - Sivep bizar :( sorry[Debian] comment faire pour résoudre ce problème d'apt-get
Pb de boot Debian sur SGI Indy (Minusplus viens :p) (cf. fin topic)pb avec xawdecode sur debian sid
[Debian] Passer à Sid ?[DEBIAN] questions sur kde
gros pb avec console-data (debian testing)[Debian Sid] Dépendances et packages sources de mplayer
Plus de sujets relatifs à : PB Startx debian


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR