Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
799 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  Installation OpenVPN sur Debian

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Installation OpenVPN sur Debian

n°907234
acetone802​000
J'aime les circuits imprimés
Posté le 26-04-2007 à 12:46:52  profilanswer
 

Bonjour,
 
J'ai installé OpenVPN sur mon Serveur Debian Etch. Le serveur à une configuration Samba opérationnelle
 
Le serveur est branché sur un routeur WRT54GS DDWRT2.3 redirigeant le port 1194 vers le serveur
 
Sur un PC sous Windows j'ai installé OpenVPN GUI et j'arrive à me connecter à mon serveur. Je ping sans difficultés le serveur au travers de l'IP virtuelle et  j'arrive à voir les fichiers partagés en faisant recherche d'un PC sous Windows et en rentrant l'IP virtuelle.
 
Par contre je ne vois aucun autre PC ( par le parcours du réseau de windows XP).
 
Donc je me demande si je n'ai pas oublié une chose dans la config de mon serveur:
 
Fichier server.conf

Citation :


;port 1194
proto udp
dev tun
ca ca.crt
cert DebianServer.crt
key DebianServer.key  
dh dh1024.pem
server 10.8.0.0 255.255.255.0
push "route 192.168.0.0 255.255.255.0"
push "dhcp-option DNS 192.168.1.1"
push "dhcp-option DOMAIN xxxxx.fr"    <- modifié pour ne pas délivrer d'infos personnelles
push "dhcp-option WINS 192.168.1.1"
keepalive 10 120
comp-lzo
user openvpn
group openvpn
persist-key
persist-tun
status openvpn-status.log
verb 3


 
le résultat de route:

Citation :


Table de routage IP du noyau
Destination     Passerelle      Genmask         Indic Metric Ref    Use Iface
10.8.0.2        *               255.255.255.255 UH    0      0        0 tun0
10.8.0.0        10.8.0.2        255.255.255.0   UG    0      0        0 tun0
192.168.1.0     *               255.255.255.0   U     0      0        0 eth0
default         DD-WRT          0.0.0.0         UG    0      0        0 eth0


 
le résultat de ifconfig

Citation :


 
eth0      Lien encap:Ethernet  HWaddr 00:xx:xx:xx:xx:xx
          inet adr:192.168.1.141  Bcast:192.168.1.255  Masque:255.255.255.0
          adr inet6: xxxx::204:xxxx:fed8:6afe/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2394214 errors:0 dropped:0 overruns:1 frame:0
          TX packets:2641707 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:1493987659 (1.3 GiB)  TX bytes:2655707843 (2.4 GiB)
          Interruption:169 Adresse de base:0xc000
 
lo        Lien encap:Boucle locale
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:17061 errors:0 dropped:0 overruns:0 frame:0
          TX packets:17061 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:5131322 (4.8 MiB)  TX bytes:5131322 (4.8 MiB)
 
tun0      Lien encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
          inet adr:10.8.0.1  P-t-P:10.8.0.2  Masque:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:162 errors:0 dropped:0 overruns:0 frame:0
          TX packets:151 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:100
          RX bytes:20817 (20.3 KiB)  TX bytes:24453 (23.8 KiB)


 
 
Sur la doc je n'ai pas trouvé comment rendre les autres PC accessibles, et ca fait 2 jours que je cherche !!!!
 
Alors si vous avez une piste je prends !!!
 
Merci d'avance

mood
Publicité
Posté le 26-04-2007 à 12:46:52  profilanswer
 

n°907280
leto3
Posté le 26-04-2007 à 14:14:27  profilanswer
 

Cf : http://www.nbs-system.com/article/openvpn2_howto
 
T'as deux modes : bridge ethernet et routé IP .
Toi t'as utilisé le pont IP , donc si tu veux accéder à distance aux machines de ton réseau il faut que tu configure sur ton serveur VPN des regles de routage. Le plus simple c'est de faire un pont ethernet (tap et pas tun).


---------------
leto3
n°907432
acetone802​000
J'aime les circuits imprimés
Posté le 26-04-2007 à 19:10:30  profilanswer
 

Merci je vais approfondir la question et je poste dès que j'ai un résultat !!

n°907617
acetone802​000
J'aime les circuits imprimés
Posté le 27-04-2007 à 09:45:22  profilanswer
 

J'ai maintenant un problème de route, mais je n'arrive pas à trouver ce que j'ai loupé !
 

Citation :


Fichier server.conf
 
local 192.168.1.141
port 1194
proto udp
dev tun
mode server
tls-server
tun-mtu 1500
mssfix
persist-key
persist-tun
ca ca.crt
cert DebianServer.crt
key DebianServer.key
dh dh1024.pem
tls-auth ta.key 0
ifconfig 192.168.0.1 192.168.0.2
route 192.168.0.0 255.255.255.0  
push "route 192.168.0.0 255.255.255.0"
client-to-client
keepalive 10 120
cipher BF-CBC
comp-lzo
max-clients 15
user nobody
chroot /var/log/openvpn
status /var/log/openvpn/status.log
log-append /var/log/openvpn/openvpn.log
verb 4
mute 10


 
 

Citation :


Le resultat du route
 
Table de routage IP du noyau
Destination     Passerelle      Genmask         Indic Metric Ref    Use Iface
192.168.0.2     *               255.255.255.255 UH    0      0        0 tun0
192.168.1.0     *               255.255.255.0   U     0      0        0 eth0
192.168.0.0     192.168.0.2     255.255.255.0   UG    0      0        0 tun0
default         DD-WRT          0.0.0.0         UG    0      0        0 eth0


 
 

Citation :


Le resultat du ifconfig
 
eth0      Lien encap:Ethernet  HWaddr 00:xx:xx:xx:xx:xx
          inet adr:192.168.1.141  Bcast:192.168.1.255  Masque:255.255.255.0
          adr inet6: fe80::204:75ff:fed8:6afe/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:72715 errors:0 dropped:0 overruns:0 frame:0
          TX packets:101714 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:13874176 (13.2 MiB)  TX bytes:121437425 (115.8 MiB)
          Interruption:169 Adresse de base:0xc000
 
lo        Lien encap:Boucle locale
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1097 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1097 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:309162 (301.9 KiB)  TX bytes:309162 (301.9 KiB)
 
tun0      Lien encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
          inet adr:192.168.0.1  P-t-P:192.168.0.2  Masque:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:100
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)


 
 

Citation :


Le log d'OpenVPN
 
Fri Apr 27 09:41:56 2007 us=222707 Current Parameter Settings:
Fri Apr 27 09:41:56 2007 us=223255   config = '/etc/openvpn/server.conf'
Fri Apr 27 09:41:56 2007 us=223333   mode = 1
Fri Apr 27 09:41:56 2007 us=223374   persist_config = DISABLED
Fri Apr 27 09:41:56 2007 us=223415   persist_mode = 1
Fri Apr 27 09:41:56 2007 us=223457   show_ciphers = DISABLED
Fri Apr 27 09:41:56 2007 us=223498   show_digests = DISABLED
Fri Apr 27 09:41:56 2007 us=223540   show_engines = DISABLED
Fri Apr 27 09:41:56 2007 us=223581   genkey = DISABLED
Fri Apr 27 09:41:56 2007 us=223622   key_pass_file = '[UNDEF]'
Fri Apr 27 09:41:56 2007 us=223663 NOTE: --mute triggered...
Fri Apr 27 09:41:56 2007 us=223739 167 variation(s) on previous 10 message(s) suppressed by --mute
Fri Apr 27 09:41:56 2007 us=223795 OpenVPN 2.0.9 i486-pc-linux-gnu [SSL] [LZO] [EPOLL] built on Jan 21 2007
Fri Apr 27 09:41:56 2007 us=252177 Diffie-Hellman initialized with 1024 bit key
Fri Apr 27 09:41:56 2007 us=255734 Control Channel Authentication: using 'ta.key' as a OpenVPN static key file
Fri Apr 27 09:41:56 2007 us=255906 Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Fri Apr 27 09:41:56 2007 us=255976 Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Fri Apr 27 09:41:56 2007 us=256054 TLS-Auth MTU parms [ L:1542 D:166 EF:66 EB:0 ET:0 EL:0 ]
Fri Apr 27 09:41:56 2007 us=277767 TUN/TAP device tun0 opened
Fri Apr 27 09:41:56 2007 us=278019 TUN/TAP TX queue length set to 100
Fri Apr 27 09:41:56 2007 us=278193 /sbin/ifconfig tun0 192.168.0.1 pointopoint 192.168.0.2 mtu 1500
Fri Apr 27 09:41:56 2007 us=289808 /sbin/route add -net 192.168.0.0 netmask 255.255.255.0 gw 192.168.0.2
Fri Apr 27 09:41:56 2007 us=299036 Data Channel MTU parms [ L:1542 D:1450 EF:42 EB:135 ET:0 EL:0 AF:3/1 ]
Fri Apr 27 09:41:56 2007 us=302648 chroot to '/var/log/openvpn' and cd to '/' succeeded
Fri Apr 27 09:41:56 2007 us=302965 UID set to nobody
Fri Apr 27 09:41:56 2007 us=303217 Socket Buffers: R=[109568->131072] S=[109568->131072]
Fri Apr 27 09:41:56 2007 us=303391 UDPv4 link local (bound): 192.168.1.141:1194
Fri Apr 27 09:41:56 2007 us=303454 UDPv4 link remote: [undef]
Fri Apr 27 09:41:56 2007 us=303525 MULTI: multi_init called, r=256 v=256
Fri Apr 27 09:41:56 2007 us=303801 Initialization Sequence Completed
Fri Apr 27 09:42:00 2007 us=617602 MULTI: multi_create_instance called
Fri Apr 27 09:42:00 2007 us=617758 192.168.1.1:1088 Re-using SSL/TLS context
Fri Apr 27 09:42:00 2007 us=617921 192.168.1.1:1088 LZO compression initialized
Fri Apr 27 09:42:00 2007 us=618565 192.168.1.1:1088 Control Channel MTU parms [ L:1542 D:166 EF:66 EB:0 ET:0 EL:0 ]
Fri Apr 27 09:42:00 2007 us=618717 192.168.1.1:1088 Data Channel MTU parms [ L:1542 D:1450 EF:42 EB:135 ET:0 EL:0 AF:3/1 ]
Fri Apr 27 09:42:00 2007 us=619029 192.168.1.1:1088 Local Options String: 'V4,dev-type tun,link-mtu 1542,tun-mtu 1500,proto UDPv4,comp-lzo,keydir 0,cipher BF-CBC,auth SHA1,keysize 128,tls-auth,key-method 2,tls-server'
Fri Apr 27 09:42:00 2007 us=619118 192.168.1.1:1088 Expected Remote Options String: 'V4,dev-type tun,link-mtu 1542,tun-mtu 1500,proto UDPv4,comp-lzo,keydir 1,cipher BF-CBC,auth SHA1,keysize 128,tls-auth,key-method 2,tls-client'
Fri Apr 27 09:42:00 2007 us=619239 192.168.1.1:1088 Local Options hash (VER=V4): '14168603'
Fri Apr 27 09:42:00 2007 us=619317 192.168.1.1:1088 Expected Remote Options hash (VER=V4): '504e774e'
Fri Apr 27 09:42:00 2007 us=619557 192.168.1.1:1088 TLS: Initial packet from 192.168.1.1:1088, sid=d3001b1d 9342b200
Fri Apr 27 09:42:00 2007 us=762766 192.168.1.1:1088 VERIFY OK: depth=1, /C=FR/ST=NA/L=-----/O=Debian_Server/CN=DebianServer/emailAddress=-------------
Fri Apr 27 09:42:00 2007 us=763801 192.168.1.1:1088 VERIFY OK: depth=0, /C=FR/ST=NA/O=Debian_Server/CN=DebianServer/emailAddress=____________
Fri Apr 27 09:42:00 2007 us=820036 192.168.1.1:1088 Data Channel Encrypt: Cipher 'BF-CBC' initialized with 128 bit key
Fri Apr 27 09:42:00 2007 us=820186 192.168.1.1:1088 Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Fri Apr 27 09:42:00 2007 us=820495 192.168.1.1:1088 Data Channel Decrypt: Cipher 'BF-CBC' initialized with 128 bit key
Fri Apr 27 09:42:00 2007 us=820581 192.168.1.1:1088 Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Fri Apr 27 09:42:00 2007 us=823015 192.168.1.1:1088 Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 1024 bit RSA
Fri Apr 27 09:42:00 2007 us=823195 192.168.1.1:1088 [DebianServer] Peer Connection Initiated with 192.168.1.1:1088
Fri Apr 27 09:42:00 2007 us=823363 DebianServer/192.168.1.1:1088 MULTI: no dynamic or static remote --ifconfig address is available for DebianServer/192.168.1.1:1088
Fri Apr 27 09:42:01 2007 us=916022 DebianServer/192.168.1.1:1088 PUSH: Received control message: 'PUSH_REQUEST'
Fri Apr 27 09:42:01 2007 us=916245 DebianServer/192.168.1.1:1088 SENT CONTROL [DebianServer]: 'PUSH_REPLY,route 192.168.0.0 255.255.255.0,ping 10,ping-restart 120' (status=1)


 
Merci d'avance.
 
PS: ce n'est pas évident pour moi alors ne tapez pas trop fort ;)
 
edit pour mise en forme et corrections fautes


Message édité par acetone802000 le 27-04-2007 à 09:51:44
n°907625
leto3
Posté le 27-04-2007 à 09:58:07  profilanswer
 

Pourquoi tu passe pas à une interface tap à la place de ta tun ?


---------------
leto3
n°907631
acetone802​000
J'aime les circuits imprimés
Posté le 27-04-2007 à 10:04:55  profilanswer
 

Sur le lien que tu m'as donné, j'ai cru comprendre que dans mon cas:
1 poste distant veut accéder à un réseau, il vaut mieux prendre une configuration du Serveur pour le mode Routed, et j'ai donc adapté ma config par rapports à ce qui est donné.

n°907634
leto3
Posté le 27-04-2007 à 10:08:08  profilanswer
 

http://www.nbs-system.com/article/openvpn2_howto

Bridger ou Router ?
Globalement, si vous ne souhaitez que mettre en relation entre elles des machines distantes, orientez vous vers un mode " Routed ". Si vous souhaitez mettre en relation des réseaux entre eux mettez en place un mode " Bridged ".


 
Tu souhaites mettre en relation 2 machines distantes ? non
Tu souhaites mettre en relation 2 réseaux distants ? oui
 
Donc soit tu adopte le mode bridge, soit tu restes en routé et tu configures ton serveur vpn pour qu'il route le traffic vers l'interieur de ton réseau (iptables).


---------------
leto3
n°907715
acetone802​000
J'aime les circuits imprimés
Posté le 27-04-2007 à 13:30:02  profilanswer
 

J'ai donc suivi ton conseil et je suis passé en configuration TAP.
(j'ai utilisé les exmples de config)
 
Par contre, dans ifconfig et dans route aucune présence d'interface.
Est-ce normal ?
 
 
Edit: j'ai rien dit, il faut créér un bridge avec bridge-utils (ca devient galère....=)


Message édité par acetone802000 le 27-04-2007 à 15:33:52
n°913674
acetone802​000
J'aime les circuits imprimés
Posté le 17-05-2007 à 21:15:51  profilanswer
 

Bon ma config en mode bridge ne fonctionne pas !!!
 
Pour préciser mon serveur n'est plus joignable dès que je mets en place le bridge (Apache, ftp et si je ping à partir de mon serveur j'ai "network unreachable" )
 
J'ai désactivé le lancement automatique d'openvpn et de bridge-start pour les essais pour être sur d'éviter qu'openvpn se lance en premier.
Mon routeur est en mode dhcp avec une adresse 192.168.1.1, les ports 1194, 80, 21 et 22 sont bien routés vers le serveur.
le fichier interfaces:

Citation :


auto lo  
iface lo inet loopback
allow-hotplug eth0
iface eth0 inet static
address 192.168.1.20
netmask 255.255.255.0
network 192.168.1.0
gateway 192.168.1.1


 
le fichier bridge-start:

Citation :


#!/bin/bash
 
#################################
# Set up Ethernet bridge on Linux
# Requires: bridge-utils
#################################
 
# Define Bridge Interface
br="br0"
 
# Define list of TAP interfaces to be bridged,
# for example tap="tap0 tap1 tap2".
tap="tap0"
 
# Define physical ethernet interface to be bridged
# with TAP interface(s) above.
eth="eth0"
eth_ip="192.168.1.20"
eth_netmask="255.255.255.0"
eth_broadcast="192.168.1.255"
 
for t in $tap; do
    openvpn --mktun --dev $t
done
 
brctl addbr $br
brctl addif $br $eth
 
for t in $tap; do
    brctl addif $br $t
done
 
for t in $tap; do
    ifconfig $t 0.0.0.0 promisc up
done
 
ifconfig $eth 0.0.0.0 promisc up
 
ifconfig $br $eth_ip netmask $eth_netmask broadcast $eth_broadcast


 
le fichier server.conf

Citation :


port 1194
proto udp
dev tap0
ca ca.crt
cert DebianServer.crt
key DebianServer.key  
dh dh1024.pem
 
ifconfig-pool-persist ipp.txt
tls-auth ta.key 0  
 
server-bridge 192.168.1.20 255.255.255.0 192.168.1.128 192.168.1.254
 
keepalive 10 120
comp-lzo
user openvpn
persist-key
persist-tun
chroot /var/log/openvpn
status /var/log/openvpn/status.log
log-append /var/log/openvpn/openvpn.log
verb 4
mute 10


 
 
Si vous avez un conseil je prend. (j'ai pourtant pris les fichiers du howto d'openvpn)


Message édité par acetone802000 le 17-05-2007 à 21:18:07
n°913782
acetone802​000
J'aime les circuits imprimés
Posté le 18-05-2007 à 09:01:52  profilanswer
 

J'ai un problème de route:
 
le résultat du ifconfig:
 

Citation :


 
br0       Lien encap:Ethernet  HWaddr 00:04:__:__:__:__
          inet adr:192.168.1.20  Bcast:192.168.1.255  Masque:255.255.255.0
          adr inet6: fe80::204:75ff:fed8:6afe/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:169 errors:0 dropped:0 overruns:0 frame:0
          TX packets:60 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:35289 (34.4 KiB)  TX bytes:5237 (5.1 KiB)
 
eth0      Lien encap:Ethernet  HWaddr 00:__:__:__:__:__
          adr inet6: fe80::204:75ff:fed8:6afe/64 Scope:Lien
          UP BROADCAST RUNNING PROMISC MULTICAST  MTU:1500  Metric:1
          RX packets:5150 errors:0 dropped:0 overruns:0 frame:0
          TX packets:842 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:715269 (698.5 KiB)  TX bytes:113740 (111.0 KiB)
          Interruption:169 Adresse de base:0xc000
 
lo        Lien encap:Boucle locale
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:714 errors:0 dropped:0 overruns:0 frame:0
          TX packets:714 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:196786 (192.1 KiB)  TX bytes:196786 (192.1 KiB)
 
tap0      Lien encap:Ethernet  HWaddr 46:__:__:__:__:__
          adr inet6: fe80::44f8:15ff:fe0f:f0f/64 Scope:Lien
          UP BROADCAST RUNNING PROMISC MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:115 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
 


debian:/home/francois# netstat -nr
 

Citation :


Table de routage IP du noyau
Destination     Passerelle      Genmask         Indic   MSS Fenêtre irtt Iface
192.168.1.0     0.0.0.0         255.255.255.0   U         0 0          0 br0


Message édité par acetone802000 le 18-05-2007 à 09:03:00
mood
Publicité
Posté le 18-05-2007 à 09:01:52  profilanswer
 

n°913980
acetone802​000
J'aime les circuits imprimés
Posté le 18-05-2007 à 18:55:23  profilanswer
 

suis honteux !!!!
j'ai trouvé ce que j'avais oublié dans la config de mon bridge.
je n'avais pas indiqué le gateway 192.168.1.1.

n°918503
silent46
Posté le 01-06-2007 à 15:17:41  profilanswer
 

salut,
pourrais tu préciser ce que tu as fait pour rajouter ta gateway s'il te plait ?
Car j'ai le même problème et je ne vois pas comment rajouter cette gateway.
merci bien

n°918553
silent46
Posté le 01-06-2007 à 16:53:18  profilanswer
 

J'ai rajouté ça a la fin de mon script bridge-start :
 
route add default gw 192.168.5.1
 
sachant que 192.168.5.1 est l'ip interne de ma passerelle (ip interne de la livebox)
et ça fonctionne
 
j'ai juste ou j'ai eu un coup de chance avec une betise ?
 

n°918575
acetone802​000
J'aime les circuits imprimés
Posté le 01-06-2007 à 18:57:45  profilanswer
 

L'adresse IP de mon routeur qui est en DHCP est 192.168.1.1
Le contenu de mon fichier interfaces:
 

Citation :


# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).
 
# The loopback network interface
#auto lo  
#iface lo inet loopback
 
# The primary network interface
#allow-hotplug eth0
#iface eth0 inet static
#address 192.168.1.20
#netmask 255.255.255.0
#network 192.168.1.0
#gateway 192.168.1.1
 
 
auto lo br0
iface lo inet loopback
iface br0 inet static
       address 192.168.1.20
       netmask 255.255.255.0
       broadcast 192.168.1.255
       gateway 192.168.1.1
       bridge-ports eth0
       post-up /etc/openvpn/scripts/ovup && /etc/init.d/openvpn start
       pre-down /etc/init.d/openvpn stop
       post-down /etc/openvpn/scripts/ovdown

n°918646
silent46
Posté le 02-06-2007 à 08:55:16  profilanswer
 

cooolll merci bien

n°918647
acetone802​000
J'aime les circuits imprimés
Posté le 02-06-2007 à 08:57:08  profilanswer
 

Au fait, tiens nous au courant de tes tests ;)

n°919907
silent46
Posté le 06-06-2007 à 10:35:23  profilanswer
 

A force de me prendre la tête sur le bridgé je suis passé en mode routé...
bien moins de soucis et il correspond nickel à mes besoins.
Merci a tous pour l'aide

n°988409
stlan
Posté le 06-12-2007 à 18:09:28  profilanswer
 

Bonjour, j'essaie aussi d'installer openVPN sur mon serveur Debian 4.0, mais depuis un bon moment, j'ai toujours la même erreur.  
 
OpenVPN 2.0.9 i486-pc-linux-gnu [SSL] [LZO] [EPOLL] built on Jan 21 2007
Dec  6 17:39:54 bill ovpn-server[26226]: IMPORTANT: OpenVPN's default port number is now 1194, based on an official port number assignment by IANA.  OpenVPN 2.0-beta16 and earlier used 5000 as the default port.
Dec  6 17:39:54 bill ovpn-server[26226]: Diffie-Hellman initialized with 1024 bit key
Dec  6 17:39:54 bill ovpn-server[26226]: Cannot load certificate file LeServeurVPN.crt: error:0906D06C:PEM routines:PEM_read_bio:no start line: error:140AD009:SSL routines:SSL_CTX_use_certificate_file:PEM lib
Dec  6 17:39:54 bill ovpn-server[26226]: Exiting
 
Alors je veux bien admettre que je me suis planté quelque part, mais je ne vois vraiment pas où.
 
Si vous vouliez bien m'aider.... merci

n°988410
o'gure
Modérateur
Multi grognon de B_L
Posté le 06-12-2007 à 18:18:42  profilanswer
 

A mon avis tu t'es planté dans le format du certificat. Il s'attend à avoir un PEM mais ton fichier LeServeurVPN.crt ne semble pas l'être.
 
Comment l'as tu  créé ?


---------------
Ton Antoine commence à me les briser menus !
n°988419
stlan
Posté le 06-12-2007 à 19:03:17  profilanswer
 

Bonjour o'gure,
Je l'ai créé en suivant cette procédure:
http://www.coagul.org/article.php3?id_article=422
donc:
# cd /usr/share/doc/openvpn/examples/easy-rsa/
# . ./vars
# ./clean-all
# ./build-ca
# ./build-key-server LeServeurVPN
# ./build-dh
 
puis en copiant les fichiers générés dans /etc/openvpn/
 
D'ailleurs, il y a une chose qui me semble étrange:
Ce fameux fichier LeServeurVPN.crt est vide et fait 0k.
 
-rw-r--r-- 1 root root    0 2007-12-06 18:43 Vpnserveur.crt
 
Voilà.
(Merci de ton aide en tous cas)
 

n°988421
o'gure
Modérateur
Multi grognon de B_L
Posté le 06-12-2007 à 19:06:31  profilanswer
 

stlan a écrit :


D'ailleurs, il y a une chose qui me semble étrange:
Ce fameux fichier LeServeurVPN.crt est vide et fait 0k.

 

-rw-r--r-- 1 root root    0 2007-12-06 18:43 Vpnserveur.crt


Ton fichier fait ok ? :heink:
Un fichier ne fait pas ok...

 


Ton fichier est vide => il ne contient pas le certificat nécessaire, et donc il n'est pas au format PEM => message d'erreur

 


Recommence exactement les étapes de la création du certificat à partir d'ici

Citation :

Création du certificat de l’autorité de certification (CA)

 


Message édité par o'gure le 06-12-2007 à 19:07:24

---------------
Ton Antoine commence à me les briser menus !
n°988423
stlan
Posté le 06-12-2007 à 19:34:55  profilanswer
 

Voilà, mais rien n'a changé. Toujours ce même message.
 
Dans cette procedure, http://www.coagul.org/article.php3?id_article=422, il est dit que je dois décompresser le fichier openssl.cnf.gz
sauf que ce fichier était déjà décompressé chez moi.
 
Un autre truc par example,  
lorsque je lance un ./build, j'ai cette ligne The commonName field needed to be supplied and was missing au lieu de ce qui est sur la procédure
 
peut-être celà vient-il du fichier conf de openssl ...?

n°988426
stlan
Posté le 06-12-2007 à 19:40:47  profilanswer
 

et ce fichier qui fait 0k
ls -l /etc/openvpn
total 6
-rw-r--r-- 1 root root  985 2007-12-06 19:23 ca.crt
-rw------- 1 root root  887 2007-12-06 19:23 ca.key
-rw-r--r-- 1 root root  245 2007-12-06 19:24 dh1024.pem
-rw-r--r-- 1 root root    0 2007-12-06 19:24 LeServeurVPN.crt
-rw-r--r-- 1 root root  887 2007-12-06 19:24 LeServeurVPN.key
-rwxrwxr-- 1 root root    0 2007-12-06 19:36 openvpn-status.log
-rwxrwxr-- 1 root root 1119 2007-12-06 19:27 server.conf


Message édité par stlan le 06-12-2007 à 19:42:03
n°988436
stlan
Posté le 06-12-2007 à 20:12:30  profilanswer
 

Bon.. je viens de refaire toute la manip en aillant fait un apt-get remove --purge openvpn avant.

 

Rien n'y fait. Dans syslog, j'ai toujours le même message:

 

Dec  6 20:04:46 bill ovpn-server[27368]: OpenVPN 2.0.9 i486-pc-linux-gnu [SSL] [LZO] [EPOLL] built on Jan 21 2007
Dec  6 20:04:46 bill ovpn-server[27368]: IMPORTANT: OpenVPN's default port number is now 1194, based on an official port number assignment by IANA.  OpenVPN 2.0-beta16 and earlier used 5000 as the default port.
Dec  6 20:04:46 bill ovpn-server[27368]: Cannot load certificate file LeServeurVPN.crt: error:0906D06C:PEM routines:PEM_read_bio:no start line: error:140AD009:SSL routines:SSL_CTX_use_certificate_file:PEM lib
Dec  6 20:04:46 bill ovpn-server[27368]: Exiting

 

et toujours ce fichier LeServeurVPN.crt qui fait 0k

 

J'avais pourtant réussis à faire pas mal de chose avec ce serveur, mais là je sèche.

 

Dans google, je trouve rien...
si une personne a rencontré le même problème...

 

Merci


Message édité par stlan le 06-12-2007 à 20:13:26
n°988444
o'gure
Modérateur
Multi grognon de B_L
Posté le 06-12-2007 à 20:31:05  profilanswer
 

Tu es sûr de faire exactement la procédure ?
export des variables ?
remplissages des différents champs quand ils te le demande ?
 
Sinon fait une recherche sur google pour créer des certificats PEM avec openssl. Généralement c'est avec openssl que je les fait quand j'ai à en faire (pas souvent, j'ai plus la procédure en tête).


---------------
Ton Antoine commence à me les briser menus !
n°988445
o'gure
Modérateur
Multi grognon de B_L
Posté le 06-12-2007 à 20:31:52  profilanswer
 
n°988454
stlan
Posté le 06-12-2007 à 21:04:09  profilanswer
 

oui, vraiment j'ai tout suivie...  
 
cd /usr/share/doc/openvpn/examples/easy-rsa/  
# . ./vars  
# ./clean-all  
# ./build-ca  
# ./build-key-server LeServeurVPN  
# ./build-dh
etc...
 
je regarde tes liens et je ré-essaie...
Je te tiens au courant

n°988478
stlan
Posté le 06-12-2007 à 22:08:24  profilanswer
 

Bon, je n'ai plus qu'a me faire tout petit....

 

C'était tout con...

 

J'ai effectivement zapé une phrase très importante de la manip:

 

ATTENTION : Pour les questions, tous les champs sont renseignés par défaut sauf le « Common Name » qu’il faut renseigner manuellement. Exemple « MonServeurVPN ». Personnellement, je n’ai pas renseigné le champ « password ».

 

et voilà...
Je mets ça sur le compte de la fatigue mais bon...pas fière de moi
C'est toi qui m'a mis sur la piste:
remplissages des différents champs quand ils te le demande ?

 

C'est vraiment l'exemple typique du truc que l'on cherche dans tous les sens alors qu'il est juste devant notre nez.

 

J'avais aussi eu du mal pour faire un point d'acces wifi en WPA sur ce serveur avec hostapd, mais bon j'y étais quand même arrivé... Mais là...

 

En tous cas un grand merci à toi o'gure pour ton aide.


Message édité par stlan le 06-12-2007 à 22:15:11
mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  Installation OpenVPN sur Debian

 

Sujets relatifs
Debian : Limitation d'accés au ftp avec netfilter ou xinetdProblème pour Installer php4 sous Debian
proftpd sur Debian 4.0automatisation d'installation de serveur
[debian] rc-update pas installé !Debian au démarrage: message visuel arrété 6 fois en 90 secondes
[LAN/debian] Autoriser uniquement web vers l'exterieurRadius(freeradius) sur Debian
[Debian] Carte réseau non reconnue après installation 
Plus de sujets relatifs à : Installation OpenVPN sur Debian


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR